Jump to content

Xgl : Linux a la classe version OpenGL


Recommended Posts

Mais sinon pourquoi il n'y a pas pas de Xgl pour FC?

Y'a déjà aiglx ( http://fedoraproject.org/wiki/RenderingProject/aiglx )

En gros c'est un peu comme Xgl sauf que c'est une surcouche à X au lieu d'être un serveur X à part.

Cette solution est soutenue par nvidia notamment (qui la trouve plus simple à intégrer avec les autres fonctions avancées de ses drivers notamment).

Au final, c'est un peu pareil, de plus les interfaces utilisées sont en train de s'uniformiser, ce qui veut dire que l'on va pouvoir lancer compiz sur aiglx et metacity avec la gestion de la composition sous Xgl.

Ah ca va être du tout bon ça alors. Les choses bougent dans le bon sens pour les eyes candy sous Linux :transpi:

Link to comment
Share on other sites

  • Replies 724
  • Created
  • Last Reply

Salut à tous,

J'ai essayé en vain d'installer Xorg7.0, pour installer après Xgl + Compiz sur ma gentoo 2006,

et là je rencontre deux problèmes distincts :

- soit je desinstalle pas ma version 6.8 de Xorg et emerge me dit qu'il y a conflit avec pleins de packages => ce que je trouve normal car installer deux Xorg de version différentes je ne sais pas si c'est possible ...

- soit je desinstalle mon ancien Xorg 6.8 avec emerge --unmerge xorg-x11, je mets à jour mon /etc/portage/package.keywords, grâce à une liste trouvée sur la doc de gentoo (Passer au X Modular), et je relance un emerge -pv xorg-x11, pour lui tout à l'air bon, donc si je lance réellement l'installation cela devrait fonctionné ...

Eh ben non !!! Il plante sur le paquet libXft, il me dit qu'il y a un autre paquet en conflit encore :transpi:

Si quelqu'un à déjà eu le problème et l'a déjà fait fonctionné sur Gentoo, je veux bien un petit coup de main ...

PS : A ce qui parait la release de Xorg 7.0 est sorti ce week-end donc normalemtn d'ici deux semaines on l'aura en version stable sous gentoo :zarb:

EDIT : Déplacement depuis le topic des "plus beaux desktops" ...

Link to comment
Share on other sites

J'ai déja vu plusieurs fois la vidéo XGL de Novell et tester un peu sur Kororaa c'est vraiment impressionant et super utile je trouve !! Vivement que ma carte graphique nvidia 7300 tc de mon asus soit supporté en 3D sous nux :transpi:

Link to comment
Share on other sites

Koronaa ne fonctionne pas chez moi. Enfin, si, mais très mal. O_o

Par exemple, je ne peut même pas changer de bureaux virtuels, et aucun des raccoursis pour compiz ne fonctionne. :ouioui:

Pourtant, ma carte vidéo est reconnu (une 9200se (et non 7200 comme j'ai pu l'écrire plus haut ici :chinois: ).

Je suis le seul à avoir eu ce genre de problème?

Link to comment
Share on other sites

Koronaa ne fonctionne pas chez moi. Enfin, si, mais très mal. O_o

Par exemple, je ne peut même pas changer de bureaux virtuels, et aucun des raccoursis pour compiz ne fonctionne. :mdr:

Pourtant, ma carte vidéo est reconnu (une 9200se (et non 7200 comme j'ai pu l'écrire plus haut ici :D ).

Je suis le seul à avoir eu ce genre de problème?

il ne faut pas rester appuyer sur la touche alt pendant ton déplacement de bureau ?

Link to comment
Share on other sites

J'ai deux petites questions, j'ai envie de retenter Xgl, j'en ai trop envie :D

Est ce qu'on peut me confirmer qu'Xgl ne marche pas avec e17 ?

et

Est ce que c'est certain que Xgl+compiz fonctionne avec une Ati radeon x550 (drivers proprio ) ?

Nan parceque j'ai déjà passé des heures dessus avant, alors si je pouvais avoir une réponse sûre.. ^^

Link to comment
Share on other sites

J'ai deux petites questions, j'ai envie de retenter Xgl, j'en ai trop envie :cartonrouge:

Est ce qu'on peut me confirmer qu'Xgl ne marche pas avec e17 ?

et

Est ce que c'est certain que Xgl+compiz fonctionne avec une Ati radeon x550 (drivers proprio ) ?

Nan parceque j'ai déjà passé des heures dessus avant, alors si je pouvais avoir une réponse sûre.. ^^

A partir du moment ou tu as des drivers qui te permettent le direct rendering et le composite, oui ta carte devrait fonctionner, après faut voir ses capacités (ca sera peut-être lent)

pour E17 et Xgl, j'ai fait une très mauvaise expérience sous gentoo et cela m'a tout cassé (faut dire que j'avais plein de paquets bloquant et que j'ai fait un fichier package.keywords de la mort (plus de 150 lignes !!!), enfin bon tout ca pour dire que moi j'azi pas réussi et j'ai pas vu encore d'informations de la part de quelqu'un qui l'aurait fait fonctionner, mais pourquoi pas essayer E16

Link to comment
Share on other sites

mhmmm, je ne vois pas pourquoi e17 ne tournerais pas dans Xgl (qui n'est somme toute qu'un serveur X sur un serveur X)...

compiz ne marchera pas avec e17, ça c'est clair. Raster ne veux pas dépendre sur quoi que ce soit.

Par contre, je ne vois pas ce qui empêche d'afficher e17 dans une macro fenêtre OpenGL.

n'importe quel wm devrait tourner dans Xgl, mais évidement, si y a pas les fenêtre qui bloblottent, ça ne sert à rien... :cartonrouge:

Link to comment
Share on other sites

Koronaa ne fonctionne pas chez moi. Enfin, si, mais très mal. O_o

Par exemple, je ne peut même pas changer de bureaux virtuels, et aucun des raccoursis pour compiz ne fonctionne. ;)

Pourtant, ma carte vidéo est reconnu (une 9200se (et non 7200 comme j'ai pu l'écrire plus haut ici :chinois: ).

Je suis le seul à avoir eu ce genre de problème?

Non tu n'es pas le seul, j'ai la même chose avec une 9800 pro. Par contre au démarrage de kororaa, les choses sont claires, puisque j'ai un message d'erreur pour l'openGL. Mais bon une fois chargé, je ne peux rien faire non plus d'intéressant... Je vais devoir attendre une prochaine version :yes:

Link to comment
Share on other sites

- soit je desinstalle mon ancien Xorg 6.8 avec emerge --unmerge xorg-x11, je mets à jour mon /etc/portage/package.keywords, grâce à une liste trouvée sur la doc de gentoo (Passer au X Modular), et je relance un emerge -pv xorg-x11, pour lui tout à l'air bon, donc si je lance réellement l'installation cela devrait fonctionné ...

Euh il me semble que xorg-x11 est un meta-ebuild. Je crois que ça pose problème à la désinstall, puisqu'il ne vire pas tous les paquets qu'il avait installés. Faudrait trouver un moyen de lister tous les paquets installés par xorg-x11 6.8 puis tous les unmerger (y'a un howto qui montre une méthode semblable avec le meta-ebuild kde, pour le passage aux ebuilds séparés).

Link to comment
Share on other sites

- soit je desinstalle mon ancien Xorg 6.8 avec emerge --unmerge xorg-x11, je mets à jour mon /etc/portage/package.keywords, grâce à une liste trouvée sur la doc de gentoo (Passer au X Modular), et je relance un emerge -pv xorg-x11, pour lui tout à l'air bon, donc si je lance réellement l'installation cela devrait fonctionné ...

Euh il me semble que xorg-x11 est un meta-ebuild. Je crois que ça pose problème à la désinstall, puisqu'il ne vire pas tous les paquets qu'il avait installés. Faudrait trouver un moyen de lister tous les paquets installés par xorg-x11 6.8 puis tous les unmerger (y'a un howto qui montre une méthode semblable avec le meta-ebuild kde, pour le passage aux ebuilds séparés).

oui dans la doc il te disent de faire un emerge -Ca xorg-x11 ...

ce que j'ai fait après mais rien n'a changer... par contre j'ai trouvé ca :

http://www.gentoo.org/proj/fr/desktop/x/x1...lar-x-howto.xml

le problème c'est que j'ai pas tout compris comment fonctionnent les scripts ... (eh oui, je suis un gros nul en script linux, bash, ksh, j'avais appris les bases mais y'a au moins 6 ou 7 ans), mais ils expliquent le problème sur lequel je suis tombé, les trois tonnes de paquets bloquants ...

le seul truc c'est que j'avais réussi un moment en faisant un emerge -pv de n'avoir plus que des lignes vertes, mais à l'install il plantait quand même, de toute façon je vais réessayer xorg 7.0 j'ai le mord :byebye: .

Sinon j'avais cru comprendre que xorg 7.0 était en release depuis cette semaine => est-ce vrai ? et si oui, combien de temps de temps faut attendre pour que ca passe en version stable sur gentoo ?

Link to comment
Share on other sites

Sinon j'avais cru comprendre que xorg 7.0 était en release depuis cette semaine => est-ce vrai ?

En tildarch depuis le 26 mars, quelque chose comme ça...

et si oui, combien de temps de temps faut attendre pour que ca passe en version stable sur gentoo ?

Le temps qu'on sache que ça marche avec toutes les applis de portage... cf http://bugs.gentoo.org/show_bug.cgi?id=112004 http://bugs.gentoo.org/show_bug.cgi?id=112675

Link to comment
Share on other sites

- soit je desinstalle mon ancien Xorg 6.8 avec emerge --unmerge xorg-x11, je mets à jour mon /etc/portage/package.keywords, grâce à une liste trouvée sur la doc de gentoo (Passer au X Modular), et je relance un emerge -pv xorg-x11, pour lui tout à l'air bon, donc si je lance réellement l'installation cela devrait fonctionné ...

Euh il me semble que xorg-x11 est un meta-ebuild. Je crois que ça pose problème à la désinstall, puisqu'il ne vire pas tous les paquets qu'il avait installés. Faudrait trouver un moyen de lister tous les paquets installés par xorg-x11 6.8 puis tous les unmerger (y'a un howto qui montre une méthode semblable avec le meta-ebuild kde, pour le passage aux ebuilds séparés).

oui dans la doc il te disent de faire un emerge -Ca xorg-x11 ...

ce que j'ai fait après mais rien n'a changer... par contre j'ai trouvé ca :

http://www.gentoo.org/proj/fr/desktop/x/x1...lar-x-howto.xml

le problème c'est que j'ai pas tout compris comment fonctionnent les scripts ... (eh oui, je suis un gros nul en script linux, bash, ksh, j'avais appris les bases mais y'a au moins 6 ou 7 ans), mais ils expliquent le problème sur lequel je suis tombé, les trois tonnes de paquets bloquants ...

le seul truc c'est que j'avais réussi un moment en faisant un emerge -pv de n'avoir plus que des lignes vertes, mais à l'install il plantait quand même, de toute façon je vais réessayer xorg 7.0 j'ai le mord :p .

Sinon j'avais cru comprendre que xorg 7.0 était en release depuis cette semaine => est-ce vrai ? et si oui, combien de temps de temps faut attendre pour que ca passe en version stable sur gentoo ?

g eu plein de ligne genre "xorg-x11<=6.9 is bloking xxx" et resolu en faisant emerge -Ca xorg-x11 !

c ca ton erreur ?

Link to comment
Share on other sites

donc tu utilises compiz :p

Au fait compiz, c'est un window manager ? Un gestionnaire de compositing ?

Et e17, ca se limite a quoi ? Window Manager ? Desktop Manager ?

Du coup, on peut avoir des effet wobbly sur les belles fenetre e17 ? Ou on doit se taper les fenetres qu'on voit dans kororaa ?

Merci !

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...