Jump to content
Dark26

Le Linux BAR - Discussion de tout et de rien

Recommended Posts

Salut tout le monde,

J'ai téléchargé debien testing, et lors de l'installation:

La première phase se passe bien, reboot, et là (en mode console), kernel panic, avec un message: unable to kill init. :craint:

Puis ça reste bloquée là.

P.S: J'ai téléchargé 4 distribs differentes dans des serveurs differents (inclus les serveurs officiels), et seulement une marche, les autres ça bloque dès le début, je peut même pas choisir la langue (le clavier ne marche pas, alors qu'il marchait au début vu que j'ai appuyé sur entrer pour débuter l'install)

Si ça peut servir, c'est une install sur un portable, dans une partition situé sur un disque externe relié par un cable usb (1)

Si quelqu'un peut m'aider..

Share this post


Link to post
Share on other sites

mhmm, pour acceder au noyau qui se trouve sur le disque externe il doit falloir loader les modules usb via une initrd qui se trouve... sur le disque externe... :craint:

donc, j'ai de sérieux doute que ça marche...

je ne pense pas que ni grub, ni lilo soient capable de démarrer un OS qui se trouve sur un disque usb. En tout cas, ça m'étonnerais fort.

la solution serait de faire une partition /boot sur un vrai disque interne, même si elle ne fait que 50Mo :transpi:

Share this post


Link to post
Share on other sites

la solution serait de faire une partition /boot sur un vrai disque interne, même si elle ne fait que 50Mo :francais:

Faut que j'ajoute une partition /boot de 50Mo pour y installer grub?

Merci pour ta réponse Lorinc :reflechis:

Share this post


Link to post
Share on other sites

non, surtout pour y installer ton noyau et ton initrd...

grub s'installera sur le premier disque qui boot, comme d'hab.

par contre, après, ça doit être un peu tendu à configurer (dire au noyau que le / est sur le disque usb...)

Share this post


Link to post
Share on other sites

Yeah!! ça marche, j'ai une debian en mode console maintenant! ;)

Mais le blem, j'ai pas le net (j'ai une passerelle):

J'ai modifié le fichier: /etc/network/interfaces, j'ai mis ip, masque, et passerelle.

Mais ça marche pas, je sais pas quel fichier modifier pour mettre le DNS?

voilà le fichier interfaces:

mapping hotplug
	script grep
	map eth0

# The primary network interface
iface eth0 inet static
address 192.168.1.1
netmask 255.255.255.0
gateway 192.168.1.3

auto eth0

Quelqu'un pourrai me donner son sources.list pour debian testing sioplaît? :transpi:

Edited by shark_atlantis

Share this post


Link to post
Share on other sites

Si je ne me trompe pas, pour les DNS, tu dois éditer le fichier /etc/resolv.conf.

Si tu veux rajouter un serveur dns, tu tapes la ligne :

nameserver adresse_ip

Tu auras plus d'infos en faisant une recherche sur google.

Share this post


Link to post
Share on other sites

Si je ne me trompe pas, pour les DNS, tu dois éditer le fichier /etc/resolv.conf.

Si tu veux rajouter un serveur dns, tu tapes la ligne :

nameserver adresse_ip

Tu auras plus d'infos en faisant une recherche sur google.

Merci, donc pour ça c'est bon, parcontre je serai ravi si quelqu'un pourrai me donner un sources.list d'une debian testing qui marchenickel ;)

EDIT: c'est bon, reste plus qu'à configurer X :transpi:

Edited by shark_atlantis

Share this post


Link to post
Share on other sites

Je vous écrit depuis ma Debian testing!!

ça y est ça marche maintenant, à dieu Ubuntu :D

Merci à tous ceux qui m'ont aider, spécialement à Lorinc et 16aR sur le chat #pcinpact-linux

Merci à tous :smack:

ciao :D

Share this post


Link to post
Share on other sites

De rien :smack:

J'aime beaucoup ton image dans ta signature sur debian. Ca vient d'ou ? :)

Share this post


Link to post
Share on other sites

yope les gens, j'ai finalement tester le drivers r300 du CVS de Mesa et ça marche !!! :oops:

$ glxinfo

name of display: :0.0

*********************************WARN_ONCE*********************************

File r300_state.c function r300Enable line 456

TODO - double side stencil !

***************************************************************************

No ctx->FragmentProgram._Current!!

display: :0 screen: 0

direct rendering: Yes

server glx vendor string: SGI

server glx version string: 1.2

server glx extensions:

GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,

GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,

GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier,

GLX_SGIX_fbconfig

client glx vendor string: SGI

client glx version string: 1.4

client glx extensions:

GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,

GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,

GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,

GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,

GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,

GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group

GLX version: 1.2

GLX extensions:

GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,

GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_swap_control,

GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_SGI_video_sync,

GLX_SGIS_multisample, GLX_SGIX_fbconfig

OpenGL vendor string: Tungsten Graphics, Inc.

OpenGL renderer string: Mesa DRI R300 20040924 AGP 1x x86/MMX+/3DNow!+/SSE TCL

OpenGL version string: 1.2 Mesa 6.4.1

OpenGL extensions:

GL_ARB_fragment_program, GL_ARB_imaging, GL_ARB_multisample,

GL_ARB_multitexture, GL_ARB_texture_border_clamp,

GL_ARB_texture_compression, GL_ARB_texture_env_add,

GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,

GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,

GL_ARB_texture_rectangle, GL_ARB_transpose_matrix,

GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_window_pos,

GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,

GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate,

GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,

GL_EXT_compiled_vertex_array, GL_EXT_convolution, GL_EXT_copy_texture,

GL_EXT_draw_range_elements, GL_EXT_histogram, GL_EXT_packed_pixels,

GL_EXT_polygon_offset, GL_EXT_rescale_normal, GL_EXT_secondary_color,

GL_EXT_separate_specular_color, GL_EXT_stencil_wrap, GL_EXT_subtexture,

GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,

GL_EXT_texture_env_add, GL_EXT_texture_env_combine,

GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,

GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp,

GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,

GL_APPLE_packed_pixels, GL_ATI_blend_equation_separate,

GL_ATI_texture_env_combine3, GL_ATI_texture_mirror_once,

GL_IBM_rasterpos_clip, GL_IBM_texture_mirrored_repeat,

GL_INGR_blend_func_separate, GL_MESA_pack_invert, GL_MESA_ycbcr_texture,

GL_MESA_window_pos, GL_NV_blend_square, GL_NV_light_max_exponent,

GL_NV_texture_rectangle, GL_NV_texgen_reflection, GL_NV_vertex_program,

GL_OES_read_format, GL_SGI_color_matrix, GL_SGI_color_table,

GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,

GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod

glu version: 1.3

glu extensions:

GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav

id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat

----------------------------------------------------------------------

0x23 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 0 0 None

0x24 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 0 0 None

0x25 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow

0x26 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow

0x27 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 0 0 None

0x28 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None

0x29 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow

0x2a 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow

0x2b 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 0 0 None

0x2c 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 0 0 None

0x2d 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow

0x2e 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow

0x2f 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 0 0 None

0x30 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None

0x31 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow

0x32 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow

comme vous pouvez le voir, y a encore quelques warning... :iloveyou:

d'autre part, niveau perfs, c'est pas aussi bien que ceux d'ati mais pas loin (je dois être ~20% en dessous)

par contre, c'est libre !!!

yeah :yes:

pour l'install, c'est super simple. tout à été mergé dans le cvs du dri, donc vous allez là :

http://dri.freedesktop.org/snapshots/

vous récupérez le snapshot r300 le plus récent, vous le décompressez.

vous coupez X, et vous lancez le script install.sh qui fait tout seul :non:

donc pas la peine de faire comme moi et d'aller sur r300.sourceforge.net qui est totalement outdated et qui ne vous menera qu'a des heures de galère :eeek2:

Bon faut que je twek mon xorg.conf pour en tirer le meilleur ;)

Share this post


Link to post
Share on other sites
Salut à tous ! Après de rudes épreuves ces dernières semaines :transpi: je reviens parmis vous :transpi:

Salut

Bienvenue et bon retour :eeek2:

a+

Share this post


Link to post
Share on other sites

yope les gens, j'ai finalement tester le drivers r300 du CVS de Mesa et ça marche !!! :transpi:

...

comme vous pouvez le voir, y a encore quelques warning... :transpi:

d'autre part, niveau perfs, c'est pas aussi bien que ceux d'ati mais pas loin (je dois être ~20% en dessous)

par contre, c'est libre !!!

yeah :eeek2:

pour l'install, c'est super simple. tout à été mergé dans le cvs du dri, donc vous allez là :

http://dri.freedesktop.org/snapshots/

vous récupérez le snapshot r300 le plus récent, vous le décompressez.

vous coupez X, et vous lancez le script install.sh qui fait tout seul :eeek2:

donc pas la peine de faire comme moi et d'aller sur r300.sourceforge.net qui est totalement outdated et qui ne vous menera qu'a des heures de galère :zarb:

Bon faut que je twek mon xorg.conf pour en tirer le meilleur :zarb:

Et c'est pour les radeon 9200, c ca ?

Edited by 16ar

Share this post


Link to post
Share on other sites

comme dit sur le chan :

les radeon 9200 sont à base de RV280 donc supporté en hard par le DRI depuis longtemps ;)

le driver r300 supporte les cartes à partir de la 9500 jusqu'aux 9800

dont la mienne, qui est un radeon 9600, par exemple.

bon, en tweakant le xorg.conf on obtient pas grand chose de mieux :yes:

j'ai fait un ut2004 en 1024 tout au min c'est pas jouable (20-25fps). niveau qualité, c'est pas tiptop non plus...

Share this post


Link to post
Share on other sites

comme dit sur le chan :

les radeon 9200 sont à base de RV280 donc supporté en hard par le DRI depuis longtemps :pleure:

le driver r300 supporte les cartes à partir de la 9500 jusqu'aux 9800

dont la mienne, qui est un radeon 9600, par exemple.

bon, en tweakant le xorg.conf on obtient pas grand chose de mieux ;)

j'ai fait un ut2004 en 1024 tout au min c'est pas jouable (20-25fps). niveau qualité, c'est pas tiptop non plus...

Bonne nouvelle quand même. ;)

Apparement ça devrait fonctionner sans probleme sous freebsd aussi, d'apres ce que j'en ai lu, sur les 9600 et X800, et avec quelques freezes sur les 9800.

/me a hate de retourner chez moi pour tester tout ça et enfin lancer les applis 3D sur ma bête ;) .

Share this post


Link to post
Share on other sites
Le libre vaincra, hein les gars, hein?
C'est évident voyons :transpi:

Rebonjour à mes amis Ouragan et Tram ;)

Share this post


Link to post
Share on other sites

Soir :D

C'est officiel: je suis libre :-D

Bon, j'ai suivi les tutos, et me voilà sous Debian, et ça marche pas trop mal :D

Sinon, pour la petite histoire, ne mettez JAMAIS le caps lock lors de l'install :chinois: sinon vous aurez un clavier mal reconnu en qwerty. Problème, quand vous tapez le mot de passe root pendant l'install, c'est du qwerty aussi et quand on a des chiffres qu'on tape avec shift+une lettre en haut, bein ça donne un caractère, et quand on repasse en azerty, pour retrouver à quoi ça correspond... ;)

Je pouvais pas me donner les droit root dans une console, le clavier était azerty. Ca marchais en mode texte vu que le clavier était en qwerty. Je change le clavier en azerty en mode texte, je peux plus me logger en root nul part :D . Et merde, pour remmetre le clavier en qwerty, faut être root :pleure:

Enfin bon, à part ce petit incident je suis satisfait, je vais bientôt commencer la migration définitive de mes fichiers vers le home :D

Edited by c.y.r.u.s

Share this post


Link to post
Share on other sites

yeaahhh, ça c'est une bonne nouvelle ;)

ça mérite un coup à boire :tchintchin: :chinois::D

sinon, petite astuce que j'utilise quand j'installe une nouvelle machine : je mets le mot de passe root à "azertyui", comme ça, ben si c'est du qwerty, c'est pas trop dur à retrouver...

je le change pour un truc plus complexe une fois que je suis sûr que tout marche bien :pleure:

Edited by lorinc

Share this post


Link to post
Share on other sites

coucou rapide ;)

chouette avatar theo... tu fais les présentations :D

(inter demande si tu couches avec.... enfin tu la connais :chinois: )

Share this post


Link to post
Share on other sites

yeaahhh, ça c'est une bonne nouvelle :D

ça mérite un coup à boire :tchintchin: :chinois::D

sinon, petite astuce que j'utilise quand j'installe une nouvelle machine : je mets le mot de passe root à "azertyui", comme ça, ben si c'est du qwerty, c'est pas trop dur à retrouver...

je le change pour un truc plus complexe une fois que je suis sûr que tout marche bien ;)

:D:pleure::-D:D

Bon, j'chuis chaud, maintenant faut que je trouve comment eDonkey version ligne de commande marche ;)

Edited by c.y.r.u.s

Share this post


Link to post
Share on other sites

c.y.r.u.s :byebye: :tchintchin: Bienvenue parmis nous ;)

theo, j'aime mieux quand tu mets un avatar sexy :D
Ah ben tu devrais être content alors ;)

(Enfin avant c'était Christian Paul, ça ne devait pas te déplaire non plus, hein ? Quel beau gosse :love:)

chouette avatar theo... tu fais les présentations :D
Fred, mademoiselle... mademoiselle, Fred ;)
(inter demande si tu couches avec.... enfin tu la connais :yes: )
Tsss... ;)

;)

Bon, je ne m'attendait pas à ce que tout le monde se focalise dessus de cette façon. La jolie demoiselle, elle est membre de Debian Women (tiens, je sens plein de monde qui veux migrer tout à coup ;)). Je ne connais pas plus que ça le projet, j'en ai déjà entendu parler et suivit quelques mouvements sur la ml dwn... Mais la photo est très jolie c'est tout :D

EDIT : excellent lien posté dans le topic des trucs marrants à partager.

Il est fort ce ploum, il me fait bien marrer :D

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...