Jump to content

[Résolu] Verrouillage numérique...


Recommended Posts

Salut la communauté !

Jamais je n'aurais pensé demander un jour de l'aide sur un sujet aussi stupide, basique, mineur... mais Windows 10 étant ce qu'il est........

Je me bat depuis des jours avec le verrouillage du pavé numérique au démarrage, sur l'écran de connexion. J'ai essayé plein de choses, et je suis ébahi que Windows soit totalement incapable de proposer une option aussi basique dans ses paramètres. Devoir trifouiller 20 fois la BDR pour constater des changements c'est dingue !

Bref, voici ce que j'ai déjà essayé :

1. modifier les valeurs InitialKeyboardIndicators (par 2, 80000002, 2147483648 ou 2147483650 - d'ailleurs personne n'explique jamais le pourquoi de ces valeurs, et leur signification) dans les clés suivantes :

HKEY_CURRENT_USER\Control Panel\Keyboard
HKEY_USERS\.DEFAULT\Control Panel\Keyboard
HKEY_USERS\S-1-5-******\Control Panel\Keyboard (5 fois)

2. éteindre le PC, le rallumer, à l'écran de login activer le numlock, puis ré-éteindre pour sauvegarder la conf dans le fast boot.

Donc avec tous ces paramètres, le mieux que je puisse obtenir c'est que le verrouillage numérique est conservé après un redémarrage, après un cycle arrêt-allumage si le temps OFF n'est que de quelques secondes, mais du soir au lendemain rebelote, le numlock est désactivé au démarrage.

Sachant que je tourne sur une fresh install de Win10 1903 qui n'a pas 2 mois, et que le numlock est activé dans l'UEFI.

Quelqu'un a-t-il une autre astuce ?

 

Edited by Nozalys
Résolu
Link to post
Share on other sites

Je vais probablement répondre à côté de la plaque car je comprends mal la question.
Chez moi, l'activation du clavier numérique est en fonction dans l'uEFI et sur mon clavier j'ai une touche de vérouillage/dévérouillage du pavé numérique.
Au démarrage /boot, le clavier numérique est activé et si je veux, je peux le désactiver en cours de session.

Link to post
Share on other sites

Si tu actives l'accès par code PIN, pas besoin que le verrouillage numérique soit enclenché, Windows prend automatiquement les chiffres.

Normalement, si tu l'actives le verrouillage numérique sur l'écran de déverrouillage de session, il s'en souvient la fois suivante pour ouvrir la même session.

Link to post
Share on other sites
Il y a 6 heures, Nozalys a écrit :

Salut la communauté !

Jamais je n'aurais pensé demander un jour de l'aide sur un sujet aussi stupide, basique, mineur... mais Windows 10 étant ce qu'il est........

Je me bat depuis des jours avec le verrouillage du pavé numérique au démarrage, sur l'écran de connexion. J'ai essayé plein de choses, et je suis ébahi que Windows soit totalement incapable de proposer une option aussi basique dans ses paramètres. Devoir trifouiller 20 fois la BDR pour constater des changements c'est dingue !

Questions:

  • Est-ce que par hasard le problème ne se poserait pas quand tu sors de veille/veille prolongée uniquement? Si c'est le cas je ne sais pas si une solution existe maintenant
  • Aurais-tu deux claviers? Ou un clavier bluetooth?
  • Ou alors aurais-tu un clavier avec pilote/logiciel constructeur particulier?
  • Ou un second pilote de clavier, ou un keylogger, un injecteur clavier comme ceux pour simuler un clavier à partir d'une manette?

 

Il y a 6 heures, Nozalys a écrit :

1. modifier les valeurs InitialKeyboardIndicators (par 2, 80000002, 2147483648 ou 2147483650 - d'ailleurs personne n'explique jamais le pourquoi de ces valeurs, et leur signification) 

C'est un masque de bits:

  • Bit 0: Caps lock (majuscules)

  • Bit 1: Num lock (pavé numérique)

  • Bit 2: Scrolllock (verrouillage défilement)

  • Les autres bits: pas d'info

Donc pour en revenir à tes valeurs:

  • Attention: 80000002 ne doit pas être saisi en décimal mais en hexa car 0x80000002 = 2147483650  en décimal
  • 80000002H = 2147483650  = 2147483648  + 2 = 1000 0000 0000 0010 en binaire. On passe simplement un bit à 1 (le 2ème, en partant de la droite) qui force numlock. Je ne connais pas la signification du 1er bit, simplement la "littérature" indique qu'il peut provoquer des fonctionnements non prévus sur certains clavier.

  • Donc la valeur 2 est plus conseillée

Tu changes la valeur dans HKCU (ton compte), puis dans HKU\.DEFAULT pour les valeurs par défaut des nouveaux utilisateurs, les S-* pour les utilisateurs système dans lesquels doit se trouver le login utilisé au moment de l'affichage de l'écran de login justement (puisque Windows ne sait pas que c'est toi qui veut utiliser l'ordi).

Link to post
Share on other sites

Alors merci pour vos réponses.

@Carpe_Diem, chez moi justement, le pavé numérique n'est pas activé, et je voudrais qu'il le soit.

@Edtech, je ne veux pas saisir de code PIN, mais mon mot de passe classique. Et je confirme que jusqu'ici ta 2ème phrase était valide, mais depuis ma fresh install ce n'est plus le cas. Autre changement, détail peut-être, j'ai maintenant un compte administrateur, que je n'utilise que très rarement, et je m'identifie sur mon compte user, et ce afin de limiter les risques en cas de problème : le compte actif n'a pas les droits d'admin, sauf élévation manuelle des privilèges.

@brice.wernet alors dans l'ordre :

  1. Je n'utilise pas la veille/veille prolongée, c'est un PC fixe et je souhaite qu'il soit 100% actif quand je le laisse allumé
  2. Un seul clavier, USB, toujours le même depuis... 10 ans
  3. C'est un logitech G19, avec ses pilotes et qui ne posait pas de souci particulier jusqu'ici
  4. Je n'ai pas ce genre de soft, par contre j'ai depuis récemment une manette xbox, toujours éteinte à l'allumage du PC.

Merci pour les explications du bitmask. Concernant la valeur 80000002, on ne peut la saisir en hexa ou en décimal car la valeur InitialKeyboardIndicators est une valeur chaine et pas DWORD. Je ne sais pas comment Windows gère ça derrière. Je vais remettre toutes les valeurs à "2" pour voir. Ce que tu décris est exactement ce que j'ai déjà testé maintes fois.

-> Edith : précision sur le comportement que je constate : ce matin, je démarre mon PC, le verrouillage numérique est -comme d'hab- désaactivé sur l'écran de login. Là, je redémarre sans m'identifier, et suite au redémarrage, le verrouillage numérique est à présent activé. Et à chaque redémarrage qui suit. Si j'éteins le PC et que j'attends quelques secondes avant de le rallumer : verrouillage numérique à nouveau désactivé.

Ça semble donc être une règle lié à l'allumage (fast boot ?) et non au reboot, qui force le rechargement entier de l'OS.

--> Edith2 : j'ai tenté avec un autre clavier USB standard (HP basique sans pilote) et j'ai exactement le même problème.

Edited by Nozalys
Link to post
Share on other sites

Essaye cela peut-être:

* Désactiver fastboot
* Modifer la base de registre comme tu l'as déjà fait
* réactiver fastboot

Il semble que fastboot conserve ses propres paramétrages.

https://www.howtogeek.com/244606/how-to-enable-num-lock-automatically-when-your-computer-boots/

https://www.tenforums.com/customization/30433-enable-numlock-fast-startup.html

Link to post
Share on other sites
  • 1 month later...
On 21/10/2019 at 09:43, brice.wernet a écrit :

Essaye cela peut-être:

* Désactiver fastboot
* Modifer la base de registre comme tu l'as déjà fait
* réactiver fastboot

Bon, il semble qu'en suivant cette procédure les choses s'améliorent. Je ne crie pas tout de suite victoire car il faut que je vérifie si ça tient une extinction longue, 1 jour par exemple.

Je viens également de constater que la diode du verrouillage numérique s'éteint juste après le splashscreen de la carte mère, pendant le chargement de l'OS, je n'avais pas vu ça avant, ou pas prêté attention. Je doute que la pile 3V de la carte mère soit en cause car tous mes paramètres de BIOS sont bien conservés.

Prochaine étape dans quelques jours 🙂

Link to post
Share on other sites

Eh bah non, rien n'a bougé d'un iota, toujours le même problème. Je crois que je vais laisser tomber et râler à chaque allumage de mon PC... ou changer de mot de passe et virer les chiffres. Mais qu'est-ce qu'il est débile, cet O.S. quand même, comparé aux précédents...

Link to post
Share on other sites

Clairement, au stade ou j'en suis, je vais essayer.

Mais je ne suis pas convaincu que ça s'applique à mon problème : c'est un programme qui se lance quand l'utilisateur est connecté. Moi j'en ai besoin juste avant : après le démarrage de Windows, sur l'écran de connexion donc quand aucun utilisateur n'est encore connecté. Je sais pas si je peux programmer une tâche planifiée de ce type..

Moche ou pas, si ça fonctionne.... ça m'ira !

Link to post
Share on other sites
  • 2 weeks later...
On 26/11/2019 at 14:30, CryoGen a écrit :

J'ai bien une solution... elle est moche mais ca devrait marcher :transpi:

https://superuser.com/questions/1206360/how-to-always-enable-numlock-by-default-on-windows-10

Oui avec un programme + tâche planifiée :dd:

Mince je voulais essayer aujourd'hui mais il n'y a que le code source.. Je vais compiler ça au boulot et tester dans la semaine.

Link to post
Share on other sites

bah c'est le github fournit par la solution de @CryoGen:

On 26/11/2019 at 14:30, CryoGen a écrit :

J'ai bien une solution... elle est moche mais ca devrait marcher :transpi:

https://superuser.com/questions/1206360/how-to-always-enable-numlock-by-default-on-windows-10

Oui avec un programme + tâche planifiée :dd:

j'ai juste aidé @Nozalys qui pensait devoir compiler l'appli lui-même.

pour info, le README est là:
https://raw.githubusercontent.com/brunolm/NumLock/master/README.md

Edited by Minikea
Link to post
Share on other sites

Alors manque de pot c'est pas encore ça. L'application NumLock fonctionne bel et bien, mais pas moyen de la faire se lancer *AVANT* l'ouverture d'une première session, donc avant la saisie d'un mot de passe sur l'interface de connexion.

J'ai fait une tâche planifiée sous mon compte admin, avec l'option "Exécuter même si aucun utilisateur n'a ouvert de session" et avec 3 déclencheurs : "au démarrage du système" + "lors du déverrouillage de la station de travail d'un utilisateur" + "lors de la connexion locale à une session utilisateur" pour bien blinder le truc, et... non. Ça ne fait pas ce que je veux.

Edit: J'ai également testé avec une GPO (méthode décrite ici) -> toujours rien !

La nouvelle question est donc : peut-on lancer un programme avant l'ouverture d'une première session après un démarrage ?

 

Edited by Nozalys
Link to post
Share on other sites

j'ai testé chez moi parce qu'il me semblait avoir le problème aussi.

En mettant "2147483650" (pas d'espaces!!!) sur InitialKeyboardIndicators dans "HKEY_USERS\.DEFAULT\Control Panel\Keyboard" (c'est un alias pour HKEY_USERS\S-1-5-18) ça a l'air de fonctionner.
Tu peux essayer de le mettre sur S-1-5-19 aussi mais ça servira à rien sur les autres par contre.

edit: par contre j'avais déjà fait des manip il y a un moment donc je n'exclue pas d'autres manipulations que celle-ci pour que ça fonctionne, notamment au niveau de la BCD.
(via BCDEdit pour changer des paramètres dans le fichier de boot de Windows 10)

Edited by Minikea
Link to post
Share on other sites

Je viens de tester à nouveau avec ces 2 paramètres --> Toujours pas !

Par contre, la valeur InitialKeyboardIndicators chez moi est de type REG_SZ (string). Or comme il mentionné plus haut une conversion hexa / décimal ( 2147483650 = 0x80000002). Chez vous elle est de type DWORD ou REG_SZ ?

Concernant bcdedit, je ne sais pas comment l'utiliser.. J'ai bien vu ça : Geoff Chappell - BCD Elements qui fait mention de la constante BCDE_LIBRARY_TYPE_NUM_LOCK_ON, prise en charge à partir de Win10 1803, mais je ne sais pas comment la lire/écrire.

By the way, ce site semble être une mine d'or...

Je finis par croire que quelque chose s'est "mal" passé pendant la dernière installation de Win10, parce que ce problème je ne l'ai jamais eu avant cette réinstall.

Edited by Nozalys
Link to post
Share on other sites

de type string aussi.

BCDEDIT ça peut être tendu: ça touche aux variables de boot de W10. si tu te loupes, ça boot plus. il te faudra un média d'install de W10 pour réparer. mais puisque le reste ne semble pas fonctionner, tu peux tenter ça.

Link to post
Share on other sites
Il y a 3 heures, Nozalys a écrit :

...
Par contre, la valeur InitialKeyboardIndicators chez moi est de type REG_SZ (string). Or comme il mentionné plus haut une conversion hexa / décimal ( 2147483650 = 0x80000002). Chez vous elle est de type DWORD ou REG_SZ ?
...

REG_SZ

Chez moi (Win10 x64 1909 CAFR, NumLock=On au boot, clavier 105 touches) :
HKCU\Control Panel\Keyboard\InitialKeyboardIndicators=2
HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\IniFileMapping\win.ini\Windows\InitialKeyboardIndicators=USR:Control Panel\Keyboard
HKLM\SOFTWARE\WOW6432Node\Microsoft\Windows NT\CurrentVersion\IniFileMapping\win.ini\Windows\InitialKeyboardIndicators=USR:Control Panel\Keyboard
HKU\.DEFAULT\Control Panel\Keyboard\InitialKeyboardIndicators=2147483648
HKU\S-1-5-18\Control Panel\Keyboard\InitialKeyboardIndicators=2147483648
HKU\S-1-5-19\Control Panel\Keyboard\InitialKeyboardIndicators=2147483648
HKU\S-1-5-20\Control Panel\Keyboard\InitialKeyboardIndicators=2147483648
HKU\S-1-5-21-583243149-2327021236-3435448560-1117\Control Panel\Keyboard\InitialKeyboardIndicators=2
HKU\S-1-5-80-4287524181-3401991209-718407576-1481970793-3068686015\Control Panel\Keyboard\InitialKeyboardIndicators=2147483648

Link to post
Share on other sites

Je vais tenter de copier la conf de @Aloyse57.

Concernant le isque avec BCDEdit, je verrais... avec une image disque via clonezilla ça peut aller vite une récupération. Sinon le workaround de base c'est que je supprime les chiffres de mon mot de passe de session !

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...