Jump to content

Archived

This topic is now archived and is closed to further replies.

freddewitt

Xgl : Linux a la classe version OpenGL

Recommended Posts

Salut, je viens aussi d'installer beryl sur ma suse 10.1, ça marche pas mal à part mes bordures de fenètres qui ont disparu, et je n'ai pas encore trouvé le bon réglage. Il y a beaucoup de nouveaux effets. Beryl-manager permet de passer de compiz à beryl (ou metacity...) sans redémarrer ni fermer la session. Je précise que je tourne avec une ati 9800 pro et les drivers proprio... alors j'ai un peu galéré, surtout que régulièrement après une mise à jour, je perds xgl, et je dois tout réinstaller..

Enfin bon, ça semble présager de belles choses à venir.

A noter aussi kiba-dock (fonctionnait déjà avec compiz) pour ceux qui ne connaissent pas!

Moi j ai desinstallé xgl apres l'installe de Beryl car j avais quelques soucis (je suis en Xorg 7.1)

Share this post


Link to post
Share on other sites

C'est juste excellent, c'est fluide et les animations sont cool. Dommage que sous KDE les bureaux virtuel bug un peu (Meme avec le kicker-compiz)

Share this post


Link to post
Share on other sites

Salut, je viens aussi d'installer beryl sur ma suse 10.1, ça marche pas mal à part mes bordures de fenètres qui ont disparu, et je n'ai pas encore trouvé le bon réglage. Il y a beaucoup de nouveaux effets. Beryl-manager permet de passer de compiz à beryl (ou metacity...) sans redémarrer ni fermer la session. Je précise que je tourne avec une ati 9800 pro et les drivers proprio... alors j'ai un peu galéré, surtout que régulièrement après une mise à jour, je perds xgl, et je dois tout réinstaller..

Enfin bon, ça semble présager de belles choses à venir.

A noter aussi kiba-dock (fonctionnait déjà avec compiz) pour ceux qui ne connaissent pas!

Verifie bien avec emerald-theme-manager que tu as un theme qui fonctionne bien (change un peu pour voir), car moi non plus au depart j'avais plus les bordures et en lancant emerald il se passait rien. J'ai change le theme, lance emerald et pouf ca s'est remit d'un coup .

Share this post


Link to post
Share on other sites

C'est juste excellent, c'est fluide et les animations sont cool. Dommage que sous KDE les bureaux virtuel bug un peu (Meme avec le kicker-compiz)

Tu entends quoi par bug un peu (je veut tester et j'utilise beaucoup les bureau virtuel)

Share this post


Link to post
Share on other sites

C'est juste excellent, c'est fluide et les animations sont cool. Dommage que sous KDE les bureaux virtuel bug un peu (Meme avec le kicker-compiz)

Tu entends quoi par bug un peu (je veut tester et j'utilise beaucoup les bureau virtuel)

Sans kicker-compiz, les bureaux virtuels ne marches pas du tout :craint: . Avec, il ya quelque probleme pour deplacer les miniatures entres les differents bureaux mais sinon ca va.

kicker-compiz est sur kde-apps.org il me semble.

Share this post


Link to post
Share on other sites

Verifie bien avec emerald-theme-manager que tu as un theme qui fonctionne bien (change un peu pour voir), car moi non plus au depart j'avais plus les bordures et en lancant emerald il se passait rien. J'ai change le theme, lance emerald et pouf ca s'est remit d'un coup .

C'était à peu près ça, j'ai viré et réinstallé emerald, et maintenant tout fonctionne. Mais comme pour targa, les performances de la machine semblent un peu ralenties.

Aujourd'hui : nouvelle mise à jour sur software.opensuse.org pour beryl et compiz, si certains sont tentés.

Share this post


Link to post
Share on other sites

J'ai installé Beryl sur mon Dual Core et excellent.

Ayant un portable aussi, ça me tenterait bien mais seul hic pas du tout la même config. N'ayant pas trouvé de config minimale, je fais appel aux "Experts" :up:

Le portable:

* Celeron 1.8Ghz

* 256 Mb RAM

* Geforce 4 420 Go (16Mb)

Je sais qu'il y en a qui l'ont installé sur la même carte 3d que moi mais en 32Mb donc, je me dis, peut-être, espérons...

Share this post


Link to post
Share on other sites

J'ai installé Beryl sur mon Dual Core et excellent.

Ayant un portable aussi, ça me tenterait bien mais seul hic pas du tout la même config. N'ayant pas trouvé de config minimale, je fais appel aux "Experts" :roll:

Le portable:

* Celeron 1.8Ghz

* 256 Mb RAM

* Geforce 4 420 Go (16Mb)

Je sais qu'il y en a qui l'ont installé sur la même carte 3d que moi mais en 32Mb donc, je me dis, peut-être, espérons...

Ca me semble possible (du moins pour compiz tout court).

Essaie la FC6 peut etre :up:

Share this post


Link to post
Share on other sites

theocrite, juste pour info je pensais suivre ton idée initialement mais je me suis dit, je suis pas un primate (c'est dur de faire semblant) et donc pour ça que je posais la question :transpi:

pcboy, Edgy me va bien tu sais... puis j'ai pas de dvd/cd sous la main...

Share this post


Link to post
Share on other sites

Le problème de XGL + compiz sur un portable, c'est que la consommation électique monte en fleche...le CPU et la CG ne s'underclockent jamais...j'avais testé sur mon portable (AMD TurionX2 TL50 + ATI Xpress1100) et je l'ai viré vite fait...en plus XGL et Netbeans semblent avoir un peu de mal à s'entendre pour le moment...spa top :-/

Share this post


Link to post
Share on other sites

Ben ya que les centrino qui s'underclockent non?

Ici c'est un celeron donc la conso on s'en fout un peu...

Pour ma part, j'ai un centrino et il s'underclocke parfaitement avec XGL+Compiz :zarb:

Je tourne souvent aux alentours des 600 voire 800Mhz

Share this post


Link to post
Share on other sites

Sans XGL, mon turionX2 TL50 est en permanance à 800Mhz...avec de temps en temps une poussée à 1.6Ghz sous certaines applications ou lors d'une compilation un peu lourde...avec une vidéo ou de la musique lancée en background...le fait que mon CPU remonte aussi en fréquence est peut être aussi du à la faiblesse du chip 3D...grosso modo équivalent à un chip Intel...mais bon...de toutes manières, vu que j'utilise intensivement NetBeans et qu'il a une légère tendance à bugger lorsque XGL est activé...ca regle le problème...c'est un portable pour bosser pas pour en mettre plein la vue :chinois:

Share this post


Link to post
Share on other sites

et alors, c'est pas parce que tu as un sabre "ANCIEN" que tu es à la retraite, hein... :transpi:

:transpi:

Share this post


Link to post
Share on other sites

Bon, faut une config adapté de xorg.conf pour la Geforce 4 420Go avec les drivers nVidia en beta.

Du coup, bah, je ne me suis pas cassé la tête et hop XGL + Beryl... bref, un peu plus lent pas des masses mais ça rox :)

Voilà pour le feedback

Share this post


Link to post
Share on other sites

et alors, c'est pas parce que tu as un sabre "ANCIEN" que tu es à la retraite, hein... :chinois:

:yes:

Pas vraiment...et c'est d'ailleurs pour ca que je suis un modo retraité 8)

Share this post


Link to post
Share on other sites

J'ai installé Xgl + Beryl, çà marche.

Joli effet.

Par contre, un petit soucis :

lorsque je me connecte avec Xgl, je ne peux plus changer d'utilisateur.

çà revient toujours sur le mien avec demande de mon pass, pas moyen de basculer sur un autre login ?

une idée ?

Du coup, ben suis revenu sous gnome (enfin, le normal).

(j'ai mis beaucoup de temps à convertir ma femme à linux, alors, faudrait pas que je la bloque...)

Share this post


Link to post
Share on other sites

Moi aussi, XGL + Beryl sous Edgy Eft sur mon portable, et que c'est beau. :mdr2:

C'est la première fois que j'arrive à le faire fonctionner, et bien, c'est classe, ça en jette, c'est assez inutile mais en réglant un peu les options, on arrive à quelque chose d'opérationnel, voire d'utile, je vais m'identifier dessus au moins un moment, pour vois si ça me lasse pas..

Quand je retourne sur le fixe qui est sous XP, ça me paraît bien fade.

Le seul truc qui me pose problème, c'est que le double-clic sur la barre de titre d'une fenêtre ne redimensionne pas la fenêtre mais enroule le contenu dans la barre de titre. Ca ne pose pas de problèmes pour passer du plein écran en mode fenêtré grâce à un effet qui s'en charge, mais dans l'autre sens, c'est un peu fastidieux de devoir viser la petite case plein écran à côté de la case fermeture de la fenêtre.

Share this post


Link to post
Share on other sites

Ca tu peux le configurer avec l'utilitaire du gestionnaire de fenetre...

Enfin... En tous cas, avec compiz j'allais dans le menu et je choisissais l'action appropiée....

Share this post


Link to post
Share on other sites

Petite question :

J'ai dernièrement installé une mandriva 2007, avec les drivers nvidia beta (sur une 6600GT), ainsi que beryl, le tout à l'aide du dépôt de Plouf.

Beryl-manager se lance bien, beryl aussi d'ailleurs (j'ai le splash screen), et j'ai même droit aux effets... Cependant le souci est que je n'ai aucune décoration de fenêtres.

J'ai essayé de recharger le décorateur, de changer de thème, mais rien n'y fait.

Une idée ?

PS : j'ai aussi remarqué que l'écran de veille faisait tout freezer, un moyen d'éviter ça ?

Edit : pour info, j'utilise AIGLX et non XGL.

Share this post


Link to post
Share on other sites

Petite question :

J'ai dernièrement installé une mandriva 2007, avec les drivers nvidia beta (sur une 6600GT), ainsi que beryl, le tout à l'aide du dépôt de Plouf.

Beryl-manager se lance bien, beryl aussi d'ailleurs (j'ai le splash screen), et j'ai même droit aux effets... Cependant le souci est que je n'ai aucune décoration de fenêtres.

J'ai essayé de recharger le décorateur, de changer de thème, mais rien n'y fait.

Une idée ?

PS : j'ai aussi remarqué que l'écran de veille faisait tout freezer, un moyen d'éviter ça ?

Edit : pour info, j'utilise AIGLX et non XGL.

Tu a pas lu les tuto qui explique comment faire avec le pilote NVIDIA beta + beryl, je parie relativement cher que tu a oublier de rajouter dans le xorg.conf:

Dans la section DEVICE tu rajoute

Option "AddARGBGLXVisuals" "True"

Et dans la section screen aussi .

Ce qui donne en gros :

Section "Device"

Identifier "device1"

VendorName "nVidia Corp."

BoardName "NVIDIA GeForce 7 Series"

Driver "nvidia"

Option "DPMS"

Option "AddARGBGLXVisuals" "True"

EndSection

Section "Screen"

Identifier "screen1"

Device "device1"

Monitor "monitor1"

DefaultColorDepth 24

Option "AddARGBGLXVisuals" "True"

Ca devrait marcher bcps mieux ... Ah aussi pour info avec le dernier pilote NVIDIA tu a besoin NI DE XGL NI DE AIGLX pour faire marcher beryl

Share this post


Link to post
Share on other sites

lance beryl avec cette commande pour voir :

beryl-manager --no-force-window-manager --no-force-decorator

(pour lancer le beryl decorator à la mano : emerald --replace&)

Share this post


Link to post
Share on other sites

×
×
  • Create New...