Jump to content

Archived

This topic is now archived and is closed to further replies.

freddewitt

Xgl : Linux a la classe version OpenGL

Recommended Posts

- drivers libres avec AIGLX (pour le driver r300 par exemple)

C'est a dire?

- drivers proprios qui l'intègrent (driver nvidia)

J'ai une ati, elle va pas etre contente si je lui donne un driver nvidia a manger :pleure:

- n'importe quel driver en utilisant Xgl (driver fglrx)

Oui évidemment... et je vais finir par y recourir si ca continue...

Share this post


Link to post
Share on other sites
- drivers libres avec AIGLX (pour le driver r300 par exemple)
C'est a dire?

Ben il faut utiliser les drivers libres r300 qui sont disponibles pour toutes les cartes ATI utilisant cette puce... Et activer aiglx... y'a plein de tutos sur le net, pour les 2 :francais:

Oui évidemment... et je vais finir par y recourir si ca continue...

Ben en fait t'as pas énormément de choix :francais:

Share this post


Link to post
Share on other sites

Ben pour moi c'est la meilleure des sources! Quoi de mieux que le SVN officiel pour appuyer son propos?

Share this post


Link to post
Share on other sites
Ben pour moi c'est la meilleure des sources! Quoi de mieux que le SVN officiel pour appuyer son propos?

En même temps là y'a 4 nouvelles lignes et une ligne supprimée... Ah si y'a le commentaire mais bon ça suffit pas vraiment à mon avis...

Le topic sur le forum par contre c'est bien :ouioui:

Share this post


Link to post
Share on other sites

Ben, on parlait du support sur les 8*** qui est apparu avec ce changeset là, j'allais pas filer les changesets à propos du copy-mode en général :ouioui: Faut être précis dans la vie -.-

Share this post


Link to post
Share on other sites

Salut,

Bon ben hier j'ai craqué : j'ai fini par installer mandriva 2007.

Et la, surprise, l'accélération de ma carte graphique (radeon 9800Pro) est prise en charge dès le début, du coup un petit drak3D, et compiz tourne bien!

Aujourd'hui, j'essaie de passer à Beryl.

Donc, pour tyrann27, si le DRI de ta carte fonctionne avec ce driver, tu peux utiliser AIGLX et non XGL pour faire tourner compiz ou beryl.

Share this post


Link to post
Share on other sites

C'est ce que je croyais aussi...

Je me suis dit qu'avec le DRI fonctionnant, j'aurais pas de soucis...

Mais bon apparement ca ne suffit pas et je vais creuser du coté de ce que tuXXX m'a donné :francais:

Share this post


Link to post
Share on other sites

Bonjour, j'ai installé les derniers drivers nvidia (9629) sous ubuntu, et maintenant "Enemy Territory" rame beaucoup, vous avez une idée pour revenir à la version précedente, 8772 je crois?

Share this post


Link to post
Share on other sites

Salut à tous, pour ceux que ça tente (si ce n'est pas déjà fait), voici un petit scipt pour lancer beryl quand on veut avec AIGLX (par exemple en le plaçant dans ~/.kde/Autostart, pour l'activer dès l'ouverture de session sous kde):

#!/bin/sh

#/usr/bin/startcompiz

killall beryl-manager

sleep 5

beryl --indirect-rendering --strict-binding --replace dbus settings &

sleep 5

beryl-manager

edit : les options indiquées peuvent bien sur etre modifiées et sont celles données par le man de beryl

Merci

Share this post


Link to post
Share on other sites

Euuuuh ton script là :/

T'es sur que c'est bien utile tout ça? Normalement juste "beryl" ou "beryl-manager" suffisent, beryl détecte automatiquement les options à mettre par défaut (et ya que du défaut là) :/

Share this post


Link to post
Share on other sites

Euuuuh ton script là :/

T'es sur que c'est bien utile tout ça? Normalement juste "beryl" ou "beryl-manager" suffisent, beryl détecte automatiquement les options à mettre par défaut (et ya que du défaut là) :/

Ben peut être que je me suis un peu emballé sur ce coup là alors, ça doit être pour ça que je n'ai pas vu de différence avec ou sans ces options... Par contre, chez moi "beryl-manager" ne lance pas beryl, et "beryl" utilisé seul ne lance pas le décorateur de fenêtres (emerald). D'où ce petit script qui, placé sur mon bureau, me permet de lancer beryl par un simple clic! (avec ça je pourrait même coller un sticker "feignant inside" sur ma tour).

Share this post


Link to post
Share on other sites

Ben voila, j'ai du passer par XGL mais bon... Pas vraiment le choix en fait...

Mon avis? Tres tres bien, un peu décu de ne pas avoir l'effet cramage de fenetre comme plouf mais je vais essayer de trouver ca :arrow:

Sinon je trouve que c'est nettement moins lourd que compiz et a part un bug jusqu'a maintenant (30min seulement...) j'ai pas de soucis :arrow:

Pour le bug, c'est mon menu Applications qui ne s'affiche pas, pourtant si je descend avec la souris, le sous-menu s'ouvre (sauf celui des jeux, c'est un complot j'en suis sur) et voila...

Enfin bon, p'tet que ca disparaitra apres un redémarrage du serveur X, c'est du tout frais aussi....

Share this post


Link to post
Share on other sites

tyrann27 tu es sous ubuntu je suppose ? Pour avoir le burn faut la version 1.1.2 de beryl . Si tu veux il y'a la version daily directement sortie du svn de beryl ici : http://3v1n0.tuxfamily.org/dists/edgy/beryl-svn/ .

Tu as même le droit à l'effet 3d lorsque tu tourne le cube, et le cube transparent (et plein d'autre trucs que j'ai pas encore compris :fou: ) .

Par contre c'est un chouilla moins stable, surtout emerald, mais qd on y touche plus c'est bon :)

Share this post


Link to post
Share on other sites

A noter que ces paquets svn sont déconseillés, non supportés, et souvent pétés...

Share this post


Link to post
Share on other sites

Merci pour l'info, mais je vais laisser comme ca...

J'ai pas vraiment envie d'installer des paquets malades...

Share this post


Link to post
Share on other sites

A noter que ces paquets svn sont déconseillés, non supportés, et souvent pétés...

bof c'est pas la cata s'il y'a un prob, tu ouvres juste une session gnome de secours, et le lendemain beryl refonctionne. :ouioui:

Share this post


Link to post
Share on other sites

J'ai mon clavier qui déconne...

J'ai changé dans les préférences de gnome, j'ai vérifié dans le xorg.conf et j'ai testé avec setxkbmap:

tyrann@sebastien:~$ setxkbmap -model pc105 -layout be -variant latin9
Couldn't interpret _XKB_RULES_NAMES property
Use defaults: rules - 'xorg' model - 'pc101' layout - 'us'
Error loading new keyboard description
tyrann@sebastien:~$ 

En fait, pour le moment je ne sais plus utiliser la touche Alt Gr et avec control-alt ca va pas :copain:

J'ai cherché sur le net et certains ont eu ce problème avec kde et l'ont résolu avec cette commande... Moi c'est gnome mais je vois pas ce que ca change...

Share this post


Link to post
Share on other sites

étrange ...

moi je n'ai absolument aucun soucis avec beryl et gnome

juste a relancer beryl de temps a autres...

Share this post


Link to post
Share on other sites
C'est XGL le problème... (je pense)

J'ai oublié de le préciser...

ahh bah j'ais pas cet inconveniant

Share this post


Link to post
Share on other sites

×
×
  • Create New...