Jump to content

Archived

This topic is now archived and is closed to further replies.

-rem-

[Debian GNU/Linux] Topic Officiel

Recommended Posts

Ben si.... juste le numero de disque qui changera.

Même pas, je rapelle que pour grub, le disque dur sur lequel grub se trouve est toujours considéré comme le hd0...

Share this post


Link to post
Share on other sites

euh oui mais c'est un raid 1, donc theoriquement il te faut le bootloader sur les 2 durs. Si un dur lache physiquement, il faut que le second puisse booter, le premier dur débranché.

Share this post


Link to post
Share on other sites

:craint:

Un lien intéressant, référencé par les leaders du projets debian, donc tres certainement de grande qualité : cliquez ici

EDT : oops, merci lorinc, z'avais pas vu !

Share this post


Link to post
Share on other sites

Une "sous-version" ( comprendre déclinaison ) de debian très renforcée au niveau sécurité, volontairement orientée sécurité pour paranoiaque. Si ca intéresse quelqu'un... j'essaierai d'incorporer une présentation sous peu de debian hardened dans ce topic, en attnedant, si vous voulez y jeter un oeil :

http://sourceforge.net/projects/debianhardened

Share this post


Link to post
Share on other sites

Salut tout le monde ........

bon j'ai un gros souci, avec cette saloperie de DEBIAN à la con ...... :kill:

je dois monter un serveur, et donc j'avais prévu du raid 1 software :8 , le tout sur 2 seagate 200 Go. :-D

Déja pas très intuitif pour monter le raid lors de l'install :cnul:, j'arrive a configurer mes 5 partition en raid 1 ( dont /boot et / )

à la fin de l'install ( il aurait pu le dire au début ce con ;) ) il me dit que debian ne gère pas les systèmes ou le / ou le /boot sont du raid 1 ... :pleure: et que ça ne va pas booter :mad2:

sans pitié je continu, :troll: , et la paf il me dis installation impossible :D .

je tente LILO, et pareil :D

du coup j'ai pas programme de démarrage et par conséquent, ça ne boote pas :D

sachant que normalement il n'y aura pas de lecteur de disquette ( enfin ça va peut être être indispensable )

comment je peux faire pour que mon système boot ????

je peux mettre lilo sur une disquette et booter sur la disquette ???? ( si quelqu'un sait comment faire je suis preneur, car je n'ai absolument pas le temps de chercher en ce moment :pleure: )

sinon peut être en bootant avec une gentoo/ rescue cd ........

en faisant un chroot en modifiant le lilo.conf, et ensuite en relançant lilo ?? :keskidit:

en plus je crois qu'il n'a pas mis que les partoches /boot étaient ootable lors de l'install ( il ne voulait pas :mad:) donc du coup ça ne marchera peut être pas sans encore modifier la table des partitions sous fdisk, pour rendre la partition /boot bootable :fou:

quelle galère....

si vous avez une solution simple et rapide........

Share this post


Link to post
Share on other sites

Salut alex,

On te voit plus beaucoup... :keskidit: tu taf ?

Pour ton, probleme, il faudrait tout simplement créer une partition en /boot qui ne soit pas en raid, limite tu la duplique a la main sur un autre disque dur.

Ensuite, tu boot le livecd gentoo, et tu installes grub dessus, et ca devrait le faire. Moi j'ai mon raid 0 software, mais un disque dur à un partoche /boot de 100Mo en début de disque pour grub. Et tout le reste du systeme est en raid software.

bon courage,

remy

Share this post


Link to post
Share on other sites

boot sur CD ou clé USB ou par disquette

pis après c'est pas dur, tu casse ton md sur lequel tu as le /boot, tu reformate en ext2/ext3, tu y mets ton noyau et tu reconfigurer grub comme il faut.

C'est comme ça chez moi : 5 partoches par disque, RAID0 entre, sauf pour le /boot (l'équivalent sur l'autre disque est une partition de swap)

par contre je suis ETONNE car les docs disent boot impossible en RAID0, pas en RAID1. T'as bien compilé le RAID en dur dans ton noyau ?

Share this post


Link to post
Share on other sites

Sandeman.... :keskidit:

par contre je suis ETONNE car les docs disent boot impossible en RAID0, pas en RAID1. T'as bien compilé le RAID en dur dans le noyau ?

Oui, je n'ai pas trop réagit en me disant que Dark avait du tester, et que je n'ai pas essayer de booter un /boot en raid, mais je pensais aussi que le probleme se posait uniquement pour le raid 0, logique, car les données sur une partition isolée ne sont pas exploitables, alors que sur du raid 0 si.

au passage, au lieu de mettre dans grub kernel=/dev/mdx/.. tu mets /dev/hda1 par exemple, ou hda1 est la partoche /boot, ca devrait le faire au pire, non ?

Share this post


Link to post
Share on other sites

ben oui normalement pas de problème en raid 1 ( j'accède aux partoches avec un mount tout con )

pas besoin d'une partition spécial ( ça marchait très bien chez moi, mais j'avais fait ça à la mano, pas avec l'install de la debian).

mais la avec la procedure d'install il ne veut pas :keskidit:

il faut que je me fasse un chroot et que je reconfigure Grub .. ( ou lilo )

en fait il me faut un truc tout con, c'est à dire une disquette de boot avec lilo dessus, qui monte ma partition md0 pour le boot et ma partition md1 pour le /

une fois que je suis dans le système, il me suffit d'installer lilo et de le mettre dans les 2 mbr ( comme j'avais fait en fait chez moi....)

vous avez une procédure facile pour ça ????

en fait comment dire à lilo de s'insatller sur le mbr de la disquette et pas sur celui du disque dur ???

Share this post


Link to post
Share on other sites

Bon je sais maintenant pourquoi ça ne marche pas :-D ( c'est marqué pourtant )

pour avoir son système sur du raid soft, il faut ABSOLUMENT que certaines options soit en hard dans le kernel

Appendix A Kernel Config, Multiple Devices

  x x [*] Multiple devices driver support (RAID and LVM)

  x x <*> RAID support

  x x < > Linear (append) mode

  x x < > RAID-0 (striping) mode

  x x <*> RAID-1 (mirroring) mode

  x x < > RAID-4/RAID-5 mode

  x x <*> Multipath I/O support

  x x <*> Logical volume manager (LVM) support

  x x      [ ] Quota support                                                     

  x x      < > Kernel automounter support                                         

  x x      <*> Kernel automounter version 4 support (also supports v3)           

du coup il faut déja que je recompile mon kernel pour qu'au démarrage suivant, mon système puisse prendre en compte le raid ..... :D

enfin j'espère que ça marchera après ....

Share this post


Link to post
Share on other sites

Raphaël Hertzog a sorti un livre consacré à la sarge. C'est le premier livre français exclusivement consacré à Debian GNU/Linux.

Elle est disponible en libraire à partir d'aujourd'hui.

Titre: Debian GNU/Linux

Auteur: Raphaël Hertzog

ISBN: 2-212-11398-6

Site web: http://www.ouaza.com/livre/admin-debian/

Le sommaire

La couverture

Share this post


Link to post
Share on other sites

Ouais, j'ai répondu a ce mec la.

Toutefois, je pense que vu les nombreux tutos et guides sur le net ( y compris les guides de référence debian officiels, guide de l'utilisateur etc... je pense que c'est peu utile tout de meme.

Share this post


Link to post
Share on other sites

Ben je ne suis pas sûr. Moi j'aime bien l'idée. Un mec qui commence sur une debian, il aura pas forcément le réflexe man, moteur de recherches, forums, newsgroups... Et pour peu qu'il ne connaisse pas beacoup de linuxiens, il va avoir du mal.

L'important, c'est que c'est accessible grand public.

On peut savoir ce que tu lui a dit ?

Share this post


Link to post
Share on other sites

Argh j'ai effacé mon message, j'avais pas vu que theocrite avait écrit la même chose juste au dessus :mdr:

Share this post


Link to post
Share on other sites

On peut savoir ce que tu lui  as dit

Que je lui présentais mes félicitations et que c'etait tres bien, que je le lirai surement, comme tous les ouvrages debian. J'ai aussi ajouter que j'avais dans l'idée d'ecrire un livre sur debian, mais qu'il fallait bcp de temps, de connaissance et de recherches.

Share this post


Link to post
Share on other sites

bonjour,

j'ai un probleme pour l'installation des drivers ati:

make.sh tout va bien, mais au make_install.sh il me met ca:

- creating sysmlink

- recreating module load of the kernel module

-trying a sample load of the kernel module

FATAL: Error insterting fglrx (/lib/modules/2.6.8.1/kernel/drivers/char/drm/fglrx.ko): Operation not permitted

failed.

le noyeaux vien d'etre compile pourtant...

P.S. j'ai pas configure le clavier pour le monent desole pour les accents etc... :D

Share this post


Link to post
Share on other sites

T'en fais pas pour les accents, ce n'est pas non plus mon fort. Tant que Théocrite ne passe pas ici, tu resteras en vie... :craint:

Eh bien as tu autorisé le chargement de modules pour le noyau ( make menuconfig ) ? Es-tu bien root ? N'est il pas deja inséré ( lsmod ) ?

Share this post


Link to post
Share on other sites

Autorisé le chargement de modules? euh... c'est a dire que.... ben... j'en sait rien au fait :yes:

j'ai chargé un driver ati radeon en dur dans le kernel à la compilation mais après réflèxion je me dit que j'aurais pas du. à confirmer...

cependent le fichier fglrx.ko dans /lib/modules/2.6.8.1/kernel/drivers/char/drm/ existe bien, j'ai aussi essayé de lui donner tout les droits (666) mais rien n'y fait.

oui je l'ai fait en root :-D

il n'apparait pas dans lsmod, j en déduit qu'il n'est pas chargé, ou inseré.

merci pour ton aide :byebye:

EDIT: ajout des accents :mdr:

Share this post


Link to post
Share on other sites

Eh bien en fait, lors de la compilation de ton noyau, il ne faut pas l'inclure, tu mets rien, juste le support de ton bus agp dans character device et ensuite, tu compilera les pilotes ATI a la main. Un tuto existe d'ailleurs et il est tres bien fait ( Sentinel ), beaucoup l'ont suivi avec succes.

Share this post


Link to post
Share on other sites

Tadadada... Tadada (Musique d'Indiana Jones)

T'en fais pas pour les accents, ce n'est pas non plus mon fort. Tant que Théocrite ne passe pas ici, tu resteras en vie... :p
:mdr: De toutes façons, tout le monde met un accent à theocrite (et des fois un 'r' en trop).

Et je n'ai rien contre les fautes involontaires :fumer:

le noyeaux noyaux vien  vientd'etre compile pourtant...

P.S. j'ai pas configure le clavier pour le monent desole pour les accents etc... ;)

Les accents c'est pas grave ;)

http://spellbound.sourceforge.net/ est là pour corriger toutes les fautes. :D

Share this post


Link to post
Share on other sites

RAV - completement HS :

Si presque tout le monde met un accent à théo, c'est parce que ça parait plus logique, alors que l'idée ne viendrait même pas d'en mettre sur theocrite... :fumer:

fin du HS

-------------------------------

Share this post


Link to post
Share on other sites

salut a tous

je viens de trouver un lien avec des jaquettes pour debian (certains doivent connaitre) mais je me suis dit pourquoi ne pas le rajouter dans la section du tuto pour les fanatique de jaquettes :keskidit:

voici le lien----> jaquette debian

Share this post


Link to post
Share on other sites

×
×
  • Create New...