Jump to content

[Debian GNU/Linux] Topic Officiel


-rem-

Recommended Posts

  • 3 weeks later...
  • Replies 381
  • Created
  • Last Reply

Bonjour à toutes et à tous,

Pour la configuration de xserver-xfree86, l'identifiant du bus de la carte video de ma 9800XT doit-être renseigné,

Dois-je simplement indiquer R365 ?

Merci

Frequence Mémoire : 365MHz et Fréquence Processeur : 412 MHZ

Link to post
Share on other sites

Bonjour à toutes et à tous,

Pour la configuration de xserver-xfree86, l'identifiant du bus de la carte video de ma 9800XT doit-être renseigné,

Dois-je simplement indiquer R365 ?

Merci

Frequence Mémoire : 365MHz et Fréquence Processeur : 412 MHZ

avec dpkg-reconfigure xserver-xfree86 ca ne te le detecte pas automatiquement ?

Et est ce un serveur ou un machine de bureau que tu souhaites installer .Sinon je te conseillerai plutot d'utiliser xserver-xorg :)

Et aussi d'installer les drivers ATi histoire de pouvoir utiliser de l'openGL

Link to post
Share on other sites
  • 3 weeks later...

Bon, une autre petite astuce.

Si vous voulez que votre Debian soit la plus légère possible, vous pouvez lui demander de ne pas installer les dépendances taggées "recommanded", ce qui est son comportement par défaut.

Lancez aptitude

F10

dans les onglets, allez à "gestion des dépendances"

décochez "installer automatiquement les paquets recommandés"

Voilà.

Normalement, lors de l'installation d'un logiciel, il vous mettra "les paquets suivants sont recommandés mais ne seront pas installés".

Lors des upgrade/dist-upgrade, il supprimera les paquets installés alors qu'ils étaient seulement recommandés ("les paquets suivants sont inutilisé blablabla".

Bref; vous gagnez de l'espace disque, du temps de téléchargement et d'installation/mise à jour.

Parfois, vous voudrez installer toutes les dépendances, même celles qui sont recommandées.

Il faut alors tapper

aptitude install -r nom_du_paquet

L'option -R fait l'inverse.

Voilà.

Attention:

Si vous êtes débutant, évitez, parce qu'il faut être capable d'identifier d'éventuels problèmes.

Par exemple, l'installation des sources du noyau ne vous installera pas make, ni gcc...

neo

Bonus:

Pour avoir complètement la main sur sa machine, faire un:

dpkg-reconfigure debconf

Choisir "basse".

A chaque installation/mise à jour de programme, on vous posera toutes les questions possibles, et vous contrôlerez précisement leur configuration.

Faudrait qu'on lance une section "astuces", ca ressuciterait le topic...

Link to post
Share on other sites
  • 1 month later...

Bonjour à tous,

Je viens de compiler un noyau 2.6.15.4 (ma première compilation :D ), par contre quand je reboote sur ce noyau, tout se passe bien jusqu'au chargement de gdm...

en regardant la sortie de X, il se trouve que celui-ci ne trouve pas le module NVIDIA ( [EE] NVIDIA(0): Failed to load the NVIDIA kernel module !).

Les pilotes que j'utilise, ont été installé à l'aide de l'installeur NVIDIA sur mon premier noyau, je suis débutant et je ne sais pas comment faire prendre en compte au nouveau noyau, le module que j'utilisais jusqu'a présent (j'ai essayé insmod et modprobe, mais il ne trouve pas de module nvidia).

Merci

:roll:

Link to post
Share on other sites

les modules noyau propriétaires, qu'ils soient nvidia, ati ou autres, doivent être réinstallés à chaque fois que tu recompile un noyau...

donc tu relance l'installer nvidia et ça devrait le faire (désolé je n'ai pas la synthaxe en tête mais c'est bateau ...)

:roll: pour ta première compile, sinon ...

Link to post
Share on other sites

C'est normal, X le cherche dans le répertoire /lib/modules/lenumerodetonnouay qui a changé, il faut donc relancé le .run de NVidia pour recompiler/réinstaller les drivers pour le 2.6.14.

En tout cas bravo pour la compil :roll:

EDIT: Arf grilled

Link to post
Share on other sites

:sms: merci à vous deux, je viens de tester tout ça et x refonctionne parfaitement.

Par contre, j'ai testé en démarrant sur mon ancien noyau et c'est lui qui ne trouve plus les modules nvidia mais ça doit être normal (c'est juste pour info) ?

J'ai une question à propos des messages qui défilent au chargement du système, je vois un message "i810_audio disabled in configuration" furtivement au démarrage, cependant quand je fais dmesg | grep i810, il ne trouve rien, est-ce normal ? :chinois:

Link to post
Share on other sites

:yes: merci à vous deux, je viens de tester tout ça et x refonctionne parfaitement.

Par contre, j'ai testé en démarrant sur mon ancien noyau et c'est lui qui ne trouve plus les modules nvidia mais ça doit être normal (c'est juste pour info) ?

J'ai une question à propos des messages qui défilent au chargement du système, je vois un message "i810_audio disabled in configuration" furtivement au démarrage, cependant quand je fais dmesg | grep i810, il ne trouve rien, est-ce normal ? :dix:

Etrange que le module ai disparu sur ton ancien mnoyau, il n'y a pas de raison, teste un find sur /lib/modules/ pour repérer tout ce qui est nvidia.

Pour la question numéro 2 c'est étrange aussi, mais j'ai toujours eu un flou sur ce qui était dans dmesg et ce qui n'y était pas. Question bête: tu as le son? si oui bah "oublie" le message :fumer:

Link to post
Share on other sites

si tu es passé de 2.4 en 2.6, le nom des modules a changé.

En tout cas sur mon portable, le module pour le son s'appele snd_intel8x0 donc tente plutôt un dmesg | grep 8x0

remarque dans la même catégorie, quand je boot, même en quiet, j'ai deux messages "Null symbol found" que je ne retrouve pas ni dans les logs (/var/log/syslog, /var/log/messages) ni dans le dmesg :fumer:

Link to post
Share on other sites

si tu es passé de 2.4 en 2.6, le nom des modules a changé.

En tout cas sur mon portable, le module pour le son s'appele snd_intel8x0 donc tente plutôt un dmesg | grep 8x0

remarque dans la même catégorie, quand je boot, même en quiet, j'ai deux messages "Null symbol found" que je ne retrouve pas ni dans les logs (/var/log/syslog, /var/log/messages) ni dans le dmesg :francais:

Ca peut s'expliquer: typiquement c'est issu d'un printk dans le noyau donc suivant le niveau de verbosité choisi dans l'appel ca peut ne pas être présent dans les logs je pense. A tester en tout cas. :reflechis:

Link to post
Share on other sites
  • 2 weeks later...

tiens ch'tite question (pour réupper un peu le topic au passage)

quelqu'un saurait comment limiter les débits lors d'un apt-get ? :yes:

avec gentoo c'est facile il suffit de modifier le paramétrage de lftp dans le make.conf, là j'ai plus de mal à trouver l'info ...

Link to post
Share on other sites

Y'a pas de date en fait ...

Même si les personnes qui s'en occupent terminent ce qu'ils avaient prévu de faire,

on pourrait encore rajouter des choses et le mettre à jour ...

Mais tu peux toujours proposer une section ou une partie de tutoriel.

Link to post
Share on other sites
Il sera finit quand le tuto ? :francais:
C'est un tuto Debian, alors... quand ce sera prêt...

dans trois ans.

Bon il y a beaucoup d'infos outdated (genre les releases, avec woody encore en stable etc.). Si quelqu'un veux mettre à jour, qu'il poste un diff et je mettrais à jour. (Faut pas trop compter sur moi, je n'ai vraiment pas le temps en ce moment).

Link to post
Share on other sites
  • 2 weeks later...

:transpi:

Bonjour, j'envisage l'achat d'une carte tuner tnt. Mais pour qu'elle fonctionne correctement, il lui faut un noyau supérieur à 2.6.12. Or, étant en stable, mon noyau est trop ancien.

J'en vois déjà me dire: compile toi un nouveau noyau. Ce serait effectivement une solution, mais, car oui il y a un mais, je ne m'en sens pas encore capable ( :D ).

D'où ma question: est-ce possible de rester en sarge et installer le noyau de etch en spécifiant bien les préférences de apt?

a/ Non, c'est pas possible.

b/ Possible, mais très déconseillé.

c/ Possible, ça devrait marcher, bien que cela soit barbare.

d/ Pas de problème.

Cochez la mention exacte.

Merci d'avance pour votre aide. :transpi:

Link to post
Share on other sites

Salut,

Il est joli ton avatar :ouioui::sucre:

Bon, si t'as pas un serveur y a aucun interet à rester en stable, vaut mieux changer en testing, un petit remake de ton sources.list et un apt-get dist-upgrade et c'est bon :sucre:

P.S: Je suis en testing et le noyaux par défaut c'est le 2.6.12-1-686

Link to post
Share on other sites
Ce serait effectivement une solution, mais, car oui il y a un mais, je ne m'en sens pas encore capable

En lisant de bons tutos tu pourra y arriver. :byebye:

Oui, rester en stable n'est pas nécessaire à moins que héberge et que ton PC reste sous tension 24/24.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...