Jump to content

[Debian GNU/Linux] Topic Officiel


-rem-

Recommended Posts

Aptitude du jour, bonjour.

Les paquets suivants sont CASSÉS :
 cupsys epiphany-browser libcupsys2 libglu1-xorg-dbg libgnomevfs2-0 libgnutls-dev libgnutls11 libldap2 slrn vlc vncserver xlibmesa-gl-dbg
 xlibosmesa-dev xlibosmesa4 xlibs-static-pic
Les NOUVEAUX paquets suivants vont être automatiquement installés :
 libdrm2 libfontenc-dev libfontenc1 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libglu1-mesa libglu1-mesa-dev libx11-data libxaw-headers
 libxdmcp-dev libxfont-dev libxfont1 libxmu-headers mesa-common-dev tzdata x11proto-core-dev x11proto-fonts-dev x11proto-input-dev x11proto-kb-dev
 x11proto-randr-dev x11proto-record-dev x11proto-render-dev x11proto-trap-dev x11proto-video-dev x11proto-xext-dev x11proto-xinerama-dev xbitmaps
 xcursor-themes xfonts-encodings xfonts-utils xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-kbd
 xserver-xorg-input-mouse xserver-xorg-video-all xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips
 xserver-xorg-video-cirrus xserver-xorg-video-cyrix xserver-xorg-video-dummy xserver-xorg-video-fbdev xserver-xorg-video-glint xserver-xorg-video-i128
 xserver-xorg-video-i740 xserver-xorg-video-i810 xserver-xorg-video-imstt xserver-xorg-video-mga xserver-xorg-video-neomagic xserver-xorg-video-newport
 xserver-xorg-video-nsc xserver-xorg-video-nv xserver-xorg-video-rendition xserver-xorg-video-s3 xserver-xorg-video-s3virge xserver-xorg-video-savage
 xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-tga
 xserver-xorg-video-trident xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vga xserver-xorg-video-via xserver-xorg-video-vmware
 xserver-xorg-video-voodoo xtrans-dev xutils-dev
Les paquets suivants seront automatiquement ENLEVÉS :
 libgnutls12 xserver-common
Les NOUVEAUX paquets suivants vont être installés :
 discover1 discover1-data libdiscover1 libdrm2 libfontenc-dev libfontenc1 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libglu1-mesa libglu1-mesa-dev
 libx11-data libxaw-headers libxdmcp-dev libxfont-dev libxfont1 libxmu-headers mesa-common-dev tzdata x11proto-core-dev x11proto-fonts-dev
 x11proto-input-dev x11proto-kb-dev x11proto-randr-dev x11proto-record-dev x11proto-render-dev x11proto-trap-dev x11proto-video-dev x11proto-xext-dev
 x11proto-xinerama-dev xbitmaps xcursor-themes xfonts-encodings xfonts-utils xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev
 xserver-xorg-input-kbd xserver-xorg-input-mouse xserver-xorg-video-all xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-ati
 xserver-xorg-video-chips xserver-xorg-video-cirrus xserver-xorg-video-cyrix xserver-xorg-video-dummy xserver-xorg-video-fbdev xserver-xorg-video-glint
 xserver-xorg-video-i128 xserver-xorg-video-i740 xserver-xorg-video-i810 xserver-xorg-video-imstt xserver-xorg-video-mga xserver-xorg-video-neomagic
 xserver-xorg-video-newport xserver-xorg-video-nsc xserver-xorg-video-nv xserver-xorg-video-rendition xserver-xorg-video-s3 xserver-xorg-video-s3virge
 xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx
 xserver-xorg-video-tga xserver-xorg-video-trident xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vga xserver-xorg-video-via
 xserver-xorg-video-vmware xserver-xorg-video-voodoo xtrans-dev xutils-dev
Les paquets suivants seront ENLEVÉS :
 discover discover-data libdiscover2 libgnutls12 xserver-common
Les paquets suivants seront mis à jour :
 libc6 libc6-dev libglu1-xorg libglu1-xorg-dev libice-dev libice6 libice6-dbg libsm-dev libsm6 libsm6-dbg libtasn1-2 libtasn1-2-dev libx11-6
 libx11-6-dbg libx11-dev libxau-dev libxau6 libxaw7 libxaw7-dbg libxaw7-dev libxcursor-dev libxcursor1 libxdmcp6 libxext-dev libxext6 libxext6-dbg
 libxft-dev libxft2 libxi-dev libxi6 libxi6-dbg libxinerama-dev libxinerama1 libxkbfile-dev libxkbfile1 libxmu-dev libxmu6 libxmu6-dbg libxmuu-dev
 libxmuu1 libxmuu1-dbg libxpm-dev libxpm4 libxpm4-dbg libxrandr-dev libxrandr2 libxrandr2-dbg libxrender-dev libxrender1 libxt-dev libxt6 libxt6-dbg
 libxtrap-dev libxtrap6 libxtrap6-dbg libxtst-dev libxtst6 libxtst6-dbg libxv-dev libxv1 libxv1-dbg render-dev x-dev x11-common xbase-clients
 xfonts-100dpi xfonts-100dpi-transcoded xfonts-75dpi xfonts-75dpi-transcoded xfonts-base xfonts-scalable xlibmesa-dri xlibmesa-gl xlibmesa-gl-dev
 xlibs-data xlibs-static-dev xserver-xorg xutils
Les paquets suivants sont RECOMMANDÉS mais ne seront pas installés :
 libtasn1-2-bin xkb-data
78 paquets mis à jour, 76 nouvellement installés, 5 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 66,2Mo d'archives. Après dépaquetage, 9458ko seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
 libgnomevfs2-0: Dépend: libgnutls12 (>= 1.2.5) mais il n'est pas installable
 epiphany-browser: Dépend: libgnutls12 (>= 1.2.5) mais il n'est pas installable
 xlibosmesa4: Dépend: xlibmesa-gl (= 6.9.0.dfsg.1-6) mais 1:7.0.10 doit être installé.
 libgnutls11: Dépend: libgnutls12 (>= 1.2.5) mais il n'est pas installable
 libglu1-xorg-dbg: Dépend: libglu1-xorg (= 6.9.0.dfsg.1-6) mais 1:7.0.10 doit être installé.
 vncserver: Dépend: xserver-common mais il n'est pas installable
 slrn: Dépend: libgnutls12 (>= 1.2.5) mais il n'est pas installable
 libgnutls-dev: Dépend: libgnutls12 (= 1.2.9-2) mais il n'est pas installable
 xlibosmesa-dev: Dépend: xlibmesa-gl-dev (= 6.9.0.dfsg.1-6) mais 1:7.0.10 doit être installé.
 xlibs-static-pic: Dépend: xlibs-static-dev (= 6.9.0.dfsg.1-6) mais 1:7.0.10 doit être installé.
 xlibmesa-gl-dbg: Dépend: xlibmesa-gl (= 6.9.0.dfsg.1-6) mais 1:7.0.10 doit être installé.
 vlc: Dépend: libgnutls12 (>= 1.2.5) mais il n'est pas installable
 libcupsys2: Dépend: libgnutls12 (>= 1.2.5) mais il n'est pas installable
 cupsys: Dépend: libgnutls12 (>= 1.2.5) mais il n'est pas installable
 libldap2: Dépend: libgnutls12 (>= 1.2.5) mais il n'est pas installable
Resolving dependencies...
Les actions suivantes permettront de résoudre ces dépendances :

Supprimer les paquets suivants :
vncserver

Installer les paquets suivants :
xkb-data [0.8-4 (unstable, unstable)]

Conserver les paquets suivants dans leur version actuelle :
libgl1-mesa-dev [Non installé]
libgl1-mesa-dri [Non installé]
libgl1-mesa-glx [Non installé]
libglu1-mesa [Non installé]
libglu1-mesa-dev [Non installé]
libglu1-xorg [6.9.0.dfsg.1-6 (now)]
libglu1-xorg-dev [6.9.0.dfsg.1-6 (now)]
libgnutls12 [1.2.9-2 (unstable, unstable, now)]
libtasn1-2 [0.2.17-1 (now)]
libtasn1-2-dev [0.2.17-1 (now)]
xlibmesa-dri [6.9.0.dfsg.1-6 (now)]
xlibmesa-gl [6.9.0.dfsg.1-6 (now)]
xlibmesa-gl-dev [6.9.0.dfsg.1-6 (now)]
xlibs-static-dev [6.9.0.dfsg.1-6 (now)]

Laisser les dépendances suivantes non satisfaites :
xserver-xorg-core recommande xkeyboard-config
Le score est de -852

Accepter cette solution ? [Y/n/q/?]

Doit-je répondre bêtement "Yes" :mdr:

Link to post
Share on other sites
  • Replies 381
  • Created
  • Last Reply

salut

si tu t'ennuie je pense pense que tu devrais accepter :non: .

Apres ça va t'occuper un bon moment :roll: :copain:

a+

:ouioui::pleure::zarb:

N'empêche, à voir lees paquets énoncés, il doit y avoir quelque chose de bizarre au niveau du serveur xorg (ils sont passés en version 7 peut-être)?

Parce que la plupart des paquets le concernent...

Link to post
Share on other sites

Apparement xorg passerait bien en version 7. J'ai pas résisté, j'ai lancé la mise à jour et tout c'est bien passé (à par les dépendances manquantes). Mais je relancerai pas le pc pour le moment :-D

Link to post
Share on other sites

Bonsoir,

Ca fait quelques jours que je m'amuse sur Debian. On trouve beaucoup de docs pour avancer à son rythme.

J'ai déjà pratiquement installé toutes les softs que je voulais (avec plus ou moins de facilité).

Là, j'ai une petite question pour vous: J'ai installé acrobat reader pour lire mes pdf. Le pb, c'est qu'à chaque fois que je double clique sur un document pdf, c'est la visionneuse de fichiers pdf (GNOME) qui se lance. Je voulais savoir comment configurer debian pour qu'à chaque fois que je double clique sur un fichier pdf, ce soit acrobat reader qui se lance, et non la visionneuse de GNOME.

Merci

NB: sinon, toujours pas résolu mon pb de police :ouioui:

Link to post
Share on other sites

Merci Sentinel mais j'ai beaucoup de fichiers pdf à ouvrir tous les jours et donc j'aimerais pouvoir simplement cliquer sur le fichier pour qu'il s'ouvre automatiquement sous Acrobat Reader. Mais je pense que je vais voir pour désinstaller la visionneuse.

En tout cas merci

Link to post
Share on other sites

Quand tu fais "ouvrir avec" y a une case à cocher pour qu'il se rappel de l'application liée à tel fichier.

Sinon Je trouve que "Evince" est un très bon visionneur pdf, et il est libre, c'est toujours mieux que d'utiliser un truc proprio..surtout sur une debian..

Link to post
Share on other sites

Quand tu fais "ouvrir avec" y a une case à cocher pour qu'il se rappel de l'application liée à tel fichier.

Sinon Je trouve que "Evince" est un très bon visionneur pdf, et il est libre, c'est toujours mieux que d'utiliser un truc proprio..surtout sur une debian..

Ok merci shark_atlantis. Plus précisément (pour ce que ca intéresse), il faut faire un clic droit sur le document et dans le menu contextuel, cliquer sur Propriétés.

Aller dans l'onglet "Ouvrir avec" et sélectionner le programme que l'on souhaite associer au fichier. Cette manip permet à tous les fichiers de la même extension (même type) d'être ouvert par cette application.

Link to post
Share on other sites

C'est très exactement ce que j'ai dit plus haut hein :modoreussi:

Pas exactement car j'ai justement un peu galéré pour trouver où cocher :fumer:

Je m'explique:

- clic droit sur le fichier pdf > Ouvrir avec: dans ce cas là, tu peux seulement choisir l'application qui va ouvrir le fichier pdf; tu n'as pas la possibilité de cocher la case correspondant à l'application que tu veux associer au fichier.

- clic droit sur le fichier pdf > Propriétés > Ouvrir avec: là, tu peux cocher la case de l'application.

Mais bon, ton indice m'a été précieux :chinois:

edit: Le boulet que je suis! Désolé Sentinel, j'ai lu ton message précédent à la va-vite! En effet, t'avais TRES bien expliqué. :fumer:

Et dire que je critique les autres qui lisent pas les messages en entier!

En même temps, ca fait 3 jours que je bosse non-stop sous Debian et je suis plus tout à fait frais!

Bon, ben je vais me coucher...

Link to post
Share on other sites

YES!!! :birthday::smack::yes::p:mdr::non::-D

J'ai enfin une police correcte!!!

Dans Firefox, il suffisait simplement de décocher la case "Permettre aux pages de choisir leurs propres polices au lieu de celles ci-dessus" dans Edition > Préférences: dans l'onglet "Contenu", zone "Polices et couleurs" > Avancée

Vous pouvez pas savoir ma joie :-D :-D :-D :-D

Je kiffe Debian de plus en plus d'autant qu'il y a beaucoup de choses à faire!!

Maintenant, je vais essayer de personnaliser l'OS et peut-être mettre à jour le noyau!

Par contre, j'ai encore des petits problèmes d'affichage:

capturesportswanadoomozillafir.th.png

Quelqu'un pourrait-il me scanner ses réglages sous Firefox?

capturepolices8dq.png

Link to post
Share on other sites
  • 1 month later...

2. Pilotes nVidia

Par rémy.harel

:transpi:Pilotes graphiques nVidia [nVidia.com]

Il y 2 types de drivers nvidia pour les distributions linux.

- Au début, il fallait installer dans un premier temps un module spécial dans le noyau, puis GLX, qui correspond à l'accélération matérielle, indispensable pour jouer par exemple.

- Mais depuis un certain temps, nVidia fournit ses drivers sous forme d'un script d'install tout en un (lien ci-dessus). Il est donc bien plus facile pour l'utilisateur d'installer ces pilotes.

Prérequis :

- Le script d'install bien sûr (lien ci-dessus)

- Vous devez posséder les sources du noyau courant. De plus, il faut absolument avoir un lien symbolique "/usr/src/linux" qui pointe vers les sources du noyau. Par exemple si les sources du noyau se trouvent dans le répertoire "/usr/src/linux-2.6.6", vous devrez créer un lien grâce à la commande suivante : "ln -s /usr/src/linux-2.6.6 /usr/src/linux".

- Le lien symbolique "/usr/bin/gcc" doit pointer vers le compilateur ayant servi à la compilation du noyau courant. Si par exemple votre noyau a été compilé avec gcc 3.2, vous devrez créer ou vérifier la présence d'un lien /usr/bin/gcc qui pointe vers gcc 3.2 : "ln -s /usr/bin/gcc-3.2 /usr/bin/gcc". Normalement, sur une installation fraîche de debian, tout est déjà en place et les versions correspondent.

I) Pilotes récents ( avec le script )

Apres avoir téléchargé le fichier contenant les pilotes Nvidia, placez-le dans /usr/src , autorisez son exécution, puis lancez-le :

mv <nom du fichier téléchargé> /usr/src/
cd /usr/src
chmod 755 <nom du fichier téléchargé>
./<nom du fichier telecharge>

Une interface graphique se lance et vous pose un certain nombre de questions :

- License : vous devez accepter les termes de la license (differents de la philosophie debian ) pour pouvoir installer ces pilotes nvidia.

- packages sur le ftp de nvidia : le script vous informe qu'il n'a pas de package ( version précompilée) des drivers correspondant à votre configuration, et vous demande si vous voulez aller en chercher sur le ftp de Nvidia. Répondez non, on va compiler les drivers (rassurez vous le script le fera tout seul).

- Il est possible que le script vous informe que votre version de gcc est peut-être differente de celle utilisée pour compiler le noyau. Il vous proposera alors de stopper l'installation. En général, vous pouvez répondre non, l'installation peut se dérouler correctement.

- Normalement, si tout se passe bien, 2 barres de progression défilent. Je n'ai jamais eu le temps de les lire (c'est ca d'avoir une grosse config... :chinois: mais je suppose que la premiere correspond à la compilation ("make") du pilote et la seconde à son installation ("make install"). Typiquement, si vous n'avez pas un lien "/usr/src/linux" qui pointe vers les sources du noyau, à la fin de la premiere barre de progression, un message vous avertira de ce probleme, en vous signalant que l'installation a echoué (installation failed). Sinon, à la fin de la seconde barre de progression, vous devriez voir apparaître un message vous disant que l'installation s'est bien deroulée (successful).

- Pensez enfin à modifier votre fichier de configuration graphique, généralement nommé "/etc/X11/XF86Config-4".

II) Pilotes anciens (méthode obsolète)

[Attention] méthode non testée sous noyau 2.6.x. Mais si vous avez des questions ou des indications sur ce sujet, vous pouvez toujours me joindre, soit sur le forum, soit par mail : remy_harel@yahoo.fr

Si pour une raison X ou Y (elles ont intérêt à être bonnes :transpi: vous ne pouvez pas installer les drivers récents, il va vous falloir faire ça "à l'ancienne". Vous avez alors 2 fichiers, un contenant le mot "kernel" et l'autre le mot "glx". Si vous ne comptez pas utiliser l'accéleration 3D, la partie glx n'est pas nécessaire.

Déplacez ces fichiers dans "/usr/src/" puis décompressez-les avec la commande "tar zxf" (si l'extension est .tar.gz) ou "tar jxf" (si l'extension est .tar.bz2).

* Le fichier Kernel
  tar jxf <nom du fichier kernel>.tar.bz2
  cd <répertoire créé par la décompression>
  ./configure
  make 
  make install

  * Le fichier GLX
  tar jxf <nom du fichier GLX>.tar.bz2
  cd <répertoire créé>
  ./configure
  make 
  make install

Les différents modules sont maintenant compilés et installés (pour un noyau 2.4, ils sont dans "/lib/modules/<version du noyau>/kernel/driver/video/nvidia.o"), mais ne sont pas chargés automatiquement au démarrage. Il faudra donc les ajouter manuellement dans "/etc/modules" grâce à la commande "echo nvidia >> /etc/modules" (attention, mettez bien deux signes "supérieur" !).

Pour finir, il faut modifier le fichier de configuration graphique "/etc/X11/XF86Config-4" de la façon suivante : à la une ligne comportant le mot "nv", il faut remplacer celui-ci par "nvidia".

Rebootez, et normalement vous devriez voir brièvement un écran blanc frappé du signe de nVidia au démarrage du mode graphique. Félicitations, cela fonctionne !

Je voulais savoir comment faire pour récupérer les sources du kernel avec apt-get. J'ai essayé apt-get source kernel-image-2.6.8-2-686... mais cela a téléchargé un fichier bz2 d'environ 70ko dans mon répertoire personnel de root et l'a décompressé... mais les sources du noyau c'est beaucoup plus gros que ça... :smack:

Si je lis ton aide, il faut avoir les sources pour permettre l'installation du pilote nVidia.

Link to post
Share on other sites

Merci Theocrite, j'ai pu installer le pilote NVidia en récupérant les sources !

J'ai remarqué une bonne amélioration de l'image... mais je n'ai malheureusement pas résolu mon problème d'affichage avec FireFox. Dans Firefox 1.0.4 quand j'ouvre un menu (de la barre de menu texte) et que je place mon curseur sur un item de la liste (ex.: comme pour choisir un favoris dans la liste) au-lieu de mettre en surbrillance ma sélection, je perds carrément l'écriture de cette sélection et elle devient toute blanche. J'ai cru à un problème d'affichage (mauvaise interprétation des nuances ou des contrastes) mais ça semble être vraiment FireFox qui ne marche pas bien.

Est-ce que une version plus récente que 1.0.4 est disponible depuis apt-get pour Debian 3.1r2 stable ? Sur la liste officiel c'est la version la plus récente...

Merci encore

Link to post
Share on other sites

Je te conseille de passer à la verion 1.5.0.3 de firefox. Il n'est peut être pas dans les sources de stable mais tu n'as que le d/l et l'installer via le site officiel.

Ce n'est pas ça qui va faire planter ton pc. :cartonrouge: (et ca corrigera sûrement le bug)

Link to post
Share on other sites

Bonjour!

Je vais installer une Debian Linux sur une petite config P3 866, VIA 133A, GF2MX...

J'ai utilisé Debian 2-3 ans, ça fait bientôt 1 an et demi que je n'y aie plus touché mais je dois avoir de beaux reste. Je demande donc si y'a quelques trucs important à savoir.

Voilou, a+!

Link to post
Share on other sites
  • 2 weeks later...

Petit réterrage de topics! :love:

Et aussi pour prévenir ceux qui vont faire leurs mises à jour de Debian Testing! X.org 7 apparait dans les paquets... Mais faites super attention! Perso, ca m'a pris un peu de temps pour réparer les conneries : entre le fichier xorg.conf qu'il n'arrivait pas à mettre à jour, vu que je l'avais retouché à la mano, les paquets manquants donc pas de détectnio de clavier au relancement du serveur X...

bref, c'est pas insurmontable, surtout si vous installez xserver-xorg-input-all (ca va tout vous mettre, mais au moins y aura ce qu'il faut!) A ce propos, il est pas encore au point leur X;org modulaire: si c'est pour se ramasser tous les paquets quand même...

Link to post
Share on other sites
le fichier xorg.conf qu'il n'arrivait pas à mettre à jour, vu que je l'avais retouché à la mano, les paquets manquants donc pas de détectnio de clavier au relancement du serveur X...

Pas de problème de xorg.conf chez moi (retouché aussi, ça en a refait un qui reprend mes changements et ça m'a sauvegardé l'ancien).

Pas de paquets manquants non plus je pense, mais j'ai plus de DRI, ils auraient pu updater le noyau aussi, ça aurait été bien.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...