Jump to content

Archived

This topic is now archived and is closed to further replies.

-rem-

[Debian GNU/Linux] Topic Officiel

Recommended Posts

si vous utilisez la fonction recherchez du forum, j'ai dans un topic expliquer de a a z a un inpactien comment faire.....

Share this post


Link to post
Share on other sites

T'inquiètes remy, je me rappelle bien que tu m'avais déjà filer le lien mais (comble de la noobitude) je ne savais pas localiser alsa dans mon système!

De toute façon c'est pas grave, je suis patient, et ça me coute rien de chercher (et de toute façon comme je disais j'ai plus mon DD Linux pour continuer mon install :D )

http://www.pcinpact.com/forum/index.php?sh...c=25265&hl=alsa

Share this post


Link to post
Share on other sites

pour alsa, moi je fais :

- compil du noyau avec support en module de alsa et en module ma cs ( emu10k1 )

- install du noyau

- reboot

- apt-get install alsa-base alsa-utils allsa-source alsamixer alsamixergui

- cd /usr/src/

- tar jxf alsa-sources.tar.bz2

- cd modules/alsadriver

- ./configure && make && make install

- reboot

- alsamixer ( => son "on" )

- je bois une sandeman pour feter ca...

Share this post


Link to post
Share on other sites
pour alsa, moi je fais :

- compil du noyau avec support en module de alsa et en module ma cs ( emu10k1 )

- install du noyau

- reboot

- apt-get install alsa-base alsa-utils allsa-source alsamixer alsamixergui

- cd /usr/src/

- tar jxf alsa-sources.tar.bz2

- cd modules/alsadriver

- ./configure && make && make install

- reboot

- alsamixer ( => son "on" )

- je bois une sandeman pour feter ca...

il faut recompiler le driver :pciwin: c'est quoi ce bordel :cnul:

sur ma fedora j'ai jamais rien compilé et ça marche, et si les modules sont dans le noyau , je ne vois pas pourquoi il faudrait encore les compiler après :mad2:

bon quand je fait un lsmod il me trouve

snd_ens1371

qui a priori est le chipset de ma carte son :eeek:

ensuite c'est la que ce'st bizarre ...

j'install alsautils et alsamixergui :cap:

ensuite j'e lance alsaconf

il fais search the sound card

il detecte ens1371 Ensoniq 5880 Audio PCI (rev02)

donc ok

di you want to modify /etc/modprobe.d/sound

ben yes

la il dit qu'il va demarrer alsa ( alsa start )

et aucun son .....

Bon j'abandonne :fumer:

pourquoi ??? je crois que le problème est vraiment plus profond...

j'ai rebooter pour tester :D

et la au reboot, de nouveau les problèmes de clavier :gne: , le serveur X encore dans les choux :gne:, donc en gros sur 2 pc totalement différents les mêmes problèmes :transpi: ..... du coup de je ne sais pas trop quoi en penser, si ce n'est que :cnul: ........

alors c'est le 2.6.6.1 de debian qui est foireux ??? ....

bon des que je recupère les cd de ma fedora / fini de d/L la suse / trouvé la nouvelle mandrake, je ressaye .....

Share this post


Link to post
Share on other sites

Bah moi pour l'instant, sans le DD devoué à l'install, mon alsa se résume à ça:

- je bois une sandeman pour fêter ça... :D

Plus sérieux, le module alsa tu l'as de base dans la 2.6.7? Tu le trouve où dans les répertoire système? (et désolé si les questions sont super con, mais j'ai pu les moyens de vérifier par moi-même :pciwin: )

Share this post


Link to post
Share on other sites

Bon j'abandonne 

pourquoi ??? je crois que le problème est vraiment plus profond...

Tu as pense a regle le son avec alsamixer ou alsamixergui ??? PAr defaut il est coupe Alex...

alors c'est le 2.6.6.1 de debian qui est foireux ??? ....

Pour le 2.6.6 j'avais pris un noyau pur, kernel.org, non patche debian... et ca marchait nickel.. Et sur le 2.6.7 la c'est un noyau debian, et ca marche du feu de dieu... J'ai galere par contre pourmettre alsa surles premiers 2.6 sur ma sid... meme genre de pb que toi. Je pense que tu fais pas tout correctement Alex, tu dois oublier qqchose.

Share this post


Link to post
Share on other sites

Dark, est-ce que tu as monté le son dans alsa-mixer? Il parait qu'il est à zero de base... (moi j'en suis même pas là... t'as du installer autre chose ou alsaconf est de base?)

[EDIT] remy: grilled! je m'incline... :D

Share this post


Link to post
Share on other sites

Horus, relis ma procedure, appliques la, et ca marchera.

em@Pai-mei:~$ ls /usr/src/ -harl

total 92M

drwxr-sr-x  3 root src    192 Aug  7 20:54 xmmsbar

drwxr-xr-x  7 root root  168 Aug  8 17:39 rpm

drwxr-xr-x  4 root src    112 Aug  5 23:09 modules

lrwxrwxrwx  1 root src    28 Jul 28 00:51 linux -> /usr/src/kernel-source-2.6.7

-rw-r--r--  1 root root  34M Aug 18 08:02 kernel-source-2.6.8.tar.bz2

drwxr-xr-x  19 root root  1016 Aug 20 19:12 kernel-source-2.6.8

-rw-r--r--  1 root root  33M Aug  5 18:49 kernel-source-2.6.7.tar.bz2

drwxr-xr-x  20 root root  1.6K Aug 21 14:05 kernel-source-2.6.7

-rw-r--r--  1 root src  2.7M Aug 20 19:01 kernel-image-2.6.8_1.0_i386.deb

-rw-r--r--  1 root src  2.7M Aug 21 14:05 kernel-image-2.6.7_1.0_i386.deb

-rw-r--r--  1 root src  1.5M May 25 21:02 kernel-image-2.4.26_1.0_i386.deb

-rw-r--r--  1 root src  965K Jun 11 18:42 install_flash_player_7_linux.tar.gz

drwxr-xr-x  2 1006 staff  224 May 21 01:03 install_flash_player_7_linux

-rw-r--r--  1 root root  1.8M Aug 15 04:23 alsa-driver.tar.bz2

-rwx------  1 root src  7.8M Aug  7 15:34 NVIDIA-Linux-x86-1.0-6111-pkg1.run

-rwx------  1 root src  7.8M Jul 28 00:35 NVIDIA-Linux-x86-1.0-6106-pkg1.run

-rw-r--r--  1 rem  rem    34K Aug  7 20:53 5882-xmmsbar-0.3.tar.gz

-rw-r--r--  1 root src    13 May 25 23:55 .xinitrc

-rw-r--r--  1 root src    26K Aug  1 15:24 .config

drwxr-xr-x  12 root root  312 May 25 21:12 ..

drwxrwsr-x  8 root src    808 Aug 19 19:58 .

rem@Pai-mei:~$ 

Share this post


Link to post
Share on other sites
il faut recompiler le driver :D c'est quoi ce bordel :cnul:

sur ma fedora j'ai jamais rien compilé et ça marche, et si les modules sont dans le noyau , je ne vois pas pourquoi il faudrait encore les compiler après :pciwin:

Ouais, je suis d'accord...

C quoi cte manière, remy?

Suffit d'avoir alsa qui a été compilé dans le noyau, les utilitaires et c bon !!!

Share this post


Link to post
Share on other sites

C quoi cte manière, remy?

Ben moi, la seule station sur laquelle j'ai alsa + 2.6 d'installer j'ai pas eu de son autrement. Et depuis, j'en ai reinstaller un max et a chaque fois comme ca... Et ca marche nickel. J'avais trouve un tuto a l'epoque des 2.4, pour faire marcher alsa, et c'etait comme ca aussi, logique, alsa n'etant pas supporte en natif par le noyau.

Share this post


Link to post
Share on other sites

ouais mais justement, maintenant, y'a plus besoin de recompiler le driver alsa vu qu'il est intégré au noyau...

faut juste avoir les utilitaires pour gérer le son...

Share this post


Link to post
Share on other sites

si tu as tout expliqué de a à z, il faudr afaire un copioer sur la première page alors :transpi:

Share this post


Link to post
Share on other sites

Pas con ca..... :fou:

Avec un peu plus de forme, une mise en page, et hop integre au topic ! J'essaie de faire c demain avec la securite...

Share this post


Link to post
Share on other sites
Pas con ca..... :-D

Avec un peu plus de forme, une mise en page, et hop integre au topic ! J'essaie de faire c demain avec la securite...

En fait mon cd d'install de la sarge :pleure: date de mon installtion de mon serveur :pleure: ...

donc je crois aux environs du mois de mai :pleure:

et maintenant le cd d'insatllation a évolué ( nouveau noyau ???? :fou: , des bugs corrigés ...))

du coup je charge la dernière version et je vais bien voir si c'est mieux..... :byebye:

il faut bien laisser une dernière à cette debian :roll:

Share this post


Link to post
Share on other sites

Bon sur la route de la gloire????? :p

bon j'ai tester avec la dernieère version de la netinsatll ( aout)..

déja c'est le 2.6.7 ;) ...

j'ai fait tout pareil ......

pas de problèmes de clavier :non:

j'install X ok impeccable ....

et la je reboot....... et X marche encore ...... :p

du coup j'install les package alsas , je lance alsaconf .....

ça merde toujours ........ :kill:

bon je reboot au cas où :transpi:

et la plus de X --> :cnul:

dons alsaconf doit modifier un/des fichiers et par conséquent détruit ma configuration de mon serveur X ( je ne sais pas comment et ce'st très embetant :fou: )

bien déterminé à tout jeté par le fenêtre :-D

je chercher je cherche et je trouve ça ...

http://www.sonic.net/~rknop/linux/debian_alsa.html

Prevent OSS drivers from loading

The discover1 pacakage tries to figure out what hardware you have and load the modules for them. Very nice. Except that it loads the OSS sound modules. To prevent it from doing this, add the line:

skip i810_audio

to the file /etc/discover.conf. Put the name of the OSS module for your sound card in place of i810_audio. (You can probably figure this out by perusing the output if lsmod.)

a ben d'accord, mais bon personne ne me l'avais dis à moi ( sinon faudra me dire où)..... :fume:

donc du coup pour que ça marche

aptitude install alsautils alsamixergui alsa-oss

modifier le fichier /etc/discover.conf et rajouter

skip i810_audio

i810_audio correspondant au chipset son du nforce 2 dans mon cas..

ensuite reboot

tetse avec alsamixer et ça semble OK

Share this post


Link to post
Share on other sites
dons alsaconf doit modifier un/des fichiers et par conséquent détruit ma configuration de mon serveur X ( je ne sais pas comment et ce'st très embetant fou.gif )

Vous faites comment pour charger vos modules ?

Car depuis qu'ils ont viré /etc/modprobe.conf

et /lib/modules/modprobe.conf

avec la mise-a-jour de module-init-tools

Moi je les met dans /etc/module

# /etc/modules: kernel modules to load at boot time.

#

# This file should contain the names of kernel modules that are

# to be loaded at boot time, one per line.  Comments begin with

# a "#", and everything on the line after them are ignored.

ide-cd

ide-detect

tvmixer

stv0299

psmouse

w83781d

i2c-isa

bttv tuner=3 card=39 pll=0 radio=0

nvidia

snd-via82xx dxs_support=4

mais je ne suis pas sur que ce soit la bonne methode. :chinois:

Share this post


Link to post
Share on other sites

pour le son il y a le autodetect d'alsa :chinois:

sinon je les maets aussi dans /etc/modules :chinois:

Share this post


Link to post
Share on other sites

dans /etc/modules ca marche

tu n'as qu'a ajouter "remy" dans /etc/modules et au boot tu verras un FATAL Can't load module remy

:chinois:

Share this post


Link to post
Share on other sites

sous gentoo, faut mettre dans /etc/modules.autoload.d/kernel-2.6, tout simplement

Share this post


Link to post
Share on other sites

salut

quelques problems avec le 2.6 :fumer:

je parametre mon noyau

#make-kpkg --initrd --revision=1.0 kernel-image

#dpkg --install kernel-image-2.6.7_1.0_i386.deb

Otherwise, I suggest you move /lib/modules/2.6.7 out of the way,

perhaps to /lib/modules/2.6.7.old or something, and then try

re-installing this image.

ya pas une autres solution? que de renommer le dossier. qqch de plus propre koi :)

FATAL: Could not open '/boot//System.map-2.6.7': No such file or directory

There was a problem running depmod.  This may be benign,

(You may have versioned symbol names, for instance).

Or this could be an error.

        depmod exited with return value 1

Since this image uses initrd, I am not deleting the file

/lib/modules/2.6.7/modules.dep. However, there is no

guarantee that the file is valid. I would strongly advice

you to either abort and fix the errors in depmod, or

regenerate the initrd image with a known good modules.dep

file. I repeat, an initrd kernel image with a bad modules.dep

shall fail to boot.

j'ai pourtant mit l'option --initrd quand j'ai fait mon make-kpkggggggggg :'(:'(:'(

et ca se finit en

Failed to create initrd image.

dpkg : erreur de traitement de kernel-image-2.6.7 (--install) :

le sous-processus post-installation script a retourné une erreur de sortie d'état 9

Des erreurs ont été rencontrées pendant l'exécution :

kernel-image-2.6.7

j'ai renommé mon dossier /lib/modules/2.6.7 en 2.6.7.old ya rien a faire il me rebalance

I suggest you move /lib/modules/2.6.7 out of the way,

perhaps to /lib/modules/2.6.7.old or something, and then try

re-installing this image.

Share this post


Link to post
Share on other sites
--append-to-version=

rajoute ça dans la ligne de commande de compile de ton kernel

style

make-kpkg --revision=1.0 --append-to-version=aout kernel_image

d'ailleurs faudra le rajouter sur la première page ;.... :fumer:

ps : si tu n'as pas de matos exotique l'inird n'ets pas indispensable

Share this post


Link to post
Share on other sites

yes il a enfin Booté :yes::D:D

euh par contre c normal que je ne puisse plus lancer xmms?

# xmms

libmikmod.so.2: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou répertoire de ce type

Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!

j'ai essayé de le desinstaller reinstaller tjrs le même pb :s

bon m'aintenant je m'attaqe a ma GF :)

Share this post


Link to post
Share on other sites

faut essayer de réinstaller la lib...

Mais de ce côté là, xmms est pas super top...chez moi, c'est pareil, un jour, segfault de xmms, depuis, plus moyen :yes:

Share this post


Link to post
Share on other sites

×
×
  • Create New...