Jump to content

Folding@home: la Team INpact qui guérit la planète


Will.
 Share

Recommended Posts

Heu normalement le client détecte qu'un instance tourne, affiche un message (avec le pid du process qu'il suspecte être une client), et s'arrête.

Qu'est qu'il fait pas dans les règles ton script ? :ouioui:

il n'y aurait pas un script de lancement auto au démarrage unifié? un genre de script qui marche à tout les coups? parce que j'ai bidouillé le mien à l'arrache et c'est peut être pour ça qu'il vérifie pas les instances déjà présente?

mes deux scripts:

#!/bin/sh

export FAH_HOME2=/home/geek85/folding2

cd $FAH_HOME2
$FAH_HOME2/FAH504-Linux.exe -local -forceasm -verbosity 9 >/dev/null 2>&1 &
exit 0

#!/bin/sh

export FAH_HOME=/home/geek85/folding1

cd $FAH_HOME
$FAH_HOME/FAH502-Linux.exe -local -forceasm -verbosity 9 >/dev/null 2>&1 &
exit 0

repris tout deux dans un fichier dans ~/.config/autostart

et si je relance mon serveur X... ça merdouille!

Link to comment
Share on other sites

Personne n'aurait donc une idée de où peut venir mon problème ?? :cartonrouge:

OK j'ai trouvé.

Il devait me manqué des packages pour exécuter des binaires... en installant le package "lsb", c'est passé beaucoup mieux :D

Encore merci

Merci, çà règle mon soucis aussi (qui était le même)

Je termine les 2 calculs en cours et je lance le smp

Link to comment
Share on other sites

Re

je le lance, je renseigne les paramètres, il démarre et il plante le PC (écran+souris bloqués).

Quelqu'un a le même problème (et la solution) ?

Merci.

Précision : je le lance sous Ubuntu 64 bit

Salut,

bon, je l'ai laissé tourner toute la journée sans résultat, il démarre, tourne un peu puis s'arrête tous seul (les CPU ne font plus rien).

dommage, je relance le client normal mais j'aurais bien voulu faire tourner le smp (Ubuntu 64 bits).

Si quelqu'un a une piste de recherche, merci.

Link to comment
Share on other sites

heu, ben non

[20:55:09] Core required: FahCore_a1.exe

[20:55:09] Core found.

[20:55:09] Working on Unit 03 [October 16 20:55:09]

[20:55:09] + Working ...

[20:55:09]

[20:55:09] *------------------------------*

[20:55:09] Folding@Home Gromacs SMP Core

[20:55:09] Version 1.74 (November 27, 2006)

[20:55:09]

[20:55:09] Preparing to commence simulation

[20:55:09] - Ensuring status. Please wait.

[20:55:10] - Fatal: Could not decompress work unit data.

[20:55:10] Error: Could not open work file

[20:55:10] Finalizing output

[20:55:10] - Starting from initial work packet

[20:55:10]

[20:55:10] Project: 822738944 (Run 16777216, Clone 3003121664, Gen 704643072)

[20:55:10]

[20:55:10] Error: Could not write local file. Exiting.

[20:55:10] - Shutting down core

[20:55:28] packet

[20:55:28]

[20:55:28] Project: 822738944 (Run 16777216, Clone 3003121664, Gen 704643072)

[20:55:28]

[20:55:28] Error: Could not write local file. Exiting.

[20:55:33] - Shutting down core

[0]0:Return code = 18

[0]1:Return code = 0, signaled with Quit

[0]2:Return code = 0, signaled with Quit

[0]3:Return code = 0, signaled with Quit

[20:57:14] CoreStatus = 12 (18)

[20:57:14] Client-core communications error: ERROR 0x12

[20:57:14] Deleting current work unit & continuing...

zut alors....

Link to comment
Share on other sites

Depuis quelques mois, j'ai une ATI X1950 GT.

Là, je n'ai pas pensé d'essayer pour plier avec ma carte graphique alors hier, j'ai téléchargé F@H GPU et je l'ai lancé.

Au bout de 13 heures, ma carte graphique a plié 860 WUs en aidant avec mon CPU :p

Alors un processeur Pentium 4 640 plie 1 WU pour 30 heures en moyenne... :chinois:

Surtout, un Pentium 4 640 calcule 1 image pour 20 minutes en moyenne (de 1 mn à 40 mn selon des WUs).

Là, ma carte graphique avec l'aide de mon CPU calcule plus de 45 images par seconde :mdr2:

Je viens voir sur le tableau des FLOPS dans le site officiel de Folding@Home :

39 TFLOPS pour 661 GPUs actifs, soit 59 GFLOPS par GPU en moyenne

951 TFLOPS pour 38 356 PS3 actifs, soit 24,79 GFLOPS par PS3 en moyenne

170 TFLOPS pour 178 852 CPUs actifs, soit 0,95 GFLOPS par CPU en moyenne (à cause des vieux processeurs existants qui servent F@H)

Les GPUs sont vraiment très performants ;)

Link to comment
Share on other sites

Parce que si tu regarde tes logs, tes WU GPU doivent se terminer en Early Unit End ... et c'est pas normal :chinois:

Tu as un problème ... il va falloir tout revérifier.

Je me rappelle que j'avais regardé mon log pour curieux. Je vois qu'ils terminent en Early Unit End...

Ma carte graphique est X1950 GT avec Catalyst 7.1.

Link to comment
Share on other sites

Voici le log d'un WU :

[15:37:18] + Attempting to send results
[15:37:19] + Results successfully sent
[15:37:19] Thank you for your contribution to Folding@Home.
[15:37:23] - Preparing to get new work unit...
[15:37:23] + Attempting to get work packet
[15:37:23] - Connecting to assignment server
[15:37:24] - Successful: assigned to (171.64.65.20).
[15:37:24] + News From Folding@Home: GPU folding beta
[15:37:24] Loaded queue successfully.
[15:37:26] + Closed connections
[15:37:31] 
[15:37:31] + Processing work unit
[15:37:31] Core required: FahCore_10.exe
[15:37:31] Core found.
[15:37:31] Working on Unit 05 [October 23 15:37:31]
[15:37:31] + Working ...
[15:37:31] 
[15:37:31] *------------------------------*
[15:37:31] Folding@Home GPU Core - Beta
[15:37:31] Version 0.10 (Mon Oct 30 12:32:17 PST 2006)
[15:37:31] 
[15:37:31] Compiler  : Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 13.10.3077 for 80x86
[15:37:31] Build host: CYGWIN_NT-5.1 vishal-gpu 1.5.19(0.150/4/2) 2006-01-20 13:28 i686 Cygwin
[15:37:31] Preparing to commence simulation
[15:37:31] - Looking at optimizations...
[15:37:31] - Created dyn
[15:37:31] - Files status OK
[15:37:31] - Expanded 87087 -> 443713 (decompressed 509.5 percent)
[15:37:31] 
[15:37:31] Project: 2741 (Run 1, Clone 119, Gen 23)
[15:37:31] 
[15:37:32] Assembly optimizations on if available.
[15:37:32] Entering M.D.
[15:37:38] Working on 1258 p2741_GPUlambda
[15:37:39] Starting GUI Server
[15:37:59] mdrun_gpu returned 114
[15:37:59] Going to send back what have done.
[15:37:59] logfile size: 7144
[15:37:59] - Writing 7682 bytes of core data to disk...
[15:37:59] Done: 7170 -> 2719 (compressed to 37.9 percent)
[15:37:59]   ... Done.
[15:37:59] 
[15:37:59] Folding@home Core Shutdown: EARLY_UNIT_END
[15:38:04] CoreStatus = 72 (114)
[15:38:04] Sending work to server

Est-ce qu'il y a anormal ?

Link to comment
Share on other sites

The following versions of Catalyst are known to work with the GPU client:

* 6.5

* 6.10 - 6.11

* 7.2 - 7.9

The GPU client will work with these drivers with a significant performance hit:

* 6.6

* 6.7

The following drivers do not work at all with the GPU client:

* 6.8

* 6.9

* 6.1

* 7.1

Je crois que j'ai touvé ... ;)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...