Jump to content
Dark26

Le Linux BAR - Discussion de tout et de rien

Recommended Posts

Dark, tu as un disque sui fait plus de 10Mo/s ? :transpi:

heu 4 :byebye: ( les 2 maxtors en raid 0 + le maxtor 160 + le seagate qui fait 20 )

m'enfin bon, j'ai aussi bcp de vieux matos, surtout pour les DD ( des 2 / 4 /8 giga ...... :francais: )

sinon image003.gif

moi je dis 8 raptors 36 giga en raid 5 sur du pci express, ça vance qaund même :roll:

Share this post


Link to post
Share on other sites

oui mais les 36go ne sont qu'un prelude de la techno raptor. Les 74Go sont bien mieux ! Et n'oubliez pas nos chers scsi les amis...car 0%cpu bouffe

Share this post


Link to post
Share on other sites
Et n'oubliez pas nos chers scsi les amis...car 0%cpu bouffe

ben pareil pour tous les contrôleurs hard...

Dark26 : marrant, j'imagine pas ton arid5 en écriture :roll:

Share this post


Link to post
Share on other sites
ben pareil pour tous les contrôleurs hard...

Dark26 : marrant, j'imagine pas ton arid5 en écriture :mdr:

le raid 5 en écriture :vomi1: ( autour de 2 mo à peu prêt :mad2: )

mais bon le but c'est pas la vitesse :non: ( sachant que je n'écrit partiquement rien :transpi: )

mais bon ça limite tout de même pour mon projet de centralisation des OS :mdr: , et je suis en train d'essayer de touver une alternative ..... ( histoire d'avoir un dur+controleur qui puisse faire du 10 mo /s en lecture écriture ... d'ou mes tests....

les durs je les ai ( ibm 13 go / seagate 20 go ) le controleur non :mdr:

le controleur ide integré à la mobo du serveur donne 1.68 mo :fou: ( je pense que disque ( WD 2go pio4) limite aussi car il supporte pas le 32bits / dma ou alors c'est le contrôleur qui le supporte pas ( si je touche une options --> freeze du serveur :pleure: )

rajouté ma carte son pour utiliser le controleur ide fourni avec .....-->pas mieux....

me reste un espoir en utilisant une carte ide isa que duke98 doit avor dans un carton :D , mais bon ça doit pas faire des miracles .... :non: ( elle date de l'époqeu des 486 il me semble :mdr: )

donc vu que les prix des cartes raid pata/sata sont chères , faudra attendre :roll:

Share this post


Link to post
Share on other sites

le dur seagate limite encore à 11 mo /s sur mon deuxième p!!! et du intel810( si je me trompe pas )

dommage ....... ( c'est pas terrible )

bon alors pour la vitesse ftp :vomi1:

serveur : mon athlon xp +vsftp + maxtor 160 go + broadcom 4401 ( 100mbps) fedora --> switch 100 --> realtek 8139, pentium 3 750 , knoppix

pour transférer direct x 9

35097792 en 3.00 s = 11431.1 kb/s

du 11.1 mo/s

ensuite

ftp> mget install*

mget install-x86-minimal-2004.2.iso? y

227 Entering Passive Mode (192,168,0,1,201,5).

150 Opening BINARY mode data connection for install-x86-minimal-2004.2.iso (82278400 bytes)

226 Transfer complete.

82278400 bytes received in 15.8 secs (5.1e+03 Kbytes/sec)

ftp>

entre mon serveur raid 5 et la fedora ( avec une magnfique utilisation à 100 % du cpu sur l'xp, je sais pas pourquoi....

entre le serveur et la knoppix ( 5216.7 kB /s ) donc pareil qu'avec la fedora...

et de nouveau avec un gros fichier entre la fedora et la knoppix, 11412,8 kB/s :transpi:

utilisation CPU :

sur le serveur ftp ( fedora + braodcom ) :

100 % de cpu utilisé sur la broadcom en reception ( avec le serveur ftp ) :cnul:

40 % de cpu utilisé sur la broadcom en emission ( avec le serveur ftp ) :cnul:

Attention c'est énorme car mon XP tourne à 2000 mhz :mdr:

sur le client FTP :

50 % de cpu utilisé ( rtl8139 ) en reception

40 % de cpu utilisé ( rtl8139 ) en émission

50 % de cpu utilisé en reception ( intel )

25 % de cpu utilisé en emission ( intel )

si en plus il devait acceuillir le daemon ftp , il faudra rajouter encore quelles % ( voir le reste ) :mdr:

la conclusion .... :roll:

la carte réseau broadcom intégré est une merde ( au moins sous linux :D )

la carte intel est meilleure que la carte realtek, surtout en emission...

ce qui est très troublant, c'est que ça consomme 50 % d'un pentium 3 750 ( 256 mo de RDRAM) , et que par conséquent ça doit pas être loin des 100 % sur un pentium 2 ....

personne ici n'a une 3com ????

car je pense qu'une 3com bouffe moins de ressoucess ( et a un meilleur driver nux)

ça me fait fait vraiment peur pour du gigalan , si les puces ne sont pas très bonnes :pleure:

Share this post


Link to post
Share on other sites

ouais, enfin y'a pas que la carte réseau qui bouffe du CPU...

Le contrôleur IDE en bouffe aussi... et par exemple, c'est ce qui me ralentit en ce moment sur mon PC (utilisation de 25% de mon bi2400+ en LAN avec transfert à 12Mo/s)

mais j'ai vu des utilisations qui étaient en dessous de 10% sur un 700MHz avec une carte raid higpoint :transpi:

Donc c pas forcément la carte réseau qui prend tout...

(tient, d'ailleur, faut que je tente avec ma nouvelle carte réseau intel intégrée...)

Share this post


Link to post
Share on other sites
ouais, enfin y'a pas que la carte réseau qui bouffe du CPU...

Le contrôleur IDE en bouffe aussi... et par exemple, c'est ce qui me ralentit en ce moment sur mon PC (utilisation de 25% de mon bi2400+ en LAN avec transfert à 12Mo/s)

mais j'ai vu des utilisations qui étaient en dessous de 10% sur un 700MHz avec une carte raid higpoint :fou:

Donc c pas forcément la carte réseau qui prend tout...

(tient, d'ailleur, faut que je tente avec ma nouvelle carte réseau intel intégrée...)

attention ..... :non:

sur la knoppix du client , les transferts se faisaient à partir ou a destination du /tmp donc dans la ram :-D , vu qu'il n'y a avait pas de disque dur :francais:

sur le client ( avec la realtek 8139 et l'intel) je suis sûr à 100 % que c'est du à la carte réseau :chinois: et pas au disque ( il y en avait pas :fumer: )

par contre si on test avec un dur ide en plus, c'est sûr qeu ça va monter encore le taux d'utilsation

en plus j'ai lancé en mode 2 donc en ligne de commande :fumer:

par contre sur la fedora et mon athlon xp, c'est sur qu'il y avait en plus le dur, X, le serveur ftp .......

donc :transpi:

mais quand même.....

le coup du 100 % en reception :mad2:

Share this post


Link to post
Share on other sites

bon je voulais m'amuser avec gdesklets, et du coup 172 mo une fois décompressé :mdr:

( il faut installer gnome :yes:)

Share this post


Link to post
Share on other sites
Je sais. Elles est par ailleurs incompatible avec la gpl car "trop libre" (elle ne permet pas d'obliger la redistribution du code modifié).

Que nenni. Une distrib est incompatible GPL si elle entraîne plus de restrictions que la GPL. La BSD en entraîne moins, donc c'est bon. Tu peux vérifier sur gnu.org.

Par contre, c'est clair que je préfère la GPL à la BSD. La (L)GPL t'oblige à jouer le jeu.

A+

Gauret.

Share this post


Link to post
Share on other sites

bon, j'ai fait les tests...

différence rtl8139 <=> intel e100 : identique...

utilisation processeur du contrôleur ide : 3%

utilisation globale en copiant par le réseau, sur un DD IDE : 10% (7% + 3% contrôleur)

le tout en faisant de la copie à environ 10Mo/s

je pensait que c'était plus d'utilisation processeur, mais bon... c cool :chinois:

Share this post


Link to post
Share on other sites
Que nenni. Une distrib est incompatible GPL si elle entraîne plus de restrictions que la GPL. La BSD en entraîne moins, donc c'est bon. Tu peux vérifier sur gnu.org.

Par contre, c'est clair que je préfère la GPL à la BSD. La (L)GPL t'oblige à jouer le jeu.

A+

Gauret.

la license BSD et GPL sont incompatibles.

L'exemple meme est que jamais un noyau mac os sera basé sur linux alors qu'il est basé sur le noyau bsd car la gpl oblige quiconque voulont ce servir d'un programme sous license gpl et de le transformer et de le redistribue en license gpl obligeatoirement.

avec la license bsd on fait tout ce que l'on veux meme un os proprietaire :(

Donc openbsd n'est pas compatible avec la gpl

Edited by darth_tux

Share this post


Link to post
Share on other sites
Comme clients IRC en mode console, tu as BitchX (le plus connu, mais je l'ai jamais testé) et Irssi (celui-là je l'aime beaucoup, il m'a déjà bien aidé).

Merci.

make install

darth_tux sur le site de GNU, les licences BSD sont 100% compatibles GPL.

En fait ce que tu dis est vrai: La licence GPL entraine une obligation pour les editeurs: publier sources et binaires.

La licence BSD non. Mac Os 10.3 basée sur FreeBSD 5.0 n'utilise pas de logiciels GPL mais beaucoup de BSD. Les logiciels GPL sont proposés en plus de l'OS.

Un OS sous Licence BSD peut porter des logiciels GLP, et réciproquement. exemple FreeBSD. Autre exemple, Debian, Mandrake, ... qui utilisent la pile TCP/IP de FreeBSD, ou openSSL et Openssh d'openBSD.

Si Microsoft décide de prendre FreeBSD pour développer son Longhorn, (ce qui pourrait arriver), il n'utilisera aucun des logiciels sous licence GPL inclus dans les portages de FreeBSD.

Enfin il faut préciser que c'est la révision 2 de la licence BSD qui est compatible GPL.

Le cas est similaire avec le X dont la licence est très proche de la licence BSD (et n'est pas GPL, mais 100% compatible).

Ce sont 2 écoles de développements, l'une centralisée (BSD) l'autre mutualisée(GNU/Linux) mais qui peut dire aujourd'hui que le mode de développement de Debian est moins bon que celui de FreeBSD? Certainement pas moi. J'utilise ce que j'aime, et c'est FreeBSD, qui revendique aujourd'hui son appartenance au monde libre.

http://www.freeBSD.org/

 FreeBSD is free 

pour Tuxxx, désolé j'ai pas cherché s'il y avait l'équivallent du patch Linux pour éviter de réinstaller les drivers nvnet après chaque recompile sous FreeBSD qui a son propre noyau... de toutes façons :

 cd /usr/ports/net/nvnet && make install 

c'est pas compliqué. :fumer:

Share this post


Link to post
Share on other sites

Dark26 désactive le support du wifi dans le bios de ton nforce2 les derniers contrôleurs SATA de NVidia bugguent souvent à cause de ça... apparemment

Edited by ouragan

Share this post


Link to post
Share on other sites
Dark26 désactive le support du wifi dans le bios de ton nforce2 les derniers contrôleurs SATA de NVidia bugguent souvent à cause de ça... apparemment

heu je veux bien mais j'ai pas de wifi , et je me sers pas de mon controleur sata sous nux.......

:fumer:

bon sinon la nuit porte conseille :ouioui: , et je vais peut être pouvoir faire décoller vos score à hdparm :roll:

pour quoi je dis ça ?????

ben j'ai réussi à faire platofonner mes durs à 10.30 mo /s ( limite du pio4 semble t -il )

comment ???? donc je ne sais pas pourquoi, mais sous la knoppix il met un mode batard par defaut

avec hdparm -p 4 --> mode pio4 et hop j'arrive à 10.30 mo /s

pour forcer les modes udma ce'st plus balèze , il faut se serveir de xfer (-X set IDE xfer mode (DANGEROUS) )

avec un code derrière

:yes:

http://tavi.debian.org.tw/index.php?page=hdparm

il y a tout ici :ouioui:

un petit test :fumer:

IDE modes for hdparm -X parameters:

PIO mode

0 -X08 3.3MB/sec

1 -X09 5.2MB/sec

2 -X10 8.3MB/sec NEC PC-98*1

3 -X11 11.1MB/sec

4 -X12 16.7MB/sec

Singleword DMA mode

0 2.1MB/sec

1 4.2MB/sec

2 8.3MB/sec

Multiword DMA mode

0 -X32 4.2MB/sec

1 -X33 13.3MB/sec

2 -X34 16.6MB/sec

Ultra DMA mode

0 16MB/sec

1 25MB/sec

2 -X66 33MB/sec UDMA33

3 50MB/sec

4 -X68 66MB/sec UDMA66

5 -x69 100MB/sec UDMA100

après reflexion en regardant dans les datasheets :fumer: le controlleur piiX de mon pentium ( et aussi de mon serveur pentium 2 :transpi: ) sont donnés pour du 22 mbytes :ouioui:

sachant qu'il y a 2 canaux ( ide1 +1de2 ) ça fait donc du 11 mbyte par canal .....

et par conséquent avec 11 théorique j'arrive à 10.3 mo /s en pratique :fumer:

mon problème sur le serveur c'est qu'il charje le module ide generique :pleure: et que donc on ne peut pas chnager les commande ..... il faut que je trouve quel module il faut pour ça ....( dur de savoir vu qu'il en dur dans la knoppix :pleure: )

Edited by Dark26

Share this post


Link to post
Share on other sites

mes tests avec hdparm sont excellents, sans avoir a passer par Xfer.... C'est quoi l'interet de Xfer ???

[root@remytux remy]# hdparm -t /dev/hda1

/dev/hda1:

Timing buffered disk reads:  64 MB in  1.25 seconds = 51.20 MB/sec

[root@remytux remy]#

Sur ma workstation au taf, avec un 40Go IBM...

Share this post


Link to post
Share on other sites

ça détecte pas automatiquement les réglages du bios?

moi, en utilisant hdparm -i, je vois que le bios détecte le DD en udma5, et il est en udma5 sous linux :yes:

Share this post


Link to post
Share on other sites
mes tests avec hdparm sont excellents, sans avoir a passer par Xfer.... C'est quoi l'interet de Xfer ???

Sur ma workstation au taf, avec un 40Go IBM...

en fait Xfer sert à forcer un mode :yes:

par exemple sur la knoppix ( dernière version) je ne sais pas pourquoi mais ça se bloquer en pio 3 ou je ne sais quoi au demarrage ce qui donne des perfs lamentables ... :vomi1:

sur la majorirté des nouvelles distribution, normalement ça choisit le bon mode :transpi: et donc il n'y a pas besoin de changer quoi que ce soit ...

mais bon sur une distribution qui date ça peut servir :

PS: le mode dma est activé masi pas le 32 bits sur la knoppix :mad2:

Share this post


Link to post
Share on other sites

euh...nan tuxxx..

sur ma a7n8x-e deluxe, le 40go ide est en dma off, et j'ai des debits genre alex ( quelle reference maintenant ! ). Un pote a exactement pareil sur sa a7v8x et 80Go ide....

C'est lourd.

Share this post


Link to post
Share on other sites

Le SATA n'as pas ces problèmes de dma, je crois...

c'est déjà ça de pris :transpi:

Share this post


Link to post
Share on other sites

A propos de DMA, qq'un saurait comment configurer pour que les durs soient remis en DMA au démarrage ?? Car comme le dit le message que j'ai au démarrage de ma Debian, si il y a un fsck sur une partition, à 2-3Mo/s, ça risque d'être long ;-)

Share this post


Link to post
Share on other sites

Le mieux c'est le petit script....je connais pas trop mal maintenant les scripts fab, je te ferais voir si tu veux...

Share this post


Link to post
Share on other sites

Donc en fait tout le monde devrait vérifier avec hdparm -i , et si c'est pas le bon mode, maintenant tout le monde sait comment le changer....

Donc en fait tout ça pour dire que je vais pouvoir mettre un disque ide ( le 13 go surement )sur mon serveur et que donc ça devrait plafonner à 10.3 mo /s , mais bon ça suffira pour alimenter la carte réseau :transpi:

mais bon pour ça il faut que je recompile le kernel pour activer le module pIIX que j'avais viré à la brute :tranpi:

Share this post


Link to post
Share on other sites
Le mieux c'est le petit script....je connais pas trop mal maintenant les scripts fab, je te ferais voir si tu veux...

ouais, mais faut être sûr qu'il soit pris en compte avant un fsck ...

Share this post


Link to post
Share on other sites

ben il suffit de le mettre dans un runlevel assez bas....

tu as vu fab, dark a les memes pb que j'ai sur sephiroth... des disques durs qui saturent notre reseau gigaethernet tellement ils envoient.... :transpi:

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...