Jump to content

Archived

This topic is now archived and is closed to further replies.

tuXXX

[Tuto][Initié] ALSA, gestion du son sous linux

Recommended Posts

Le truc c'est que j'utilise amarock avec le moteur xine et je me suis rendu compte que la carte son qui était utilisée correspondait tout simplement à la premiere de la liste dans kmix.

Merci pour ton aide

Bon j'ai changé un truc la, dans amarock pour le moteur xine j'ai reussi à utiliser alsa dans les option mais le son sort toujour sur les mauvaises enceintes. Ca pourrait pas venir d'un truc genre quemon alsa gere pas asound ?

ah ca y est ca viens de marcher !!

Bon je vais tirer quelques conclusion: alsa mettait du temps à se recharger du coup xine plantait dans amarock. En fait en bricolant un peu (et surtt en laissant s'ecouler plusieurs secondes !!) xine a pu utiliser alsa et du coup amarock sortir sur la bonne carte son !!

Merci pour tout !!

Share this post


Link to post
Share on other sites

Sinon tout BIOS qui se respecte permet la désactivation de la puce AC'97 intégrée. Enfin normalement.

(Ce qui ne résout pas le problème de la webcam :francais:)

Share this post


Link to post
Share on other sites

Hello,

j'ai eu beau chercher, j'ai pas trouvé la solution à mon problème... je me suis décidé à poster.

Je cherche à avoir sur la même machine un serveur icecast avec 2 sources darkice.

Les sources audio sont différentes et sur deux channels différents de la carte son (delta 66).

Je n'ai pas réussi à trouver la configuration ALSA (slave entre autre) pour que tout ça fonctionne.

Quelqu'un a-t-il déjà réussi à faire cohabiter tout ça ?

Share this post


Link to post
Share on other sites

apparement, darkice peut lire edpuis jack, alors je serais toi, je passerais par jack où le routage sera ultra simple :chinois:

Share this post


Link to post
Share on other sites

apparement, darkice peut lire edpuis jack, alors je serais toi, je passerais par jack où le routage sera ultra simple :transpi:

J'ai trouvé ma solution.

Un plugin dnsoop et des plug. Les plug sont des slave du dsnoop et c'est dans leur définition que je bind les channels :transpi:

Si quelqu'un est intéressé je peux poster un asoundrc.

Share this post


Link to post
Share on other sites

.asoundrc :

Tout d'abord le plugin dsnoop :

pcm.dsnooped {
	type dsnoop
	ipc_key 147852 # doit être unique
	ipc_key_add_uid yes

	slave {
			pcm "hw:0,0" # device 0, subdevice 0, en fonction de vos cartes
			period_time 0
			period_size 1024 # en fonction de votre carte
			buffer_size 5461 # en fonction de votre carte
			format S32_LE # en fonction de votre carte
			rate 44100
	}
}

Pour les commentaires "en fonction de votre carte", faîtes un simple arecord avec une conf par défaut, puis

cat /proc/asound/card0/pcm0p/sub0/hw_params

(dans le cas de la carte 0) pour avoir des valeurs concrètes.

Les plugins de type plug :

pcm.channel1 {
	type plug
	slave { pcm "dsnooped" }
	ttable.0.0 1 # le bind des channels
	ttable.0.1 1 # le bind des channels
}

pcm.channel2 {
	type plug
	slave { pcm "dsnooped" }
	ttable.0.2 1 # le bind des channels
	ttable.0.3 1 # le bind des channels
}

pcm.channel3 {
	type plug
	slave { pcm "dsnooped" }
	ttable.0.4 1 # le bind des channels
	ttable.0.5 1 # le bind des channels
}

pcm.channel4 {
	type plug
	slave { pcm "dsnooped" }
	ttable.0.6 1 # le bind des channels
	ttable.0.7 1 # le bind des channels
}

Ceci est une conf pour une carte 8 channels du type M-Audio delta66.

Il est maintenant possible avec cette conf de lancer par exemple plusieurs instances de darkice avec comme input channel1, channel2, channel3 et channel4.

Share this post


Link to post
Share on other sites

Salut.

J'ai essayé de configurer dmix comme expliquer dans le tuto, afin de pouvoire profiter du son de WoW + TS ou de musique + films, etc...

Malheurseusment, je n'ai pas trouvé le fichier /etc/asound.conf . Je l'ai créé et y ai placé les ligne suivante (du tuto) :

{
type plug
slave.pcm "dmix"
}


pcm.dsp0
{
type plug
slave.pcm "dmix"
}

Hors, vu que le fichier n'existait pas avant ca risque pas de marcher vu que la configuration de alsa dois du coup être autre part...

Une idée de où je pourrais le trovuer ?

Share this post


Link to post
Share on other sites
J'ai essayé de configurer dmix comme expliquer dans le tuto, afin de pouvoire profiter du son de WoW + TS ou de musique + films, etc...

Malheurseusment, je n'ai pas trouvé le fichier /etc/asound.conf . Je l'ai créé et y ai placé les ligne suivante (du tuto) :

{
type plug
slave.pcm "dmix"
}


pcm.dsp0
{
type plug
slave.pcm "dmix"
}

Hors, vu que le fichier n'existait pas avant ca risque pas de marcher vu que la configuration de alsa dois du coup être autre part...

Une idée de où je pourrais le trovuer ?

Non non, c'est bien ça.

Les fichiers de configuration de alsa sont /etc/asound.conf et ~/.asoundrc

Ils peuvent ne pas exister (l'un, l'autre, ou les 2), mais alsa essaye toujours de les charger dans l'ordre

:transpi:

Share this post


Link to post
Share on other sites

En effet, après une déco/reco, je peux lancer WoW et de la musique, ou un film et de la musique, le tout en mettant "aoss" devant le lanceur du programme. Merci bien.

Par contre, j'ai essayé avec Ts (je me traine toujours ce problème de micro, alors j'ai encore voulu faire un test) et bien que je mette la variable "aoss" ou non, si j'ai un autre logiciel sonore derriere il ne détecte pas ma voix (et pourtant pour le test je gueule ^^).

Share this post


Link to post
Share on other sites
En effet, après une déco/reco, je peux lancer WoW et de la musique, ou un film et de la musique, le tout en mettant "aoss" devant le lanceur du programme. Merci bien.

Ça veut dire que chez toi wine est configuré pour utiliser oss au lieu de alsa, au lieu d'utiliser aoss il serait plus simple de mettre la sortie alsa directement dans les préférence (winecfg -> onglet "Audio", cocher "ALSA Driver")

Par contre, j'ai essayé avec Ts (je me traine toujours ce problème de micro, alors j'ai encore voulu faire un test) et bien que je mette la variable "aoss" ou non, si j'ai un autre logiciel sonore derriere il ne détecte pas ma voix (et pourtant pour le test je gueule ^^).

Le problème en effet avec TeamSpeak c'est que c'est pas un logiciel libre, et donc c'est impossible de l'améliorer pour ajouter le support de alsa :kimouss: .

En fait avec TeamSpeak il semble qu'il faille utiliser aoss, non pas sur le script "teamspeak", mais sur le binaire "TeamSpeak.bin", cf par exemple http://gentoo-wiki.com/HOWTO_Sound_servers_and_TeamSpeak

Share this post


Link to post
Share on other sites

Hop hop, je poste ici parce que je n'ai... plus de son ^^"

A vrai dire j'ai suivi le tuto sur dmix dans ce sujet :

http://forum.ubuntu-fr.org/viewtopic.php?id=19402

Résultat, je n'ai plus aucun son... pour le fichier asound, j'ai bêtement recopié, j'avoue.

Bon, je panique pas, au pire je fais un retour en arrière, mais s'il y avait moyen de me faire retrouver le son en gardant dmix, je ne crache pas dessus...

(PS :

nal@nilou:~$ lspci | grep "Multimedia audio"
0000:00:05.0 Multimedia audio controller: nVidia Corporation nForce Audio Processing Unit (rev a2)
0000:00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)

A noter que dans le tutorial, il est écrit à un moment :

ensuite, on redémarre ALSA:

sudo /etc/init.d/alsa restart

Comme j'avais droit à un "command not found", j'ai simplement redémarré l'ordinateur...

Share this post


Link to post
Share on other sites

sudo aptitude install alsa-base

Hmm... il était déjà installé, alors je l'ai réinstallé, redémarré et tout entre, rien à faire (et oui, mes enceintes sont branchées :transpi: )

Share this post


Link to post
Share on other sites

EpiDress : essaye alsaconfig déja.

Gigatoaster : première page du topic.

Share this post


Link to post
Share on other sites

merci merci et encore merci pour ce tuto très utile :craint:

je viens de trouver la réponse à ma question sur le redemarrage du son par lorinc (ça craint!!)

sinon mon soundserver plante une fois par jour c'est grave docteur d'autant plus que je touche à rien?

Share this post


Link to post
Share on other sites

EpiDress : essaye alsaconfig déja.

Merci :chinois:

J'ai de nouveau le son... je ne sais pas trop comment l'expliquer, mais j'ai désinstallé/réinstaller des paquets, un peu modifié dans les configurations...

ça doit être un beau bordel dans mes paquets maintenant, mais au moins, ça fonctionne. Je ferai le nettoyage plus tard.

Share this post


Link to post
Share on other sites

Petit truc que j'ai trouvé aujourd'hui.

Pour lancer maniadrive chez moi par exemple, je dois le lancer avec aoss.

C'est une peu relou, mais bon.

Voici une astuce pour ne pas avoir a lancer via aoss.

modprobe snd_pcm_oss

Ca créé le périphérique /dev/dsp, et du coup, on peut lancer les applis sonores sans soucis (mon audacity ne fonctionnait pas sans cette astuc ou aoss :( )

Share this post


Link to post
Share on other sites
Ca créé le périphérique /dev/dsp, et du coup, on peut lancer les applis sonores sans soucis (mon audacity ne fonctionnait pas sans cette astuc ou aoss :( )

Tu doit pouvoir dire à audacity d'utiliser alsa au lieu d'émuler OSS ;)

Share this post


Link to post
Share on other sites

Bon pour résumer mon problème de son résolu par lorinc en moins de deux minutes

pas de son sous myspace (flash) avec l'image apparente

fermer tout

redemarrer la session

konsole

ps aux

fermer tous les trucs connus avec du son...

killall artsd

résulat du son et de l'image sous myspace

:cartonrouge:

Share this post


Link to post
Share on other sites

Ah oui KDE c'est chiant pour ça :francais:

Avec gnaphron on avait résolu le problème en cherchant dans les options de KDE, et en ajoutant audio au user et en relançant la session.

Menu => Centre de configuration KDE => son et multimedia => systeme de sons.

Ensuite Decocher "activer le systeme sonore" dans l'onglet general ou "choisir alsa dans l'onglet materiel, je ne sais plus.

Share this post


Link to post
Share on other sites

Mmh, le plus simple étant encore de virer complètement arts, qui est vraiment chiant. Avec un petit dmix derrière alsa, et c'est beaucoup plus avantageux.

Au passage, arts va même gicler dans KDE 4.

M'enfin je sais pas si c'est simple de virer arts sous toutes les distribs (moi c'est gentoo, y'a juste un USE flag à définir)...

Share this post


Link to post
Share on other sites
Ca créé le périphérique /dev/dsp, et du coup, on peut lancer les applis sonores sans soucis (mon audacity ne fonctionnait pas sans cette astuc ou aoss :( )

Tu doit pouvoir dire à audacity d'utiliser alsa au lieu d'émuler OSS :cartonrouge:

C'est bien ce que je me disais, mais j'ai pas vu les options ou on regle ca :/

Surtout pour une application orientée son sous linux, etre encore sous oss, c'est dommage :(

Share this post


Link to post
Share on other sites

Ah oui KDE c'est chiant pour ça :mdr:

Avec gnaphron on avait résolu le problème en cherchant dans les options de KDE, et en ajoutant audio au user et en relançant la session.

Menu => Centre de configuration KDE => son et multimedia => systeme de sons.

Ensuite Decocher "activer le systeme sonore" dans l'onglet general ou "choisir alsa dans l'onglet materiel, je ne sais plus.

:francais: pourquoi je viens juste d'ouvrir pcinpact à cette heure ci , problème résolu avec tes réponses théo vers 15h :mdr:

j'ai pas vu le message avant de trouver, heureusement google il avait aussi la solution , et scara, et le manuel de kde...

sinon 16 ar tu peux raccrocher ton topic ici?

et effectivement je vais essayer de voir où est le firefoxrc sous mandriva

:francais:

sinon theo pour ajouter audio c'est fait, mais j'ai eu besoin d'aide j'avais pris le groupe à l'envers enfin je me comprends...

Share this post


Link to post
Share on other sites

×
×
  • Create New...