Jump to content

Archived

This topic is now archived and is closed to further replies.

tuXXX

[Tuto][Initié] ALSA, gestion du son sous linux

Recommended Posts

Arf, mer** !

Ben je le trouve pas ... jutse une question: ma carte est une sound Blaster Live 24bits (donc snd-ca0106), ca pourrai marcher si je met celui des sound blaster Live "tout court" (snd-emu10k1), qui lui est présent ?

J'ai également un modules "snd-sb-common", vous croyez qu'il correspond à la plupart des Sound Blaster ?

Comment ca j'essaye de m'en sortir :francais: ?

Parce que là je suis vraiment pas chaud pour recompiler le noyau d'une debian vieille d'une semaine seulement (et puis chui un noob moi...) :roll: .

EDIT: J'ai trouvé cet article, vous croyez qu'il pourrait méviter une recompil du noyau ?

Share this post


Link to post
Share on other sites
Ben je le trouve pas ... jutse une question: ma carte est une sound Blaster Live 24bits (donc snd-ca0106), ca pourrai marcher si je met celui des sound blaster Live "tout court" (snd-emu10k1), qui lui est présent ?

ça m'étonnerais, le chip n'a pas l'air d'être le même, donc il faut un driver différent

J'ai également un modules "snd-sb-common", vous croyez qu'il correspond à la plupart des Sound Blaster ?

"Sound Blaster" c'est très large, vu le nombre de cartes différentes... c'est peut être un module qui sert de base à quelques drivers se ressemblant.

Mais bon, il te faut le driver SB24

Parce que là je suis vraiment pas chaud pour recompiler le noyau d'une debian vieille d'une semaine seulement (et puis chui un noob moi...) :francais: .

EDIT: J'ai trouvé cet article, vous croyez qu'il pourrait méviter une recompil du noyau ?

Le module est présent dans le package kernel-image de debian/ubuntu

Donc tu met à jour ton noyau, tu reboot en le sélectionnant au démarrage et ça marchera

Share this post


Link to post
Share on other sites

Excuse mon ignorance (une fois de plus), mais tu entend quoi par "mettre à jour" et avec quelle commande je le fais ?

Car moi j'ai rapidement fais une recherche et le seul moyen que j'ai vu de mettre un noyau à jour c'est d'un compiler un nouveau...

Share this post


Link to post
Share on other sites

ben avec apt...

normalement, debian fournit tous les modules avec chaque noyau, donc il devrait y être... au moins dans un version récente :francais:

Share this post


Link to post
Share on other sites

Merci, mais quoi avec apt ? Car j'ai pas trouvé de commande apt- pour mettre le noyau à jour... (j'ai essayé apt-get upgrade mais il ne m'a pas proposé de le mettre à jour...).

Sinon il est vrai que je comprend pas qu'il n'y ai pas le support pour mon noyau, je ne pense aps qu'il soi vieux pourtant (2.6.8-11-amd64-generic)...

Share this post


Link to post
Share on other sites
normalement, debian fournit tous les modules avec chaque noyau, donc il devrait y être... au moins dans un version récente :|

C'est pas dans la stable ( mais bon, personne ne met une stable pour un desktop, si? )

Dans le 2.6.11 de la debian testing ( cf )

Dans les 2.6.11 de la debian unstable (mais bon, quand on débute on met pas ça non plus) ( cf )

Pas dans le ubuntu warty (oldstable?)

Dans le 2.6.11 de ubuntu hoary (stable?) ( cf )

Dans les 2.6.11 et 2.6.12 de ubuntu breezy (testing/unstable?) ( cf )

Pour les installer... ben c'est dans les tutos je pense...

Share this post


Link to post
Share on other sites

@lorinc : apt-get update ne change rien , il download des truc mais j'ai pas l'impression que ce soit en rapport avec le noyau.

@tuXXX : Merci, je vais aller voir ca...

Limite si ca veut toujours pas marcher, soit je réinstall, soit je met Ubuntu(j'ai rien mis su ma distrib, ca me coute rien) et puis comme ca j'arrête de faire chier le monde :cartonrouge: . (En plus j'ai d'autres petits problèmes con assez chiant... alors bon)

Voilà voilà :)

Share this post


Link to post
Share on other sites

Plop. Pardon pour le doule post.

Bon, j'ai installé Ubuntu 5.04, et ce qui me dépasse vraiment, c'est que le paquet snd-ca0106 n'y est pas non plus . Alors là je comprend pas...

EDIT : le premier qui dis que Ubuntu n'est pas fais pour débuter je l'explose :yes: .

Share this post


Link to post
Share on other sites

Quel est le noyau installé ( dpkg -l kernel-image )

Si il ne fait pas partie des noyaux cités plus haut, met à jour...

Share this post


Link to post
Share on other sites

Désolé pour la réponse tardive...

Ben mon noyau ne fais pas partie de la liste que tu donnes, Vu que c'est un noyau pour amd64 et que la liste n'en contient pas... Et aucun apt-get upgrade ou update ne m'a mis à jour mon noyau ...

Je pense que je suis bon pour retélécharger un ISO d'Ubuntu (ou de Debian si il me pose pas un autre problème pour installer openoffice...), mais pas pour amd64 ... ca me fais vraiment ch*** mais bon .

Enfin bref, ce que je trouve bizarre quand même, c'est que je ne pense pas être le seul à posséder cette carte son sous amd64 et pourtant cela parait impossibled'avoir le son avec (à part compiler un autre noyau amd64, non ? ).

Bon, alors à moins que vous ayez autre chose à me proposer je m'en vais prendre un autre ISO ... :-D

@+ les gens

Share this post


Link to post
Share on other sites

Je croyait l'avoir dis pourtant ... désolé si c'est vraiment pas le cas ;) .

Merci en tout cas :-D .

Par contre, je pense qu'il ne dois pas faire partie des noyaux de la liste que tu me donnes, vu que je ne possède pas ce module nativement, et je ne vois toujours pas comment le rajouter, vu qu'un apt-get update ou upgrade ne me met pas à jour mon noyau pour obtenir un de ceux de la liste (j'ai l'impression de m'embrouiller, mais je vois toujours pas comment obtenir un des noyau de la liste , recompilation exclue j'entend... ;) ).

[à moitié HS]Limite, je suppose que c'est possible mais je demande confirmation : C'est possible de choisir le noyau à installer pour une net install de Debian Etch /Ubuntu Hoary/Breezy ? Car si j'ai la possibilité de choisir un des noyau possédant le dis package, je ne suis pas contre une réinstall ^^ (chui plus à une près et maintenant que je maitrise l'install debian, c'est pas long d'install X et tout le tintouin ;) ).[/ à moitié HS]

Share this post


Link to post
Share on other sites

Y'a pas moyen juste avec "apt-get install kernel-image-2.6.11-1-amd64-k8" ?

(enfin faut mettre le paquet qui correspond à ce qui est installé pour l'instant)

Debianistes, si vous êtes là... (si j'avais eu une debian sous la main j'aurait essayé, puis man apt-get, man dpkg au pire...) (Morneithan tu peux le faire aussi...)

Share this post


Link to post
Share on other sites

Question pour pas faire une connerie: tu parles d'executer cette commande là de suite ou de la faire après une réinstall de Debian/Ubuntu (car les deux derniers paragraphes de mon précédent post peuvent accépter ta réponse ) ?

Les Debianiste, vous emmerdez pas, je vais le faire :fou: (chui demeuré mais je pens epouvoir y arriver :p ). Et puis chui déjà assez lourd comme ca avec vous pour en plus vous demander d'executer les commandes à ma place :mad2: ^^

Merci tuXXX , je vois si ca marche demain :) . (en tout cas, en ce qui me concerne le paquet serait plutôt 2.6.11-1-amd64-generic , enfin je pense vu que ce n'est pas un kernel en "amd64-k8" à la fin , je dis peut être une connerie...)

@+ :D

Share this post


Link to post
Share on other sites

Juste un chtit Up pour dire que je vais essayé la commande que tu me donne avec le noyau 2.6.11-9-amd64-generic sous Debian Etch (j'ai préféré réinstaller Debian, vu que au final j'avais les même problèmes sous Ubuntu... :/ ).

J'éditerais ce post pour dire si le son marche après cela ou non.

Merci de votre patiente, qui je pense dois être infinie à voir comment vous vous maitrisez avec moi :chinois::incline: .

Share this post


Link to post
Share on other sites

à l'occase, tu pourra faire semblant de recompiler un noyau (c'est à dire ne faire que le make menuconfig et sans enregistrer) pour voir si le module est dispo en amd64 ? des fois que...

Share this post


Link to post
Share on other sites

Tu veux dire, le faire avec le noyau que j'ai d'installé à la base avec Debian ?

Je vais voir... En tout cas il est dispo en amd64 vu que le noyau que je vais essayé de mettre le contient.

EDIT : Bon, j'ai installé le nouveau noay et j'ai désormais mon moudles ca0106 !!! J'ai donc utilisé alsaconf , toussa.

Sauf que voilà, j'ai un autre problème ... quand je fais

cat /proc/asound/cards

, il me sort "no soundcards" . J'ai essayé de la faire manuellement avec modprobe, pareil ...

Voici au passe mon dmesg | tail :

dmesg | tail
ACPI: PCI interrupt 0000:01:0d.0[A] -> GSI 16 (level, low) -> IRQ 16
Model 1009 Rev 00000000 Serial 10091462
AC'97 0 does not respond - RESET
AC'97 0 access is not valid [0x0], removing mixer.
CA0106: probe of 0000:01:0d.0 failed with error -5
ACPI: PCI interrupt 0000:01:0d.0[A] -> GSI 16 (level, low) -> IRQ 16
Model 1009 Rev 00000000 Serial 10091462
AC'97 0 does not respond - RESET
AC'97 0 access is not valid [0x0], removing mixer.
CA0106: probe of 0000:01:0d.0 failed with error -5

Ensuite, j'ai essayé de faire "alsamixer", au cas ou... et voici l'erreur:

alsamixer: function snd_ctl_open failed for default: No such file or directory

Voilà voilà... donc j'avance mais vraiment petit à petit... :-D

Share this post


Link to post
Share on other sites

:francais: vers l'edit rouge du post juste dessus.

Je voulais pas faire de double post mais vu qu'apparement personne est passé ici entre temps ...

Share this post


Link to post
Share on other sites

quand tu modrpoe ton module, il ne te dit rien ? essaye de le voir dans un lsmod ?

à la vue de ton dmesg, tu es sûr que le chip est bien en "on" dans le bios ?

Share this post


Link to post
Share on other sites

Désolé pour le méchant :chinois: ( :iloveyou: ) , j'ai pas été là depuis un chtit moment...

Heu... où je peux voir ca dans le bios ? ce que je comprend pas, c'est qui si était pas "on" je devrait même pas avoir de son sous windows non ?

Share this post


Link to post
Share on other sites

Plop,

Vous allez surement trouver la question con, mais le seul endroit ou je n'ai pas trop de problème sur linux (gentoo), c'est le son! ..... Sauf quand arts plante :p

Bien entendu, je ne trouve pas le moyen de le redemmarrer sans rebooter l'ordi complet 8)

Qu'elle est donc cette commande qui permet de relancer artsd? :yes:

Ensuite je ne sais pas comment avoir le son avec firefox sans killer arts. Mais après je n'ai plus qu'a rebooter l'ordi pour que arts se relance et avoir de la musique :(

Mici d'avance

Dush

Share this post


Link to post
Share on other sites

sous KDE, il suffit d'ouvrir le centre de controle, et de décochoer puis recoher (et en avant chocher!! -- j'ai la forme moi, ce matin... un lapin...) laz case correspondant au serveur de son, ça suffit à le redémarrer :zarb:

sinon, tu peux utiliser artscontrol (qui n'a rien à voir) qui va te relancer arts...

ou alors, tu retiens les options avec lesquelles est lancé arts et tu le lances à la main

/usr/kde/3.4/bin/artsd -F 4 -S 1024 -a alsa -d -b 16 -s 60 -m artsmessage -c drkonqi -l 3 -f &

chez moi

voilou ;)

Share this post


Link to post
Share on other sites

Bonjour, j'essai désespérement de passer de windows à linux, fedora core 4 x86_64

parmi plusieurs problème que je n'ai pas pu résoudre il y a le son:

chips nforce 3 (carte mère msi k8n neo2 platinium) et j'ai des haut-parleurs logitech x-530

alsa intallé par défault

j'ai réussi à avoir du 5.1 avec vlc, mais une qualité très médiocre

-je n'arrive pas à activer le 5.1 pour lire un dvd sous mplayer, pourtant j'ai choisi alsa pour l'audio et séléctionné surround 5.1

- dans alsa mixer j'ai pas de barre pour régler les 2 haut-parleurs arrières

- et ce qu'il y a moyen de modifier l'option duplicate front pour que le son sorte aussi du haut parleur central lors de la lecture de mp3 setereo ?

++

Share this post


Link to post
Share on other sites

×
×
  • Create New...