Jump to content
Dark26

Le Linux BAR - Discussion de tout et de rien

Recommended Posts

Bonjour,

je suis un petit nouveau sur linux, et hier soir, j'ai installer la dernière version d'Ubuntu disponible sur ubuntu.com.

J'ai pris la version 64bits pour intel.

Tous fonctionne bien (même ma carte graphique nvidia :francais: ) et j'en suis très content.

Malheureusement il y a un petit problème...

Il n'y a pas de son :francais:

La carte son est le chipset son intégré de ma p5b deluxe...

Si quelqu'un a une solution...

merci !

PS: désolé si sa ne se poste pas ici...

Share this post


Link to post
Share on other sites

La carte son est bien une SoundMax AD1988B?

Le problème est connu pour la version 8.04 d'Ubuntu . (= https://bugs.launchpad.net/ubuntu/+source/linux/+bug/213206)

Visiblement ils conseillent la mise à jour vers un noyau 2.6.27. Mais bon, il risque d'y avoir des problèmes celui-ci n'étant pas encore finalisé.

Si tu sais comment modifier tes dépôts pour apt, tu n'as qu'à les remplacer par ceux d'intrepid (en gros tu remplaces hardy par intrepid dans /etc/apt/sources.list) et il suffit d'installer les paquetages "linux-image-2.6.27-4-generic" et "linux-restricted-modules-2.6.27-4-generic".

Après avoir fait ça, tu remets tes dépôts hardy (ne surtout pas faire de mise à jour avec tes dépôts intrepid).

Bon, je ne sais pas si j'ai été clair donc si tu as le moindre doute ou si quelque chose ne vas pas, n'hésite pas à le dire.

edit : Ton chargeur de démarrage va être reconfiguré, tu devra choisir le noyau 2.6.27 via grub lors du démarrage.

Share this post


Link to post
Share on other sites

Donc si j'ai bien compris,

je lance le terminal,

je tape:

sudo gedit /etc/apt/sources.list

après je cherche tous les mots "hardy" et je les remplace par "intrepid" ? même pour les lignes qui commence par # ?

Quand est il de la première ligne ou il y a le "deb cdrom", il y a le nom de la distrib entière ?!

et après je fais un :

sudo apt-get update
sudo apt-get install linux-image-2.6.27-4-generic
sudo apt-get install linux-restricted-modules-2.6.27-4-generic

Et je refais la modification inverse pour le sources.list ( que je peut copier comme backup ?)

et je refais un

sudo apt-get update

?

c'est sans risque ?

Share this post


Link to post
Share on other sites
Donc si j'ai bien compris,

je lance le terminal,

je tape:

sudo gedit /etc/apt/sources.list

après je cherche tous les mots "hardy" et je les remplace par "intrepid" ? même pour les lignes qui commence par # ?

Quand est il de la premier ligne ou il y a le "deb cdrom", il y a le nom de la distrib entière ?!

En fait, je viens de vérifier, tu ne dois modifier que la ligne concernant les dépots main, car il me semble que intrepid-security et intrepid-update n'existent pas.

Tu aura donc cette ligne :

deb http://fr.archive.ubuntu.com/ubuntu/ intrepid main restricted

J'espère ne pas t'avoir embrouillé. :francais:

edit :

et après je fais un :

sudo apt-get update
sudo apt-get install linux-image-2.6.27-4-generic
sudo apt-get install linux-restricted-modules-2.6.27-4-generic

Et je refais la modification inverse pour le sources.list ( que je peut copier comme backup ?)

et je refais un

sudo apt-get update

?

c'est sans risque ?

C'est bien ça.

Le seul problème que tu pourrais avoir, c'est un bug avec le noyau mais comme tu peux toujours sélectionner l'ancien après avoir installé le nouveau, il n'y a pas de soucis.

Share this post


Link to post
Share on other sites

Okay,

Je test ça se soir et je vous tiens au courant...

merci !

Édit:

ça marche :francais::francais::francais:

C'est presque nickel, maintenant j'aimerais monter automatiquement au démarrage le disque "data" qui est en ntfs possible?

Share this post


Link to post
Share on other sites

Tu créer le dossier ou tu veux monter ton disque en faisant :

sudo mkdir /tondossier (genre /media/windows)

Ensuite tu ajoute a ton fstab (dans /etc/fstab)

/dev/sda1 /media/windows ntfs-3g defaults 0 0 (aveec mon example :D)

Share this post


Link to post
Share on other sites
/dev/sda1 /media/windows ntfs-3g defaults 0 0

Je dois copié cette ligne exactement comme ceci ou je dois faire une modif ?

c'est quoi "/dev/sda1" ? pourquoi "-3g" après ntfs ? "defaults 0 0" ??

On peut m'expliquer ? :p

Oui je suis un peut curieux, j'aime bien comprendre ce que je fais...

Merci !

Share this post


Link to post
Share on other sites

Donc je dois juste adapter le "/dev/sda1" au bon disque/partition et le "/media/windows" au dossier que j'aurais créer avec mkdir ?

Share this post


Link to post
Share on other sites
pourquoi "-3g" après ntfs ?
C'est le nom du driver.

ntfs-3g a largement supplanté ntfs en terme de fonctionnalités et permet presque tout sans risque de pertes de données.

Share this post


Link to post
Share on other sites
Donc je dois juste adapter le "/dev/sda1" au bon disque/partition et le "/media/windows" au dossier que j'aurais créer avec mkdir ?

C'est bien cela.

Share this post


Link to post
Share on other sites
Donc je dois juste adapter le "/dev/sda1" au bon disque/partition et le "/media/windows" au dossier que j'aurais créer avec mkdir ?

C'est bien cela.

Ça me fait penser que j'ai un bug bizarre avec fstab

/dev/sdc1	   /media/Stockage ntfs,auto,user,umask=0, 0 0

Mais dans mon poste de travail il est nommé Média 400,1Gio alors que les autres DD sont bien nommés comme dans le fstab.

Share this post


Link to post
Share on other sites

Merci, maintenant mon disque data est monté automatiquement ;)

Ps: je l'ai monté dans /mnt comme ça, il ne s'affiche pas sur le bureau

Share this post


Link to post
Share on other sites
Ça me fait penser que j'ai un bug bizarre avec fstab

/dev/sdc1	   /media/Stockage ntfs,auto,user,umask=0, 0 0

Mais dans mon poste de travail il est nommé Média 400,1Gio alors que les autres DD sont bien nommés comme dans le fstab.

:craint:

Je ne suis pas certain d'avoir compris.

Ton "bug" c'est que ça marque Média 400 dans ton poste de travail mais tu voudrais que ça soit nommé Stockage, c'est ça?

Je ne suis pas un as de la partition mais il me semble que les noms de partitions ne sont pas gérés par fstab. Je crois plutôt que Gnome lit l'étiquette de la partition et l'utilise comme nom (ce qui serait logique en fait).

Donc si tu veux que ta partition /dev/sdc1 soit nommée Stockage, je crois que tu dois modifier cette étiquette. -> GParted -> clic droit sur /dev/sdc1 -> label (/étiquette) -> tu entres le nom de la partition

J'espère ne pas me planter :chinois:

Share this post


Link to post
Share on other sites

Exact, souvent il prend le nom qu'il a sous wndows :chinois:

Share this post


Link to post
Share on other sites
Ça me fait penser que j'ai un bug bizarre avec fstab

/dev/sdc1	   /media/Stockage ntfs,auto,user,umask=0, 0 0

Mais dans mon poste de travail il est nommé Média 400,1Gio alors que les autres DD sont bien nommés comme dans le fstab.

:pleure:

Je ne suis pas certain d'avoir compris.

Ton "bug" c'est que ça marque Média 400 dans ton poste de travail mais tu voudrais que ça soit nommé Stockage, c'est ça?

Je ne suis pas un as de la partition mais il me semble que les noms de partitions ne sont pas gérés par fstab. Je crois plutôt que Gnome lit l'étiquette de la partition et l'utilise comme nom (ce qui serait logique en fait).

Donc si tu veux que ta partition /dev/sdc1 soit nommée Stockage, je crois que tu dois modifier cette étiquette. -> GParted -> clic droit sur /dev/sdc1 -> label (/étiquette) -> tu entres le nom de la partition

J'espère ne pas me planter :chinois:

C'est bien ce que je pensait mais je voulait pas prendre de risque ^^

Edit : bon ben j'ai pas l'option etiquette dans gparted :craint:

Share this post


Link to post
Share on other sites
C'est bien ce que je pensait mais je voulait pas prendre de risque ^^

Edit : bon ben j'ai pas l'option etiquette dans gparted :craint:

Ni label? :chinois:

Chez moi l'option est entre Vérifier et Informations lors d'un clic droit sur une partition.

Share this post


Link to post
Share on other sites
Ben j'ai pas :chinois:

Le paquetage ntfsprogs est-il installé? (dosfstools s'il s'agit d'une partition FAT)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...