Jump to content
Dark26

Le Linux BAR - Discussion de tout et de rien

Recommended Posts

Donc je mets defaults,user,rw ?

Je viens d'essayer, ça marche toujours pas...

Share this post


Link to post
Share on other sites

Exemple pour /dev/sda1 montée dans /mnt/disque (fdisk -l "en root" )

/dev/sda1	   /mnt/disque  vfat user,exec,rw,noauto,umask=022,gid=1000 0   0

Share this post


Link to post
Share on other sites

Donc je mets defaults,user,rw ?

Je viens d'essayer, ça marche toujours pas...

T'as pensé à démonter/remonter la partoche? Parce que sinon je suis pas sûr qu'il prenne en compte les nouveaux arguments de ton fstab...

Share this post


Link to post
Share on other sites
Exemple pour /dev/sda1 montée dans /mnt/disque (fdisk -l "en root" )

/dev/sda1	   /mnt/disque  vfat user,exec,rw,noauto,umask=022,gid=1000 0   0

Donc je mets defaults,user,rw ?

Je viens d'essayer, ça marche toujours pas...

T'as pensé à démonter/remonter la partoche? Parce que sinon je suis pas sûr qu'il prenne en compte les nouveaux arguments de ton fstab...

Je viens de le faire avec la dernière modif proposée et ça marche :D

Merci à tous :D

Pour une ntfs on fait pareil ?

Share this post


Link to post
Share on other sites

/dev/hda2	/mnt/windows	ntfs	ro,user,auto,gid=100,umask=002,nls=utf8  0	0

Juste parceque c'est ma tournée :craint:

P.S: Là la partoche est montée automatiquement "auto" (cf tuto fstab sur ce forum par :craint: )

Share this post


Link to post
Share on other sites
/dev/hda2	/mnt/windows	ntfs	ro,user,auto,gid=100,umask=002,nls=utf8  0	0

Juste parceque c'est ma tournée :craint:

P.S: Là la partoche est montée automatiquement "auto" (cf tuto fstab sur ce forum par :craint: )

Merci :craint:

Ca a l'air de marcher, je vais tester un peu :craint:

EDIT : je peux écrire sur la partition fat32 (j'ai rajouté iud=500 et gid=100)

Par contre la ntfs, je ne sais pas si linux en est capable...? normalement avec le noyau 2.6-16 on peut mais je sais si ça a été débloqué...

Peut-il ?

Share this post


Link to post
Share on other sites
/dev/hda2	/mnt/windows	ntfs	ro,user,auto,gid=100,umask=002,nls=utf8  0	0

Juste parceque c'est ma tournée :transpi:

P.S: Là la partoche est montée automatiquement "auto" (cf tuto fstab sur ce forum par ;) )

Merci :-D

Ca a l'air de marcher, je vais tester un peu :transpi:

EDIT : je peux écrire sur la partition fat32 (j'ai rajouté iud=500 et gid=100)

Par contre la ntfs, je ne sais pas si linux en est capable...? normalement avec le noyau 2.6-16 on peut mais je sais si ça a été débloqué...

Peut-il ?

;)

pour le NTFS, il faut toujours passer par captive, je viens de regarder dans le 2.6.16-gentoo-r2 ;)

Share this post


Link to post
Share on other sites

Le truc c'est pas que je veux écrire sur ma ntfs, c'est que je veux copier des fichiers de ma ntfs vers une fat32 (par linux) et que j'ai pas envie de mettre une permission d'écriture sur chaque dossier et fichier un par un (14go de musique :transpi: + d'autres trucs)...

Comment faire ?

Share this post


Link to post
Share on other sites

:transpi:

pour copier de A vers B, il faut des droits en lecture sur A et en écriture sur B, logique, non ?

si A est en NTFS et B en FAT32, alors aucun problème :transpi:

Share this post


Link to post
Share on other sites
:transpi:

pour copier de A vers B, il faut des droits en lecture sur A et en écriture sur B, logique, non ?

si A est en NTFS et B en FAT32, alors aucun problème :transpi:

Ben je viens d'essayer, il faut mettre le droit d'écriture sur chaque fichier chez moi...

Share this post


Link to post
Share on other sites

root@gollum:~# apt-get upgrade
Reading package lists... Done
Segmentation faulty tree... 0%

Ca pue !!! :D:vac:

:D8)

Share this post


Link to post
Share on other sites
root@gollum:~# apt-get upgrade
Reading package lists... Done
[b]Segmentation fault[/b]y tree... 0%

Ca pue !!! :vac::roll:

:baton:8)

Salut

MoUaaAaaaAA :eeek2::eeek2: .

Apt-get reinstall debian :D:D

a+

Share this post


Link to post
Share on other sites

bon j' avance dans mon diag :

je lance un debug avec

strace -fF apt-get upgrade > aptget.log 2>&1

quand je regarde le fichier aptget.log, il essaie d'ouvrir "/etc/apt/preferences" (qui n'existe pas) juste avant de segfaulter

je touch /etc/apt/preferences mais rien n'y fait

je google /etc/apt/preferences

je tombe sur http://free2.org/d/

qui me recommande

apt-get install gnupg apt-show-versions apt-listbugs wget

il installe

The following NEW packages will be installed:
 apt-listbugs libdpkg-ruby1.8 libintl-gettext-ruby1.8 libxml-parser-ruby1.8 ruby

et surprise, l'apt-get install marche, et l'apt-get upgrade remarche :transpi::yes:

on me la fait pas à moi :ouioui:

Share this post


Link to post
Share on other sites

Hum.... comment ça se fait que le apt/preferences ait viré :ouioui: ?

En tout cas tu as eu de la chance à pouvoir faire un apt-get install malgré ça :yes:

Sans ça je sais pas trop comment faire (un dpkg -reconfigure apt peut être?)

Share this post


Link to post
Share on other sites

bon j' avance dans mon diag :

je lance un debug avec

strace -fF apt-get upgrade > aptget.log 2>&1

quand je regarde le fichier aptget.log, il essaie d'ouvrir "/etc/apt/preferences" (qui n'existe pas) juste avant de segfaulter

je touch /etc/apt/preferences mais rien n'y fait

je google /etc/apt/preferences

je tombe sur http://free2.org/d/

qui me recommande

apt-get install gnupg apt-show-versions apt-listbugs wget

il installe

The following NEW packages will be installed:
 apt-listbugs libdpkg-ruby1.8 libintl-gettext-ruby1.8 libxml-parser-ruby1.8 ruby

et surprise, l'apt-get install marche, et l'apt-get upgrade remarche :D:D

on me la fait pas à moi :transpi:

le bonheur de sid...

Tu es passé à xorg 7.0 aussi ? :ouioui:

Share this post


Link to post
Share on other sites

le bonheur de sid...

Tu es passé à xorg 7.0 aussi ? :transpi:

Nan encore heureux. Bon remarque c'est un P166 sans écran, et avec 1 Go de disque donc pas de place à perdre pour X !

Share this post


Link to post
Share on other sites

Hum le package xorg 7.0 n'est vraiment pas bon, obligé de refaire des liens à la mano, puis les drivers nvidia n'aime pas la nouvelle organisation pour y placer les modules en .so (mais bon là c'est à cause de nvidia).

Donc upgrade à risque pour l'isntant (en même temps apt-list-bugs m'avait prévenu...)

Share this post


Link to post
Share on other sites

Cela dit mon post dans le topic était également destiné à expliquer une piste d'auto-dépannage : utiliser strace et consulter les logs :transpi:

Share this post


Link to post
Share on other sites

Perso ca a été log de X, puis chercher dans les fichiers de conf le fichier perdu pour m'appercevoir que le fichier recherché était en dur dans le binaire Xorg :transpi: d'où le lien un peu porkas...

Si quelqu'un recontre le problème pour le xorg7.0/sid je peux détailler quitte à aller dans le topic debian :ouioui:

Share this post


Link to post
Share on other sites

:iloveyou:

heureusement qu'il s'agit de la station internationale, sinon, il risquait de se prendre un DoS... :D

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...