Jump to content
Patrick.

Virtualbox empêche accès réseau local ? [Résolu]

Publications recommandées

Bonjour,

mes pc sous windows 10 se trouvent derrière un routeur (sous réseau 192.168.1.xxx) et livebox (192.168.0.x).

Le réseau local et l'accès à internet fonctionnaient parfaitement.

Suite à la dernière mise à jour de Windows 10, un logiciel d'un de mes pc ne fonctionnait plus. J'ai installé Windows XP à l'aide de VirtualBox.

Cela m'a permis d'utiliser de nouveau ce logiciel. Ce PC ne me sert que très rarement.

En voulant l'utiliser aujourd'hui sous Windows 10, je m'aperçois que je n'ai plus accès au réseau local mais qu'internet fonctionne.

Lorsque j'ai installé VirtualBox, je n'ai pas vérifié qu'avec Windows 10 l'accès au réseau local fonctionnait.

Je ne sais pas si cela vient de VB mais en faisant un ipconfig /all, je vois une adresse IP que je ne connaissais pas :

192.168.56.1 (VirtualBox Host-Only Ethernet Adapter).

Dans VB, j'ai essayé les différentes configurations réseau possibles (aucune connexion, NAT, Réseau NAT, Accès par pont, ...)

mais aucune ne résout mon problème.

La configuration que j'avais paramétrée à l'installation de VB était l'accès par pont.

Je ne vois pas ce qui bloque et je vous remercie de me conseiller pour résoudre ce problème.

Je vous souhaite une bonne fin de week-end.

Patrick.

Modifié par Patrick.

Partager cette publication


Link to post
Share on other sites

A l'aide du gestionnaire de périphériques, supprime l'"interface réseau virtualbox (ainsi que les fichiers du pilote) et ne démarre pas VB avant que ton hôte ai de nouveau accès au réseau.
Ça te permettra de travailler sereinement sur une configuration "normale" avant de t'atteler à ton invité

Partager cette publication


Link to post
Share on other sites

Bonjour et merci L33thium pour ta réponse,

je retiens ta solution mais j'aimerais, si possible, retrouver le réseau sous W10 et utiliser VB.

Ou bien, il ne me reste plus qu'à rester avec XP. Avec lui sous VB, je vois mon réseau local, j'ai accès à internet

et bien sûr mon logiciel fonctionne. It's a joke.

Partager cette publication


Link to post
Share on other sites

il faut d'abord regler le problème de l'hote, ensuite une réinstallation du pilote VB suffira

Partager cette publication


Link to post
Share on other sites

Bonsoir L33thium,

j'ai supprimé l'interface réseau de VB et cela fonctionne. Merci.

Dernier point : comment effectuer la réinstallation du pilote VB ?

Et où le récupérer ?

Partager cette publication


Link to post
Share on other sites

Bonjour,

j'ai réinstallé VB (nouvelle version du logiciel) et l'interface réseau s'est de nouveau installée.

Je n'ai plus donc accès au réseau local.

Partager cette publication


Link to post
Share on other sites

Bonsoir Foetus,

je peux désactiver quoi ? l'interface réseau ?

Si oui, entre désactiver et supprimer je ne vois pas trop la différence (pour mes besoins).

La solution est sans doute de supprimer le réseau sur VB et de pouvoir utiliser normalement ce PC hors XP.

 

 

Partager cette publication


Link to post
Share on other sites

Non, si tu supprimes l'interface (tout comme si tu désinstalles un pilote), Windows va te réinstaller ton périphérique inconnu.

Il faut la désactiver pour dire à Windows : "Ne prend pas"

Partager cette publication


Link to post
Share on other sites

Bonjour,

j'ai désactivé l'interface réseau VB et cela fonctionne.

Je ne comprends pas mais j'ai accès au réseau local avec windows XP (VirtualBox) et au réseau local "normal" avec Windows 10.

Merci à tous les deux pour votre aide.

Bonne journée à tous.

Patrick.

Désolé Tromatism et Edtech mais je n'avais pas vu vos réponses.

Mon PC est W10 Famille.

Bonne journée.

Partager cette publication


Link to post
Share on other sites

Il y a que Windows est un OS proprement NUL conçu par de vraies BALTRINGUES, et dans leur nullité ils se sont dit que les interfaces réseaux "récentes" sont à consulter de façon prioritaire en cas de communication directe au réseau local. Et forcément, vu que l'interface Virtualbox n'est PAS le réseau local mais logiquement le dernier qu'on installe, ça foire...

Il faut donc changer la table de routage pour que l'interface réseau souhaité soit prioritaire. Cet ordre de priorité se change par la modification d'une valeur "métrique" propre à chaque interface réseau. Et Windows interrogera toutes les interfaces en partant du plus petit, jusqu'à obtenir la réponse souhaité.

Il est possible de faire ça assez simplement par la section des adaptateurs :

https://pandapow.co/how-to/win10-set-network-adapter-metric/

Je recommande avant de modifier ces valeurs, de regarder d'abord ce qui est marqué dans cette case aussi bien sur l'interface normale que celle de Virtualbox, pour comparer. Personnelement je ne pense pas qu'il soit sage de mettre 1 en métric comme marqué dans ce lien, et il me semble d'ailleurs que de base c'est 50 pour l'interface principale, et Virtualbox devait avoir probablement 35 de mémoire, le rendant donc prioritaire.

Du coup j'ai inversé ces valeurs. 35 pour mon interface principale, 50 pour Virtualbox pour le mettre en seconde position.

Il est possible de voir tous les métriques avec une commande, or on peut voir des valeurs assez fantaisistes comme 331 ou autres, d'où mon doute sur mettre 1 :

route print

Cette information est à garder de côté pour pourquoi pas un jour mettre un VPN, vu qu'il faudra prioriser ce dernier :D

Modifié par TheKillerOfComputer

Partager cette publication


Link to post
Share on other sites

Avant de critiquer Windows 10, on réfléchi deux secondes aux raisons de ce choix et aussi de pourquoi ça marche avec HyperV et VMware sans soucis, et on en conclut que VirtualBox, comme très souvent, ne fait pas les choses correctement lors de la création des cartes réseaux virtuelles...

Par contre merci pour la solution, ça peut servir !

Partager cette publication


Link to post
Share on other sites

Bonjour The Killer,

intéressant ton explication.

Pour le moment cela fonctionne mais si ça déconne de nouveau je paramétrai comme indiqué.

Dans la colonne métrique, j'ai tout en 281 ou 331

Ou alors les solutions de Tromatism et de Edtech.

Bonne fin de journée.

Modifié par Patrick.
Ajout des valeurs métriques

Partager cette publication


Link to post
Share on other sites
Il y a 10 minutes, Edtech a écrit :

Avant de critiquer Windows 10, on réfléchi deux secondes aux raisons de ce choix et aussi de pourquoi ça marche avec HyperV et VMware sans soucis, et on en conclut que VirtualBox, comme très souvent, ne fait pas les choses correctement lors de la création des cartes réseaux virtuelles...

Par contre merci pour la solution, ça peut servir !

Je me suis pris tellement de bugs chelous avec cet OS que j'ai bien du mal à rester pragmatique quand on l'évoque :D Le dernier en date (et encore heureux ce n'est pas grave et manuellement contournable), c'est le Wifi qui ne se connecte pas automatiquement à l'allumage/reboot malgré la case cochée (bug apporté depuis Creator Update, checkez Google) et absolument AUCUNE des 19 solutions sur le net ne fonctionne, et cela d'usine, après un formatage et mise à jour Windows Update UNIQUEMENT. A un moment ça devient difficile de garder son calme:mad:donc maintenant je critique Windows 10 avant le reste, les chances que je me trompe sont faibles.

Modifié par TheKillerOfComputer

Partager cette publication


Link to post
Share on other sites

Je suis d'accord qu'il y a beaucoup de bogues dans Windows 10, je suis le premier à gueuler, enfin, je publie ds tonnes de bogues dans le Hub de Commentaires.

Comme en plus je suis Insider, j'en ai à la pelle en ce moment !

Partager cette publication


Link to post
Share on other sites

Je suis aussi insider et je me demande comment ça se fait qu'on soit aussi maso pour continuer à être insider :transpi:

  • Haha 1

Partager cette publication


Link to post
Share on other sites
Il y a 2 minutes, Aloyse57 a écrit :

Je suis aussi insider et je me demande comment ça se fait qu'on soit aussi maso pour continuer à être insider :transpi:

Bah, perso, j'espère que ça corrige des bogues chiants. Et d'ailleurs, c'est le cas ! Mon écran ne se mettait jamais en veille (il restait vide mais rétro-éclairé), et passer en Insider a corrigé le problème.

D'ailleurs, sur PC, la version Insider, ça va. Par contre, sur ma Surface Pro 4, ça bogue beaucoup et c'est lent.

Partager cette publication


Link to post
Share on other sites

Veuillez vous connecter pour commenter

Vous serez en mesure de laisser un commentaire après vous être connecté



Se connecter dès maintenant

×