Jump to content

Archived

This topic is now archived and is closed to further replies.

gyan000

[SCRIPT] Installation pilote ATI sous Mandriva

Recommended Posts

tu pourrais soit recupérer kernel-2.6-2.6.8.1-12mdk.i586.rpm (c'est le numero qui est important)

je ne l'ai pas déjà récupérée?

# urpmi kernel-source-2.6

  ftp://ftp.ciril.fr/pub/linux/mandrakelinux/official/10.1/i586/media/main/ker                 nel-source-2.6-2.6.8.1-12mdk.i586.rpm
installation de /var/cache/urpmi/rpms/kernel-source-2.6-2.6.8.1-12mdk.i586.rpm
Préparation...              ##################################################
 1:kernel-source-2.6      ##################################################

Share this post


Link to post
Share on other sites

:transpi: tu as récupéré des sources avec ce numero de version, pas un kernel...

je t'ai donné 2 lien qui devrait être cohérents. récupère les paquetages, et rpm -Uvh nom_du_paquetage...

ensuite, il faudra certainement redémarrer (une des rares fois), car le kernel aura vraissemblablement changé ;)

Share this post


Link to post
Share on other sites

J'ai installé le paquetage kernel-2.6.8.1.12mdk-1-1mdk.i586.rpm:

[root@localhost tmp]# rpm -Uvh kernel-2.6.8.1.12mdk-1-1mdk.i586.rpm
Préparation...                                                          (1                                                 ########################################### [100%]
  1:kernel-2.6.8.1.12mdk                                               (                                                  ########################################### [100%]
Looking for deps of module cramfs
Looking for deps of module ide-mod
Looking for deps of module ide-probe-mod
Looking for deps of module ide-core
Looking for deps of module ide-disk
Looking for deps of module ext3
        jbd
Looking for deps of module jbd
Using modules:  ./kernel/fs/jbd/jbd.ko ./kernel/fs/ext3/ext3.ko
Using /root/tmp as temporary directory.
/sbin/nash -> /root/tmp/initrd.WWx6W8/bin/nash
/lib/modules/2.6.8.1-12mdk/./kernel/fs/jbd/jbd.ko.gz:    59.7%
copy from /root/tmp/initrd.WWx6W8/lib/jbd.ko(elf32-i386) to /root/tmp/initrd.WWx6W8/lib/stf1ULOh(elf32-i386)
/lib/modules/2.6.8.1-12mdk/./kernel/fs/ext3/ext3.ko.gz:  55.4%
copy from /root/tmp/initrd.WWx6W8/lib/ext3.ko(elf32-i386) to /root/tmp/initrd.WWx6W8/lib/stLv4afl(elf32-i386)
Loading module jbd.ko
Loading module ext3.ko
/sbin/udev-klibc -> /root/tmp/initrd.WWx6W8/sbin/udev
/sbin/udevstart-klibc -> /root/tmp/initrd.WWx6W8/sbin/udevstart
Contents of RCFILE:
#!/bin/nash

echo "Loading jbd.ko module"
insmod /lib/jbd.ko
echo "Loading ext3.ko module"
insmod /lib/ext3.ko
echo Mounting /proc filesystem
mount -t proc /proc /proc
echo Mounting sysfs
mount -t sysfs none /sys
echo Creating device files
mountdev size=1M,mode=0755
echo starting udev
udevstart
echo -n /sbin/hotplug > /proc/sys/kernel/hotplug
echo Creating root device
mkrootdev /dev/root
echo Mounting root filesystem
mount -o defaults --ro -t ext3 /dev/root /sysroot
echo 0x0100 > /proc/sys/kernel/real-root-dev
pivot_root /sysroot /sysroot/initrd
umount /initrd/sys
umount /initrd/proc
echo Initrd finished
bootsplash not found in /boot/initrd-2.6.8.1-12mdk.img
Added linux
Added windows *
Added 2681-10smp
Added 2681-12
[root@localhost tmp]#

J'ai redémarré mon PC. Et effectivement, mon uname a changé :keskidit:

[root@localhost tmp]# uname -r
2.6.8.1-12mdk
[root@localhost tmp]#

Je vais reprendre tout depuis le début pour voir si ca marche... à suivre

Share this post


Link to post
Share on other sites

c'est bon, fgl_glxgears marche!!! Je vois le cube en mouvement!!!

$ fgl_glxgears
2379 frames in 5.0 seconds = 475.800 FPS
3187 frames in 5.0 seconds = 637.400 FPS
3201 frames in 5.0 seconds = 640.200 FPS
3183 frames in 5.0 seconds = 636.600 FPS
3213 frames in 5.0 seconds = 642.600 FPS
2822 frames in 5.0 seconds = 564.400 FPS
2145 frames in 5.0 seconds = 429.000 FPS
2760 frames in 5.0 seconds = 552.000 FPS
2768 frames in 5.0 seconds = 553.600 FPS
2275 frames in 5.0 seconds = 455.000 FPS
2018 frames in 5.0 seconds = 403.600 FPS

Le problème était donc bien au niveau des sources du noyau!

Merci lorinc :keskidit::chinois::-D:keskidit::chinois::pleure:

Share this post


Link to post
Share on other sites

tu peux vérifer que direct rendering est ok (soit avec

$glxinfo | grep direct

soit avec fireglcontrol qui te donne toute les infos sur la 3D utilisée)

:keskidit:

EDIT : j'avais pas vu les score : tout est ok. encore bravo :chinois:

Share this post


Link to post
Share on other sites

Merci beaucoup à le barjo pour son script sous mandrake 10.1 et the redburn pour m'avoir aidé.

Avec noel, j'ai eu un graveur de dvd et je suis donc passé sur la 10.1 me permetant d'utiliser me script du bajo.

Merci à vous donc, ça marche nickel :byebye:

Share this post


Link to post
Share on other sites
J'ai installé le paquetage kernel-2.6.8.1.12mdk-1-1mdk.i586.rpm:

Depuis la mise a jour de cette nouvelle version des sources du noyau, j'ai perdu le son.

En plus de ca, j'ai un pb au chargement du centre de contrôle: une fenêtre apparaît en plein milieu de l'écran et elle se bloque! :p

EDIT: Je me suis renseignée auprès d'un ami informaticien un peu plus calé que moi sur les commandes urpmi et rpm.

Il m'a dit que la commande urpmi permettait d'installer un paquetage sans se soucier de ses dépendances (qui sont installées en même temps). Alors que pour la commande rpm, il faut que toutes les dépendances soient installées au préalable.

Si vous confirmez ces définitions, je me demande alors pourquoi quand j'ai fait la mise à jour des sources du noyau avec cette commande:

# urpmi kernel-source-2.6

je n'ai vu aucun changement?

C'est en faisant:

# rpm -Uvh kernel-2.6.8.1.12mdk-1-1mdk.i586.rpm

que le changement a été effectif.

Merci de votre réponse

Share this post


Link to post
Share on other sites

urpmi gere sa propre base de paquetage (dispo sur un server distant), donc quand tu tape urpmi nom_du_paquetage, il regarde dans sa liste et installe ce qui lui semble le plus approprié.

alors que rpm installe un paquetage spécifique que tu lui donne en argument (et que tu à préalablement téléchargé).

pour ta fenetre du centre de controle qui se bloque, tu n'as acces à rien?

essayes de le lancer en root dans un console:

#drakconf

peut-être que des informations mystiques apparaîtront dans la console...

tu peux aussi essayer de le mettre à jour avec urpmi histoire de remettre les choses en places :D

Share this post


Link to post
Share on other sites
#drakconf

peut-être que des informations mystiques apparaîtront dans la console...

tu peux aussi essayer de le mettre à jour avec urpmi histoire de remettre les choses en places :D

En fait, il se lance bien de temps en temps et là, ca marche! :D

J'essaierai au prochain plantage.

Par contre, quand j'essaie urpmi, voilà ce qu'il me met:

# urpmi drakconf

Tout est déjà installé

EDIT: Je peux peut-être faire la même chose avec le son? Mais je ne sais pas la commande. Je vais chercher....

J'ai trouvé un pilote pour le son intégré à ma carte mère: alsa-driver-0.9.6.tar.bz2

mais quand j'essaie de le décompresser, j'ai le message suivant:

# tar -zxvf alsa-driver-0.9.6.tar.bz2

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Statut d'erreur reporté d'erreurs précédentes.

EDIT 2: C'est bon pour le son :D

J'ai lancé alsaconf depuis un terminal et ca m'a ouvert une interface graphique qui m'a refait l'installation du pilote pour le son! Et maintenant, je peux écouter Alanis Morissette à volonté :D

Depuis que je suis sur ce forum, j'arrive à résoudre plus vite mes erreurs! MERCI MERCI (surtout lorinc :D )

EDIT 3: Le centre de contrôle a planté!! Le pire, c'est que la fenêtre reste en plein milieu de l'écran sans que je puisse la retirer! J'ai tapé drakconf dans un terminal et ca me fait la même chose: chargement du centre de contrôle bloqué. Idem avec la commande mcc.

Je pense qu'il faut que je réinstalle le centre de contrôle...

Share this post


Link to post
Share on other sites

tu devrais ouvrir un topic.

pour le son, ALSA est integrer dans le noyau 2.6, donc pas besoin de l'installer :cartonrouge:

pour drakconf, tu peux essayer de le desintaller avec urpme puis de le reinstaller avec urpmi :cartonrouge:

Share this post


Link to post
Share on other sites

bonsoir,

je suis debutante sous linux, et je rencontre le meme probleme que pirlouy au demarage de X:

...

(EE) unable to locate/open config file

...

getconfig.pl: file 'usr/X11R6/lib/getconfig/xorg.cfg' has bad signature

: no rules in file:'/usr/bin.../xorg.cfg'

...

Fatal servor error :

Cannot run in framebuffer mode: please specify BusIDs for all framebuffer devices

...

carte mere A7N8X-E delux

carte graphique geforce fx5200

proc amd 3200+

1G de RAM

mandrake 10.1 officiel

pour plus d'info j'ai pu utiliser mdk pendant 2 semaine sans probleme c'est apres avoir installer amule et l'avoir fait tourner que j'ai planter et que j'ai plus X (c'est peut etre juste parcequ'amule demande d'un coup plus de ressource...)

j'ai vu qu'il fallait faire kelke chose avec Xorg mais en tant que debutante je n'ai pas bien compris.

merci de vos reponses...

Share this post


Link to post
Share on other sites

il faut que tu regenere un fichier xorg.conf.

pour cela tu as plusieurs outils ( xorgconfig, par exemple, ou même l'utilitaire maison mandrake, drakxxx ou xxxdrake, je sais plus son nom). ou alors tu peux éditer le fichier à la main ( /etc/X11/xorg.conf)

tu devrais lire le tutos sur X qui est dans les meilleurs liens, ainsi qu'en présentation en haut de page.

:D

Share this post


Link to post
Share on other sites

thaly

bonsoir,

je suis debutante sous linux, et je rencontre le meme probleme que pirlouy au demarage de X:

...

(EE) unable to locate/open config file

...

getconfig.pl: file 'usr/X11R6/lib/getconfig/xorg.cfg' has bad signature

: no rules in file:'/usr/bin.../xorg.cfg'

...

Fatal servor error :

Cannot run in framebuffer mode: please specify BusIDs for all framebuffer devices

...

carte mere A7N8X-E delux

carte graphique geforce fx5200

proc amd 3200+

1G de RAM

mandrake 10.1 officiel

pour plus d'info j'ai pu utiliser mdk pendant 2 semaine sans probleme c'est apres avoir installer amule et l'avoir fait tourner que j'ai planter et que j'ai plus X (c'est peut etre juste parcequ'amule demande d'un coup plus de ressource...)

j'ai vu qu'il fallait faire kelke chose avec Xorg mais en tant que debutante je n'ai pas bien compris.

merci de vos reponses...

1/ Tu as une carte graphique Nvidia et non ATI.

2/ J'espère que tu n'as pas essayé d'installer les pilotes ATI pour ta carte nvidia. Si c'est le cas, ne t'étonnes pas si cela ne fonctionne pas.

3/Pour retrouver un écran normal, essaye de reconfigurer le fichier xorg.conf.

http://www.linux-wizard.net/faq.php?sectio...isplay_settings

4/ Pour l'installation des pilotes Nvidia sous linux, il y a plein de tutos sur le net, d'ailleurs j'en prépare un pour le forum de pcinpact.

5/ Je pense qu'un nouveau poste pour résoudre ton problème serai le bienvenue.

6/ Ta mandrake fonctionnait jusqu'à l'installation des pilotes ou bien jusqu'à l'installation de amule ? Ce n'est pas très claire, peux-tu préciser ?

Share this post


Link to post
Share on other sites

p'tain, j'avais même pas fait gaffe que c'était le topic du tuto pilotes ATI :iloveyou: tu m'étonnes que ça ne marche pas...

> noobietux : il me semble que xorg examine aussi les fichier XF86Config-4, pour assurer une certaine compatibilité, mais avec des priorité moindre, donc si tu as un tel fichier, rien ne sert de le renomer... :eeek2:

Share this post


Link to post
Share on other sites

en fait si j'ai posté mon message ici c'est qu'en faisant une recherche de mon message d'erreur " Cannot run in framebuffer mode" c'est le seul forum ou j'ai trouvé quelqu'un qui avait eu le meme message. je n'ai pa installer les pilote ATI.

j'ai installer amule je l'ai fait tourner sans probleme un soir j'eteint (je l'eteint pa souvent) mon pc le matin je le rallume et bug au demarrage de X tout frise plus de clavier plus de souris. sur ce qui s'est lancer au demarage de X je voit amule. en rebootant mechament (vu que j'ai plus le clavier!) je redemarre en mode texte avec le fameu message d'erreur si je veu lancer X manuellement.

voila pour les detail...

d'autre part je precise vraiment que ca fait juste deux semaine que j'ai mandrake alors le mode texte je suis pas encore au point... merci a tous

Share this post


Link to post
Share on other sites

Salut, pour ton problème ne t'inquiètes pas on va trouver la solution...

Alors...

1/ Change quand même de topic pour ne pas squatter celui de ATI (crées-en un nouveau)... ne t'inquiètes pas, on te suivra dessus :chinois:

2/ Comme l'a dit Lorinc, il faut que tu re-génère ton fichier xorg.conf...

Essaye ce qu'il a dit et dit nous si ça fonctionne ou pas (histoire de suivre le problème au fur et à mesure, et de trouver la bonne solution par élimination)

Pour l'utilitaire de config sous Mandrake, c'est en console (en root):

mcc

ou

drakconf

tu peux peut-être sinon regarder directement du coté de XFdrake (qui doit certainement appartenir à DrakConf):

xfdrake

Si tout ça ne marche pas, renvoies des nouvelles (sur ton nouveau topic rien qu'à toi)...

Share this post


Link to post
Share on other sites

voilà, c'est ça que je cherchais : xfdrake (marche tres bien en console (enfin du temps ou j'avais encore une mandrake :D )

Share this post


Link to post
Share on other sites

bonjour je viens d'essayer d'installer les pilotes ati sur une mdk 10.1 final et a l'etape 2.2 il ne trouve pas le module fglrx et pour l'autre je dois decharger le module nvidia avant.

Ensuite j ai voulus installer les drivers et j ai le 1 messages d'erreur

failed.

*** Error: no kernel module build environment - please consult readme.

mais il termine la commande d'install

*** Warning ***

The QT based control panel application did not load in any version.

===

ATI display drivers successfully installed

please run 'fglrxconfig' now

===

donc la je vais recupere les sources (2.6.8.1-12.mdk)

et ensuite j ai ce message

nitializing...

Error:

kernel includes at /usr/src/linux/include do not match current kernel.

they are versioned as ""

instead of "2.6.3-7mdk".

you might need to adjust your symlinks:

- /usr/include

- /usr/src/linux

et maintenant je ne sais plus quoi faire

Share this post


Link to post
Share on other sites

P'tit problème pour installer les nouveaux pilotes ATI pour Xorg. Je vous met le fichier Xorg.0.log

(WW) fglrx(0): Cannot read colourmap from VGA.  Will restore with default
(II) fglrx(0): UMM area:     0xc0501000 (size=0x07aff000)
Symbol fbGetWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetPixmapIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol fbGetWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetPixmapIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetScreenIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetScreenIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetScreenIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetScreenIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetScreenIndex from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol noCompositeExtension from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol noCompositeExtension from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!

  *** If unresolved symbols were reported above, they might not
  *** be the reason for the server aborting.

Fatal server error:
Caught signal 11.  Server aborting

J'ai une mdk10.1, et j'avais installé les drivers ati avec le script fait par lebarjoe (merci à toi)

Share this post


Link to post
Share on other sites

×
×
  • Create New...