Jump to content

Archived

This topic is now archived and is closed to further replies.

gyan000

[SCRIPT] Installation pilote ATI sous Mandriva

Recommended Posts

j'ai ouvert le fichier /var/log/XFree86.0.log

Mais que faut t'il regarder plus précisement ?

Share this post


Link to post
Share on other sites
j'ai ouvert le fichier /var/log/XFree86.0.log

Mais que faut t'il regarder plus précisement ?

Les erreurs :transpi:

Share this post


Link to post
Share on other sites

par exemple ca :

(II) fglrx(0): Kernel Module Version Information:

(II) fglrx(0): Name: fglrx

(II) fglrx(0): Version: 3.9.0

(II) fglrx(0): Date: May 11 2004

(II) fglrx(0): Desc: ATI Fire GL DRM kernel module

(WW) fglrx(0): Kernel Module version does *not* match driver.

(EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work

(II) fglrx(0): [drm] removed 1 reserved context for kernel

(II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0xe183d000 at 0x4026a000

(WW) fglrx(0): ***********************************************

(WW) fglrx(0): * DRI initialization failed! *

(WW) fglrx(0): * (maybe driver kernel module missing or bad) *

(WW) fglrx(0): * 2D acceleraton available (MMIO) *

(WW) fglrx(0): * no 3D acceleration available *

(WW) fglrx(0): ********************************************* *

(II) fglrx(0): FBADPhys: 0xc0000000 FBMappedSize: 0x08000000

(II) fglrx(0): FBMM initialized for area (0,0)-(1024,8191)

(II) fglrx(0): FBMM auto alloc for area (0,0)-(1024,768) (front color buffer - assumption)

(==) fglrx(0): Backing store disabled

(==) fglrx(0): Silken mouse enabled

(II) fglrx(0): Using hardware cursor (scanline 768)

(II) fglrx(0): Largest offscreen area available: 1024 x 7419

(**) Option "dpms"

(**) fglrx(0): DPMS enabled

(II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)

Screen to screen bit blits

Solid filled rectangles

Solid Horizontal and Vertical Lines

Offscreen Pixmaps

Setting up tile and stipple cache:

32 128x128 slots

32 256x256 slots

16 512x512 slots

(II) fglrx(0): Acceleration enabled

(II) fglrx(0): Direct rendering disabled

(II) Loading extension FGLRXEXTENSION

(II) Loading extension ATITVOUT

Share this post


Link to post
Share on other sites
(II) fglrx(0): Desc: ATI Fire GL DRM kernel module

(WW) fglrx(0): Kernel Module version does *not* match driver.

(EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work

:transpi:

Share this post


Link to post
Share on other sites

Donc quel est la solution ?

J'ai lu que certain avait réussit à installer la carte ATI radeon 9600 avec une mandrake 10 donc que faut il fiare ?

a- Passez à la toute dernièe version kernel

b- Trouver un version du driver qui soit compatible avec le kernel ? (mais ou ? et comment ? :oops: )

Share this post


Link to post
Share on other sites
J'ai lu que certain avait réussit à installer la carte ATI radeon 9600 avec une mandrake 10

Jee confirme : chez mes parents, j'ai installé à partir de la PowerPack 10 le support 3D pour cette carte mais c'est Mandrake qui a tout fait...

Share this post


Link to post
Share on other sites
a- Passez à la toute dernièe version kernel

b- Trouver un version du driver qui soit compatible avec le kernel ? (mais ou ? et comment ? :oops: )

Ben moi j'aurais pris un noyau tout propre et reconfiguré...en plus, le 2.6.8 vient de sortir...

Au moins, cela fera une expérience de compilation de noyau :D

(guarder celui de mandrake en réserver évidemment :transpi:)

(et vu que mandrake utilise automount, activer ça aussi dans le noyau...)

Share this post


Link to post
Share on other sites

Ben moi j'aurais pris un noyau tout propre et reconfiguré...en plus, le 2.6.8 vient de sortir...

Au moins, cela fera une expérience de compilation de noyau

Donc tu conseille quoi comme noyeau ?

(guarder celui de mandrake en réserver évidemment )

(et vu que mandrake utilise automount, activer ça aussi dans le noyau...)

c'est koi l'automount ?

Share this post


Link to post
Share on other sites

Je suis en train de faire la doc pour X, et je suis tombé sur ceci :

The dri module enables support in the X server for Direct Rendering Infrastructure (DRI).  Note that support for DRI must also exist in the kernel, the video card, and the installed version of the Mesa libraries for hardware-accelerated 3D operations using DRI to work.  Otherwise, the server falls back to software rendering.

...ce qui expliquerait tout...

...Essaye un peut en enlevant

Load "dri"

de ton fichier de config de X...

Share this post


Link to post
Share on other sites

Salut,

D'abort merci du temps passé pour éssayé de résoudre mon pb.

J'ai oté le load "dri" de mon fichier , mais rien n'a change :

[nico@NiVaNo nico]$ fgl_glxgears

Xlib: extension "XFree86-DRI" missing on display ":0.0".

Error: couldn't get fbconfig

[nico@NiVaNo nico]$ glxgears

Xlib: extension "XFree86-DRI" missing on display ":0.0".

1305 frames in 5.0 seconds = 261.000 FPS

1292 frames in 5.0 seconds = 258.400 FPS

1280 frames in 5.0 seconds = 256.000 FPS

1360 frames in 5.0 seconds = 272.000 FPS

1280 frames in 5.0 seconds = 256.000 FPS

X connection to :0.0 broken (explicit kill or server shutdown).

[nico@NiVaNo nico]$ fgl

fgl_glxgears fglrxconfig fglrxinfo fglrx_xgamma

[nico@NiVaNo nico]$ fglrx

fglrxconfig fglrxinfo fglrx_xgamma

[nico@NiVaNo nico]$ fglrxinfo | grep "direct rending"

Xlib: extension "XFree86-DRI" missing on display ":0.0".

[nico@NiVaNo nico]$ fglrxinfo | grep "direct rending"

Xlib: extension "XFree86-DRI" missing on display ":0.0".

[nico@NiVaNo nico]$

Share this post


Link to post
Share on other sites

faudrait que tu examine à chaque fois le log, et éventuellement que tu compare avec un autre fichier de conf de quelqu'un qui a une ATI...

Share this post


Link to post
Share on other sites

double post

salut

as tu procede comme suit

1/ as tu mis le bon kernel source car il pose pose probleme par la commande suivante :

2/Si y'a une erreur qui parle de kernel includes, c'est parce qu'a l'install de Mdk 10, dans mise a jour ils ont mis kernel-source-2.6.3-9 et le kernel est un 2.6.3-7... Donc si c'est installé: revenir au 2.6.3-7: (En root)

CODE

urpme kernel-source

(seulement si une autre version est istallée...) puis

CODE

urpmi kernel-source-2.6.3-7

et ça marche...

(merci a user pour cette aide)

tuer le serveur X mode console taper en mode root "init 3" tres important pour les drivers ati

une fois arrive en mode console sans le serveur X demarre proceder comme suit:

3/urpmi --allaw-force fglrx.xxxx..xxxx..xxxx.rpm

4/fglrxconfig

-pour la souris generalement c est psaux

-external agp mettre yes

-le reste par defaut sera bon

4/initialisation des modules

#modprobe fglrx

#modprobe nvidia-agp (pour chip nvidia)

exit

startx

5/test

ouvrir dans une console

glxgears -- si superireur a 2000 ok

6/ reste a mettre en place l auto chargement des modules

en mode superutils ajouter les lignes dans :

/etc/modprobe.preload

fglrx

nvidia-agp (pour chip nvidia)

et normalement tout est ok

Share this post


Link to post
Share on other sites

Bonjour,

Encore merci à ceux qui contribuent à essayer d'installer ma carte ATI avec ma mandrake 10.

J'ai essayer de faire la manip de vinced33 mais ca n'a rien faiit de plus qu'avant.

Mais j'ai deux hypothéses pour expliquer que l'installation ne marche pas :

1. J'ai vu sur le site de mandrake qu'avec des distribution supérieur (et payante) il existaiit des rpm du stype ATI_kernel_blablabla. j''ai essyé de les installer via urpmi mais le message d'erreur dit qu'ils sont innexistant.

Est il possible qu'il y ait une incompatibilité (voulue) entre le kernel de la mandrake 10 et le driver fglrx livré par ATI ? Ce qui forcerait les gens à acheter le distribution PowerPack10 ?

2. Ou alors est ce posible que l'écran (ViewPanel VE150 m) bride les performances de la carte ? Et pourquoi avec Win2000 la carte s'installe ?

Enfin j'invite ceux qui auait la même config que moi et qui ont réussit à installer leur carte à me faire part de leur truc et astuces....

Shuttle FN45G2 V2

Athon XP1800

512 DDR

ATI Radeon 9600 256M pro

Mandrake 10

Share this post


Link to post
Share on other sites

Est il possible qu'il y ait une incompatibilité (voulue) entre le kernel de la mandrake 10 et le driver fglrx livré par ATI ? Ce qui forcerait les gens à acheter le distribution PowerPack10 ?

non jene pense pas. Et un driver ati disponible pour tout lemonde doit compiler sur n'importe quel noyau. Si ce n'est pas le cas, et que ce n'est toi qui est en tort ( genre tu as oublie qqchose ), un noyau comme ca moi il degage de suite du systeme car pour moi c'est une merde.

Share this post


Link to post
Share on other sites

Ben à priori, c'est vachement plus facile avec mandrake que avec les autres distribs non-rpm...

Il faudrait essayer ce qu'il y a marqué sur le topic jeux par rapport au DRI et les droits "666" ... ça peut très bien venir de là...

Share this post


Link to post
Share on other sites
a l'install de Mdk 10, dans mise a jour ils ont mis kernel-source-2.6.3-9 et le kernel est un 2.6.3-7
?????????????

A l'installation, Mandrake n'installe jamais le kernel-source sauf si on lui demande ...

C'est bizarre cette histoire car avec la même carte graphique et le même kernel Mandrake 10 a installé sans l'ombre d'un problème ce qu'il faut pour la carte ATI chez mes vieux.

un noyau comme ca moi il degage de suite du systeme car pour moi c'est une merde.

Ca m'énerve, dès qu'il y a un problème c'est la faute à Mandrake ou à ses noyaux ou à je ne sais quoi, faudrait arrêter un jour .

Rémy :roll: mais là t'exagères un peu, franchement.

Share this post


Link to post
Share on other sites

A l'installation sûrement pas et pour les mises à jour hé bien on ne coche pas tout sans regarder ...

Mandrake a quand même le droit de dire qu' un nouveau kernel-source est dispo non ?

Share this post


Link to post
Share on other sites

Décidement mes intérogations sucite des réactions :incline:

non jene pense pas. Et un driver ati disponible pour tout lemonde doit compiler sur n'importe quel noyau. Si ce n'est pas le cas, et que ce n'est toi qui est en tort ( genre tu as oublie qqchose ), un noyau comme ca moi il degage de suite du systeme car pour moi c'est une merde.

Franchement, les différents tutorials de ce site ont l'air pas trop mal fait. J'ai de plus regardé sur d'autre forums et iils y donnent les même indications ( c'est bon signe !!!)

Et même si je ne suis pas trés vieux dans la comunautée linux, je sais lire un tutorial, surtout quand il donne les instrctions pas à pas.

Peut être simplement qu'il n'est pas exhaustif pour toutes les configurations ? ou alors il y a des pré requis implicites, quoi qu'il en soit il a le mérite d'avoir sauvé beaucoup de personne ... sauf moi :incline:

C'est bizarre cette histoire car avec la même carte graphique et le même kernel Mandrake 10 a installé sans l'ombre d'un problème ce qu'il faut pour la carte ATI chez mes vieux.

Avec quelle distribution (Télécharger sur le net - La Discovery - power Pack - Power Pack +) ?

Car j'ai lu que les driver ATI était intégré dans les Power Pack. (d'ou l'intérogation sur la conpatibilité), mais pas dans la idscovery.

Enfin je viais creuser le pb du

topic jeux par rapport au DRI et les droits "666"

Voila merci encore d'aider un pauvre petit padawan :incline:

Share this post


Link to post
Share on other sites

Ca m'énerve, dès qu'il y a un problème c'est la faute à Mandrake ou à ses noyaux ou à je ne sais quoi, faudrait arrêter un jour .

Rémy  mais là t'exagères un peu, franchement.

Dsl green, mais ce n'est pas Mandrake que je vise, je vise aucune distrib en particulier. Si demain je suis obliger de patcher mon noyau sur debian pour pouvoir compiler un driver ati ou nvidia ( qui sont de grands drivers ) alors ca sera de la merde. D'ailleurs, ca m'etonnerait qu'il faille patcher un noyau sur une distrib pour installer son pilote graphique venant du site officiel. Le site officiel fournit un driver pour le noyau linux standard, pas un specifique a une distrib. Donc, ca doit marcher ss pb, on s'est mal compris la green....

Ce n'est pas le noyau de mdk que je vire direct, c'est le noyau qui necessite d'etre patche pour compiler un driver ati ou nvidia.

Share this post


Link to post
Share on other sites

oui, mais je n'ai pas encore lu ton mail.... 470 mails non lus hier ...encore pas loin de 200 qui restent ! Debian emet a mort sur ses listes de diffusion, c'est une periode un peu particuliere ( debuggage de la future stable, "Sarge" ). Je le lirais d'ici ce we, je te reponds de maniere complete dans le we.

Share this post


Link to post
Share on other sites

Ok, merci sympa.

J'suis content car Tuxxx ma dit que c'était très bien ... j' attends donc ton verdict.

En tout cas, beaucoup de fun à le préparer... ce tuto.

Par contre, j'ai un peu peur pour la mise en ligne car les images d'originede KSnapShot, je les ai après adaptées à mon fichier OpenOffice donc si on prend les originales ...

Enfin, on verra le moment venu...

Share this post


Link to post
Share on other sites

Je vais peut-être dire une grosse conneries, mais pourtquoi utiliser un module nvidia-agp si la carte est une ATI???? c'est pas un peu louche?

Pour ma 9200 j'ai viré le nvidia-agp et je l'ai remplacé par via-agp.

Désolé si je dis une connerie, parce que ça a l'air d'avoir choqué personne...

Share this post


Link to post
Share on other sites

×
×
  • Create New...