Jump to content

Archived

This topic is now archived and is closed to further replies.

gyan000

[SCRIPT] Installation pilote ATI sous Mandriva

Recommended Posts

export kernel_version=2.6-2.6.8.1-12mdk #A modifier suivant votre noyau, tapez : uname -r

là il suffit de mettre :

export kernel_version=`uname -r`

et c'est déjà plus simple...

Share this post


Link to post
Share on other sites

En fait, j'ai une carte mère nforce2 et j'avais les mêmes symptômes que toi.

J'avais lu qu'il fallait installer les drivers ATI après avoir arrêté X mais ça m'embêtait et je ne pensais pas que ça résoudrait le problème. Pourtant, après avoir essayé le script de lebajoe ça a enfin fonctionné.

Je n'ai pas fait de tests pour voir si c'était l'arrêt de X ou le déchargement des modules fglrx, nvidia-agp et agpgart qui en était la cause, mais c'est un des deux.

Le fait que tu aies arrêté X et réussi à décharger le module fglrx signifie que c'est soit le module agpart soit le module amd64-agp qui est en cause.

Pour ce qui est du fichier modules.preload, apparemment, ce sont les lignes

agpgart

amd64-agp

fglrx

qu'il faut ajouter (donc pas de nvidia-agp qui n'est nécessaire que pour les nforce2).

Mais ça m'étonnerait que cela change quoi que ce soit étant donné que le module amd64_agp est chargé automatiquement.

Par contre, tu pourrais faire un lsmod et copier le résultat ici pour voir quels sont les modules chargés, on ne sait jamais...

Et aussi copier le contenu du fichier XFree86.0.log se trouvant dans /var/log.

Share this post


Link to post
Share on other sites

Bonjour :troll:

Je suis en train d'installer le pilote ATI sous mandrake 10.1 Official.

Ma configuration est la suivante:

- Carte mère Asus P4C800 Deluxe

- Processeur Pentium 4 2,8GHz

- Carte graphique MSI 9800 Pro 256 Bits

Pour celà, j'ai utilisé le script install_ati_drivers.sh de 'lebarjoe'.

Voici les modifications que j'ai pu faire:

export drivers=fglrx-4.3.0-3.14.6.i386.rpm
export kernel_version=`uname -r` #A modifier suivant votre noyau, tapez : uname -r
export agp_chipset=intel-agp # A modifier en fonction de votre chipset de votre carte mÚre : intel-agp ou via-agp ...etc...

Toute l'installation s'est passée sans problème. Quand je lance la commande fgl_glxgears, j'ai le message d'erreur suivant:

$ fgl_glxgears
X Error of failed request:  BadMatch (invalid parameter attributes)
 Major opcode of failed request:  143 (GLX)
 Minor opcode of failed request:  5 (X_GLXMakeCurrent)
 Serial number of failed request:  31
 Current serial number in output stream:  31

Comment faire?

Merci

Cassandra

NB: Voici d'autres informations qui pourront peut-être vous aider (c'est avant l'installation du nouveau pilote):

$ uname -rs
Linux 2.6.8.1-10mdksmp

En root:
# glxgears
1574 frames in 5.0 seconds = 314.800 FPS
1400 frames in 5.0 seconds = 280.000 FPS
1820 frames in 5.0 seconds = 364.000 FPS
2100 frames in 5.0 seconds = 420.000 FPS
1960 frames in 5.0 seconds = 392.000 FPS
1960 frames in 5.0 seconds = 392.000 FPS
420 frames in 5.0 seconds = 84.000 FPS
420 frames in 6.0 seconds = 70.000 FPS
420 frames in 6.0 seconds = 70.000 FPS
420 frames in 5.0 seconds = 84.000 FPS
420 frames in 6.0 seconds = 70.000 FPS
420 frames in 6.0 seconds = 70.000 FPS
420 frames in 5.0 seconds = 84.000 FPS
X connection to :0.0 broken (explicit kill or server shutdown).
En localhost:
$ glxgears
1294 frames in 5.0 seconds = 258.800 FPS
1540 frames in 5.0 seconds = 308.000 FPS
1820 frames in 5.0 seconds = 364.000 FPS
1680 frames in 5.0 seconds = 336.000 FPS
1540 frames in 5.0 seconds = 308.000 FPS
700 frames in 6.0 seconds = 116.667 FPS
280 frames in 5.0 seconds = 56.000 FPS
280 frames in 6.0 seconds = 46.667 FPS
280 frames in 5.0 seconds = 56.000 FPS
280 frames in 5.0 seconds = 56.000 FPS
280 frames in 6.0 seconds = 46.667 FPS
280 frames in 5.0 seconds = 56.000 FPS
280 frames in 5.0 seconds = 56.000 FPS
280 frames in 6.0 seconds = 46.667 FPS
X connection to :0.0 broken (explicit kill or server shutdown).
Version de X.org:
$ X -version

Release Date: 18 December 2003
X Protocol Version 11, Revision 0, Release 6.7
Build Operating System: Linux 2.4.19-44mdkenterprise i686 [ELF]
Current Operating System: Linux localhost 2.6.8.1-10mdksmp #1 SMP Wed Sep 8 16:41:52 CEST 2004 i686
Build Date: 18 November 2004
       Before reporting problems, check http://wiki.X.Org
       to make sure that you have the latest version.
Module Loader present

Share this post


Link to post
Share on other sites

Si je dis pas de bétises, les drivers ATI ne sont pas prévus pour XOrg, ils crashent l'OpenGL de ce dernier. Donc l'open est désactivé quand tu utiliser XOrg+drivers ATI, d'où fgl_glxgears ne marche pas et les perfs de glxgears sont celles du rendu logiciel :(

Share this post


Link to post
Share on other sites

Il utilise xorg6.7, ca devrait fonctionner normalement. C'est à partir de xorg 6.8 que ca plante. bizarre ce problème, c'est la première fois que je vois ca...

Share this post


Link to post
Share on other sites
Il utilise xorg6.7, ca devrait fonctionner normalement. C'est à partir de xorg 6.8 que ca plante. bizarre ce problème, c'est la première fois que je vois ca...

:mad2: C'est elle (c'est moi sur l'avatar ;) )

En effet, j'ai la version 6.7 de Xorg

Share this post


Link to post
Share on other sites

glxinfo

name of display: :0.0
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
   GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
   GLX_EXT_import_context, GLX_SGI_make_current_read, GLX_SGIS_multisample
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
   GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
   GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
   GLX_ATI_render_texture
GLX extensions:
   GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
   GLX_EXT_import_context
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.4 Mesa 5.0.2)
OpenGL extensions:
   GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
   GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
   GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
   GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
   GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
   GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
   GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
   GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

  visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  1 0 None
0x24 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  1 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x27 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  1 0 None
0x28 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  1 0 None
0x29 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x2a 24 dc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None

lsmod

Module                  Size  Used by
nls_cp850               5472  1
vfat                   12704  1
fat                    41952  1 vfat
sd_mod                 20320  2
usb-storage            67040  1
scsi_mod              107428  2 sd_mod,usb-storage
snd-pcm-oss            51080  0
snd-mixer-oss          18592  1 snd-pcm-oss
snd-intel8x0           31660  1
snd-ac97-codec         70736  1 snd-intel8x0
snd-pcm                86948  2 snd-pcm-oss,snd-intel8x0
snd-timer              22724  1 snd-pcm
snd-page-alloc          8392  2 snd-intel8x0,snd-pcm
gameport                4416  1 snd-intel8x0
snd-mpu401-uart         7168  1 snd-intel8x0
snd-rawmidi            21188  1 snd-mpu401-uart
snd-seq-device          7336  1 snd-rawmidi
snd                    49028  11 snd-pcm-oss,snd-mixer-oss,snd-intel8x0,snd-ac97-codec,snd-pcm,snd-timer,snd-mpu401-uart,snd-rawmidi,snd-seq-device
ppp_async              10208  0
ppp_generic            27028  1 ppp_async
slhc                    7104  1 ppp_generic
crc-ccitt               2656  1 ppp_async
af_packet              17864  0
floppy                 57168  0
eth1394                18792  0
sk98lin               168072  1
ide-cd                 38528  1
cdrom                  38844  1 ide-cd
ohci1394               32676  0
ieee1394              294872  2 eth1394,ohci1394
loop                   13896  0
nls_iso8859-15          5216  7
ntfs                  149980  6
intel-agp              20608  1
agpgart                29036  1 intel-agp
tda9887                12196  0
tuner                  19312  0
saa7134                95152  0
video-buf              18212  1 saa7134
v4l2-common             5888  1 saa7134
v4l1-compat            14084  1 saa7134
soundcore               8288  2 snd,saa7134
i2c-core               20356  3 tda9887,tuner,saa7134
ir-common               4964  1 saa7134
videodev                8224  1 saa7134
usblp                  11936  0
tsdev                   6848  0
joydev                  9056  0
evdev                   8672  0
usbmouse                5216  0
ehci-hcd               27972  0
usbhid                 43328  0
uhci-hcd               30448  0
usbcore               107396  8 usb-storage,usblp,usbmouse,ehci-hcd,usbhid,uhci-hcd
genrtc                  9112  0
ext3                  123496  1
jbd                    56600  1 ext3

Share this post


Link to post
Share on other sites

bon bah fglrx n'est pas loadé...

un petit modprobe fglrx, peut-être.

sinon, reprend le tuto pour voir comment automatiser le chargement du module au démarrage (je tourne pas avec mdk, désolé). :ouioui:

EDIT : pas oublier de redemarrer X non plus (ctrl+alt+backspace)

Share this post


Link to post
Share on other sites
un petit modprobe fglrx, peut-être.

sinon, reprend le tuto pour voir comment automatiser le chargement du module au démarrage (je tourne pas avec mdk, désolé). :ouioui:

EDIT : pas oublier de redemarrer X non plus (ctrl+alt+backspace)

Merci pour votre aide.

modprobe fglrx me donne le message d'erreur suivant:

FATAL: Module fglrx not found.

Je dois refaire la partie du script suivante en désactivant X?

echo "--------------------------------------------------------"
echo " Ajout du module flglrx au démarrage de la mandrake "
echo "--------------------------------------------------------"
grep -i ${agp_chipset} /etc/modprobe.preload
if [ $? -eq 0 ];then
echo ${agp_chipset} >> /etc/modprobe.preload
fi
grep -i fglrx /etc/modprobe.preload
if [ $? -eq 0 ];then
echo fglrx >> /etc/modprobe.preload
fi

Share this post


Link to post
Share on other sites

ahah!

n'y aurait-il pas eu un message d'erreur avant? lors de l'execution du script?

est-il possible de le "faire à la main"? c'est à dire en téléchargeant les drivers sur le site d'ATI,

ctrl+alt+F1

su -

init 3

rpm --force -Uvh ati-truc-machin-nom-du-driver

si jamais il y a eu des warning lors de l'install du rpm, aller dans le rep d'installation /lib/modules/fglrx je crois...

aller dans build_je_sais_plus_quoi

et lancer un

$sh make.sh

(qui n'est pas executable)

puis revenir dans le repertoire parent (/lib/modules/fglrx)

et

$sh make_install.sh

(qui n'est pas non plus executable)

et enfin modprobe fglrx

??

(le tuto le fait mieux que moi...)

c'est pas que je n'ai pas confiance envers le script donné, mais on voit mal ce qui se passe :ouioui:

Share this post


Link to post
Share on other sites
# rpm -force -Uvh /tmp/fglrx-4.3.0-3.14.6.i386.rpm
-force: option iconnue

# sh make.sh
ATI module generator V 2.0
==========================
initializing...
Error:
kernel includes at /usr/src/linux/include do not match current kernel.
they are versioned as ""
instead of "2.6.8.1-10mdksmp".
you might need to adjust your symlinks:
- /usr/include
- /usr/src/linux

Share this post


Link to post
Share on other sites

classique. il faut installer les sources du kernel (kernel-sources) et prier pour qu'elles soient d'accord avec ta version du noyau.

soit en graphique (avec le gestionnaire de paquetage)

soit

$urpmi kernel-sources

(EDIT : au passage pour toutes les options longues (comprendre plus d'une lettre) dans une ligne de commande, il faut mettre 2 -. par exemple --force)

Share this post


Link to post
Share on other sites

J'ai déjà fait la récupération des sources de kernel

# urpmi kernel-source

   ftp://ftp.ciril.fr/pub/linux/mandrakelinux/official/10.1/i586/media/main/kernel-source-2.4.27-0.pre2.1mdk.i586.rpm
       0% sur 42.5M, temps total = 11:11:16, vitesse = 1107
       0% sur 42.5M, temps total = 0:21:09, vitesse = 177k                                   
       0% sur 42.5M, temps total = 0:06:07, vitesse = 234k                                   
       1% sur 42.5M, temps total = 0:04:37, vitesse = 242k                           
installation de /var/cache/urpmi/rpms/kernel-source-2.4.27-0.pre2.1mdk.i586.rpm
Préparation...              ##################################################
  1:kernel-source          ##################################################
#

EDIT: Y a-t-il une différence entre urpmi kernel-source et urpmi kernel-sources ?

J'ai pu exécuter sh make_install.sh dans le répertoire /lib/modules/fglrx/:

# sh make_install.sh
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
#

Share this post


Link to post
Share on other sites

bien, il faut maintenant que tu aille dans le repertoire build_truc (dans /lib/modules/fglrx) et que tu lance

$sh make.sh

qui va compiler le module

make_install.sh sert à le copier au bon endroit :topigliss:

Share this post


Link to post
Share on other sites

J'ai refait l'a récupération des sources du noyau mais en tapant la commande suivante (ca a été fait dans un autre tutorial):

# urpmi kernel-source-2.6

   ftp://ftp.ciril.fr/pub/linux/mandrakelinux/official/10.1/i586/media/main/ker                 nel-source-2.6-2.6.8.1-12mdk.i586.rpm
installation de /var/cache/urpmi/rpms/kernel-source-2.6-2.6.8.1-12mdk.i586.rpm
Préparation...              ##################################################
  1:kernel-source-2.6      ##################################################

Mais quand je fais uname -rs, j'ai toujours la même chose qu'avant:

# uname -rs
Linux 2.6.8.1-10mdksmp

Je ne devrais pas avoir 2.6-2.6.8.1-12mdk?

Share this post


Link to post
Share on other sites

:topigliss: J'ai toujours les 2 messages d'erreur:

[root@localhost build_mod]# sh make.sh
ATI module generator V 2.0
==========================
initializing...
Error:
kernel includes at /usr/src/linux/include do not match current kernel                                  .
they are versioned as ""
instead of "2.6.8.1-10mdksmp".
you might need to adjust your symlinks:
- /usr/include
- /usr/src/linux
[root@localhost build_mod]# cd ..; sh make_install.sh
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
[root@localhost fglrx]# modprobe fglrx
FATAL: Module fglrx not found.
[root@localhost fglrx]# cd build_mod/
[root@localhost build_mod]# sh make
make.log  make.sh
[root@localhost build_mod]# sh make.sh
ATI module generator V 2.0
==========================
initializing...
Error:
kernel includes at /usr/src/linux/include do not match current kernel.
they are versioned as ""
instead of "2.6.8.1-10mdksmp".
you might need to adjust your symlinks:
- /usr/include
- /usr/src/linux
[root@localhost build_mod]#

Share this post


Link to post
Share on other sites

tu devrais avoir la même version que ton kernel (donné par uname -r)

mais malheureusement, mandrake donne des mises à jour du noyau sans faire suivres les mise à jour des sources, ou inversement. ce qui fait que lorsqu'on veut compiler un module pour le noyau (comme un driver de CG, par ex :D ), on se retrouve avec un conflit de version.

je crois qu'ATI à prevu le coup en permettant de ne pas tenir compte de la version du kernel, mais cela reste très hasardeux... :topigliss:

le sujet à déjà été débattu, et il me semble que la solution la plus propre était de trouver des paquetages cohérent entre noyau et source.

pour le coup, je travaille pas avec mandrake, mais d'autre INpactien le font et pourront te donner leur avi.

enfin, s'il n'y a pas d'autre solution, alors on peut peut-être envisager l'override à la compilation...

EDIT : bien évidement, il y a aussi, comme l'a souligné liryc, la possibilité de recompilé son noyau, mais il me semble que rien que le fait de le dire, fait peur à beaucoup de monde... :roll:

Share this post


Link to post
Share on other sites

:roll:

bon Deux solutions soit tu installes les meme source que le noyeau que tu obtients avec uname, soit tu installe (recompile et installe le noyeau que tu as installer ).

a mon avis la premiere solution est la plus simple.

:topigliss:

Share this post


Link to post
Share on other sites
:p 

bon Deux solutions soit tu installes les meme source que le noyeau que tu obtients avec  uname, soit tu installe (recompile et installe le noyeau que tu as installer ).

a mon avis la premiere solution est la plus simple.

:pleure:

quand je fais uname -rs, j'obtiens:

# uname -rs
Linux 2.6.8.1-10mdksmp

je dois donc récupérer kernel-source-2.6-2.6.8.1-10mdk.i586.rpm?

EDIT: Je ne comprend pas grand chose à ce que je fais :roll:

Pourquoi parle-t-on de sources du noyau?

Share this post


Link to post
Share on other sites

:p

il va falloir que tu aille faire un tour du cote des meilleurs topic (le post epingle au debut) et lire un peut , je sais , je sais c'est peut etre ch... mais c'est comme ca .

un lien quand meme qui parle de la compilation du noyau http://www.pcinpact.com/forum/sujet_23973.htm

je dois donc récupérer kernel-source-2.6-2.6.8.1-10mdk.i586.rpm?

exactement.

:pleure:

Share this post


Link to post
Share on other sites

quand tu veux compiler un module du noyau (comme un driver), tu as besoin des sources du noyaux car elles contiennent des choses qui y sont nécéssaires.

mais, il faut que et les sources et le noyau aient la même version, sinon, les infos recupérées dans les sources ne sont d'aucune utilité pour le module que tu va inserrer dans le noyau (logique, non?)

il faut donc que les paquetage kernel et kernel-source soient cohérents.

tu pourrais soit recupérer kernel-2.6-2.6.8.1-12mdk.i586.rpm (c'est le numero qui est important)

soit kernel-source-2.6-2.6.8.1-10mdk.i586.rpm

c'est quelque chose qui est super lourd, etpeut-être fait exprès par mdk pour inciter les gens à echeter une boîte :pleure:

Share this post


Link to post
Share on other sites

×
×
  • Create New...