Jump to content

Archived

This topic is now archived and is closed to further replies.

lebarjoe

[Tutorial] Installation pilote Nvidia sur Mandriva

Recommended Posts

Bonjour,

Je souhaite utiliser les sources plf pour installer les pilotes Nvidia. Cependant je n'ai pas de connexion internet à mon domicile.

Quels sont les paquetages à télécharger pour résoudre les dépendances ?

Merci d'avance

Share this post


Link to post
Share on other sites

J'ai un petit problème là, dans l'installation des drivers... avant, j'avais déjà fait de la même façon, ça marchait très bien, mais là :incline:

En fait, le script n'arrive même pas à la question "type de carte : pci ou agp"... ayant mis le cd3 dans le lecteur, il me le ressort sans demander son reste ;)

J'ai relancé plusieurs fois, pour recommencer la manip, mais rien... il telecharge bien les fichiers sur le ftp, mais après, nada..

Share this post


Link to post
Share on other sites

Visiblement c'est un problème avec l'ecriture d'un fichier sur "etc/urpmi/urpmi.cfg"

je capte pas trop :francais:

Share this post


Link to post
Share on other sites

Bonjour,

Après avoir installé les drivers nvidia avec le script shell et en respectant les consignes présentes au début de ce topic, l'accélération 3D de ma carte graphique ne semble toujours pas fonctionner... Les drivers sont vraisemblablement chargés puisque lorsqu'on regarde dans le fichier XF86Config, on a bien nvidia a la place de nv pour le champs driver.

J'utilise la version de Mandriva 2006 avec une carte graphique AGP 4X Geforce TI4200 128mo. (P4 2Ghz, 512mo RAM)

Voici les résultats obtenus avec gfxgears :

47 frames in 5.0 seconds = 9.337 FPS

47 frames in 5.1 seconds = 9.242 FPS

49 frames in 5.0 seconds = 9.790 FPS

50 frames in 5.0 seconds = 9.910 FPS

50 frames in 5.0 seconds = 9.902 FPS

Et voici les infos sur les drivers utilisés :

[olivier@localhost ~]$ cat /proc/driver/nvidia/agp/status

Status: Enabled

Driver: AGPGART

AGP Rate: 4x

Fast Writes: Enabled

SBA: Enabled

[olivier@localhost ~]$ cat /proc/driver/nvidia/cards/0

Model: GeForce4 Ti 4200

IRQ: 16

Video BIOS: 04.25.00.34.00

Card Type: AGP

Share this post


Link to post
Share on other sites

et bien sur direct rendering est on... :

[olivier@localhost ~]$ glxinfo

name of display: :0.0

display: :0 screen: 0

direct rendering: Yes

server glx vendor string: NVIDIA Corporation

server glx version string: 1.3

Share this post


Link to post
Share on other sites

salut tous....

Bon, j'ai reinstallé mandriva 2006, j'ai installé les sources urpmi, j'ai installé nvidia-xorg8174, j'ai l'ecran nvidia au demarrage, mais qd je fais nvidia-settings ds la console, j'ai nen plus du panneau nvidia un mess ki dit

(nvidia-settings:4914): Gdk-CRITICAL **: gdk_window_invalidate_rect: assertion `window != NULL' failed

C'est grave docteur????

Share this post


Link to post
Share on other sites

Bah mince y a un probleme le lien du script est mort pr le moment :chinois:

si qq un pouvez etre sympa et me l'envoyer par MP ;)

En utilisant les PLF j arrive a rien : il m indique qu il y a un probleme ac dkms... Meme probleme que bois007 ms ac les 8178!!! apparament les rpm sont pas encore totalement au point... Par contre ac le script c est vraiment impec!!!

en tt cas merci pr le boulot fait sur ce script

++

Share this post


Link to post
Share on other sites

minority, verifie ke tu tourne sous le derier kernel, moi, j'ai resolu mon pb de dkms kom ca, tu fais un kernel update, tu lance linux avec ce kernel et tu lance l'install par plf, et ca marche tout seul....

Sauf pour le mess bizarre deja dit, mais j'ai le panneau Nvidia, les jeux tournent, tout nickel....

Share this post


Link to post
Share on other sites

salut,

je souhaite installer les drivers nvidia, mais le script ne se telecharge pas, de plus j ' ai vu qu il fallait priviligié les PLF, c' est quoi ce truc et comment on proçède.

merci de vos réponse.

ps: c' est ma troisième tentative de passage sous linux :francais: je profite que j' ai un peu plus de temps :chinois:

Share this post


Link to post
Share on other sites

PLF, mode d'emploi :

Tu vas sur http://easyurpmi.zarb.org , tu fais tout qu'est ce qui est écrit.

Et tu auras accès à tout plein de nouveaux programmes (dont les drivers ati) que tu pourras installer facilement avec ton gestionnaire de paquetages.

Voilà :chinois:

Share this post


Link to post
Share on other sites

désolé pour l' écriture sous forme de texto, mais j' étais un peu pressé :roll: apero :transpi:

Sinon j' ai reussi a installer ça marche correctement.

Merci à tous.

Share this post


Link to post
Share on other sites

bon apparament ça semblait marché; mais jsuis pas sur quand je tape glxgears tout se lance mais j' ai que 200fps!!! c 'est pas beaucoup nan??

Share this post


Link to post
Share on other sites

Le scipt n'est plus dispo???

Est ce que quelqu'un l'aurait sur une de ces partoches et pourrais me l'envoyé? :up:

Share this post


Link to post
Share on other sites

Quand je tapes urpmi nvidia-xorg ca me renvoi paquetages deja installé...

Ok mais comment je configure ma carte graphque?

Faut encore que je mettes les drivers ou ils sont déjà dans le systeme?

:mad2:

Share this post


Link to post
Share on other sites

Bonsoir,

je souhaite installer ma carte nvidia avec les drivers dipo grace a urpmi.

libnvidia-xorg1 8178-4.1.20060plf

nvidia-xorg 8178-4.1.20060plf

Lorsque je boot, lors du chargement des services et le lancement de dkms, j'ai unerreur:

Bad exit status 10

Build failed

Installation skipped

Donc les drivers pour ma carte nvidia ne sont pas installes.

Si je fais un uname -r, j obtiens: 2.6.12-12mdk

Quelqu un a une idee?

Merci de votre aide.

Share this post


Link to post
Share on other sites

Le scipt n'est plus dispo???

Est ce que quelqu'un l'aurait sur une de ces partoches et pourrais me l'envoyé? :francais:

non, plus dispo, utilisez les packages PLF dorenavent ?...

Share this post


Link to post
Share on other sites

Bonsoir,

je souhaite installer ma carte nvidia avec les drivers dipo grace a urpmi.

libnvidia-xorg1 8178-4.1.20060plf

nvidia-xorg 8178-4.1.20060plf

Lorsque je boot, lors du chargement des services et le lancement de dkms, j'ai unerreur:

Bad exit status 10

Build failed

Installation skipped

Donc les drivers pour ma carte nvidia ne sont pas installes.

Si je fais un uname -r, j obtiens: 2.6.12-12mdk

Quelqu un a une idee?

Merci de votre aide.

un petit up pour mon pb.

Si vous voulez plus d'infos..

Share this post


Link to post
Share on other sites

bonjour

Aprés l'install de mandriva 2006 64bits je me retrouve en console Apparemment c'est le pilote

d'affichage qui bloque .....encore lui ...

- J'ai carte graphik Asus N6600 GT Silencer -nvidia PCI -Express

ecran samsung 930bf.,Carte mére : asus a8n sli premuim, DD sata 250, amd 64, 1giga mo memoire.

Bref en console j'ai fait un DrakConf pour essayer de changer le pilote

Aprés plusieurs tests j'ai tj la même erreur:

"Failed the iniatialize the nvidia kernel module that is a supported

nvidia gpu in this system"

je comprends bien ce qu'il dit mais ça me fait pas avancer.

je suis aller chez nvidia et j'ai récupéré un pilote d'affichage : 9 MO

et avec ça....??? le probleme comment copier ce fichier sur le dd pour pouvoir l'installer en console?

j'ai bien lu les divers messages mais étant DEBUTANT linux parfois je n'y perds :francais::craint::francais:

help!!!!!!!!!!!!!!!!

merci

Share this post


Link to post
Share on other sites

Bonjour,

juste pour info, est-ce que les drivers nvidia propriétaires livrés avec la mandrake community ont fonctinné chez quelqu'un ? Parce que chez moi c'est une catastrophe, j'ai à peine le temps de faire 3 clics par ci par là et hop ! Ca freeze... La seule chose qui fonctionne encore, et encore pas toujours, c'est le pointeur de ma souris qui se déplace, mais plus rien d'autre ne répond et je suis obligé de faire un reboot via le gros bouton sur le boitier.

Alors j'ai déjà essayé de modifier la config (moyennant un ctrl+alt+F1 plus rapide que l'éclair au démarrage de l'interface graphique) mais malgré tous mais efforts, toujours la même histoire.

Pour info j'ai :

- ajouté "noapic" dans la ligne de boot correspondante dans le menu.list de mon grub préféré,

- ajouté l'option "Option "NvAgp" "2"" dans xorg.conf section device

- et surement d'autres trucs dont je ne me rappelle plus...

et..... :chinois:

Des idées, suggestions... Je comprends pas, je dois n'avoir que des machines allergiques à mandrake, euh... mandriva je veux dire. J'ai installé des tonnes de distribs différentes dans ma vie mais je n'ai jamais gardé une madrake plus de 3 jours. Pitié, faites moi changer d'avis, montrez moi comme cette distrib est géniale !!!

Share this post


Link to post
Share on other sites

×
×
  • Create New...