Jump to content

Archived

This topic is now archived and is closed to further replies.

lebarjoe

[Tutorial] Installation pilote Nvidia sur Mandriva

Recommended Posts

Bonsoir,

je souhaite installer ma carte nvidia avec les drivers dipo grace a urpmi.

libnvidia-xorg1 8178-4.1.20060plf

nvidia-xorg 8178-4.1.20060plf

Lorsque je boot, lors du chargement des services et le lancement de dkms, j'ai unerreur:

Bad exit status 10

Build failed

Installation skipped

Donc les drivers pour ma carte nvidia ne sont pas installes.

Si je fais un uname -r, j obtiens: 2.6.12-12mdk

Quelqu un a une idee?

Merci de votre aide.

Salut,

Est-ce que tu as bien installé le paquetage "dkms-nvidia" et surtout :

Est-ce que tu as installé le paquetage kernel source (ou kernel source stripped) et si oui est-ce qu'il a exactement le même numéro de version que le kernel sur lequel tu demarre.

Le problème de compilation de modules dkms viens assez souvent d'une différence de numéro de version, même infime, entre la version du kernel et celle du kernel source (comme le kernel source se met a jour automatiquement avec la distribution et les nouveaux kernels ne s'installent pas automatiquement, au but d'un moment tu peux avoir une différence de version).

Ton kernel est en 2.6.12-12mdk mais il se peut que ton kernel source soit en 2.6.12-17mdk, le dernier en date, cette simple différence me faisait planter la compilation des drivers dkms. Dans ce cas installe explicitement le nouveau kernel 2.6.12-17mdk

Voila, en espérant que ça puisse t'aider.

Share this post


Link to post
Share on other sites

pour moi les drivers nvidia fournis avec la mandriva one version club (qui sont donc ceux de la 2006.0) fonctionnent impec ... ça s'est installé tout seul :-D

pour le kernel, quand tu as pas le dernier en date faut aller chercher le rpm contenant les sources directements sur le miroir (avec des sources en community ....) c'est ce que j'ai du faire vu que le dernier kernel passe pas chez moi (Pentium mobile inside) :ouioui:

Share this post


Link to post
Share on other sites

salut tous

bon, alors voila mon probleme. j'ai reinstallé mandriva 2006 (version download), j'ai ajouté toute les source de easy urpmi, j'ai mis a jour mon kernel (2.6.12.18), j'ai fait un urpmi-kernel-source et recuperé la version 2.6-2.6.12.18 et j'ai lancé l'install de dkms-nvidia, tout se deroule bien, je redemarre sous le kernel 2.6.12.18, je lance un $ nvidia-settings, et là arghhhhhhhhhhhhhhhhh

[boiss007@localhost ~]$ nvidia-settings

ERROR: NV-CONTROL extension not found on this Display.

ERROR: Unable to determine number of NVIDIA GPUs on ':0.0'.

ERROR: Unable to determine number of NVIDIA Frame Lock Devices on ':0.

je fais un glxgears, et j'ai de pfs de pc asthmatique unijambiste :

[boiss007@localhost ~]$ glxgears

2272 frames in 5.0 seconds = 454.226 FPS

2830 frames in 5.0 seconds = 565.731 FPS

2820 frames in 5.0 seconds = 563.946 FPS

2753 frames in 5.0 seconds = 550.513 FPS

2230 frames in 5.0 seconds = 445.947 FPS

bref, le package plf y marche poôooo. Le pire c'est ke je l'ai deja fait marché, mais la, je sais vraiment pas ce qui cloche, ya til un espoir doc???

PS : je sais ke ca doit saouler ceux ki maitrisent linux de voir tjrs les meme questions, mais je debute vraiment, et je sais pas quoi faire...

PS2 : Zorgub, si tu pouvais dire comment t'as resolu ton pb, ca ressemble aps mal au mien, ca serait cool^^

merci d'avance

Share this post


Link to post
Share on other sites

ah ah ah ahhhhh.bon il est 4h30 du mat, et j'ai reussi à lancer le driver nvidia en editant /etc/modprobe.conf (rajout de alias /dev/nvidia* nvidia), et /etc/X11/xorg.conf (driver nv => nvidia)...

maintenant, le probleme, c'est que je n'ai pas de support opengl (glxinfo ne donne rien) et que mon ecran est fenetré

Je m'explique : mon 17" Dell D1025 (CRT) n'affiche qu'une fenetre entouré de bande noir de la moitié en hauteur et en largeur en gros. je peux explorer mon bureau en bougeant la souris (le bureau bouge).

je mets mon xorg.conf, pitetre que ca aidera, siouplait, me faites pas regretter ma linux experience....

# File generated by XFdrake.

# **********************************************************************

# Refer to the XF86Config man page for details about the format of

# this file.

# **********************************************************************

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)

# By default, Mandrake 6.0 and later now use a font server independent of

# the X server to render fonts.

FontPath "unix/:-1"

EndSection

Section "ServerFlags"

#DontZap # disable <Crtl><Alt><BS> (server abort)

AllowMouseOpenFail # allows the server to start up even if the mouse does not work

#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)

EndSection

Section "Module"

Load "dbe" # Double-Buffering Extension

Load "v4l" # Video for Linux

Load "extmod"

Load "type1"

Load "freetype"

Load "glx" # 3D layer

EndSection

Section "InputDevice"

Identifier "Keyboard1"

Driver "keyboard"

Option "XkbModel" "pc105"

Option "XkbLayout" "fr"

Option "XkbOptions" "compose:rwin"

EndSection

Section "InputDevice"

Identifier "Mouse1"

Driver "mouse"

Option "Protocol" "ExplorerPS/2"

Option "Device" "/dev/mouse"

Option "ZAxisMapping" "6 7"

EndSection

Section "Monitor"

Identifier "monitor1"

VendorName "Dell"

ModelName "Dell D1025HTX"

HorizSync 31.5-92.0

VertRefresh 50.0-150.0

Section "Device"

Identifier "device1"

BoardName "NVIDIA GeForce 6800 (generic)"

Driver "nvidia"

Option "DPMS" "on"

option "NoDDC" "true"

EndSection

Section "Screen"

Identifier "screen1"

Device "device1"

Monitor "monitor1"

DefaultColorDepth 24

Subsection "Display"

Depth 8

Virtual 1280 960

EndSubsection

Subsection "Display"

Depth 15

Virtual 1280 960

EndSubsection

Subsection "Display"

Depth 16

Virtual 1280 960

EndSubsection

Subsection "Display"

Depth 24

Virtual 1280 960

EndSubsection

EndSection

Section "ServerLayout"

Identifier "layout1"

InputDevice "Keyboard1" "CoreKeyboard"

InputDevice "Mouse1" "CorePointer"

Screen "screen1"

EndSection

euh.....A l'AIDDDDDDDDDDDDE

Share this post


Link to post
Share on other sites

Bonjour,

juste pour info, est-ce que les drivers nvidia propriétaires livrés avec la mandrake community ont fonctinné chez quelqu'un ? Parce que chez moi c'est une catastrophe, j'ai à peine le temps de faire 3 clics par ci par là et hop ! Ca freeze... La seule chose qui fonctionne encore, et encore pas toujours, c'est le pointeur de ma souris qui se déplace, mais plus rien d'autre ne répond et je suis obligé de faire un reboot via le gros bouton sur le boitier.

Alors j'ai déjà essayé de modifier la config (moyennant un ctrl+alt+F1 plus rapide que l'éclair au démarrage de l'interface graphique) mais malgré tous mais efforts, toujours la même histoire.

Pour info j'ai :

- ajouté "noapic" dans la ligne de boot correspondante dans le menu.list de mon grub préféré,

- ajouté l'option "Option "NvAgp" "2"" dans xorg.conf section device

- et surement d'autres trucs dont je ne me rappelle plus...

et..... :non:

Des idées, suggestions... Je comprends pas, je dois n'avoir que des machines allergiques à mandrake, euh... mandriva je veux dire. J'ai installé des tonnes de distribs différentes dans ma vie mais je n'ai jamais gardé une madrake plus de 3 jours. Pitié, faites moi changer d'avis, montrez moi comme cette distrib est géniale !!!

Des drivers proprio dans la community je me demande bien où tu as put voir ça parce que les version dl de mandriva n'intègrent AUCUN soft proprios.

installation de mandriva, configuration des source PLf à l'aide d'easyurpmi (http://easyurpmi.zarb.org) ensuite

urpmi --auto-select kernel-2.6 kernel-source-2.6 

ensuite reboot sur le dernier kernel (18mdk en ce moment si je ne m'abuse)

urpmi --auto nvidia-xorg

pas trés compliqué

Share this post


Link to post
Share on other sites

bon, j'ai refais l'install avant de mettre a jour mes paquets, uprmi kernel et kernel-source, urpmi nvidia-xorg, j'ai du modifier /etc/modprobe.conf et /etc/X11/xorg.conf mais j'ai mon ecran nvidia au demarrage, et tout semble ok, sauf que....

sauf que si je lance glgears ou glxinfo, j'ai un ecran bizarre (ligne de toute les couleurs et pis retour direct a l'ecran d'ouverture de session....

c'est pas que j'en ai marre, mais ca commence à y ressembler vraiment... dur dur d'utiliser un vrai OS....

si qqun lit ce message, a l'aide siouplait...

aide toi et le ciel t'aidera......

il me manquais un Laod "glx" dans mon xorg.conf....

linux c'est compliiiiiiiquéééééééééééééé

Share this post


Link to post
Share on other sites

Bonjour,

J'ai installé Mandriva 2006 sur mon HP Pavilion DV8365.

Malheureusement ma carte graphique n'a pas été reconnue. C'est une Nvidia GeForce Go 7600.

J'ai essayé plusieurs configurations manuelles mais les tests me renvoient toujours le meme message:

"(EE) No devices detected".

Est ce que le script proposé ici serait une solution et si oui comment puis je me le procurer. Il semble bien que les liens ne fonctionnent plus.

Merci pour toute aide !

Share this post


Link to post
Share on other sites

Alors je te conseil d'installer une 2007 parce qu'une 2006 est largement dépassée maintenant ensuite utilises le driver plf.

Share this post


Link to post
Share on other sites

plouf, tu penses qu'il faut fermer ce topic vu que les drivers ATI sont packagés par le plf ou au moins mettre un ajout en début de topic le signalant ?

(je suis nulle en drivers graphiques et je sais pas si ça peut encore servir ce script 8))

Share this post


Link to post
Share on other sites

Tout le monde m'a fait cette remarque ! Mais installe donc mandriva 2007 !

Il se trouve que je veux utiliser un logiciel qui est certifié pour mandriva 2006 et pas 2007. Et comme je suis nul en linux je n'ai pas osé.

Concernant ma carte graphique, j'ai trouvé le pilote et une doc pour l'installer sur le site officiel de Nvidia.

Ca marche ...

Share this post


Link to post
Share on other sites

×
×
  • Create New...