Jump to content

Archived

This topic is now archived and is closed to further replies.

Recommended Posts

Je pense pas.

Les options qui sont requises à l'install d'un logiciel porté sont accessibles via

make config

dans le répertoire du logiciel en question.

Pour le reste, ce qui est dans /usr/ports fait partie des logiciels tiers.

Peut-être en fouillant ce qui existe dans /usr/ports/ports-mgmt/ ?

Je sais pas pour toi, mais je suis impressionné par la vitesse du wifi sur la 8.0-RC2.

Share this post


Link to post
Share on other sites
Est-il possible de spécifier quelque part toutes les options que l'on veut pour les ports ?

Et plus encore, est-il possible de spécifier quelque part ces options mais pour un port en particulier ?

En personnalisant le fichier make.conf:

http://www.freebsd.org/cgi/man.cgi?query=make.conf

http://www.mtdev.com/2005/02/saving-freebsd-ports-make-flags

Attention le dernier lien date quand même de 2005...

Share this post


Link to post
Share on other sites
Est-il possible de spécifier quelque part toutes les options que l'on veut pour les ports ?

Et plus encore, est-il possible de spécifier quelque part ces options mais pour un port en particulier ?

En personnalisant le fichier make.conf:

http://www.freebsd.org/cgi/man.cgi?query=make.conf

http://www.mtdev.com/2005/02/saving-freebsd-ports-make-flags

Attention le dernier lien date quand même de 2005...

Ah oui j'suis tombé sur le lien " using newer version of GCC " qui propose aussi des configurations particulières dans le make.conf directement :

http://www.freebsd.org/doc/en/articles/cus...ORMANCE-IMPARCT

Mais est ce que ça permet de se passer de l'affichage ncurse généré par le port en question ?

Sinon j'ai moi aussi une question . ;)

C'est plutot une colle , je compte pas m'en servir ( ou alors dans un cadre très particulier ) :

La WebCam de mon portable est une webcam usb ( intégrée, mais passant par un port usb ) .

Elle est reconnue et fonctionnelle. ( on va dire en ugen5.2 ).

J'ai KDE-4 , KDM , hal et dbus .

J'ai aussi installé un logiciel " cheese " .

Cependant le lancement de cheese me donne des erreurs génériques qui me font penser que la webcam n'est peut-être pas montée . Ce qui me semble normal. vu que j'ai pas paramétré le montage de périphériques par l'utilisateur, sauf que je me suis dépêché de rajouter vfs.usermount=1 dans sysctl.conf quand j'ai rajouté la déclaration des daemons hald et dbus .

0 -> Existe-t il une aide particulière concernant le montage des webcams qui utilisent l'usb avec les " nouveaux " drivers usb ?

( utilisation de ugenx.y en particulier )

J 'ai cherché, en particulier il existe des références à des commandes qui n'existent pas encore ( ou j'ai zappé quelque chose ) et n'ont pas de page de manuel .

Bref, avant de singer le montage d'un disque dur externe, si quelqu'un a une référence qui ne renvoie pas sur un forum où on pose la question et qui renvoie sur Google , ça serait cool .

1 -> Comment monter la webcam ( /root , ligne de commande ) ? ( en particulier : Système de fichiers )

2 -> Comment permettre à /user de monter la webcam ? ( je sais qu'il faut monter un périf vers /home/user/point_de_montage_utilisateur , mais qu'en est-il avec hal ? )

Share this post


Link to post
Share on other sites

Merci.

Pour mes questions ( vagues ) sur la webcam , un des points bloquant était qu'on trouve des références à usbdevs ( 8 ) .

Dans FreeBSD-8 usbconfig ( 8 ) remplace usbdevs .

Les documentations ne devraient pas tarder à arriver, mais en attendant, c'est un peu difficile de s'y retrouver.

Pour info :

#usbconfig -u 5 -a 2 dump_device_desc
ugen5.2: <USB 2.0 Camera Sonix Technology Co., Ltd.> at usbus5, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON

 bLength = 0x0012 
 bDescriptorType = 0x0001 
 bcdUSB = 0x0200 
 bDeviceClass = 0x00ef 
 bDeviceSubClass = 0x0002 
 bDeviceProtocol = 0x0001 
 bMaxPacketSize0 = 0x0040 
 idVendor = 0x0c45 
 idProduct = 0x62c0 
 bcdDevice = 0x0100 
 iManufacturer = 0x0002  <Sonix Technology Co., Ltd.>
 iProduct = 0x0001  <USB 2.0 Camera>
 iSerialNumber = 0x0003  <SN0001>
 bNumConfigurations = 0x0001

La camera dispose de l'idproduit 0x62c0 .

edit :

après plusieurs recherches , il semblerait que le driver /multimedia/linux-gspca-kmod soit celui qui convient pour faire fonctionner cette webcam.

Mais ni lui, ni /graphics/spca ne compilent sur 8.0 pour l'instant. :reflechis:

Donc affaire réglée.

Share this post


Link to post
Share on other sites
après plusieurs recherches , il semblerait que le driver /multimedia/linux-gspca-kmod soit celui qui convient pour faire fonctionner cette webcam.

Mais ni lui, ni /graphics/spca ne compilent sur 8.0 pour l'instant. :p

Donc affaire réglée.

si tu aimes faire des tests :

http://lists.freebsd.org/pipermail/freebsd...ber/011532.html

et

http://www.mail-archive.com/freebsd-usb@fr...g/msg05799.html

perso ma webcam est reconnu j'arrive à avoir l'image mais l'intégration pour kde4 ne fonctionne pas...

Share this post


Link to post
Share on other sites

Bonjour,

Je voudrais m'essayer à FreeBSD 8.0 et j'ai une question : je voudrai savoir si le DVD inclut les drivers wifi à base d'Atheros (ath5k) ?

Share this post


Link to post
Share on other sites
après plusieurs recherches , il semblerait que le driver /multimedia/linux-gspca-kmod soit celui qui convient pour faire fonctionner cette webcam.

Mais ni lui, ni /graphics/spca ne compilent sur 8.0 pour l'instant. :p

Donc affaire réglée.

si tu aimes faire des tests :

http://lists.freebsd.org/pipermail/freebsd...ber/011532.html

et

http://www.mail-archive.com/freebsd-usb@fr...g/msg05799.html

perso ma webcam est reconnu j'arrive à avoir l'image mais l'intégration pour kde4 ne fonctionne pas...

merci je vais tester ça ce soir.

Bonjour,

Je voudrais m'essayer à FreeBSD 8.0 et j'ai une question : je voudrai savoir si le DVD inclut les drivers wifi à base d'Atheros (ath5k) ?

Alors pour les atheros ça va dépendre de la version, la plupart sont bien reconnues et utilisables avec les drivers libres ( féminin atheros non ? ), pour le Wifi, il y a des nouveautés dans le réglage ( un peu de recherches sur gcu-squad http://www.freebsddiary.org/wireless-8.php , etc... ) .

Tu as aussi une image pour cle usb .

http://www.freebsd.org/where.html

Share this post


Link to post
Share on other sites

Dernière question : Est-il possible de mettre le bootloader sur la partition racine car je souhaite me servir de Grub-pc (Ubuntu) pour charger FreeBSD.

Share this post


Link to post
Share on other sites

Effectivement cela m'intéresse de savoir si il est possible à l'install de FreeBSD de ne pas mettre de bootloader et depuis un grub linux de faire démarrer FreeBSD parce que j'ai un seven (pour les jeux de temps en temps donc petite partition), une ubuntu pour tout ce que je fais en général donc grosse partition et les deux sont lancé par grub et donc j'aimerais essayer FreeBSD 8 avec la place qu'il me reste mais pouvoir lancer avec mon grub déjà mis en place.

Si c'est possible comment faire ?

Share this post


Link to post
Share on other sites

absolument.

A l'install de FreeBSD, il suffit de lui demander de ne pas réécrire le MBR.

Pour la config de Grub, c'est .

PErso, je préfère utiliser le mbr FreeBSD qui a l'avantage d'envoyer directement aux racines des partitions physiques qu'il a trouvé.

Share this post


Link to post
Share on other sites

Pour l'instant je vais juste tester donc pas trop chambouler mon système en place par contre si j'ai envie de me garder FreeBSD pourquoi pas mettre le MBR FreeBSD => avec ce MBR je pourrais assez facilement configurer pour que je puisse lancer Ubuntu et Seven (et FreeBSD forcement) ?

Share this post


Link to post
Share on other sites
absolument.

A l'install de FreeBSD, il suffit de lui demander de ne pas réécrire le MBR.

Pour la config de Grub, c'est .

PErso, je préfère utiliser le mbr FreeBSD qui a l'avantage d'envoyer directement aux racines des partitions physiques qu'il a trouvé.

Sauf pour grub-pc il faut éditer le fichier /etc/grub/40_custom. Il suffit de rajouter ça :

menuentry "FreeBSD 8.0" {
set root=(hd1,1,a)
kernel /boot/loader
}

un petit sudo update-grub et normalement c'est bon.

Une autre solution existe c'est de se servir de Windows pour amorcer FreeBSD. Il suffit d'utiliser EasyBCD.

Share this post


Link to post
Share on other sites

:up::transpi:

J'ai un petit souci avec portupgrade.

Quand je fais le -a, il ne dit

** Port directory not found: devel/autoconf268** Listing the failed packages (-:ignored / *:skipped / !:failed)	- devel/autoconf268 (port directory error)

C'est la seule erreur qu'il me reste suite au passage 8.1 à 8.3. D'ailleurs, merci à :

#pkgdb -L           (Vérifie et réinstalle les dépendances perdues)#pkgdb -F           (fixe la db des ports)#portsclean -C      (nettoie toutes l'aborescence des ports -make clean dans tout les dossiers)#portsclean -D      (supprime les dossiers qui ne sont plus maintenus dans les ports)

Avez-vous une idée pour supprimer ce "lien" vers un dossier qui n'existe plus? (portsclean -D ne faisant rien)

Share this post


Link to post
Share on other sites

Bonjour à tous,

tous les pcbsd à installer sont en 64 bits. or mon pc est en 32 bits. J'ai une copie sur dvd de la dernière version, mais rien ne se passe. est-ce normal ?

merci à vous.

Share this post


Link to post
Share on other sites

Bonjour à tous,

tous les pcbsd à installer sont en 64 bits. or mon pc est en 32 bits. J'ai une copie sur dvd de la dernière version, mais rien ne se passe. est-ce normal ?

merci à vous.

Bonjour,

 

Effectivement, c'est totalement normal. Config 32bit = OS 32bit.

J'espere que tu as trouvé une alternative depuis février.

 

++

Share this post


Link to post
Share on other sites

×
×
  • Create New...