Jump to content

Archived

This topic is now archived and is closed to further replies.

xplzok

Plein de questions sur LinUX

Recommended Posts

:fumer: Slt Tlm :byebye:

Donc voila, je viens d'installer Linux pour la première fois. J'ai lu quelques documents dessus mais j'ai plein de questions trés trés basiques sans doute pour la pluspart mais pas pour moi. Je me permet donc de les poser, je suppose que d'autres se les posent aussi :

1) Je vois dans mon nom de navigateur web Mandrake Mozilla, il me semble cependant reconnaitre l'interface netscape navigator? Alors? c'est quoi au final ?

:mad2:

2) Y a t'il dans la version Mandrake un antivirus et un pare-feu?

3) Dans windows, lorsqu'il y a des images, il y a moyen d'avoir un tout petit apercu. C'est possible avec linuX?

4)Les spywares? Ca existe aussi sur LInux?

5) Comment installer un programme? J'ai telecharger FireFox, et la, j'ai un fichier, que j'ouvre, et il s'ouvre comme un dossier...etc :zarb:

Share this post


Link to post
Share on other sites

http://www.pcinpact.com/forum/sujet_23814.htm

manuel mandrake pci

déja ca va t'aider :fumer:

sinon, les spywares n'existent pas dans les logiciels libres. par contre, skype existe sous linux,mais c'est un logiciel propriétaire et il "pourrait" contenir des spywares.

oui, il y a un pare feu dans mandrake, je ne me rappel plus de son nom...

l'antivirus, pas besoin, tu as clamav sinon, ca peut te servir à scanner des windows qui pourraient etre verrolés.

Share this post


Link to post
Share on other sites

1) Si c'est mozilla, c'est le même moteur que netscape, il me semble.

2) Parefeu, oui, il n'est pas activé par défaut ? Il existe des "frontend" pour configurer le firewal iptables, comme firestarter.

3) Que ce soit sous KDE ou Gnome, il y a une gestion des "vignettes", comme Windows, il faut être en mode d'affichage 'icônes'.

4) Je ne crois pas... Enfin, tout est possible. Linux est trop sécurisé par défaut pour le permettre de toute façon.

5) idem.

LE conseil qui vaut tous les autres : "Tu n'invoqueras pas root en vain" Ne travaille jamais loggué en root, il est toujours temps d'ouvrir une console et de taper 'su' pour effectuer les opérations importantes.

Share this post


Link to post
Share on other sites

2) Parefeu, oui, il n'est pas activé par défaut ? Il existe des "frontend" pour configurer le firewal iptables, comme firestarter.

voila c'est celui la auquel je pensais :fumer:

Share this post


Link to post
Share on other sites

Bonjour,

1) Dans la version Mandrake,il y a le Firewall Shorewall qui est livrée avec la distribution et que tu peut l'activer grace a au panneau de controle, et pour L'antivirus je te conseille Clamav .

2) Les Spyware n'existe pas sur Linux

3) Pour installer un programme c'es simple :

Methode 1 :

- Ouvre une Konsole

- met toi en Root

- tu tappe ça : urpmi nom_du_fichier

- Exemple : urpmi clamav

Methode 2 :

Tu va chercher les RPM sur ce Site , et ensuite tu demmarre l'installation .

:-D

Share this post


Link to post
Share on other sites
Personne n'a la réponse à la question 5 :-D ?

;) Quand j'ai répondu, tu n'avais rien mis pour 5) alors je t'ai répondu "idem" !

Share this post


Link to post
Share on other sites

Il existe d'excellents tutos sur pci, donc merci de les lire avant de poser ces question d...

Share this post


Link to post
Share on other sites

Methode 2 :

Tu va chercher les RPM sur ce Site , et ensuite tu demmarre l'installation .

:-D

Methode à utiliser en dernier recours, car hautement danguereuse.

En fait cette methode ne sert pas si urpmi est correctement configuré

pour le reste, tout est déja dit

Share this post


Link to post
Share on other sites

Bonjour,

Oui, d'accord avec toi , il ne reste plus qua voir si les probleme de notre ami es Resolue .

Share this post


Link to post
Share on other sites

Salut tout le monde,

Pour les Mandrakiens (sur le firewall):

Dès que je coche une des cases sur le firewall integrer à madrake, je n'ai plus acces au net (je peux plus consulter les pages)

Quel sont les options à cocher pour avoir une sécurité standart en sachant que j'ai mon pc en réseau local et accès net (je veux aussi consulter les partages des autres pc) :francais:

++

Share this post


Link to post
Share on other sites
Salut tout le monde,

Pour les Mandrakiens (sur le firewall):

Dès que je coche une des cases sur le firewall integrer à madrake, je n'ai plus acces au net (je peux plus consulter les pages)

Quel sont les options à cocher pour avoir une sécurité standart en sachant que j'ai mon pc en réseau local et accès net (je veux aussi consulter les partages des autres pc)  :byebye:

++

fut une époque où le script de conf d'iptables de mdk merdait comme pas permis sur les conf adsl pppoe. (je me rappelle avoir passé un bon nombre de nuit blanche... :byebye: )

en fait il remplaçait un ppp0 par un eth0. on doit encore pouvoir trouver ça en googlant un coup.

la méthode est simple

-> trouver un vbon terminal

-> stopper le service shorewall

-> éditer le fichier de conf (dans /etc/shorewall/ , peut-être interfaces, ou un truc du genre, j'ai plus l'arborescence mdk sous la main)

-> relancer shorewall

et ne plus toucher au front-end de mdk. Mais ça à sûrement du changer depuis :mdr:

Share this post


Link to post
Share on other sites

:D Bon, je reprend depuis le début. Je me suis mis un peu plus à lire la documentation (comme conseillé :D )

Je crois avoir compri en partie la gestion des disques dur, du "root" etc.

et là, je voudrais savoir, un truc me semble étrange. Je vois avec le gestionnnaire de disque (en bas à droite) mes différents disques. Lorsque je veux acceder à n'importe quel disque

on me met :

Erreur KdF

Appelé : umount/dev/hda

Umount: only root can unmount/dev/hda 7 from/home

J'en déduis que je ne peux pas acceder aux différents disques si on n'est pas root. Ca me semble un peu bizar comme principe? J'ai bien compri ou mal? ;)

Par ailleurs, je trouve qqchose d'étrange. Si là on me dit que je ne suis pas root, lorsque je veux installé un programme comme indiqué ici : http://lea-linux.org/fiches/administration/ficheinstall.html

Je note qu'on ne me demande pas mon pass de root, ce qui signifirait alors que je suis déja loggé en root.

Faudrait savoir!!!!

Autre chose, finallement, j'ai préféré me penché sur une doc "en image" (toujours ici :http://lea-linux.org/fiches/administration/ficheinstall.html)

et la, je ne comprend pas,

la ligne "mise à jour des sources est remplacé par "mise à jour des médias". ok, je met ca sur le compte d'une vesrion différente (?je me trompe?). Si c'est la même chose, le resultat quant à lui est trés différent : on me dit de choisir les media que je veux mettre à jour : j'ai le choix entre les 3 cd d'installation de linux...que faire?

Share this post


Link to post
Share on other sites

Ta déduction est bonne, mais ce qui n'est pas normal, c'est que tu trouve ca bizarre. Ce n'est pas parce que l'on gare sa voiture sur un parking que toutes les autres sont à notre disposition. Dommage me direz vous... :transpi:

Regarde mon tuto sur le fstab maintenant, tu comprendras un peu mieux ( c'est pour les debutants ) et surtout comment faire pour que tes disques se montent correctement.

Share this post


Link to post
Share on other sites

xplzok, j'ai eu le meme probleme pour m'adapter au montage de disque :transpi:

Mais ca va maintenant j'ai pris l'habitude.

C'est vrai qu'en venant de windows, le plus déroutant, c la maniere de gerer les comptes utilisateurs/droits. En tout cas ct le cas pour moi :)

Share this post


Link to post
Share on other sites

:p Débutant ! c'est le terme!

Donc si tu pouvais être plus explicite sur ton tuto "fstab", j'ai recherché avec l'outil recherche mais pas trouvé.

:transpi: merci

Share this post


Link to post
Share on other sites

:transpi:

merci, j'en viens, j'essaye de comprendre

:byebye:

ok, donc, j'ai lu tout ca....

Je pense avoir compris, j'ai fait ma modif en rajoutant le petit "user" où il se doit afin de permettre à tlm (pas le root) d'y acceder.

Pour se faire, j'ai bien compri que bien que pouvant ouvrir et lire ce fichier en "pas root", si je veux le modifier, il faut que je sois "root"

je suis donc aller dans la console et tapé

su root (on ne me demande pas mon pass, car je n'en n'ai pas mis, pas grave)

apparait alors le message :

[root@localhost matthieu] #

je suppose que cela signifie que je suis alors considéré comme "root" (?j'ai raison?)

Malheureuseument, même avec ce statut, lorsque je veux modifier le fichier fstab et surtout enregistrer les modifications, il apparait

"le document n'a pas pu être enregistré, car il n'a pas été possible d'écrire dans file:/etc:fstab.

Vérifier que vous avez les droits d'écriture dans ce fichier ou qu'il y a suffisament d'espace disque disponible""

Donc, soit je suis pas root et j'ai zappé un épisode (ce qui est trés possible), soit j'ai zappé un autre épisode.

:craint:

...Désolé :transpi:

Share this post


Link to post
Share on other sites

Il faut que tu lances l'éditeur de texte depuis ta console, puisque c'est le seul endroit où tu es loggué en root. Et oui, sous linux tu n'as pas besoin de te délogguer complètement pour te logguer en root, tu peux ne le faire que dans une fenêtre, sans déranger le reste.

Donc solution : dans ta console, taper "gedit /etc/fstab" ou "kedit /etc/fstab" (en fait "<n'importe_quel_editeur_de_texte> /etc/fstab")

Share this post


Link to post
Share on other sites

oki, je comprend, j'ai donc essayé avec KWrite, qui semble être l'éditeur par défaut. Ca ne marche pas, j'ai essayé en mettant le chemin complet (en précisant /file:), toujours pas, j'ai ensuite essayé en mettant l'éditeur que tu proposais, toujours rien. :incline:

[matthieu@localhost matthieu]$ su root

[root@localhost matthieu]# KWrite/etc/fstab

bash: KWrite/etc/fstab: No such file or directory

[root@localhost matthieu]# KWrite/file:/etc/fstab

bash: KWrite/file:/etc/fstab: No such file or directory

[root@localhost matthieu]# gedit/etc/fstab

bash: gedit/etc/fstab: No such file or directory

[root@localhost matthieu]#

[root@localhost matthieu]#

Si vous remarquez ce que je fais mal, hésitez pas, faites partager

merci

Share this post


Link to post
Share on other sites

kwrite <adresse du fichier>

Il faut un espace entre KWrite et l'adresse du fichier ! :)

Et pareil pour gedit etc :incline:

gedit = commande

adresse du fichier = 1 parametre

Dans un shell, pour lancer un logiciel c'est toujours : commande <parametre 1> <parametre 2> ... <parametre n>

(et tout en minuscule pour leslogiciels en général. Y'a ptet que X qui echappe a cette regle quasiment)

(TAB est ta tres tres grande amie sous la console :)

kw<TAB>) :-D

Share this post


Link to post
Share on other sites

met toi deux seconde à la place du programme qui interprète ta commande. Il faut bien un moyen de séparer les différentes informations : c'est l'espace. Si tu écris tout à la suite ca risque pas de marcher :incline:

Share this post


Link to post
Share on other sites

×
×
  • Create New...