Jump to content

Gentoo A64 + ATI 9800 PRO [Enfin Installé]


Recommended Posts

bizarre de chez bizarre......... euuuuu y aurait po un probleme entre GRub et le kernel 2.6.8-gentoo-r3 (pour ceux qui n'ont pas suivi, je suis en version X86 en 32 bits)?

J'ai meme refais une reinstall complete a partir du stage 1 et j'obtients la meme erreur au boot

Grub se charge sans pb avec l'image et j'ai une seule entrée avec ce kernel

l'erreur est la suivante (de tete) : Erreur 15 blablablabla et je reviens a la fenetre Grub

Avec deux entrés avant ma reinstall j'avais la 2.4.X-gentoo-r9 ca marchait sans pb avec ce kernel et si je choisissais le 2.6.8 meme code erreur 15blablabla

donc je recharge le noyau 2.4 pour essayer de modifier le fichier grub.conf mais le repertoire /boot/grub/ n'existe pu meme en partant du CD? :pleure: (d'ou ma reinstall complete)

Link to post
Share on other sites
  • Replies 211
  • Created
  • Last Reply

Un jour viendra, Terminou arrivera a installer gentoo. Et ce jour la, Ati aura fait de fantastiques drivers Linux pour son ATI Radeon 18500 Pro,2Go de DDR5 a 5ghz sur 1024bits....

:pleure: coucher le tigre !

Link to post
Share on other sites
Un jour viendra, Terminou arrivera a installer gentoo. Et ce jour la, Ati aura fait de fantastiques drivers Linux pour son ATI Radeon 18500 Pro,2Go de DDR5 a 5ghz sur 1024bits....

:pleure: coucher le tigre !

Tu tombes bien j'ai pas encore pris mon P'tit dej :mdr::mdr::mdr:

J'me demande quel gout ca a un modo.. Je devorerai bien un modo :rhooo::pleure::non::yes: ....

Link to post
Share on other sites
l'erreur est la suivante (de tete) : Erreur 15 blablablabla et je reviens a la fenetre Grub

Hop

ouvres peut-être un petit topic spécial, je crois qu'on s'écarte là.

C'est comme pour le topic de modophilie qui est en train de se former ci-dessus :pleure:

un tip, quand même: erreur 15 pour grub c'est qu'il ne trouve pas le ou les fichiers.

mais grub est souple et t'autorise l'édition (touche e) et l'emploi de la touche tab pour faire la complétion automatique, si tu te souviens pas du nom de ton noyau.

Sinon un truc, accessoirement, quand tu as compilé ton noyau, c'est de monter /boot AVANT d'y copier ton bzImage :rhooo:

Link to post
Share on other sites

Merci pour la suggestion mais j'ai suivi la procédure du guide...

Bon ce soir je sens que je vais me creuser les meninges pour finter Grub...

PS: J'arriverai à 5000 avant tes 1000 posts :pleure:

EDit : Promis je redeviens serieux apres ce post :rhooo:

Link to post
Share on other sites

Terminou :

Ton problème ne serait-il pas lié à la partition "/boot" ? (c'est ce que me fait penser tout ce qui a été dit)

Utilise la ligne de commande et la "tab-completion" de grub:

Dans le menu de grub, tape "c"

ensuite, tape "kernel (hd"<tab>

tu va avoir une liste de possibilités (disque 0, 1, etc...)

donc cela donne "kernel (hd0,"<tab>

ici tu va voir les différentes partitions, avec leur type...choisis la bonne

Ensuite donc "kernel (hd0,1)/"<tab>

tu va avoir accès à l'arborescence linux... donc ça se passe comme l'auto-completion du shell

et tu te retrouve à la fin avec "kernel (hd0,1)/boot/kernel-2.6.23-gentoo-r12" (ou un truc dans le genre :rhooo:)

là tu rajoute tes options à la fin : "root=/dev/hdXX"

tu appuie sur "entrée"

et "boot" <entrée>

...et voilà...

n'oublie pas que les noyaux se trouvent sur /boot su tu as une partition spérée pour ça... (moi je dit à 90% que c'est ça... on vote? :pleure:)

(Je ferai un topic bootloader... j'avais envoyé quelque chose à remy pour grub pour le manuel "INpact/Linux", je vais donc reprendre cela et rajouter des trucs, mettre 2 mots sur lilo, quelques fichiers de conf et des explications pour mettre une image de fond pour chacun)

Link to post
Share on other sites

J'ai une question quand meme. Maintenant que les lignes de commandes manuelles fonctionnent...

Je fais comment pour modifier le fichier grub.conf?

J'ai beau essayer de monter des partitions mount /dev/hdd1 /mnt/gentoo/boot et j'obtients

mount : moint point /mnt/gentoo/boot does not existe

Link to post
Share on other sites

Je suis un vrai boulet c po possible. J'ai juste inversé des chiffres...

JE loadais le kernel 2.8.6-gentoo-r3 au lieu de 2.6.8-gentoo-r3 ... ooooooook j'etais un peu en avance

bon j'ai encore une question a propos du kernel et ATI. Que faut il mettre en DRM ? Rien ou pas je pige pas car les avis diverges pour l"acceleration 3D. Modules? Chargé ? Rien? :-D

Link to post
Share on other sites

Ce n'est que mon avis perso, mais les meilleurs perfs, je les ai faites sans compiler le DRM (même pas en module) et en utilisant le support agp integré de ATI (c-à-d sans compiler le modules via-agp ou nvidia-agp, juste le support agp )

après, les avis diverge (en un seul mot :transpi: )

Link to post
Share on other sites

ca se termine coment en general ce genre de pb ?

EXT2-fs error (device ram0) : ext2_get_inode : unable to read inode block - inode=263, block=8197

mount_devfs_fs() :unable to mount devfs, err : -5

Kernel panic : no init found .try passing init = option to kernel (FREEZE)

http://www.google.fr/search?hl=fr&ie=UTF-8...he+Google&meta=

j'ai vu des trucs dansce genre en solution

Script started on Wed Mar 7 12:22:20 2001

# mke2fs -Fq /dev/ram0 1440

mke2fs 1.19, 13-Jul-2000 for EXT2 FS 0.5b, 95/08/09

# mount /dev/ram0 /mnt

# ls -la /mnt

total 0

# umount /mnt

# exit

Link to post
Share on other sites

On dirait qu'il veut un initrd ton noyau...tu n'as pas du suivre la doc a la lettre, car l'install de la gentoo n'en demande pas.

Au fait, juste une question comme ca, pourquoi tu as choisi gentoo d'entrée de jeu terminou ??

Link to post
Share on other sites

Il faut juste bien mettre les option dans le bootloader...

(:iloveyou: ah oui, faut que je fasse le topic là dessus :transpi:)

comme il est marqué dans le manuel gentoo :

si on utilise juste un noyau sans initrd :

title linux

kernel (hdX,Y)/boot/kernel-2.6.X-xxx root=/dev/hdROOT

avec (hdX,Y) la partition "/boot" et /dev/hdROOT la partition "/"

par exemple :

hdc1 : windows

hdc2 : /boot

hdc3 : swap

hdc4 : /

...et grub sur ce disque là...

cela donne : "kernel (hd0,1)/boot/kernel root=/dev/hdc4"

(hd0,1) correspond à la partition "1" (numéroté à partir de 0) du disque "0" (celui où grub est installé)

si il y a un initrd (initrd gentoo, tous ne marchent pas pareil ...)

title linux

kernel (hdX,Y)/boot/kernel-2.6.X-xxx root=/dev/ram0 init=/linuxrc real_root=/dev/hdROOT

initrd (hdX,Y)/boot/initrd-2.6.X-xxx

ce qui donnerait :

"kernel (hd0,1)/boot/kernel root=/dev/ram0 init=/linuxrc real_root=/dev/hdc4"

"initrd (hd0,1)/boot/initrd"

(bon, tout ça est un peu marqué dans la doc gentoo, mais je ferait un truc... (en plus je fini le taf aujourd'hui :transpi:)

Link to post
Share on other sites

ou, plus sobrement ?

root (hd0,0)
kernel /boot/bzImage-2.6.8-ck5 root=/dev/md0

(par exemple)

pis après quand tu es plus sport

splashimage=(hd0,0)/boot/grub/gentoo-splash.xpm.gz

title=Gentoo/2.6.8-ck5
root (hd0,0)
kernel /boot/bzImage-2.6.8-ck5 root=/dev/md0 hdc=ide-cd video=vesafb:ywrap,mtrr vga=0x31A splash=silent
initrd=/boot/initrd-1280x1024

le gentoo-splash.xpm étant fait à partir d'une image piquée dans le thème bootsplash gentoo-highquality, convertit en 15 couleurs, ramené en 640x480, converti en xpm et gzippé :)

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...