Jump to content

Archived

This topic is now archived and is closed to further replies.

Terminou

Gentoo A64 + ATI 9800 PRO [Enfin Installé]

Recommended Posts

oki mais apres ??? ca f pas avance le chmilblik......

je v pas recommecer toute l'instal ljuste a cause de grub kan meme? ca serai un peu cul cul la praline comme systeme... :fumer:

ben sinon, tu passes au plan B

tu boot sur le live cd

tu modprobe les drivers dont t'as besoin

tu montes ton /boot dans l'arbo du live cd

tu modifie ton fichiers de config et tu reboot

Share this post


Link to post
Share on other sites

Mooouuaaaiichhh.. C ce que je comptais faire de toute facon...esperons que ca marchera sinon :fumer::D

Share this post


Link to post
Share on other sites

Coucou!!!

Y a pas quelqu'un qui pourrait m'expliquer comment parametrer mon fichier grub.conf. car ca palnte toujour .. Erreur machin truc (hd1,0)......

(infos : j'ai utilisé Genkernel)

Mes partitions de la Gentoo sont sur le Disk

Hdd : hdd1 (Boot) hdd2 (Swap) Hdd3 (ROOT)

Ce disk est sur le port IDE secondaire en Slave.

lorsque je tape : uname -r j'ai le résultat suivant.

2.6.7-gentoo-r14-up

J'ai un DD hda (windobe), un lecteur DVD , des autres DD sur carte fille RAID hde et hdg il me semble.

Au fait vu que mon Grub plante, je boot a partir du CD de Gentoo.

JE charge le module ide-disks et tg3, monte les parttions comme dans l'install

4.e. Mounting

Now that your partitions are initialized and are housing a filesystem, it is time to mount those partitions. Use the mount command. Don't forget to create the necessary mount directories for every partition you created. As an example we mount the root and boot partition:

Code Listing 15: Mounting partitions

mount /dev/hdd3 /mnt/gentoo

# mkdir /mnt/gentoo/boot (ca je ne le fais pas puisque deja la)

mount /dev/hdd1 /mnt/gentoo/boot

Ai je besoin de refaire la parti CHrooting ? A mon avis nan mais bon....

ON peut installer autre chose que Grub? lilo par exemple.....

autre question:

LA variable USE dans mon fichier /etc/make.conf n'est pas définit

Mais il me semble que ce n'est pas nécessairep uisque un autre fichier contient cette variable et que si je definit USE dans le fichier /etc/make.conf cela revient à customiser cette variable ..... nan?

Share this post


Link to post
Share on other sites

Bien ...

Pour commencer vérifie que tu pointes vers le bon disque

exemple :

root@gandalf ~ # cat /boot/grub/device.map
(hd0)   /dev/hda
(hd1)   /dev/hdd

c'est ce qui permet (chez moi) de faire comprendre à Grub que (hd1) correspond à /dev/hdd

Sinon si tu as un device intermédiaire (genre hdb ou hdc) il va pointer dessus, et évidemment ça va marche beaucoup moins bien

pour la variable USE, je te recommande d'emerger et d'utiliser ufed ...

cela dit pour répondre également, l'entête de /etc/make.globals est

#            *****************************
#            **  DO NOT EDIT THIS FILE  **
# ***************************************************
# **** CHANGES TO make.conf *OVERRIDE* THIS FILE ****
# ***************************************************
# ** Incremental Variables Accumulate Across Files **
# **  USE, CONFIG_*, and FEATURES are incremental  **
# ***************************************************

:)

Share this post


Link to post
Share on other sites
Bien ...

Pour commencer vérifie que tu pointes vers le bon disque

exemple :

root@gandalf ~ # cat /boot/grub/device.map
(hd0)   /dev/hda
(hd1)   /dev/hdd

c'est ce qui permet (chez moi) de faire comprendre à Grub que (hd1) correspond à /dev/hdd

Sinon si tu as un device intermédiaire (genre hdb ou hdc) il va pointer dessus, et évidemment ça va marche beaucoup moins bien

pour la variable USE, je te recommande d'emerger et d'utiliser ufed ...

cela dit pour répondre également, l'entête de /etc/make.globals est

#            *****************************
#            **  DO NOT EDIT THIS FILE  **
# ***************************************************
# **** CHANGES TO make.conf *OVERRIDE* THIS FILE ****
# ***************************************************
# ** Incremental Variables Accumulate Across Files **
# **  USE, CONFIG_*, and FEATURES are incremental  **
# ***************************************************

:)

:yes: oki doki.. JE testerai demain soir.....

Y a toujours des p'tits trucs qui font merdouiller..... ;)

Share this post


Link to post
Share on other sites

coucou

est ce quelqu'un pourrai me montrer le contenu de son fichier /boot/grub/grub.conf svp avec une ch'tite explication de ces partitions svp

je pige pas pourquoi grub plante.

il me marque

Booting Gentoo linux 2.6.7

root (hd1,0)

Filesystem type unknow,partition type 0x7

kernel /kernel-2.6.7-gentoo-r14 root=/dev/ram0 init=linuxrc ramdisk=_&çé real_root=/dev/hdd3 vga=792

error 17 :cannot mount selected partition :francais:

edit: J'ai utilisé genkernel

Share this post


Link to post
Share on other sites

rem@Pai-mei:~$ cat /boot/grub/grub.conf

default 1

timeout 10

title=Experimentation

root (hd0,0)

kernel (hd0,0)/kernel-2.6.7 root=/dev/md0

title=Surete

root (hd0,0)

kernel (hd0,0)/vmlinuz-2.6.7 root=/dev/md1

title=Bonheur

root (hd0,0)

kernel (hd0,0)/vmlinuz-2.6.8 root=/dev/md1

title=Malheur

rootnoverify (hd2,1)

makeactive

chainloader +1

rem@Pai-mei:~$

1e section gentoo raid 0

2e section debian raid 0 2.6.7

3e section debian raid 0 2.6.8

4e section windaube ( ca ne fonctionne pas au passage...)

Booting Gentoo linux 2.6.7

root (hd1,0)

Filesystem type unknow,partition type 0x7

kernel /kernel-2.6.7-gentoo-r14 root=/dev/ram0 init=linuxrc ramdisk=_&çé real_root=/dev/hdd3 vga=792

error 17 :cannot mount selected partition

Fais bien attention a la maniere dont il a numerote tes disques.... Ca peut poser pb, et c'est pas forcement dans le meme ordre que le noyau linux, grub etant ecrit a la base pour hurd.

Share this post


Link to post
Share on other sites

alors...

fdisk -l :

/dev/hda1  *          1        2550    20482843+  7  HPFS/NTFS

/dev/hda2            2551      10010    59922450    f  W95 Ext'd (LBA)

/dev/hda5            2551        6186    29206138+  7  HPFS/NTFS

/dev/hda6            6187      10010    30716248+  7  HPFS/NTFS

/dev/hdb1              1      23252    11718976+  83  Linux

/dev/hdb2          23253      26310    1541232  83  Linux

grub est installé sur le mbr de hdb...

voici un exrtait du grub.conf :

default 0 <=par défaut, la première entrée

timeout 10 <=10 secondes avant de sélectionner l'entrée par défaut

title 268 <=nom qui apparaîtra dans la liste

root (hd0,0) <=endroit où est le système de fichiers où se situe le noyau : (hd0,0) représente le disque hdb1 car grub est installé dessus...

kernel /boot/kernel-2.6.8 root=/dev/ram init=/linuxrc real_root=/dev/hdb1 vga=794 <=d'abord, le nom du noyau, ensuite root et init pour l'initrd, real_root pour le vrai système de fichiers, et le vga pour 1280x1024

initrd /boot/initrd-2.6.8 <=où est l'initrd

si tu veux être sûr, il suffit de taper dans l'invite de commande de grub ("c" au démarrage), et d'utiliser <TAB>

Share this post


Link to post
Share on other sites

Quand tu as fait tout ça, tu peut aussi essayer de désactiver la détection automatique des disques dans le bios (c'est un problème récurent).

Pour ton "unknow fs", il me semble que 0x7 c'est du ntfs...

Share this post


Link to post
Share on other sites

merci pour les infos.. je vais essayer de compiler tout cas dans mon p'tit cerveau et ej vous tiens au courant

Share this post


Link to post
Share on other sites

je l'avais bien dit que c'etait une connerie de numerotation... ok, je reconnais j'ai eu le coup :

Sur pai mei j'ai

hda ( ide )

hdb ( ide )

hde ( sata )

hdg ( sata )

et grub lui les as numerote comme ca :

hd0 -> hde

hd1 -> hdg

hd2 -> hda

hd3 -> hdb

:D sur le coup pour comprendre que c'etait ca !

Share this post


Link to post
Share on other sites

hd0 est toujours le disque sur lequel grub est installé...

faut le savoir, c'est tout...

Share this post


Link to post
Share on other sites

juste une question (c'etait trop beau pour que tous les pb soient fixés)

Mon system boot sans probleme, pas de message d'erreur apperemnt mais

mon system reste bloqué au prompt login.

aucune touche ne fonctionne( meme la touche du clavier numerique num pad ne clignote pas). je suis oblige d'eteindre

Pensez vous que ce soit un pb relati a unmauvois choix de compile du noyau?

pourtant j'ai bien mis en * clavier sur PS/2

cela dit c'est curieux. J'ai deja modifié le fichier /etc/rc.conf et sauvé (pour mettre le claviern en FR) et en reboot a partir du LiveCD (monté les partitions) le fichier est à nouveau intact a chaque reboot....:transpi:

Share this post


Link to post
Share on other sites
cela dit c'est curieux. J'ai deja modifié le fichier /etc/rc.conf et sauvé (pour mettre le claviern en FR) et en reboot a partir du LiveCD (monté les partitions) le fichier est à nouveau intact a chaque reboot....:fou:

C'est possible que tu ai mal compilé...par exemple le support PS/2 (je sais pas comment t'aurais fait ça, mais c possible...)

Pour ton truc de fichier intact, tu parle du fichier du CD? parce que ça, c'est normal...

Si tu veux utiliser le live-CD pour voir ta partition linux, il faut que tu monte ta partition ("mount /dev/hdXX /mnt/gentoo"), puis que tu regarde là-dedans ("vi /mnt/gentoo/etc/rc.conf")...

Cela m'étonnerais que le fichier ne soit pas changé...

Share this post


Link to post
Share on other sites

Si tu veux utiliser le live-CD pour voir ta partition linux, il faut que tu monte ta partition ("mount /dev/hdXX /mnt/gentoo"), puis que tu regarde là-dedans ("vi /mnt/gentoo/etc/rc.conf")...

Cela m'étonnerais que le fichier ne soit pas changé...

ba si. c le cas.

Bon demain je recompilerai le kernel alors. MErci quand meme :fou:

Share this post


Link to post
Share on other sites
ba si. c le cas.

si tu utilise vi, il faut faire ":wq" ...

si c'est nano, il faut faire "ctrl-o" "ctrl-x"

...et ça modifie les fichiers...si tu les réouvre, ils ont été changés, et si tu reboot, ils sont comme il faut (modifiés, quoi)

Si les fichiers revenaient dans leur état initial sous linux à chaque démarrage, ce serait un peu embêtant :fou:

Share this post


Link to post
Share on other sites

2 ptits trucs :

- Pour vi ( je connais plus que bien Vi, Vi est mon ami :fou: ) pour sauver je vous conseille "ZZ", c'est equivalent a ":wq" mais c'est plus facile a taper lorsqu'on a un clavier a la con... Pour anecdote, editer un fichier sous gentoo, faire des modifs, me rendre compte que le clavier etait mauvais, et me demerder pour annuler mes conneries puis sauver sans faire de degats...

- PAs de clavier au demarrage, c'est vraiment severe si c'est un ps2. Si c'est un usb, ben c'est de la saloperie, mets un adapteur ps2

rem, toujours avec bcp de tact....

Share this post


Link to post
Share on other sites

On a eu le même problème à l'école (Debian testing/unstable). Certains PC ne répondaient plus au clavier (PS2) au boot.

Par contre tu as toujours ton accès en ssh. Si tu as besoin de bidouiller dedans ça peut t'aider à trouver ce qui chie.

Pour anecdote, editer un fichier sous gentoo, faire des modifs, me rendre compte que le clavier etait mauvais, et me demerder pour annuler mes conneries puis sauver sans faire de degats...
Hum, tu peut donner plus de précisions sur le problème et le clavier ? Parce que ça ne semble pas méchant comme ça.

Pour annuler, il suffit de faire '[ctrl]+Z' (berk!) ou 'UU' normalement. Et je suppose que comme tu travaille dans un millieu high secure(c'est pas beau high secure, mais j'ai pas trouvé mieux), tu dois avoir l'option set backup, et donc un fichier non modifié.

Est qu'il y a quelque chose que j'ai encore zappé ?

Share this post


Link to post
Share on other sites

nan theo, c'etait chez moi, a me premiere install de gentoo... En fait, j'ai un peu chier mon fichier fstab avec Vi, et comme un con, par habitude j'ai voulu sauver. Dans un pemier temps, j'ai fait des ptits degats, puis j'ai voulu sauve et quitte... Mais la, hic ! En fait, c'etait avec les retours a la ligne.... ca avait tronque les lignes, mais je m'en suis tire ! C'etait pas extraordinaire, mais le 'ZZ' etait bien plus facilement trouvable que le :wq, surtout sur un truc a l'aveugle.... Donc, je recommandais ca.

Share this post


Link to post
Share on other sites

Bon je recompile tout (cf FAQ Gentoo : Probleme de noyau). J4ai vu une option Clavier/souris PS2 manquant dans mon choix. J'espere que ce n'etait que cela.

Je vous tiens au courant.

Juste une question annexe.

J4ai beau lire et relire mais j'arrive pas à piger le chroot. A quoi ca sert?

Pour recompiler mon noyau, j'ai booté à partir de LiveCD.

JE monte les partitions ( ca c'est normal) mais ensuite pourquoi je dois faire

mount -t proc none.......

et un chroot blablabla????

Share this post


Link to post
Share on other sites

Ca sert a deplacer la racine d'un systeme, lors de l'install de gentoo c'est necessaire de le faire afin qu'il considere /mnt/gentoo comme le nouveau /

Donc des que tu travailles dans / apres, ca fait reference a /mnt/gentoo

Share this post


Link to post
Share on other sites

oki merci

sinon ca marche bien maintenant. J'install des packages . Pour le moment j'attaque par Gnome....

Share this post


Link to post
Share on other sites

Bon apres 1H30 de comile de GNome il me faut installer les pilote ATI

Cependant en tapant : emerge ati-drivers

j'ai Calculating dependencies

!!! all ebuilds that could satisfy "ati-drivers" have been masked

!!! possible candidates are:

-media-video/ati-drivers-2.9.12 (masked by : -* keyword)

-media-video/ati-drivers-2.9.13-r1 .....

-media-video/ati-drivers-2.9.13

-media-video/ati-drivers-3.11.1..

.....

!!!Error calculatig dependencies. Please correct

pas moyen d'installer... :yes:

Share this post


Link to post
Share on other sites

t'as un athlon64 avec une ATI?

mais lol...ati ne fait pas de drivers pour x86-64 (t'aurais eu une nvidia, no prob...)

donc, tu va essayer, si ça marche, t'aura de la chance :

 $ echo "media-video/ati-drivers -*" >> /etc/portage/package.keywords
$ emerge ati-drivers

(les drivers ati sont masqués sur les autres plate-formes que x86 :yes: )

Share this post


Link to post
Share on other sites

×
×
  • Create New...