Jump to content

[CLOS] SSD M2 dans un boitier externe fonctionne sur port USB type C arrière, mais pas sur le port de façade


Recommended Posts

Bonjour à tous,

Je rencontre un problème de connexion de périphérique avec un boitier pour SSD M2 lorsque je le branche sur le port USB type C de façade de mon PC principal et je recherche un peu d'aide. 🙏 :chinois:

 

Ayant souhaité me créer une "grosse" clé usb rapide j'ai acheté ceci :

- SSD M2 nvme seagate firecuda 510 500Go

- Boitier inatek (FE2025)( la connectique du boitier c'est du USB type C)

Le boitier vient avec un câble type C ---> type C et un câble type C ---> type A comme sur la photo du lien.

 

J'ai monté le tout et j'ai un souci de détection du SSD quand je branche le boitier sur le port type C de la façade (pas de souci avec le câble type C --> type A en façade)).

Quand je le branche sur le port USB type C "arrière" de la carte mère par contre cela fonctionne sans problème (ainsi que sur le port USB type C de mon pc portable).

Une clé usb tierce en type C fonctionne aussi sans problème en façade du boitier.

 

Lorsque le SSD est branché en façade, l'explorateur windows galère, le SSD n'apparait le plus souvent pas dans l'explorateur de windows (ou alors juste l'icône) mais je ne peux accéder au contenu, à un moment j'ai eu l'erreur indiquée sur l'image fournie : F:/ n'est pas accessible, impossible de satisfaire à la demande en cours etc..

Le contrôleur du boitier à lui l'air d'être détecté car quand je vais pour éjecter en toute sécurité son nom s'affiche.

Le bios de la CM (B550M mortar wifi) est en V18 (soit la dernière version stable), il y a un bios beta que je peux essayer au besoin mais pas d'indication de compatibilité USB améliorée il me semble.

"Gestion des disques" voit le SSD comme un disque dur de 2To, je n'ai pas de tel disque dans le pc.

Si vous avez une idée, je vous écoute 🙂

Cordialement

 

clé usb nvme - branchée en type C façade - message erreur.png

Gestion des disques.png

clé usb nvme -  branchée en type C façade, contrôleur détecté.png

Edited by bred94
Link to comment
Share on other sites

quel est ton boitier pc et où as tu branché le connecteur usb type c de la face avant du boitier sur ta carte mère ?

un mauvais contact de se connecteur ou le fil est abimé peux poser ce soucis. Essaie avec un autre câble usb type c vers type c j'ai déjà eu des soucis avec ce genre de câble qui marche pas tout le temps.

  • Aime 1
  • Merci 1
Link to comment
Share on other sites

Le boitier pc est un IN WIN 101C, sa connectique USB-C interne est branchée directement sur la carte mère sur le connecteur adéquat.

il y a 26 minutes, ashlol a dit :

un mauvais contact de se connecteur ou le fil est abimé peux poser ce soucis. Essaie avec un autre câble usb type c vers type c j'ai déjà eu des soucis avec ce genre de câble qui marche pas tout le temps.

D'après mes observations, il n'y a que sur le port type C de la façade que le boitier SSD inatek ne fonctionne pas, il a fonctionné à chaque fois quand je l'ai branché ailleurs (derrière + pc portable) du coup je ne penche pas trop perso pour un câble qui dysfonctionnerait^^ (puis je n'ai pas d'autres câbles USB C --> C à dispo^^)

Je vais peut-être tenter de débrancher et rebrancher la connectique USB-C interne dans le doute, mais ma clé usb C fonctionne bien devant, elle. 🤔

Link to comment
Share on other sites

il y a une heure, bred94 a dit :

Je vais peut-être tenter de débrancher et rebrancher la connectique USB-C interne dans le doute, mais ma clé usb C fonctionne bien devant, elle. 🤔

@ashlol parlait bien de la connectique interne. Par ailleurs, les broches utilisées pour une clé USB et pour un disque SSD ne sont pas forcément les mêmes, et pas forcément avec les mêmes contraintes.

Une clé USB-C peut se contenter de communiquer en mode USB2 même sur un port USB-C, ou n'utiliser que l'alim "classique"

  • Aime 2
Link to comment
Share on other sites

Alors là !

J'ai débranché/ rebranché le câblage interne USB-C et maintenant cela fonctionne !

Je n'avais pas pensé cela car j'étais à peu près sûr que j'avais bien inséré le câble, d'ailleurs avant de le retirer j'ai d'abord appuyé dessus et pris en main pour vérifier sa tenue et le câble semblait bien mis.

J'avais imaginé un autre problème^^. Merci @ashlol et @brice.wernet

Edited by bred94
  • Aime 1
Link to comment
Share on other sites

  • bred94 changed the title to [Résolu] SSD M2 dans un boitier externe fonctionne sur port USB type C arrière, mais pas sur le port de façade
Il y a 1 heure, brice.wernet a dit :

@ashlol parlait bien de la connectique interne. Par ailleurs, les broches utilisées pour une clé USB et pour un disque SSD ne sont pas forcément les mêmes, et pas forcément avec les mêmes contraintes.

Une clé USB-C peut se contenter de communiquer en mode USB2 même sur un port USB-C, ou n'utiliser que l'alim "classique"

oui exactement

il y a 5 minutes, bred94 a dit :

Alors là !

J'ai débranché/ rebranché le câblage interne USB-C et maintenant cela fonctionne !

pas plus étonné que ça j'ai déjà eu le soucis, je trouve le connecteur interne mal fait

Link to comment
Share on other sites

Il y a 3 heures, ashlol a dit :

pas plus étonné que ça j'ai déjà eu le soucis, je trouve le connecteur interne mal fait

A noter pour ceux qui passent par là, je viens de le découvrir, le connecteur interne usb-c possède une orientation, il faut mettre le câble usb du boitier dans le bon sens.

Je n'étais pas bien en face du port mais je crois que j'ai justement retourné le câble avant de le remettre (edit : enfin pas sûr non plus, mais j'ai observé un détail sur le connecteur qui m'a laissé penser qu'il y avait un sens à respecter..)

usb-c.png

Edited by bred94
Link to comment
Share on other sites

Un truc bizarre s'est produit, je viens de reconnecter le SSD externe à l'instant au pc  et rebelote, le SSD n'était pas reconnu (même symptômes, pas visible dans l'explorateur windows), alors que je n'ai pas retouché à ce câble interne. depuis mes derniers messages.. 👽

J'ai éteint le pc, débranché - rebranché le câble interne usb-c en veillant bien à le placer de manière à ce que le "détrompeur" aille à l'endroit où il n'y a un espace vide du connecteur, le SSD remarche pour l'instant. Je ne comprends pas.

Une petite question, si le câble usb type C interne est mis dans le mauvais sens sur la carte mère, le port usb type C fonctionne un peu quand même où est-il censé ne pas fonctionner du tout ?

(d'après ce que 'ai compris, la 1ère option est possible ? car je me suis dit que j'avais mal branché ce câble ce qui provoquait une erreur avec le SSD (mais pas avec une clé usb type C) ce qui indique un port qui ne fonctionne qu'à moitié mais est-ce que ça fonctionne comme cela ?)

Merci

Edit : bon ben le SSD ne marche plus à nouveau en façade, explorateur qui galère... clé usb type C ok en façade

Edited by bred94
Link to comment
Share on other sites

Comme dit plus haut, un périphérique connecté en usb-c peut fonctionner en usb2 (cas de ta clé j'imagine) ou usb3 ,(le ssd)

En usb2, seules 4 broches sur les 24 sont nécessaires et elles sont toutes doublées.

Donc tu dois avoir un mauvais contact sur une des broches dédiées usb3. Il faut juste espérer que ce ne soit pas côté carte mère... En tout cas, ça va être coton à changer!

Link to comment
Share on other sites

Merci pour les explications.

Sur ma clé usb type C samsung est indiqué usb 3.1^^.

En 1er essai à l'instant le SSD refonctionne contrairement à hier soir, un coup cela marche et un coup ça ne fonctionne pas j'ai l'impression, sans ne rien toucher niveau câblage.

Link to comment
Share on other sites

vu qu'en débranchant et rebranchant ton connecteur interne cela refonctionne tu as bien un mauvais contact comme je l'avais dis sur ce connecteur ou ce câble interne car le fait de le bouger peux faire contacter un fil abimé.

comme l'as dis @brice.wernet sur l'usb c toutes les pins sont en double et seules 4 pins du milieu sont nécessaires pour fonctionner en usb2.

ça c'est sur le connecteur usb c mais ça ne veut pas dire que entre le connecteur carte mère et le connecteur boitier ce soit pareil. JUSB1 le connecteur mini 20pins ne peux pas être branché à l'envers car il a un détrompeur un ergot plus gros que l'autre normalement. Si t'arrives à le brancher à l'envers il y a un problème car plusieurs pins ne seront pas bonne notamment le vbus et gnd sont inversé

USB 3.1 Front Panel Connector (Internal USB3.1_E1)

il y a 3 minutes, bred94 a dit :

Sur ma clé usb type C samsung est indiqué usb 3.1

c'est la norme maximale prise en charge mais elles peuvent toujours fonctionner en mode dégradé usb2 avec débit à la ramasse

Link to comment
Share on other sites

Il y a 4 heures, ashlol a dit :

vu qu'en débranchant et rebranchant ton connecteur interne cela refonctionne tu as bien un mauvais contact comme je l'avais dis sur ce connecteur ou ce câble interne car le fait de le bouger peux faire contacter un fil abimé.

Un mauvais contact est une possibilité en effet, cependant je n'ai pas touché le câble interne entre hier soir et ce midi et pourtant hier soir je ne pouvais plus connecter le SSD et ce midi c'est ok, alors que je n'ai touché à rien, le fonctionnement me semble parfois aléatoire indépendamment des manipulations sur le branchement.

 

Il y a 4 heures, ashlol a dit :

ça c'est sur le connecteur usb c mais ça ne veut pas dire que entre le connecteur carte mère et le connecteur boitier ce soit pareil. JUSB1 le connecteur mini 20pins ne peux pas être branché à l'envers car il a un détrompeur un ergot plus gros que l'autre normalement. Si t'arrives à le brancher à l'envers il y a un problème car plusieurs pins ne seront pas bonne notamment le vbus et gnd sont inversé

En fait, je ne suis pas sûr d'avoir à un moment branché le câble interne du boitier à l'envers , c'est ce que j'ai déduis en 1er lieu au 1er fonctionnement du SSD sur le pc après manipulation sur ce câble sans trop faire gaffe au sens en voyant le SSD refonctionner, mais ce fonctionnement n'a pas duré au final^^.

En tout cas le branchement se faisait avec aisance à chaque fois, je vais peut-être inspecter les pins à l'occasion si j'ai d'autres soucis, a voir comment se comporte le SSD par la suite.

Edit : j'ai bien regardé le design du câble usb type C du boitier ainsi que le port carte mère correspondant et effectivement je n'aurais pas pu le brancher dans le mauvais sens sans remarquer qu'il était mal branché, ce câble est donc branché dans le bon sens depuis le début

Il y a 4 heures, ashlol a dit :

c'est la norme maximale prise en charge mais elles peuvent toujours fonctionner en mode dégradé usb2 avec débit à la ramasse

D'accord 👍

Edited by bred94
Link to comment
Share on other sites

Bonjour,

Rapidement, je tiens à signaler qu'il peut y avoir des déperditions de courant dans un câble allant jusqu'au port en face avant. 

Donc si tu te branches directement sur le port à la carte mère, tu n'as plus de déperditions et donc un fonctionnement 100% optimal.

 

Normalement, tu as des ergots de détrompage, des détrompeurs sur tes connecteurs. Donc tu peux faire l'essai machine éteinte et déconnectée du secteur de vérifier que le câble ne s'insère pas dans le sens incorrect.

Link to comment
Share on other sites

c'est peut être tout simplement ton port usb-c en façade qui est un peu sensible, sur le portable du boulot je dois brancher l'usb-c bien droit et ne pas le bouger sinon il ne se connecte pas correctement ou se déconnecte intempestivement (ce qui est très chiant d'ailleurs).

Link to comment
Share on other sites

Bonjour,

Il y a 4 heures, digital-jedi a dit :

Rapidement, je tiens à signaler qu'il peut y avoir des déperditions de courant dans un câble allant jusqu'au port en face avant. 

Donc si tu te branches directement sur le port à la carte mère, tu n'as plus de déperditions et donc un fonctionnement 100% optimal.

Ah c'est bon à savoir, dans mon cas, j'utilise simplement le câble usb C ---> usb C fourni avec le boitier SSD (il doit faire 20cm) que je branche devant (problème) ou derrière (ok)

Il y a 4 heures, digital-jedi a dit :

Normalement, tu as des ergots de détrompage, des détrompeurs sur tes connecteurs. Donc tu peux faire l'essai machine éteinte et déconnectée du secteur de vérifier que le câble ne s'insère pas dans le sens incorrect.

Effectivement avec les détrompeurs, il semble difficile de pouvoir brancher le câble usb type C du boitier dans le mauvais sens ^^

J'avais pensé à un moment que j'avais pu mal le brancher mais en fait non.

Il y a 4 heures, ashlol a dit :

c'est peut être tout simplement ton port usb-c en façade qui est un peu sensible, sur le portable du boulot je dois brancher l'usb-c bien droit et ne pas le bouger sinon il ne se connecte pas correctement ou se déconnecte intempestivement (ce qui est très chiant d'ailleurs).

Merci. Cette piste m'étonnerait un peu car ma clé usb type C fonctionne très bien à haut débit sur ce port sans jamais se déconnecter^^ elle semble stable une fois insérée^^.

 

En tout cas, cela est dommage car c'est du matos récent (boiter et carte mère) dont j'ai pris soin, peut-être qu'il y a problème avec cette connectique (câblage du port usb C côté carte mère ou câble du boitier), qui ne pose pas de soucis sur la clé usb type C mais n'aime pas le boitier SSD, qui fonctionne sans souci ailleurs / ou avec l'autre câble usb type A).

Bizarre tout ça ... 👽

Link to comment
Share on other sites

Il y a 16 heures, bred94 a dit :

Ah c'est bon à savoir, dans mon cas, j'utilise simplement le câble usb C ---> usb C fourni avec le boitier SSD (il doit faire 20cm) que je branche devant (problème) ou derrière (ok)

je pense qu'il parle du câble interne du boîtier qui relie la CM au port en façade, il fait forcément plus de 20cm et s'ajoute au câble "final" entre le ssd et le port usb en façade, donc si le contrôleur du ssd est un peu sensible / gourmand peut-être que c'est trop limite alors qu'une "simple" clef usb s'en sort mieux car moins gourmande / puce moins susceptible

 

si t'as l'occasion d'essayer un autre câble usb-c <-> usb-c pour brancher ton ssd, c'est peut-être la combinaison "câble interne CM <-> prise façade + câble externe prise façade <-> ssd" qui dépasse de pas grand chose les tolérances du ssd et qu'un autre câble (externe) poserait moins de souci

Link to comment
Share on other sites

Il y a 5 heures, fry a dit :

je pense qu'il parle du câble interne du boîtier qui relie la CM au port en façade, il fait forcément plus de 20cm et s'ajoute au câble "final" entre le ssd et le port usb en façade, donc si le contrôleur du ssd est un peu sensible / gourmand peut-être que c'est trop limite alors qu'une "simple" clef usb s'en sort mieux car moins gourmande / puce moins susceptible

Ah oui tu as raison merci, j'avais mal compris 🙂

J'ai aussi pensé à un moment à la possibilité d'un manque d'alimentation sur ce port usb-c de façade^^

Si à l'occasion je chope un petit câble usb C-->C j'essaierai alors 🙂

Edited by bred94
Link to comment
Share on other sites

il y a 50 minutes, bred94 a dit :

Si à l'occasion je chope petit un petit câble usb C-->C j'essaierai alors 🙂

bah "petit" limite les soucis de conducteurs trop fin sur des câbles trop longs, mais un câble plus long peut très bien marcher si les conducteurs sont de bonne section

en cherchant un boîtier usb l'autre jour je lisais les commentaires sur certains produits et des clients se plaignaient que le câble fourni n'était pas génial et qu'ils avaient des soucis de connexion, alors qu'avec un autre câble acheté "à part" mais "d'une bonne marque" le boîtier marchait très bien

t'es peut-être tombé sur un produit de ce genre

et/ou un défaut de fabrication dans le câble qui se trouve "trop limite" une fois au bout de la rallonge de la cm à la façade

 

bon, tout ça ne reste que des spéculations sur le fait que le souci vient principalement du câble hein, ce qui n'est pas encore totalement prouvé XD

 

edit : typo

Edited by fry
Link to comment
Share on other sites

Merci pour les explications sur les câbles 👍

Le câble usb C-->C fonctionne bien sur mon pc portable (le boitier SSD branché en type USB-C est toujours fonctionnel) mais oui peut être qu'en bout de course sur la façade de mon pc de bureau c'est juste..

Link to comment
Share on other sites

  • bred94 changed the title to [CLOS] SSD M2 dans un boitier externe fonctionne sur port USB type C arrière, mais pas sur le port de façade

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...