Jump to content

Archived

This topic is now archived and is closed to further replies.

Compte_supprime_92985

conseils d'organisation de disque dur

Recommended Posts

j'ai pu finalement installer gparted et les drivers mp3 : j'ai dû cocher des cases supplémentaires dans les sources disponibles : j'ai coché les 4 premières cases dans le premier onglet, et les 2 premières dans l'onglet "updates".

allez, j'avance, grâce à vous.

Share this post


Link to post
Share on other sites
- mon disque de donnée est un IDE avec une seule partition dedans. il est dans monté dans /media/data/

Si ton disque est monté dans /media, il y a fort à parier qu'il ne soit pas monté au boot, mais en cours de route...

Grosso merdo, la manière la plus usuelle de faire est de monter à chaud dans /media, et de monter statiquement dans /mnt (même s'il semble que les bonnes habitudes aient tendance à se perdre, ces temps-ci :francais: )...

Ca pourrait expliquer pourquoi il faut que tu parcoures ton HDD (ce qui peut le monter automatiquement, en fonction de comment tu t'y prends... il se peut que le volume-manager de ta distro ne le monte que quand tu l'explores manuellement...) pour accéder à ta homepage personnalisée...

Dans ce cas, il faudrait rajouter une entrée dans /etc/fstab pour qu'il soit monté à la phase d'init... avant que le clickodrome ne se lance...

Si c'est du NTFS, il faudrait quelque chose comme ça dans le fstab:

/dev/TA_PARTITION /mnt/TON_POINT_DE_MONTAGE ntfs-3g defaults,locale=fr_FR.utf8 0 0

Bien sûr, dans ce cas, il faut que le point de montage existe...

sous ubuntu tout ce qui est montage secondaire est monté dans /media. En gros, /media a remplacé /mnt.

Mais ca n'explique pas pourquoi il doit taper son mot de passe. Moi j'ai une dizaine de partoche dans /media et je ne tappe a aucun moment mon password ... Meme en branchant une clé/disque usb.

@bgse : tu sembles avoir un serieux probleme de dependances quelques part. Je ne sais pas d'ou ca vient, mais c'est bizarre ... Je crains que tu vas devoir ouvrir une console et taper :

sudo aptitude -f install

ou au pire :

sudo dpkg --configure -a

(aptitude gere les dependances en les telechargeant si elles existent (ce qui devrait etre le cas pour tout paquet dans les depots ubuntu de base, dpkg ne gere pas les dependances : il sait qu'elles existent, mais il va pas faire le boulot, il va juste se stopper tout seul en indiquant quelle dependances ne sont pas installées.)

La commande aptitude que je t'ai indiqué permet de terminer l'installation des dernier paquet et le cas echéant d'afficher l'erreur qui bloque.

La commande dpkg que je t'ai indiqué force la configuration/installation des paquets qui ont planté lors de l'install auparavant. Elle est a faire si la commande aptitude n'a rien reglé et n'a pas affiché d'erreur.

Si tu peux copier les messages d'erreurs ici ca serait cool :)

Share this post


Link to post
Share on other sites

Pour compiz, ne faut-il pas installer xserver-xgl?

Chez moi, ça ne fonctionne pas sans qu'il soit installé et qu'il ait introduit sa petit ligne dans xorg.conf + restart de X.

Share this post


Link to post
Share on other sites

j'ai pu aussi installer les drivers proprio, et j'ai redémarré.

en allant dans "apparance", puis effets visuels, quand je clique sur "normal" ou autre, ça me mets : "The Composite extension is not available"

j'ai essayé dans synaptic d'installer des trucs en rapport avec compiz, mais ça ne change rien.

et j'entend le ventilo de ma CG depuis que j'ai installé le drivers proprio...

c'est obligatoire d'installer les drivers proprio pour faire marcher compiz ou compiz fusion ??

dans /mnt j'ai QUEDALLE !!! :(

en fait quand je viens de démarrer mon pc, il me demande le mot de passe une fois (pour explorer un disque, ou pour aller dans synaptic), et après il ne me le demande plus. par contre, je ne peux pas écouter un mp3 sans que j'ai exploré au moins une fois le disque en question. pareil pour firefox : il n'accède pas au fichier .html sans que le disque sur lequel se trouve le fichier n'ait été exploré au moins une fois.

Share this post


Link to post
Share on other sites
Pour compiz, ne faut-il pas installer xserver-xgl?

Chez moi, ça ne fonctionne pas sans qu'il soit installé et qu'il ait introduit sa petit ligne dans xorg.conf + restart de X.

Hmmm en effet, c'est vrai que ati c pas trop ca de base ... Mais il me semble que les derniers pilotes n'ont plus besoin de XGL vu qu'ils implémentent AIGlx. Normalement ca devrait fonctionner de base.

bgse : reva dans le panneau des pilotes proprio, ca devrait fonctionner maintenant que tu as les depots restricted/multiverse activé :)

En fait, tes problemes de dépendances venaient du fait que tu avais des paquet de main qui avait besoin d'autres paquet pour fonctionner. Or ces paquets la etaient dans d'autres dépots qui n'etaient pas activés... Forcément, impossible de les telecharger vu que le systeme ne sait pas ou ils sont. Néanmoins je ne considere pas que les messages que tu as eu soient tres explicite. Faudrait remonter un bug a ubuntu. Je le ferai si j'ai le temps. (en gros que ca verifie si les dépots restricted et multiverse sont activés avant de dire que c un problème de dépendance ...)

Et notamment les codecs mp3 sont dans restricted car ils sont interdit dans certains pays (US pour ne pas les citer) mais légaux dans d'autre. Et main et restricted, c'est la société Canonical qui s'en occupe directement. Donc normalement, bonne qualité. Universe et multiverse c'est pareil, mais géré par la communauté : il peut y'avoir plus de bug. Mais vu les procedure pour faire rentrer quelque chose dans les depots officiels universe/multiverse, c'est qu'il faut en vouloir et que ton paquet est de bonne qualité.

main et universe : logiciels libre et légaux partout

restricted et multiverse : logiciels et pilotes soumis a du code propriétaire, non libre.

L'un géré par Canonical, l'autre par la communauté. :)

Share this post


Link to post
Share on other sites
j'ai pu aussi installer les drivers proprio, et j'ai redémarré.

en allant dans "apparance", puis effets visuels, quand je clique sur "normal" ou autre, ça me mets : "The Composite extension is not available"

j'ai essayé dans synaptic d'installer des trucs en rapport avec compiz, mais ça ne change rien.

et j'entend le ventilo de ma CG depuis que j'ai installé le drivers proprio...

c'est obligatoire d'installer les drivers proprio pour faire marcher compiz ou compiz fusion ??

dans /mnt j'ai QUEDALLE !!! :(

en fait quand je viens de démarrer mon pc, il me demande le mot de passe une fois (pour explorer un disque, ou pour aller dans synaptic), et après il ne me le demande plus. par contre, je ne peux pas écouter un mp3 sans que j'ai exploré au moins une fois le disque en question. pareil pour firefox : il n'accède pas au fichier .html sans que le disque sur lequel se trouve le fichier n'ait été exploré au moins une fois.

Pour ton probleme de bureau, il me semble que l'erreur est indiqué sur la doc ubuntu : http://doc.ubuntu-fr.org/compiz_fusion

Faut bien rajouter une ligne au xorg.conf (composite ). Bizarre que ca ne soit pas fait automatiquement avec l'installation des pilotes proprio ...

Pour les mots de passe que tu dois taper, en fait c'est le mecanisme de sudo (gksudo/kdesu). Tu es connecté en tant qu'utilisateur de base. Tu ne pas tout casser sans taper ton mot de passe une deuxieme fois pour acquerir les droits administrateur. Synaptic, le gestion de mise a jour, gparted, ... nécéssite les droits administrateurs pour fonctionner.

Ce qui est bizarre, c'est que ton disque ne soit pas monté automatiquement et de plus nécéssite les droits root/admin pour etre ouvert ... Et ton fichier .html dans firefox, c'est le fichier html par défaut (file:///usr/share/ubuntu-artwork/home/locales/index-fr_FR.html). Si oui, c'est un gros probleme que ton /usr ne soit pas monté au demarrage et la, je me pose pleins de questions ^^

Tu peux ouvrir /etc/fstab et nous le copier coller par ici ?

Share this post


Link to post
Share on other sites
- mon disque de donnée est un IDE avec une seule partition dedans. il est dans monté dans /media/data/

Si ton disque est monté dans /media, il y a fort à parier qu'il ne soit pas monté au boot, mais en cours de route...

Grosso merdo, la manière la plus usuelle de faire est de monter à chaud dans /media, et de monter statiquement dans /mnt (même s'il semble que les bonnes habitudes aient tendance à se perdre, ces temps-ci :transpi: )...

Ca pourrait expliquer pourquoi il faut que tu parcoures ton HDD (ce qui peut le monter automatiquement, en fonction de comment tu t'y prends... il se peut que le volume-manager de ta distro ne le monte que quand tu l'explores manuellement...) pour accéder à ta homepage personnalisée...

Dans ce cas, il faudrait rajouter une entrée dans /etc/fstab pour qu'il soit monté à la phase d'init... avant que le clickodrome ne se lance...

Si c'est du NTFS, il faudrait quelque chose comme ça dans le fstab:

/dev/TA_PARTITION /mnt/TON_POINT_DE_MONTAGE ntfs-3g defaults,locale=fr_FR.utf8 0 0

Bien sûr, dans ce cas, il faut que le point de montage existe...

sous ubuntu tout ce qui est montage secondaire est monté dans /media. En gros, /media a remplacé /mnt.

Mais ca n'explique pas pourquoi il doit taper son mot de passe. Moi j'ai une dizaine de partoche dans /media et je ne tappe a aucun moment mon password ... Meme en branchant une clé/disque usb.

cf mon post plus haut, message 97

Share this post


Link to post
Share on other sites

hum hum!

sur tous les systemV depuis le kernel 2.6 et des poussières, par convention, on met dans /media les disques amovibles et dans /mnt les disques fixes.

juste histoire de s'y retrouver... :transpi:

Share this post


Link to post
Share on other sites

Juste pour préciser des choses (oui, j'encule encore les mouches... mais ça a un sens)...

Pour ceux qui n'utilisent pas Ubuntu, j'explique : lorsque les partitions ne sont pas montées mais montables alors elles apparaissent non montées et le fait de tenter d'y accéder fait qu'elle se monte dans /media avec le libellé du disque.

Ca, c'est tout à fait logique... si c'est monté à chaud en utilisant pmount (fût-ce transparent à l'utilisateur), c'est fait pour être monté dans "/media" (d'ailleurs, pas besoin de spécifier media: si je fais "pmount /dev/sda1 prout", "/dev/sda1" est monté dans "/media/prout", et pas dans "./prout")... "/media" est d'ailleurs fait pour ça: servir d'emplacement de montage pour les utilisateurs membres du groupe "plugdev" qui se servent de pmount (quand c'est bien fait... enfin, si on peut considérer pmount comme "bien fait"... l'impossibilité de démonter un volume, pourtant potentiellement accessible à tous les membres de plugdev, par un autre membre de plugdev que celui qui l'a monté, si on souhaitait l'autoriser, est une chose que je trouve exaspérante au possible, et qui me fait secrètement rêver à un Hurd fonctionnel :transpi: )...

sous ubuntu tout ce qui est montage secondaire est monté dans /media. En gros, /media a remplacé /mnt.

Je ne suis pas un pro de cette distro, mais j'ai plus l'impression que les seuls à avoir remplacé "/mnt" par "/media", ce sont des utilisateurs qui, ayant vu que le volume manager de gnome monte dans "/media", ne se posent pas plus de questions... la chose allant jusqu'à faire boule de neige dans les tutos...

... et d'une manière ou d'une autre, je trouve ça bien dommage... en faisant la distrinction "/mnt" et "/media", au moins, on ne risque pas de perturber le volume manager avec un point de montage qui existe déjà et qui peut-être pris par autre chose... je préfère un "/media" propre dans lequel on sait qu'il n'y a que de l'amovible et de l'éphémère (mort à la création automatique de "/media/cdrom" et cie... comme si HAL et sa surcouche n'étaient pas capables de traiter un lecteur optique comme n'importe quelle autre chose... ou comme si la quasi-totalité des applis ayant besoin de l'emplacement précis d'un lecteur optique [je pense aux lecteurs et rippeurs de partitions qui n'ont pas vocation à être montées, comme les CD audios, les DVD et cie] avaient besoin de le monter pour s'en servir... :francais: ... non mais, franchement, c'est quoi, ce mambo-jambo? ... et pour les quelques rares cas où c'est effectivement intéressant de monter à un emplacement connu, il y a des choses comme apt-cdrom qui peuvent s'interfacer avec les surcouches de HAL...)...

Ca n'empêche d'ailleurs pas de faire des symlinks ou d'utiliser du bind dans le fstab si on veut pouvoir accéder à la partoche de différents endroits (le "/exports" NFSv4, le home de l'utilisateur, ...)... c'est même d'ailleurs indiqué...

Mais confondre "/mnt" et "/media", je trouve ça gênant et potentiellement source de bugs...

Alors, certes, pour monter dans "/mnt", il faut avoir les privilèges root (ou spécifier l'abominable option "users" dans le fstab) et que le point de montage existe... mais justement, au moins, c'est carré...

Sinon, @Arafel, pour fr_FR.utf8, je sais bien que c'est par défaut, mais je me méfie tellement des partitions formatées par les os redmondiens que je prends toujours des doubles précautions avec ce genre de choses (et c'est d'ailleurs pour ça que je n'utilise le "force" que manuellement, au besoin... d'autant que les partitions ntfs qui entrent chez moi, il ferait beau voir que ce soient les miennes :D )...

Share this post


Link to post
Share on other sites
Juste pour préciser des choses (oui, j'encule encore les mouches... mais ça a un sens)...
Pour ceux qui n'utilisent pas Ubuntu, j'explique : lorsque les partitions ne sont pas montées mais montables alors elles apparaissent non montées et le fait de tenter d'y accéder fait qu'elle se monte dans /media avec le libellé du disque.

Ca, c'est tout à fait logique... si c'est monté à chaud en utilisant pmount (fût-ce transparent à l'utilisateur), c'est fait pour être monté dans "/media" (d'ailleurs, pas besoin de spécifier media: si je fais "pmount /dev/sda1 prout", "/dev/sda1" est monté dans "/media/prout", et pas dans "./prout")... "/media" est d'ailleurs fait pour ça: servir d'emplacement de montage pour les utilisateurs membres du groupe "plugdev" qui se servent de pmount (quand c'est bien fait... enfin, si on peut considérer pmount comme "bien fait"... l'impossibilité de démonter un volume, pourtant potentiellement accessible à tous les membres de plugdev, par un autre membre de plugdev que celui qui l'a monté, si on souhaitait l'autoriser, est une chose que je trouve exaspérante au possible, et qui me fait secrètement rêver à un Hurd fonctionnel :transpi: )...

sous ubuntu tout ce qui est montage secondaire est monté dans /media. En gros, /media a remplacé /mnt.

Je ne suis pas un pro de cette distro, mais j'ai plus l'impression que les seuls à avoir remplacé "/mnt" par "/media", ce sont des utilisateurs qui, ayant vu que le volume manager de gnome monte dans "/media", ne se posent pas plus de questions... la chose allant jusqu'à faire boule de neige dans les tutos...

... et d'une manière ou d'une autre, je trouve ça bien dommage... en faisant la distrinction "/mnt" et "/media", au moins, on ne risque pas de perturber le volume manager avec un point de montage qui existe déjà et qui peut-être pris par autre chose... je préfère un "/media" propre dans lequel on sait qu'il n'y a que de l'amovible et de l'éphémère (mort à la création automatique de "/media/cdrom" et cie... comme si HAL et sa surcouche n'étaient pas capables de traiter un lecteur optique comme n'importe quelle autre chose... ou comme si la quasi-totalité des applis ayant besoin de l'emplacement précis d'un lecteur optique [je pense aux lecteurs et rippeurs de partitions qui n'ont pas vocation à être montées, comme les CD audios, les DVD et cie] avaient besoin de le monter pour s'en servir... :D ... non mais, franchement, c'est quoi, ce mambo-jambo? ... et pour les quelques rares cas où c'est effectivement intéressant de monter à un emplacement connu, il y a des choses comme apt-cdrom qui peuvent s'interfacer avec les surcouches de HAL...)...

Ca n'empêche d'ailleurs pas de faire des symlinks ou d'utiliser du bind dans le fstab si on veut pouvoir accéder à la partoche de différents endroits (le "/exports" NFSv4, le home de l'utilisateur, ...)... c'est même d'ailleurs indiqué...

Mais confondre "/mnt" et "/media", je trouve ça gênant et potentiellement source de bugs...

Au niveau de l'install d'ubuntu, les partoches autres que tu selectionnes lors du partitionnement sont indiquée pour aller dans /media (alors que ces partoches la seront bien dans le fstab...) Donc a priori, pour ubuntu, tout ce qui n'est pas systeme ubuntu, ca va dans media.

Share this post


Link to post
Share on other sites
c'est obligatoire d'installer les drivers proprio pour faire marcher compiz ou compiz fusion ??

Avec une x1950, à moins de tout faire en 100% software avec le driver vesa ou avec le proto-driver libre qui est en train d'être développé, oui... après à toi de voir si le eye-candy vaut la chandelle de traiter avec l'ignoble fglrx... sinon, attends que le driver libre pour ta carte évolue...

dans /mnt j'ai QUEDALLE !!! :(

Et bien, pour y monter quelque chose que tu références dans le fstab, il faut créer le sous répertoire de montage dans /mnt (en ayant les droits de super-utilisateur)... ça ne va pas se faire tout seul, et justement, c'est une très bonne chose qui évite que des applis sans privilège root aillent mettre n'importe quoi dans un endroit fait pour le montage statique en phase d'init....

Au niveau de l'install d'ubuntu, les partoches autres que tu selectionnes lors du partitionnement sont indiquée pour aller dans /media (alors que ces partoches la seront bien dans le fstab...) Donc a priori, pour ubuntu, tout ce qui n'est pas systeme ubuntu, ca va dans media.

Ce n'est jamais qu'une chose de plus que je déteste dans cette distro... :D:transpi:

Share this post


Link to post
Share on other sites

bon j'ai niqué mon ubuntu...

j'ai joué avec les drivers graphiques pour pouvoir activer compiz, et je n'arrive plus à arriver sur le bureau. écran noir au lieu de l'écran de login.

pareil sur mandriva, que j'ai installé pour voir, après avoir fait joujou avec les drivers graphique, même symptomes. exactement la même chose.

soit je règle tout ça en ligne de commande (mais je le sens pas trop), soit je réinstall ubuntu sur une de mes 2 partitions restantes et en allant plus doucement au lieu d'aller trop vite.

mais merde, sur le cd live de mandriva compiz c'était activé tout seul et j'avais des jolis effets...

tiens, je vais rebooter dessus pour voir quels pilotes sont activés pour les effets.

Share this post


Link to post
Share on other sites

Tu m'en veux si je la refais? :

après à toi de voir si le eye-candy vaut la chandelle de traiter avec l'ignoble fglrx

:francais: :francais: :transpi::D

Sinon, à voir si tu ne peux pas éditer le xorg.conf pour spécifier manuellement que tu veux les drivers vesa à la place de fglrx, au moins pour récupérer un clickodrome...

Edit: pour le "comment éditer ce fichier?", soit en accédant à la partoche à partir d'un livecd, soit, si tu te sens warrior (à voir si le ctrl+alt+f1 marche, ie, si ce n'est pas un hard-lock), dans un terminal, "sudo nano /etc/X11/xorg.conf" (ctrl+x pour quitter, ctrl+s pour sauvegarder)...

Share this post


Link to post
Share on other sites
bon j'ai niqué mon ubuntu...

j'ai joué avec les drivers graphiques pour pouvoir activer compiz, et je n'arrive plus à arriver sur le bureau. écran noir au lieu de l'écran de login.

pareil sur mandriva, que j'ai installé pour voir, après avoir fait joujou avec les drivers graphique, même symptomes. exactement la même chose.

soit je règle tout ça en ligne de commande (mais je le sens pas trop), soit je réinstall ubuntu sur une de mes 2 partitions restantes et en allant plus doucement au lieu d'aller trop vite.

mais merde, sur le cd live de mandriva compiz c'était activé tout seul et j'avais des jolis effets...

tiens, je vais rebooter dessus pour voir quels pilotes sont activés pour les effets.

Une idée serait de piquer le /etc/X11/xorg.conf du liveCD et le foutre dans le /etc/X11/ de ton ubuntu qui ne fonctionne plus.

Par contre fait une copie du xorg.conf de ton ubuntu pété avant :) (au cas ou. Les backup, c bon, mangez en :transpi:)

Bon courage en tout cas. Vivement que Ati libère ses pilotes. Parce que si les serveurs X sont souvent en rade, c'est souvent que les gens veulent de la 3D ou de l'acceleration matérielle avec tous les trucs du genre compiz...

Tu installes une ubuntu sur un chipset intel dont le pilote est opensource, y'a pas de xorg a modifier. Tout marche impec sans rien faire, c'est un vrai plaisir :)

Share this post


Link to post
Share on other sites
Vivement que Ati libère ses pilotes

Il y a peu de chances que ça arrive... apparemment, ça semble tellement foutré de violations de brevets en tout genre qu'on ne doit pas attendre plus que des specs... et d'un autre côté, tant mieux: vaut peut-être mieux que les devs se tapent des drivers à écrire from scratch plutôt que de tenter de débugguer fglrx, même avec de la doc...

... ceci dit, ça avance... le nouveau driver pour les X1xxx et X2xxx est passé en 1.0, ce qui signifie que le support 2D est censé être fonctionnel (même si ça reste de la version de développement)... il supporte apparemment les derniers Xrandr (ce qui est quand même très pratique)... et un dev de driver libre radeon a été embauché pour accélérer la libération des spécifications...

Share this post


Link to post
Share on other sites
Vivement que Ati libère ses pilotes

Il y a peu de chances que ça arrive... apparemment, ça semble tellement foutré de violations de brevets en tout genre qu'on ne doit pas attendre plus que des specs... et d'un autre côté, tant mieux: vaut peut-être mieux que les devs se tapent des drivers à écrire from scratch plutôt que de tenter de débugguer fglrx, même avec de la doc...

... ceci dit, ça avance... le nouveau driver pour les X1xxx et X2xxx est passé en 1.0, ce qui signifie que le support 2D est censé être fonctionnel (même si ça reste de la version de développement)... il supporte apparemment les derniers Xrandr (ce qui est quand même très pratique)... et un dev de driver libre radeon a été embauché pour accélérer la libération des spécifications...

que ca soit libération des pilotes et des specs, je m'en fous, tant que l'un des deux est libre. Et je suis assez d'accord avec toi ^^ Vaut mieux des specs libres et sympa que des pilotes mauvais mais libre. (non non, je ne pense pas aux drivers ralink ^^)

Share this post


Link to post
Share on other sites
Pour compiz, ne faut-il pas installer xserver-xgl?

Chez moi, ça ne fonctionne pas sans qu'il soit installé et qu'il ait introduit sa petit ligne dans xorg.conf + restart de X.

Hmmm en effet, c'est vrai que ati c pas trop ca de base ... Mais il me semble que les derniers pilotes n'ont plus besoin de XGL vu qu'ils implémentent AIGlx. Normalement ca devrait fonctionner de base.

Sauf que le paquet xorg-driver-fglrx proposé dans les dépôts est toujours le pilote 8.37.6, qui date méchamment. :transpi:

Share this post


Link to post
Share on other sites

j'ai réinstallé mandriva proprement et j'arrete de faire le con avec mon ATI...

je réinstallerai ubuntu plus tard.

la différence entre les deux, à part la gestion des packets... c'est quoi ?

maintenant, place à la virtualisation...

Share this post


Link to post
Share on other sites
j'ai réinstallé mandriva proprement et j'arrete de faire le con avec mon ATI...

je réinstallerai ubuntu plus tard.

la différence entre les deux, à part la gestion des packets... c'est quoi ?

maintenant, place à la virtualisation...

gestion des paquets differentes, gestion des services differentes, gestion de l'administration differente, quantité/qualité des paquets (je ne dis pas que l'une est mieux que l'autre a part en quantitatif, je pense que ubuntu est mieux fourni, mais pas sur. Le qualitatif, c'est plus difficile de juger et je ne connais pas mandriva, mais j'imagine que ca varie d'un paquet a l'autre d'une distrib a l'autre).

En gros, ca fait la meme chose, mais la maniere n'est pas la meme. Si une maniere te plait plus qu'une autre, bingo, garde la :) Par contre, il faut savoir que ca reste des Linux, donc il y'a des normes/standards derriere (POSIX, LSB, ...) ce qui implique que malgré les differences, ca sera tout de meme tres proche. Peut etre qu'un fichier de conf ne sera pas au meme endroit qu'a une autre distrib, ou que telle distrib démarre le service apache avant le service samba, mais ce n'est pas forcément essentiel..

Pour la virtualisation je te conseille virtualbox qui est facile de comprehension et pas mal fonctionnel :)

Share this post


Link to post
Share on other sites

bon, je vais aller voir virtual box.

questions :

1) comment je fais pour avoir les droits en écriture sur tous mes disques ?? je peux pas créer de folder sous mandriva... ni de fichiers. je ne peux que modifier des fichiers existants

2) j'ai lu qu'on pouvait mutualiser les /home entre les différentes distributions installées sur un PC. c'est vraiment recommandé ??

3) si je veux déplacer mon /home, il suffit de déplacer les fichiers, et de modifier le mount vers la bonne partition ??

4) où se situe généralement le fichier qui fait les mount ? (je dois supprimer des lignes, car le gestionnaire de mandriva m'a monté plusieurs fois une partition

5) sous mandriva, j'ai des gressillements quand j'écoute de la musique. est ce que je peux changer de codec pour voir si il y a une différence ? et où puis faire ce changement ?

Share this post


Link to post
Share on other sites
1) comment je fais pour avoir les droits en écriture sur tous mes disques ?? je peux pas créer de folder sous mandriva... ni de fichiers. je ne peux que modifier des fichiers existants

En te tirant une balle dans le pied à bout portant... ie, en te logguant en tant que root, ce qu'on ne fait JAMAIS, quand on n'est pas suicidaire... où alors, tu parles juste des partitions où il y a tes documents? Dis-en nous plus au sujet de quels répertoires il s'agit (où ils sont, à quoi ils te servent, et de quels types de partitions il s'agit)... en outre, si c'est du ntfs, vérifie que tu as bien ntfs-3g d'installé, puisque le driver ntfs du kernel (ntfs-3g se base sur fuse, et est donc en userland, ie pas dans le kernel) n'est pas fait pour écrire dans les partitions mais juste pour les lire...

2) j'ai lu qu'on pouvait mutualiser les /home entre les différentes distributions installées sur un PC. c'est vraiment recommandé ??

Non, pas vraiment... la faute aux fichiers de configuration cachés qui commencent par "." dans ton /home... et surtout aux applis qui ne permettent pas de les dépacer où l'on veut... si sur une distrib tu as un logiciel d'une certaine version, dont les fichiers de conf sont incompatibles avec la version d'une autre distribution, tu vas faire de la boucherie en les mutualisant... à la limite, si tu veux juste partager des documents entre distributions, crée de la partition (ou utilise un disque dédié) pour ça... tu auras moins d'emmerdes.

3) si je veux déplacer mon /home, il suffit de déplacer les fichiers, et de modifier le mount vers la bonne partition ??

Qu'entends-tu par "déplacer mon /home"?

4) où se situe généralement le fichier qui fait les mount ? (je dois supprimer des lignes, car le gestionnaire de mandriva m'a monté plusieurs fois une partition

La configuration des points de montage statiques est dans /etc/fstab, et il y a un script d'init pour ça, bien souvent dans /etc/init.d (mais ça peut dépendre des distros)... M'enfin, tu n'as a priori à traiter qu'avec le fstab...

Share this post


Link to post
Share on other sites
1) comment je fais pour avoir les droits en écriture sur tous mes disques ?? je peux pas créer de folder sous mandriva... ni de fichiers. je ne peux que modifier des fichiers existants

En te tirant une balle dans le pied à bout portant... ie, en te logguant en tant que root, ce qu'on ne fait JAMAIS, quand on n'est pas suicidaire... où alors, tu parles juste des partitions où il y a tes documents? Dis-en nous plus au sujet de quels répertoires il s'agit (où ils sont, à quoi ils te servent, et de quels types de partitions il s'agit)... en outre, si c'est du ntfs, vérifie que tu as bien ntfs-3g d'installé, puisque le driver ntfs du kernel (ntfs-3g se base sur fuse, et est donc en userland, ie pas dans le kernel) n'est pas fait pour écrire dans les partitions mais juste pour les lire...

oui, mes deux disques de données...

sous mandriva, par défaut je ne peux rien faire, alors que sous ubuntu par défaut j'ai accès. bon j'étudierai la chose plus en détail demain.

sinon une autre question : pour faire un backup de ma partition ubuntu, je peux me contenter de démarrer mandriva et faire un copier coller de la partition ubuntu sur une partition vierge ?? les fichiers cachés se copieront--ls ?

merci encore, je suis presque converti.

Share this post


Link to post
Share on other sites
oui, mes deux disques de données...

sous mandriva, par défaut je ne peux rien faire, alors que sous ubuntu par défaut j'ai accès. bon j'étudierai la chose plus en détail demain.

Désolé de ne pas répondre directement, mais ce sont bien des partitions ntfs?

Si oui, vérifie que ntfs-3g est bien installé... il faudrait aussi voir si elles sont montées avec l'accès en écriture... tu passes par le fstab, pour les gérer? Auquel cas, lâche-nous ton fstab... autrement, essaye aussi de jeter un coup d'oeil aux options umask et dmask de ntfs-3g: peut-être que ta distro utilise de l'umask bizarre pour ces partoches :transpi:

... sinon, probablement un problème d'uid (l'identifiant numérique qui caractérise les différents utilisateurs): mais avant de te conseiller un "chown -r" du répertoire où sont montées tes partoches, vu que ntfs ne gère pas directement les permissions unixiennes, il vaut mieux savoir si ce sont des ntfs, et si la gestion du ntfs (driver utilisé et montage) est correcte...

sinon une autre question : pour faire un backup de ma partition ubuntu, je peux me contenter de démarrer mandriva et faire un copier coller de la partition ubuntu sur une partition vierge ?? les fichiers cachés se copieront--ls ?

Non... tu va foutre en l'air les permissions sur tes partitions, si tu les copies en tant qu'utilisateur normal... d'autant qu'il y a certains trucs qui vont être zappés, vu que seul root peut y accéder...

Il vaut mieux utiliser diverses et variées méthodes comme le recours à dd, tar, ou d'autres sûrement plus user-friendly qui ne m'intéressent ipso facto pas :birthday: ... n'ayant pas mes bookmarks sous la main, je laisse quelqu'un d'autre t'indiquer un tuto... :birthday:

Share this post


Link to post
Share on other sites

bon, mon vieux disque norton ghost 2003 ne fonctionne pas sur ma config actuelle... je sais pas pourquoi.

j'ai DL norton ghost 10 et norton ghost 12 et aucun des deux ne boot sur un système pour sauvegarder ou restaurer des partitions.

à la place j'ai un immonde menu qui me propose diverses options inintéressantes.

comment je fais pour sauvegarder mes partoches en bootant sur un cd ??

une appli bootable à part norton ghost ? je ne veux pas installer norton ghost sur windows, car je dépendrai d'un OS.

je veux pouvoir restaurer même si tout mes OS sont flingués...

merci d'avance. je vais faire une recherche sur le site d'ubuntu

Share this post


Link to post
Share on other sites

×
×
  • Create New...