Jump to content

serveur solaris 8 redhat entreprise 3 jumpstart


Recommended Posts

ah, c'est possible que la connexion en root soit refusée pour des raisàons de sécu (par défaut sur pas mal de serveur)

essaye avec un user, et surtout, lance le service sshd sur la cible :fou:

J'ai fait un ps -e | grep ssh pour reperer si le deamon est lancé ou pas, mais je n'est rien trouvé :chinois::pleure:

Pourtant j'arrive à me connecter en ssh ( sous putty ) au serveur sun :mdr:

heeelp meeeee

Link to post
Share on other sites
  • Replies 68
  • Created
  • Last Reply

et avec putty, tu peux te connecter en sftp ? auquel cas, tu pourrais faire des put et des get pour trimbaler des fichier :reflechis:

Ce que tu dis est tout a fait vrai! par contre , je ne peux pas faire par ftp des commandes tel que dd ou autre. Et moi j'en aurai surement besoin d'ou l'intérêt de ssh. Et je ne veux pas bosser et en ftp et en ssh. C'est la raison pour laquelle je veux pouvoir tout faire en ssh.

met jette plutot un coup d'oeil a ca et dis moi ce que t en pense:

De nos jours, on trouve souvent SSH lancé par le meta-daemon inetd (ou xinetd, plus récent et plus puissant) plutôt que sous forme de daemon autonome.

Donc lorsque tu te connectes sur le port 22 du serveur, le daemon inetd (ou xinetd) voit que SSH est défini pour répondre sur ce port et le lance avec le contexte idoine. Une fois toute connexion finie, SSH sera arrêté.

En tapant la commande ps -e , je vois bien le daemon inetd qui tourne.

Donc si j'ai bien compris , quand je me connecte en ssh sous putty , alors la connexion ssh est reconnue et gérée par inetd . Mais quand j'essaie de lancer la commande ssh pscp , alors inetd ne le prend pas en compte , d'ou le message d'erreur: Fatal : Network error : connexion refused Maintenant ca ne m'explique pas pourquoi est ce que je ne m'identifie pas dans la commande pscp ( sachant que pour copier le fichier .sh j'ai besoin de droits en root et donc du mot de passe que j'ai d'ailleurs ).

thanks

ps: de plus , ca veut dire que je dois telecharger et , installer et lancer sshd ? ( as tu une @ où le dl )

merci lorinc for your help

Link to post
Share on other sites
Je ne pense pas pouvoir installer des logiciels comme ca sur le pc
http://prdownloads.sourceforge.net/winscp/...82.exe?download
Je suis donc bien obligé de passer soit par le mode console ( ms-dos )
Mwahaha
soit par putty
Comme dit plus haut, putty ne permet *PAS* de faire des transferts (sauf avec echo)!
ou meme ssh secure shell client mais je n'arrive pas à me connecter au serveur en ssh avec ce logiciel
Bien sûr que si tu arrives à te connecter au serveur ssh.

Le serveur ssh est sur la machine linux. Putty est un client. Le client se connecte au serveur.

C'est pas plus compliqué que ça.

pscp ip_du_serveur:chemin_du_fichier_sur_le_serveur chemin_repertoire_courant_client
Mais qu'est ce que c'est que cette commande ???
Je pense savoir d'ou vient le problème: pour pouvoir copier ce fichier du serveur , il faut se loguer en root et il y a un mot de passe.
Non, pour pouvoir copier un fichier, il faut avoir les droits en lecture sur le ficheir en question et les droits en écriture sur le dossier destination.
J'ai le mot de passe pour le login root mais dans la synthaxe de la commande pscp , ils n'ont pas prévu ca apparement :inpactitude:
Qu'est ce que pscp ?
Remarque: Pour ce qui est du premier point, la question est : peut on se connecter avec putty en ssh au serveur sans sshd d'installé et de lancé sur ce serveur?
Non, il faut que le sshd tourne pour accepter les connexions...
Sinon , y a t il une commande pour chercher ce daemon?
ps aux | grep --color ssh
et avec putty, tu peux te connecter en sftp ? auquel cas, tu pourrais faire des put et des get pour trimbaler des fichier ;)
Non il faut utiliser filezilla ou winscp pour faire du sftp sous Windows, comme je l'ai dit précédemment.
Et je ne veux pas bosser et en ftp et en ssh. C'est la raison pour laquelle je veux pouvoir tout faire en ssh.
sftp et ftp n'ont rien à voir. sftp c'est du over ssh.
quand j'essaie de lancer la commande ssh pscp
d'où tu sort cette histoire de pscp ?
Link to post
Share on other sites

et avec putty, tu peux te connecter en sftp ? auquel cas, tu pourrais faire des put et des get pour trimbaler des fichier :yes:

bon, mon pb est simple ( à expliquer du moins ...:fou: )

je dois copier des iso ou des packages ( environ 3 gbits ) à distance ( c'est à dire en utilisant mon pc windows ) d'une deuxième machine ( ou du moins d'un hdd ) vers une troisième machine ( mon serveur Jumpstart ) !

et voilà mes questions:

1) à partir de mon pc windows , puis-je le faire avec putty? ou faut -il installer autre chose?

2) si on est dans la configuration de trois machines ( on copie en remote , d'une deuxième machine vers une troisième) comment faire pour copier les iso ou les packages et faut il installer quelque chose sur les différentes machine ( sachant que sur mon pc , il y a putty et que sur le serveur jumpstart , il y a ftpd et inetd qui tournent )

3) si on est dans la configuration deux machines : c'est à dire qu'il y a mon pc windows , mon serveur jumpstart solaris et j 'ai les iso ou packages sur hdd ( à part ) : comment fait-on , une fois qu'on a mis les hdd dans le serveur , pour que solaris puisse les detecter et les prendre en compte .

merci d'avance Lorinc pour ton aide

Link to post
Share on other sites

pourquoi tu passes par un intermédiaire?

tu n'a qu'a passer directement entre les 2 serveurs.....

tu fais un putty sur ton jumpstart.

et ensuite tu copies les fichiers de l'autre serveurs sur celui-la... ;)

Link to post
Share on other sites

pourquoi tu passes par un intermédiaire?

tu n'a qu'a passer directement entre les 2 serveurs.....

tu fais un putty sur ton jumpstart.

et ensuite tu copies les fichiers de l'autre serveurs sur celui-la... :zarb:

Salut Dark 26 ,

Je suis obligé de passer par une machine intermédiaire parce que c'est mon pc de bureau , et que je ne peux accéder ( du moins, je ne le pense pas ) au serveur contenant les isos ou packages. De plus, même si je pouvais , je ne crois pas qu'il y ait de putty dessus, puisque c'est des serveurs qui tournent soit sur des distributions redhat enterprise 3 ou solaris 8 ( et que putty est reservé à windows :-D ) ; du coup, je me connecte en telnet au serveur qui contient les isos , puis je me connecte en ftp à mon serveur Jumpstart 8) ( c'est trop la classe...je sais :transpi: )

voilà

Mais j'ai une question : Je pense que lorsqu'on veut faire un 'get' en ftp avec des dossiers de plus de 2 gbits, il y a un truc à ajouter ( j'ai du le voir dans un man du net , mais je ne m'en souviens plus ) connaitrais tu le petit plus à ajouter à get pour que ça marche?

de plus, quand j'essaie de monter mon lecteur cd-rom sur mon serveur sunOS 5.8 ( Solaris 8 ) :

1) Je definis un point de montage : mkdir -p /mnt/copie

2) Je monte le lecteur de cd-rom : mount -t iso9660 /dev/cdrom /mnt/copie

Alors , ça me crée bien un repertoire copie ( rien de bien spécial jusque la :mdr: )

Mais là où ça marche pas , c'est au niveau de la ligne de commande avec le mount .

Quand j'execute, il me sors la syntaxe du mount en me disant que le mount est utilisable uniquement avec l'option 'v'

I need help :kill:

Link to post
Share on other sites

pourquoi tu passes par un intermédiaire?

tu n'a qu'a passer directement entre les 2 serveurs.....

tu fais un putty sur ton jumpstart.

et ensuite tu copies les fichiers de l'autre serveurs sur celui-la... ;)

Salut Dark 26 ,

Je suis obligé de passer par une machine intermédiaire parce que c'est mon pc de bureau , et que je ne peux accéder ( du moins, je ne le pense pas ) au serveur contenant les isos ou packages. De plus, même si je pouvais , je ne crois pas qu'il y ait de putty dessus, puisque c'est des serveurs qui tournent soit sur des distributions redhat enterprise 3 ou solaris 8 ( et que putty est reservé à windows :-D ) ; du coup, je me connecte en telnet au serveur qui contient les isos , puis je me connecte en ftp à mon serveur Jumpstart 8) ( c'est trop la classe...je sais :zarb: )

voilà

Mais j'ai une question : Je pense que lorsqu'on veut faire un 'get' en ftp avec des dossiers de plus de 2 gbits, il y a un truc à ajouter ( j'ai du le voir dans un man du net , mais je ne m'en souviens plus ) connaitrais tu le petit plus à ajouter à get pour que ça marche?

de plus, quand j'essaie de monter mon lecteur cd-rom sur mon serveur sunOS 5.8 ( Solaris 8 ) :

1) Je definis un point de montage : mkdir -p /mnt/copie

2) Je monte le lecteur de cd-rom : mount -t iso9660 /dev/cdrom /mnt/copie

Alors , ça me crée bien un repertoire copie ( rien de bien spécial jusque la :smack: )

Mais là où ça marche pas , c'est au niveau de la ligne de commande avec le mount .

Quand j'execute, il me sors la syntaxe du mount en me disant que le mount est utilisable uniquement avec l'option 'v'

I need help :hs:

Petite precision par rapport au petit plus à ajouter à la commande get :)

Alors , d'abord ce n'est pas avec la commande get

mais avec la commande mount , de plus ce n'est pas un petit truc à ajouter mais je pense que c'est plus à titre informatif ( je pense dire une grosse erreur là .... corrigez moi svp )

la commande mount ( tout comme la commande umount d'ailleurs ) est une large file aware utility c'est à dire que c'est une commande qui prend en compte les fichiers dont la taille excède 2gbits ;)

Mais mon soucis , c'est que dans l'explication , ils ajoutent :

The following /usr/sbin utilities are large file aware for cachefs file systems:

cachefslog cachefswssize cfsadmin fsck

mount umount

Je ne comprends pas trop ce qu'ils veulent dire par là ( là ca devient trop technique pour moi ... :( )

Ca voudrait dire que lorsque les fichiers qui depassent 2 gbits ne sont pas de type fichier système cachefs, alors ils ne sont pas pris en compte par les commandes mount et umount ?

Comment faire alors pour monter et démonter des fichiers de plus de 2 gbits ?

Link to post
Share on other sites
quand j'essaie de monter mon lecteur cd-rom sur mon serveur sunOS 5.8 ( Solaris 8 ) :

[...]

2) Je monte le lecteur de cd-rom : mount -t iso9660 /dev/cdrom /mnt/copie

[...]

là où ça marche pas , c'est au niveau de la ligne de commande avec le mount .

Quand j'execute, il me sors la syntaxe du mount en me disant que le mount est utilisable uniquement avec l'option 'v'

La syntaxe de mount sous Solaris 8 est sûrement différente de celle sous GNU/Linux.

la commande mount ( tout comme la commande umount d'ailleurs ) est une large file aware utility c'est à dire que c'est une commande qui prend en compte les fichiers dont la taille excède 2gbits

Elle peut monter des systèmes de fichiers de plus de 2G (bits?) contenant des fichier des plus de 2G?

Heureusement, sinon ça ferait un peu mal quand même... :transpi:

Perso sous GNU/Linux j'ai jamais eu aucun problème, que ce soit en montant des isos de plus de 2Go (isos de DVD notamment) ou en utilisant des systèmes de fichiers avec de tels fichiers dessus.

Cette discussion des 2G c'est peut-être juste sous Solaris qui est pas top...

Link to post
Share on other sites
quand j'essaie de monter mon lecteur cd-rom sur mon serveur sunOS 5.8 ( Solaris 8 ) :

[...]

2) Je monte le lecteur de cd-rom : mount -t iso9660 /dev/cdrom /mnt/copie

[...]

là où ça marche pas , c'est au niveau de la ligne de commande avec le mount .

Quand j'execute, il me sors la syntaxe du mount en me disant que le mount est utilisable uniquement avec l'option 'v'

La syntaxe de mount sous Solaris 8 est sûrement différente de celle sous GNU/Linux.

la commande mount ( tout comme la commande umount d'ailleurs ) est une large file aware utility c'est à dire que c'est une commande qui prend en compte les fichiers dont la taille excède 2gbits

Elle peut monter des systèmes de fichiers de plus de 2G (bits?) contenant des fichier des plus de 2G?

Heureusement, sinon ça ferait un peu mal quand même... :craint:

Perso sous GNU/Linux j'ai jamais eu aucun problème, que ce soit en montant des isos de plus de 2Go (isos de DVD notamment) ou en utilisant des systèmes de fichiers avec de tels fichiers dessus.

Cette discussion des 2G c'est peut-être juste sous Solaris qui est pas top...

tuXXX tu tombes à point nommé :zarb:

Justement je dois monter un lecteur de dvd et copier son contenu ( fichiers .sh .info .txt ... dont la taille totale tourne autour de 3 Giga ) , peux tu stp me donner la syntaxe pour monter un lecteur dvd et copier le contenu du dvd

peux tu m'etayer les syntaxes par un exemple aussi

merci :copain:

Link to post
Share on other sites

Perso sous GNU/Linux j'ai jamais eu aucun problème, que ce soit en montant des isos de plus de 2Go (isos de DVD notamment) ou en utilisant des systèmes de fichiers avec de tels fichiers dessus.

Cette discussion des 2G c'est peut-être juste sous Solaris qui est pas top...

Oui je crois bien en effet. Sous solaris tu peux monter en largefiles ou nolargefiles (je ne sais pas si c'est pour tous les file systèmes par contre :craint: ). Tu peux le voir une fois monté avec un simple mount. Et lorsque tu dois transférer de gros tar sur un montage en nolargefiles au début ca fait bizar de voir tes transferts s'arréter à 2G :copain:

Link to post
Share on other sites

Perso sous GNU/Linux j'ai jamais eu aucun problème, que ce soit en montant des isos de plus de 2Go (isos de DVD notamment) ou en utilisant des systèmes de fichiers avec de tels fichiers dessus.

Cette discussion des 2G c'est peut-être juste sous Solaris qui est pas top...

Oui je crois bien en effet. Sous solaris tu peux monter en largefiles ou nolargefiles (je ne sais pas si c'est pour tous les file systèmes par contre :fumer: ). Tu peux le voir une fois monté avec un simple mount. Et lorsque tu dois transférer de gros tar sur un montage en nolargefiles au début ca fait bizar de voir tes transferts s'arréter à 2G :transpi:

:yes: s'arrêter à 2 giga ?????? Heureusement que j'ai pas encore testé , sinon j'aurai pété les plombs ;)

Que faut-il faire alors ? comment sait-on qu'un montage est en nolargefile et qu'un montage est en largefile?

et comment faire pour qu'un montage soit en largefile?

ps: c'est quoi la différence entre file system et system tout cours? ;)

mici boucou :yes:

Link to post
Share on other sites
Cette discussion des 2G c'est peut-être juste sous Solaris qui est pas top...
Ça ne veux rien dire solaris n'est pas top...

Si c'est un problème inhérent à Solaris 8 (ce dont je doute) il faut se rappeller que c'est pas un OS de toute première jeunesse (sortit en 2000).

Solaris 10 et opensolaris ont le ZFS, le fs qui supporte les plus grosses partoches / fichier.

Link to post
Share on other sites

Mais de toute manière le problème de la limitation des 2G n'en est pas un: c'est un choix fait lors du montage pour avoir plus de perf je crois (inodes plus petites?). Rien n'empèche à ma connaissance de mettre plus.

Link to post
Share on other sites
Cette discussion des 2G c'est peut-être juste sous Solaris qui est pas top...
Ça ne veux rien dire solaris n'est pas top...

Si c'est un problème inhérent à Solaris 8 (ce dont je doute) il faut se rappeller que c'est pas un OS de toute première jeunesse (sortit en 2000).

Solaris 10 et opensolaris ont le ZFS, le fs qui supporte les plus grosses partoches / fichier.

J'ai un petit souci avec la commande mount, je t'envoie le message et la commande d'erreur ( il parait que les syntaxes dépendent des distributions :lock: )

voila la commande et le message d'erreur qui va avec:

# mount -t iso9660 /dev/cdrom mnt/copie

mount: illegal option -- t

Usage:

mount [-v | -p]

mount [-F FSType] [-V] [current_options] [-o specific_options]

{special | mount_point}

mount [-F FSType] [-V] [current_options] [-o specific_options]

special mount_point

mount -a [-F FSType ] [-V] [current_options] [-o specific_options]

[mount_point ...]

#

ps: >le point de montage est le repertoire /mnt/copie

>sachant que le montage a pour but de monter le lecteur de cdrom qui contient le cd que je veux stocker sur mon serveur jumpstart ( avec la commande dd ).

>Si tu as compris le problème et la syntaxe en anglais , peux tu me donner un exemple concret de syntaxe.

merci

Link to post
Share on other sites

uname -a

pour connaitre ta version de Solaris (SunOs en fait).

D'après le message pour préciser un fs, c'est -F et pas -t.

Sinon man mount dans la solaris et pas depuis un nux.

Tu ne devineras jamais ce que j'ai découvert !!!!

/dev/cdrom n'existe pas dans mon serveur

Alors il y a bien un repertoire /cdrom ( à la racine donc ) mais il est vide

Je ne comprends plus rien

Est il possible qu'il n ait aucun repertoire qui corresponde au lecteur cd ( et dvd ) de mon serveur ???

Là je crois que je nage en haute mer

please , i need backup

Link to post
Share on other sites

Si tu mets une galette dans le cd, ça le montera automatiquement dans /cdrom.

Au Fait , on m'a dit que le repertoire corespondant au lecteur cdrom sous solaris ( puisque mon serveur jumpstart tourne sous solaris 8 ) était <ital>/cdrom</ital> donc j'utilise comme device <ital>/cdrom</ital> et lorsque j'utilise les lignes de commande suivantes, ca donne les messages d'erreur suivants:

1)# mount /cdrom /mnt/copie

mount: /cdrom not a block device

2)# mount -F iso9660 /cdrom /mnt/copie

mount: operation not applicable to FSType iso9660

3)# mount -rF hsfs /dev/sr0 /cdrom

mount: /dev/sr0 is already mounted, /cdrom is busy,

or allowable number of mount points exceeded

PS:Je sens que ça pas être de la tarte de monter ce lecteur :(

J'espère me tromper.

please help

Link to post
Share on other sites

Non non, ce n'est pas ça que je t'ai dit.

1/ Mettre le lecteur dans le CD

2/ ls /cdrom

Et c'est tout !

Il y a un automount (tu le vera en faisant mount sans arguments en ligne de commande).

Donne moi le résultat de

mount
uname -a

1)# mount /cdrom /mnt/copie

mount: /cdrom not a block device

Normal, cdrom c'est un dossier, pas un block device. La commande ne va pas.
mount -F iso9660 /cdrom /mnt/copie

mount: operation not applicable to FSType iso9660

Pareil.

D'autant plus que les CD Sun ne sont pas iso9660 il me semble (à confirmer).

# mount -rF hsfs /dev/sr0 /cdrom

mount: /dev/sr0 is already mounted, /cdrom is busy,

or allowable number of mount points exceeded

Ça ça me parrait bon ( quoi que je suis surpris que ton lecteur CD soit identifié en /dev/sr0).

Sauf que /dev/sr0 est DEJA monté. Et que /cdrom est déja un point de montage.

Donc tu n'as pas à utiliser mount.

PS:Je sens que ça pas être de la tarte de monter ce lecteur :(
Bah pourtant... ce n'est pas compilqué.
Link to post
Share on other sites

Non non, ce n'est pas ça que je t'ai dit.

1/ Mettre le lecteur dans le CD

2/ ls /cdrom

Et c'est tout !

Il y a un automount (tu le vera en faisant mount sans arguments en ligne de commande).

Donne moi le résultat de

mount
uname -a

1)# mount /cdrom /mnt/copie

mount: /cdrom not a block device

Normal, cdrom c'est un dossier, pas un block device. La commande ne va pas.
mount -F iso9660 /cdrom /mnt/copie

mount: operation not applicable to FSType iso9660

Pareil.

D'autant plus que les CD Sun ne sont pas iso9660 il me semble (à confirmer).

# mount -rF hsfs /dev/sr0 /cdrom

mount: /dev/sr0 is already mounted, /cdrom is busy,

or allowable number of mount points exceeded

Ça ça me parrait bon ( quoi que je suis surpris que ton lecteur CD soit identifié en /dev/sr0).

Sauf que /dev/sr0 est DEJA monté. Et que /cdrom est déja un point de montage.

Donc tu n'as pas à utiliser mount.

PS:Je sens que ça pas être de la tarte de monter ce lecteur :(
Bah pourtant... ce n'est pas compilqué.

J'ai fait les deux commande que tu m'a dit et voila ce que ca donne pour mount :

# mount

/ on /dev/dsk/c0t0d0s0 read/write/setuid/intr/largefiles/logging/onerror=panic/d

ev=800000 on Mon Jul 31 10:12:41 2006

/proc on /proc read/write/setuid/dev=4300000 on Mon Jul 31 10:12:40 2006

/dev/fd on fd read/write/setuid/dev=43c0000 on Mon Jul 31 10:12:42 2006

/etc/mnttab on mnttab read/write/setuid/dev=44c0000 on Mon Jul 31 10:13:02 2006

/var/run on swap read/write/setuid/dev=1 on Mon Jul 31 10:13:02 2006

/tmp on swap read/write/setuid/dev=2 on Mon Jul 31 10:13:06 2006

/home on /dev/dsk/c0t1d0s0 read/write/nosuid/intr/largefiles/logging/onerror=pan

ic/dev=800008 on Mon Jul 31 10:13:06 2006

/backup on /dev/dsk/c0t0d0s5 read/write/setuid/intr/largefiles/logging/onerror=p

anic/dev=800005 on Mon Jul 31 10:13:06 2006

/export/masters on /dev/md/dsk/d10 read/write/setuid/intr/largefiles/onerror=pan

ic/dev=154000a on Mon Jul 31 10:13:06 2006

/cdrom/050810_0911 on /vol/dev/dsk/c1t6d0/050810_0911 read only/nosuid/maplcase/

noglobal/rr/traildot/dev=16c0005 on Thu Aug 3 09:14:27 2006

Et voila ce que ca donne pour le uname -a

# uname -a

SunOS jumpstart1 5.8 Generic_108528-13 sun4u sparc SUNW,Ultra-4

Voila , Théocrite.

Que penses tu de tout ca

ps: j'espere , que dans le lot , je ne t'ai pas donné d'information confidentielle :francais:

Link to post
Share on other sites
J'ai fait les deux commande que tu m'a dit
Manque la plus importante :

ls /cdrom

/cdrom/050810_0911 on /vol/dev/dsk/c1t6d0/050810_0911 read only/nosuid/maplcase/
Bah il est monté ton CD...
Link to post
Share on other sites
J'ai fait les deux commande que tu m'a dit
Manque la plus importante :

ls /cdrom

/cdrom/050810_0911 on /vol/dev/dsk/c1t6d0/050810_0911 read only/nosuid/maplcase/
Bah il est monté ton CD...

Salut Theocrite :D

1)Manque la plus importante :

ls /cdrom

le mal est réparé: :p

# ls cdrom

050810_0911 cdrom0

2) Oui , il est monté , tu m'as toi même spécifié qu'il y avait un automount sur le cd.

Mais mon soucis , c'est que lorsque je copie le contenu du cd avec la ligne de commande suivante:

dd if=/cdrom of=/mnt/copie/test.iso

ca me donne un test.iso dans /mnt/copie mais il ne pèse que 512 octets au lieu des 650 Mo de données contenus dans le cd :eeek2::yes:

Ce que l'on m'a dit , c'est que pour copier un cdrom sous solaris en utilisant la commande dd , il fallait stopper Volum Management :

/etc/init.d/volmgt stop

le site où l'explication est détaillée : ici

Mais même en faisant cette manip , je retrouve le même resultat : test.iso de 512 octets ;):transpi:

Je trouve tout ca un peu bizarre :yes:

Link to post
Share on other sites

Il ne faut pas faire le dd sur le mount point, mais sur le block device.

Essaye

dd if=/dev/dsk/dsk/c1t6d0/050810_0911 of=/mnt/copie/test.iso

Ensuite pour monter l'iso, c'est

 mout /mnt/copie/test.iso /mnt/iso -o loop

Et je ne pense pas qu'il faille forcément stopper le volume manager.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...