Jump to content

Archived

This topic is now archived and is closed to further replies.

lebarjoe

[Tutorial] Installation pilote Nvidia sur Mandriva

Recommended Posts

Bonsoir tuXXX

La carte, je viens de l'acheter chez LDLC, qd a l'ecran je l'ai depuis 3-4 ans et il a tjrs bien fonctionner sous linux mais a l'epoque j'avais une ati.

Personne n'a une idee pkoi mon affichage deconne??

:D

Share this post


Link to post
Share on other sites

voila mes fps sous glxgears:

48901 frames in 5.0 seconds = 9780.200 FPS

49004 frames in 5.0 seconds = 9800.800 FPS

48811 frames in 5.0 seconds = 9762.200 FPS

48734 frames in 5.0 seconds = 9746.800 FPS

Marche bien ma carte mais bon l'affichage...........

Share this post


Link to post
Share on other sites
Bonsoir tuXXX

La carte, je viens de l'acheter chez LDLC, qd a l'ecran je l'ai depuis 3-4 ans et il a tjrs bien fonctionner sous linux mais a l'epoque j'avais une ati.

Personne n'a une idee pkoi mon affichage deconne??

Carte graphique ou mauvaise configuration...

Et puisque les cartes graphiques récentes n'ont globalement aucun problème d'affichage, je penche pour la config...

Donc sauvegarde du fichier de config du serveur X, reconfig (xorgconfig) et test...

Share this post


Link to post
Share on other sites

bon j'ai commence xorgconfig et puis j'arrive la

You must indicate the horizontal sync range of your monitor. You can either

select one of the predefined ranges below that correspond to industry-

standard monitor types, or give a specific range.

It is VERY IMPORTANT that you do not specify a monitor type with a horizontal

sync range that is beyond the capabilities of your monitor. If in doubt,

choose a conservative setting.

hsync in kHz; monitor type with characteristic modes

1 31.5; Standard VGA, 640x480 @ 60 Hz

2 31.5 - 35.1; Super VGA, 800x600 @ 56 Hz

3 31.5, 35.5; 8514 Compatible, 1024x768 @ 87 Hz interlaced (no 800x600)

4 31.5, 35.15, 35.5; Super VGA, 1024x768 @ 87 Hz interlaced, 800x600 @ 56 Hz

5 31.5 - 37.9; Extended Super VGA, 800x600 @ 60 Hz, 640x480 @ 72 Hz

6 31.5 - 48.5; Non-Interlaced SVGA, 1024x768 @ 60 Hz, 800x600 @ 72 Hz

7 31.5 - 57.0; High Frequency SVGA, 1024x768 @ 70 Hz

8 31.5 - 64.3; Monitor that can do 1280x1024 @ 60 Hz

9 31.5 - 79.0; Monitor that can do 1280x1024 @ 74 Hz

10 31.5 - 82.0; Monitor that can do 1280x1024 @ 76 Hz

11 Enter your own horizontal sync range

moi j'ai envie de mettre la 10 ou alors celle donne par viewsonic 1280*1024 @ 85hz

T'en pense quoi tuXXX

Share this post


Link to post
Share on other sites

met la 10, de toute façon, c'est commenté par défaut je crois

Share this post


Link to post
Share on other sites

Bon j'ai fait xorgconfig et le serveur x ne s'est pas lance.

j'ai garde la conf que je viens de faire.

j'imagine qu'il doit y avoir des logs

tu veux les voir?

Share this post


Link to post
Share on other sites

/var/log/Xorg.0.log

non je veux pas forcément les voir...

Y'a marqué ce qui déconne, normalement.

Share this post


Link to post
Share on other sites

je viens de regarder mes logs et je tombe sur ca:

(EE) No devices detected.

Fatal server error:

no screens found

Ca dit quelque chose a quelqu'un?

Cordialement

Share this post


Link to post
Share on other sites

Bon j'ai refait un xorgconfig avec les options les basiques et mon pb persiste.

Mon image n'est pas nette, legerement decale sur la droite comme une ombre en plus.

je vais commence a regretter windows.

:yes:

Share this post


Link to post
Share on other sites

Essaye peut-être de changer la fréquence de rafraichissement (y'a des utilitaires sous gnome et kde, sinon utilises xrandr)

Share this post


Link to post
Share on other sites

je viens de taper xrandr sous ma console et il me sort aucun affcihage superieur a 1024*768 @85hz.

Il y a bien un pb quelque part, j'ai une geforce 6800 GT et un 19' et je peux pas faire plus que ca :ouioui:

Est ce que le pb pourrait pas venir de la carte car je sais que mon ecran peut supporter plus car je l'ai deja vu tourner avec une ati en 1280*1024.

Cordialement

Share this post


Link to post
Share on other sites

voila les resultat de xrandr:

$ xrandr

SZ: Pixels Physical Refresh

*0 1024 x 768 ( 347mm x 260mm ) *85 75 70 60 87

1 800 x 600 ( 347mm x 260mm ) 85 75 72 70 65 60 56

2 640 x 480 ( 347mm x 260mm ) 85 75 73 60

3 960 x 720 ( 347mm x 260mm ) 75 60

4 928 x 696 ( 347mm x 260mm ) 75 60

5 896 x 672 ( 347mm x 260mm ) 75 60

6 832 x 624 ( 347mm x 260mm ) 75

7 1024 x 480 ( 347mm x 260mm ) 86

8 768 x 576 ( 347mm x 260mm ) 100

9 700 x 525 ( 347mm x 260mm ) 75 60

10 640 x 512 ( 347mm x 260mm ) 85 75 60

11 720 x 400 ( 347mm x 260mm ) 85

12 640 x 400 ( 347mm x 260mm ) 85

13 576 x 432 ( 347mm x 260mm ) 75

14 640 x 350 ( 347mm x 260mm ) 85

15 512 x 384 ( 347mm x 260mm ) 85 75 70 60 87

16 416 x 312 ( 347mm x 260mm ) 75

17 400 x 300 ( 347mm x 260mm ) 85 75 72 60 56

18 320 x 240 ( 347mm x 260mm ) 85 75 73 60

19 320 x 200 ( 347mm x 260mm ) 85

20 320 x 175 ( 347mm x 260mm ) 85

Current rotation - normal

Current reflection - none

Rotations possible - normal

Reflections possible - none

:ouioui:

Share this post


Link to post
Share on other sites

:ouioui: bon en fait me suis trompe pour xrandr.

qd je me suis manuellement en 1280*1024 et que j'ai fait xrandr ce dernier m'a affiche plusieur valeur pour cette resolution, neanmoins mon pb persiste mon image n'est pas nette .

J'ai un leger decalage de l'ombre de chaque mot sur la droite.

Je tourne avec kde, est ce qu'il y aurait une option d'affichage qui permet de corriger ca?

Share this post


Link to post
Share on other sites

ça change rien de changer de fréquence de rafraichissement (xrandr -r xx ou dans kde/gnome) ?

Share this post


Link to post
Share on other sites

Lorsque je me met en 1280*1024 que je mette 60hz ou 70hz ou 85 hz ou 100hz ben c'est pareil j'ai pas une image nette.

De plus j'ai installe ut2004, ca rame, j'ai la moitie des decors affiches, le reste des decors est noir, je comprends rien, avec glxgears j'ai de bon fps.

Cordialement

Share this post


Link to post
Share on other sites

Dans un des tuto pour le jeux tu dis qu'il faut mettre " Option "NvAGP" "1" dans le fichier de conf de X" ca sert a quoi? pkoi la valeur 1?

Merci

Share this post


Link to post
Share on other sites
avec glxgears j'ai de bon fps.

à ce que je me souvient, ça doit faire dans les 12000fps avec une 6800GT

Share this post


Link to post
Share on other sites

De plus de je viens de mettre Option "NvAGP" "3".

Par contre :

$ cat /proc/driver/nvidia/agp/status

Status: Enabled

Driver: AGPGART

AGP Rate: 8x

Fast Writes: Disabled

SBA: Enabled

j'ai fast writes qui est en disable au lieu d'etre en enable.

Normalemnt cela se trouve a /etc/modules.d/nvidia mais je n'ai pas de dossier modules.d

Cordialement

Share this post


Link to post
Share on other sites
à ce que je me souvient, ça doit faire dans les 12000fps avec une 6800GT

Exact, avec ma 6800GT, je suis dans les 12800fps avec glxgears :-D

Share this post


Link to post
Share on other sites
De plus de je viens de mettre Option "NvAGP" "3".

Par contre :

$ cat /proc/driver/nvidia/agp/status

Status: Enabled

Driver: AGPGART

AGP Rate: 8x

Fast Writes: Disabled

SBA: Enabled

j'ai fast writes qui est en disable au lieu d'etre en enable.

Normalemnt cela se trouve a /etc/modules.d/nvidia mais je n'ai pas de dossier modules.d

Cordialement

Dans un terminal en root :

tapes la commandes suivantes :

echo -e "options nvidia NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1" >> /etc/modprobe.conf

(le script le fait)

Share this post


Link to post
Share on other sites

Bonjour a tous,

aloors mon /etc/modules.conf est vide et /etc/modprobe.conf ne contient aucune informations relatives a nvidia.

J'ai installe les drivers nvidia a la main.

Share this post


Link to post
Share on other sites

Bon je viens de reinstaller mandrake 10.1, encore des habitudes de windows :|

j'ai utilise le script de lebarjoe , il a pas marche completement alors j'ai termine a la main.

j'ai fait un test avec glxgears:

59304 frames in 5.0 seconds = 11860.800 FPS

84752 frames in 5.0 seconds = 16950.400 FPS

84613 frames in 5.0 seconds = 16922.600 FPS

84740 frames in 5.0 seconds = 16948.000 FPS

84718 frames in 5.0 seconds = 16943.600 FPS

84718 frames in 5.0 seconds = 16943.600 FPS

84684 frames in 5.0 seconds = 16936.800 FPS

je suis en 1280*1024.

C'est mieux que tout a l'heure

Ensuite:

cat /proc/driver/nvidia/agp/status

Status: Enabled

Driver: AGPGART

AGP Rate: 8x

Fast Writes: Enabled

SBA: Enabled

Par contre j'ai toujours mon pb de rendu 2D a savoir une image pas nette.

Share this post


Link to post
Share on other sites
Bon je viens de reinstaller mandrake 10.1, encore des habitudes de windows :|

j'ai utilise le script de lebarjoe , il a pas marche completement alors j'ai termine a la main.

j'ai fait un test avec glxgears:

59304 frames in 5.0 seconds = 11860.800 FPS

84752 frames in 5.0 seconds = 16950.400 FPS

84613 frames in 5.0 seconds = 16922.600 FPS

84740 frames in 5.0 seconds = 16948.000 FPS

84718 frames in 5.0 seconds = 16943.600 FPS

84718 frames in 5.0 seconds = 16943.600 FPS

84684 frames in 5.0 seconds = 16936.800 FPS

je suis en 1280*1024.

C'est mieux que tout a l'heure

Ensuite:

cat /proc/driver/nvidia/agp/status

Status: Enabled

Driver: AGPGART

AGP Rate: 8x

Fast Writes: Enabled

SBA: Enabled

Par contre j'ai toujours mon pb de rendu 2D a savoir une image pas nette.

Pourquoi le script ne fonctionne pas complètement ?

Qu'est-ce que tu as dû faire de plus ?

Peux-tu me faire un retour, comme ça je corrige mon script si tu veux ?

Share this post


Link to post
Share on other sites

16900 avec une 6800GT !!!!

T'aurai pas caché la fenêtre derrière une autre par hasard ? :|

Share this post


Link to post
Share on other sites

×
×
  • Create New...