Jump to content

Archived

This topic is now archived and is closed to further replies.

lebarjoe

[Tutorial] Installation pilote Nvidia sur Mandriva

Recommended Posts

Désolé pour les temps de réponses, je suis en dual boot et il faut que je laisse tourner des trucs sous win :yes:

Donc, la je viens d'aller voir ma mandrake.

En fait je n'avais betement pas penser à essayer de redemarrer.

Ca a demarré normalement en mode graphique. Alors j'ai essayé glxgears et ça marche !

Mais, il y a un mais ( ca en fait 2 maintenant, ok j'arrete :D ). J'ai essayé les petits jeux fournit avec mdk pour voir la différence et eux rament comme sans les drivers :8 .

Share this post


Link to post
Share on other sites

tu as comparé les scores obtenus sous glxgears avec ceux du topic jeux ??

tu fais combien?

Share this post


Link to post
Share on other sites

Glups ! :cartonrouge:

Je n'avais jamais lu ce topic, je n'avais pas idée des scores.

Bon alors je rectifie : il n'y a rien de bon...170fps.... :naz:

Share this post


Link to post
Share on other sites

Tu as quoi comme carte graphique ?

Peux-tu me faire un retour des commandes suivantes :

cat /etc/modprobe.conf
lsmod |grep nvidia (en root)
grep "GLcore" /etc/X11/xorg.conf
grep "dri" /etc/X11/xorg.conf
grep "glx" /etc/X11/xorg.conf
cat /proc/driver/nvidia/agp/status

Merci.

Share this post


Link to post
Share on other sites

J'ai une geforce 2 mx

donc voila ce que ça dit :

cat /etc/modprobe.conf

alias eth0 forcedeth
alias sound-slot-0 nvaudio
remove snd-intel8x0 /sbin/modprobe --first-time -r --ignore-remove snd-intel8x0
install snd-intel8x0 /sbin/modprobe --first-time --ignore-install snd-intel8x0
install usb-interface /sbin/modprobe ohci-hcd; /sbin/modprobe ehci-hcd; /bin/true
alias eth1 eth1394
alias ieee1394-controller ohci1394
remove nvaudio /sbin/modprobe --first-time -r --ignore-remove nvaudio
install nvaudio /sbin/modprobe --first-time --ignore-install nvaudio

bon là, pas de driver de cg en vue

lsmod |grep nvidia

nvidia-agp              5788  1
agpgart                27752  1 nvidia-agp

grep "GLcore" /etc/X11/xorg.conf et grep "dri" /etc/X11/xorg.conf ne me donnent rien

grep "glx" /etc/X11/xorg.conf

Load "glx" # 3D layer

et enfin, cat /proc/driver/nvidia/agp/status ben /driver est vide

voila

Share this post


Link to post
Share on other sites

Bas pas vraiment... Attends un peu pour l'installation des drivers nvidia. Je suis en train de modifier le script et de l'améliorer.

Share this post


Link to post
Share on other sites

pendant que tu es dans le modif, j'ai une proposition :chinois:

pour pouvoir compiler cedega via le cvs il faut les drivers en version 6111

ca serait cool si tu pouvais faire une version modifiée pour repasser en 6111 le temps de la compile de cedega :byebye:

je le mettrais en lien ici ( http://www.pcinpact.com/forum/index.php?sh...ndpost&p=772963 ) pour aider les gens à compiler cedega via cvs :transpi:

tu pense que c'est possible ?

Share this post


Link to post
Share on other sites

Je vais regarder ça après avoir fini le script pour ATI.

Le script nvidia est déjà pas mal avancé, mais je pense que c'est faisable.

Share this post


Link to post
Share on other sites

Bonjour, je suis donc un nouveau sur le forum, et un gros n00b sur mandrake..

Enfin bref, j'ai voulu installer les driver avec le script, mais ils n'ont pas été installés..

j'ai vérifié dans proc/driver/ ya pas de dossier nvidia... le module n'est donc pas chargé, et j'ai toujour le drivers vesa..

Il faut que j'attende la mise à jour du script ou je peux faire quelque chose ?

Share this post


Link to post
Share on other sites

c'est à dire que si tu donnais un peu plus de détail sur les erreurs renvoyées ça aiderait peut-être ;)

PS : au fait, bienvenue!

Share this post


Link to post
Share on other sites

Tout d'abord,

Voilà mon "modprobe.preload" :

# /etc/modprobe.preload: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line.  Comments begin with
# a `#', and everything on the line after them are ignored.
# this file is for module-init-tools (kernel 2.5 and above) ONLY
# for old kernel use /etc/modules

amd64-agp
amd64-agp
nvidia

Déjà, c'est normal que j'ai deux fois "amd64-agp" ? ( j'ai la version 32bits de linux..)

Après j'ai fais "lsmod |grep -w nvidia" , la commande ne donne rien, donc j'ai mis lsmod et la pas de nvidia..

La commande "modprobe -r nvidia && modprobe nvidia && init5" ne fais rien non plus

Je suis un gros noob, peut etre que je ne tape pas correctement les commandes... :oops:

Après dans le "X86Config" j'ai pas de ligne nvidia, mais toujour le "vesa" et mandrake me dit que la commande "nano" n'existe pas.. alors je ne peux pas modifier le fichier...

En appuyant un peu sur toutes les touches, je suis arriver à pouvoir modifier la ligne, mais je ne suis pas arrivé à sortir du mode édition ou les commandes sont coloriés..

J'étais arrivé à voir un truc du genre "FATAL: couldn't opens nvidia module" ou un truc qui y ressemble..

Dsl de mes explications peut précises..

[edit] j'ai oublier de dire que dans "/proc/driver", je n'ai rien pour nvidia.. donc quand je tape la commande "cat /proc/driver/nvidia/agp/status" il me met qu'aucun dossier n'existe, ce qui est normal..

C'est parce que le driver ne s'est pas installé que ça me fait tt ça :keskidit:

Share this post


Link to post
Share on other sites

bon, étant donné que le script de lebarjoe est beaucoup moins avancé que celui pour ATI (et c'est normal, puisque normalement personne ne galère avec nvidia...), je crois que t'es bon pour :

- soit attendre

- soit le faire à la main.

pour le faire à la main, c'est pas dur:

1) tu télécharge les derniers dirvers sur le site de NVidia.

2) tu passe dans une console (Ctrl+Alt+F1) et tu te logue en root

3) tu stoppes l'interface graphique : service dm stop

4) tu vire les modules du noyau relatifs à la video de la memoire :

rmmod nvidia

rmmod amd64-agp

rmmod agpgart

5) tu lance l'installeur de NVidia : ./NVidia-truc-machin (et si ça marche pas, vérifies les droits en execution dessus : chmod +x NVidia-truc)

6) tu édites ton /etc/X11/xorg.conf (avec vi)

tu remplaces à la ligne drivers dans la section Devices le "nv" ou "vesa" par "nvidia"

tu sauvegarde en quittant ( échap puis :wq puis entrée -- il y a un excellent tuto sur vi dans les meilleurs liens, je te le conseille vivement)

7) tu reload les bon modules:

modprobe agpgart

modprobe amd64-agp

modprobe nvidia

:oops: tu relance l'inteface graphique

services dm start

et si ça ne marche pas, je veux bien toutes les erreurs que ça te sort :keskidit:

Share this post


Link to post
Share on other sites

J'ai essayé, 5minutes au total pour tt installer...

Merci de votre aide :)

Par contre j'ai eu quand mee un problème : il ne voulait pa me stoper les modules, amd64-agp était sois disant en utilisation(bien qu'il n'y est aucune raison), agpgart lui disait kil ne pouvait pas s'arréter car il est avec amd64...

Enfin bon, tt a quand même marché et au redémarrage graphique, un logo nvidia s'est affiché et now je lag plus sous super tux en open gl LOL

Jm'en vais essayer de mettre des jeux.. et peut être laisser windows une bonne fois pour toute :)

Share this post


Link to post
Share on other sites

à la limite, pour les modules agp, ce n'est pas grave, car ce seront les même qui seront reloadés.

Share this post


Link to post
Share on other sites

Heu j'ai un probleme avec ce script :

Quand je vérifie que si les pilots sont bien installé via cette commande : cat /proc/driver/nvidia/agp/status

Il me retourne ça :

Status: Disabled

Faut il que j'édite ce fichier ? ou il y a un aute probleme ?

Share this post


Link to post
Share on other sites
Heu j'ai un probleme avec ce script :

Quand je vérifie que si les pilots sont bien installé via cette commande : cat /proc/driver/nvidia/agp/status

Il me retourne ça :

Status: Disabled

Faut il que j'édite ce fichier ? ou il y a un aute probleme ?

ça c'est juste le status de la gestion de l'AGP du driver nvidia...

pour le driver, c'est /proc/driver/nvidia/cards/0

Share this post


Link to post
Share on other sites
pendant que tu es dans le modif, j'ai une proposition  :zarb:

pour pouvoir compiler cedega via le cvs il faut les drivers en version 6111

ca serait cool si tu pouvais faire une version modifiée pour repasser en 6111 le temps de la compile de cedega ;)

je le mettrais en lien ici ( http://www.pcinpact.com/forum/index.php?sh...ndpost&p=772963 ) pour aider les gens à compiler cedega via cvs ;)

tu pense que c'est possible ?

J'ai trouvé un pacth pour les drivers 66.29 pour pouvoir compiler cvscedega.

Donc cela sera inclus dans le nouveau script.

Pour info :

Confirmation de ton info Duke : Wiki cvscedega + nvidia 66.29

Patch 66.29 : Patch pour nvidia 66.29 pour compiler cvscedega

Share this post


Link to post
Share on other sites

Salut,

pouvez vous me dire comment modifier le .sh pour ajouter la configuration de twinview, le texte du genre (dans XF86CONFIG) :

Otion "TwinView" "true"

Option "MetaModes" "1024x768, 1024x768"

Option "SecondMonitorHorizSync" "30-95"

Option "SecondMonitorVertRefresh" "50-160"

Option "TwinViewOrientation" "RightOf"

Option "TwinViewOrientation" "Clone"

Option "NoTwinViewXineramaInfo" "false"

Option "ConnectedMonitor" "CRT, DFP"

Merci d'avance.

Share this post


Link to post
Share on other sites

Bonjour,

pouvez-vous me dire comment ajouter, dans le .sh, les lignes suivantes au fichier x86congig (pour activer dans la foulée le twinview) :

Otion "TwinView" "true"

Option "MetaModes" "1024x768, 1024x768"

Option "SecondMonitorHorizSync" "30-95"

Option "SecondMonitorVertRefresh" "50-160"

Option "TwinViewOrientation" "RightOf"

Option "TwinViewOrientation" "Clone"

Option "NoTwinViewXineramaInfo" "false"

Option "ConnectedMonitor" "CRT, DFP"

Merci d'avance.

Share this post


Link to post
Share on other sites

Avec la commande sed voir un exemple du nouveau script.

http://gentoo.sn41g2.free.fr/scripts/insta...idia_drivers.sh

Exemple :

mv /etc/X11/XF86Config /etc/X11/XF86Config.bak
sed -e "${nvidia_pos}a\    Option \"NoLogo\" \"1\"" \
     -e "${nvidia_pos}a\    Option \"RenderAccel\" \"1\"" \
     -e "${nvidia_pos}a\    Option \"NvAGP\" \"3\"" \
     -e "${nvidia_pos}a\    Option \"AllowGLXWithComposite\" \"1\"" /etc/X11/XF86Config.bak > /etc/X11/XF86Config
rm /etc/X11/XF86Config.bak

Share this post


Link to post
Share on other sites

après avoir testé le script pour les ati, j'ai essayer celui si pour mon autre PC (GF 4600)

tt à marché mais j'ai du lancer 2x le script (1ère fois un telechargement a planté je crois)

Merci aussi pour ce script lebarjoe des scripts :byebye:

Share this post


Link to post
Share on other sites

×
×
  • Create New...