Jump to content

Archived

This topic is now archived and is closed to further replies.

tuXXX

[Tuto][Initié] Configuration de X

Recommended Posts

gnome et kde ont leur propre utilitaire de configuration de clavier... donc en général, ça marche assez bien

Share this post


Link to post
Share on other sites

Pitite question: c'est normal que ma MX700 branchée en USB marche avec /dev/psaux ? (Non pas que ça me dérange mais la curiosité... :incline:)

Share this post


Link to post
Share on other sites

ben c'est une souris, non? tu voulais qu'elle marche en /dev/dsp, peut-être... :incline:

ps : je dis ça, mais j'en sais rien, ça me parait logique, stout

Share this post


Link to post
Share on other sites

Vi, mais je la voyait plutôt en /dev/input/mice ...

(d'ailleurs faudra que j'essaye cette histoire de /dev/psaux > /dev/dsp :incline:)

Share this post


Link to post
Share on other sites
bash-2.05b$ ls -l /dev/input/

total 0

crw-r--r--  1 root root 13, 63 fév  1 13:20 mice

crw-r--r--  1 root root 13, 32 fév  1 13:20 mouse0

et

bash-2.05b$ ls -l /dev/psaux

lrwxrwxrwx  1 root root 10 fév  1 13:20 /dev/psaux -> misc/psaux

si ça peut te rassurer... (j'utilise /dev/psaux)

si tu utilises udev, tu peux regarder le fichier de conf pour voir comment s'effectue le peuplement de ton /dev

Share this post


Link to post
Share on other sites

Bonjour à tous !

J'ai juste une petite question : est-il possible de changer de ServerLayout à chaud (sans redémarer X) comme on peu le faire avec les résolutions d'écrans (XRandR si je ne me trompe).

PS : j'utilise fluxbox et gnome (p-e il existe des logs pour le faire mais google ne m'a pas bcp aider).

Merci d'avance !

Share this post


Link to post
Share on other sites

Bonjour !

J'ai un soucis avec ma Ubuntu fraichement installé ici ...

Je suis coincé en 640x480 et quand je m'efforce de configurer pour du 1280x1024, le serveur X plante au boot, ça marche pas quoi :p

La je vous parle en 640x480, seul choix de resolution quand j vais dans "screen resolution"

Voici pourtant mon xorg.conf :

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
#   sudo dpkg-reconfigure xserver-xorg

Section "Files"
FontPath	"unix/:7100"  	# local font server
# if the local font server has problems, we can fall back on these
FontPath	"/usr/lib/X11/fonts/misc"
FontPath	"/usr/lib/X11/fonts/cyrillic"
FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath	"/usr/lib/X11/fonts/Type1"
FontPath	"/usr/lib/X11/fonts/CID"
FontPath	"/usr/lib/X11/fonts/100dpi"
FontPath	"/usr/lib/X11/fonts/75dpi"
       # paths to defoma fonts
FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load	"bitmap"
Load	"dbe"
Load	"ddc"
Load	"dri"
Load	"extmod"
Load	"freetype"
Load	"glx"
Load	"int10"
Load	"record"
Load	"type1"
Load	"vbe"
EndSection

Section "InputDevice"
Identifier	"Generic Keyboard"
Driver  "keyboard"
Option  "CoreKeyboard"
Option  "XkbRules"	"xorg"
Option  "XkbModel"	"pc105"
Option  "XkbLayout"	"fr-latin9"
EndSection

Section "InputDevice"
Identifier	"Configured Mouse"
Driver  "mouse"
Option  "CorePointer"
Option  "Device"  "/dev/input/mice"
Option  "Protocol"  "ImPS/2"
Option  "Emulate3Buttons"	"true"
Option  "ZAxisMapping"  "4 5"
EndSection

Section "Device"
Identifier	"NVIDIA Corporation NV18 [GeForce4 MX - nForce GPU]"
Driver  "nv"
BusID  "PCI:2:0:0"
EndSection

Section "Monitor"
Identifier	"901B"
Option  "DPMS"
EndSection

Section "Screen"
Identifier	"Default Screen"
Device  "NVIDIA Corporation NV18 [GeForce4 MX - nForce GPU]"
Monitor  "901B"
DefaultDepth	24
SubSection "Display"
 Depth  1
 Modes  "1280x1024" "1024x768"
EndSubSection
SubSection "Display"
 Depth  4
 Modes  "1280x1024" "1024x768"
EndSubSection
SubSection "Display"
 Depth  8
 Modes  "1280x1024" "1024x768"
EndSubSection
SubSection "Display"
 Depth  15
 Modes  "1280x1024" "1024x768"
EndSubSection
SubSection "Display"
 Depth  16
 Modes  "1280x1024" "1024x768"
EndSubSection
SubSection "Display"
 Depth  24
 Modes  "1280x1024" "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier	"Default Layout"
Screen  "Default Screen"
InputDevice	"Generic Keyboard"
InputDevice	"Configured Mouse"
EndSection

Section "DRI"
Mode	0666
EndSection

Quelqu'un pourrait-il m'aide ? :D

Mon écran est bien un LG 901B (19" cathodique) et ma carte video une GeForce 4 MX (IPG nForce2)

Share this post


Link to post
Share on other sites

J'essaie de forcer le 1280x1024 et là il me met comme erreur

(EE) Unable to find a valid framebuffer device

(EE) NV(0) : Failed to open framebuffer device, consult warnings and/or errors above for possible reasons

(EE) Screen(s) found, but none have a usable configuration

Fatel server error :

no screens found

Share this post


Link to post
Share on other sites

J'ai juste besoin d'un serveur X qui marche en 1280x1024x24, avoir des drivers optimisés je m'en fiche :yes:

Chais pas si ça peut aider mais j'ai fait un

apt-get install nvidia-settings

Share this post


Link to post
Share on other sites

Yahoo ! A force de jouer entre mon fichier xorg.conf et celui qui m'a été envoyé hier et après de multiples lectures de logs d'erreur ... miracle :)

Merci à celui qui m'a envoyé son fichier xorg.conf hier (desolé j'ai oublié qui c'etait, c'etait sur #pcinpact-linux

Share this post


Link to post
Share on other sites

L'extension composite c'est bien mais ca devient rapidement le boxon :chinois:

Capture.png

Merci TuxXx pour ton tuto

Par contre je sais pas si ca fait la meme chose chez vous mais des que jactive l'effet d'ombre

xcompmgr -c

et que je j'essais de fermer ma session sur gnome ben ca ne reponds pas et je suis oubligé de

/etc/init.d/xdm stop

, par contre si je kill xcompmgr avant la pas de soucis ca quite gnome, et ca revien sur gdm , et je peux ainsi me relogger normalement

transset is good aussi ;)

Share this post


Link to post
Share on other sites

hop, juste aussi pour dire que composite c'est bon ;)

mais ptit détails :

Personnelement, j'ai du mettre

Section "Extensions"
   Option "Composite" "Enable"
   Option "RENDER" "Enable"
EndSection

dans mon xorg.conf pour que ca fonctionne

Ensuite, dans la section device (carte nvidia) :

Option      "RenderAccel" "true"
Option "AllowGLXWithComposite" "True"

et Option "backingstore" "true" dans la section Screen

Source : http://fr.gentoo-wiki.com/TIP_Xorg_X11_et_transparence

ensuite, un ptit ctrl+alt+backspace et ca marche nickel, avec une superbe fluidité :chinois:

le seul truc, quand je maximise une fenetre, elle prend tout l'ecran et cache les barres de menus gnome ... si quelqu'un à la solution ...

PS : je tourne sous ubuntu, et tous les packages nécessaires à cette manipulation sont dispos avec synaptic

Share this post


Link to post
Share on other sites

j'ai le meme soucis, mon mozilla prends tout l'espace sur l'ecran, il passe par dessus la "barre des taches" en faite..

Si quelqu'un a la soluce je suis aussi preneur

Share this post


Link to post
Share on other sites

a oui, autre chose :

essayez "xcompmgr -c -f", et vous aurez un superbe effet sur les menus :ouioui:

Share this post


Link to post
Share on other sites

Une commande pour lister les fontes:

find /usr/share/fonts -mindepth 1 -maxdepth 1 -type d -exec echo 'FontPath "{}"' ';'

Reste plus qu'à les copier-coller.

(Modifier le début de la commande si chez vous elles se trouvent dans un autre répertoire)

Share this post


Link to post
Share on other sites

bon, j'ai enfin réussi à installer xorg 7.0rc3...

je vous raconte pas la galère... (270 package à unmasker -- portage qui ne sait plus gérer les dépendaces comme il faut...)

bientôt j'aurais finit de mettre le driver r300 total expérimental, et on vera si on peut avoir de la 3D en étant libre :mdr2:

Share this post


Link to post
Share on other sites

Merci pour ce super tuto, ca m'a permis de configurer ma souris :mdr2:

Par contre je bloque au moment ou il faut faire la manip pour que la config se charge au demarrage.

:DConfiguration des souris à 5 boutons

[...]

Il ne reste plus qu'à mettre celà au démarrage de X, et ce sera parfait :

pointer = 1 2 3 6 7 4 5

 $ ln -s /usr/X11R6/lib/X11/xinit/.Xmodmap /etc/X11/Xmodmap

j'essaie de faire un

sudo gedit /usr/X11R6/lib/X11/xinit/.Xmodmap

ca m'ouvre un nouveau fichier ou je mets "pointer = 1 2 3 6 7 4 5"

seulement une fois que je veux enregistrer, ca me dit impossible d'enregistrer le fichier .Xmodmap.

voila, si qqun pouvait m'eclairer un peu plus sur la manip qu'il faut faire.

Merci d'avance.

Share this post


Link to post
Share on other sites

arf, sudo appli graphique, je me permets d'avoir quelques réserves...

soit tu essaye avec un éditeur texte (vim/nano/emacs), soit avec gksudo :byebye:

Share this post


Link to post
Share on other sites

J'ai essayé avec emacs et gksudo, et toujours impossible de faire cette manip, j'arrive pas a creer le fichier.

Share this post


Link to post
Share on other sites

"gksudo gedit" ne marcherais pas ?

pourtant, gksudo marche bien pour plein d'autre truc :reflechis:

Share this post


Link to post
Share on other sites

×
×
  • Create New...