Jump to content

[Tuto][Initié] Configuration de X


tuXXX

Recommended Posts

  • Replies 147
  • Created
  • Last Reply

Bon, j'ai enfin réussi à utiliser "composite", le nouvelle extension de X.org 6.8 !

C'est tout joli et tout, y'a des belles ombres et de la transparence temp réel !

J'expliquerait comment faire quand j'aurai tout fini :chinois:

(franchement, c'est vraiment sympa ce truc, par contre, attention, interdit aux possesseurs de cartes ATI... déjà sous nvidia c'est tendu de faire marcher ça vite, alors sous ATI, c'est quasiment impossible : les drivers fglrx provoquent des bugs visuels un peu partout...)

Link to post
Share on other sites

oki je finis de compiler Perl (oui je suis un peu à la bourre :-D ) je fixe mon pb de grub qui me fait un truc strange :ouioui: je fais les benches pour remy :D et j'essayer ça :yes: et j'arrête de mettre des smileys à la place de la ponctuation :8

Link to post
Share on other sites

ronotudju

Driver "Keyboard"

unable to load driver "Keyboard" !!!

il suffisait de mettre

Driver "keyboard"

j'ai même downgradé en 902 pour voir si ça venait de là :(

:-D:eeek2:

bon ayé maintenant tout va bien, sauf ...

bah que le driver ATI intégré est un peu meilleur que celui de la 6.7 : 340 fps au lieu de 250 à glxgears sans DRI, mais j'arrive pas à activer le DRI ... commence à se faire tard, de toute, là y'a un truc qui marche donc je vas pas me creuser plus :(

Link to post
Share on other sites

pauvre sandeman...il va se faire :-D ....

T'as qu'a pretexter que si vous utiliez windaube, il aurait fallu tout reinstaller sandeman ! Alors que la, juste qq h de compil au pire !!! ( pas sur qu'elle trouve ca mieux ! )

Link to post
Share on other sites

Mais franchement, j'ai vu nulle part que les nouveaux drivers intégrés à X.org (les drm, quoi) étaient 3D...

Ils supportent les 9200, 9600, 9800 et X800, c'est à dire que maintenant, on peut mettre : Driver "radeon" en 2D (au lieu de vesa) et ça rame pas trop (moins que vga/vesa, quoi).

Mais nulle part ils ne parlaient de 3D :-D

En gros, c'est comme les drivers "nv" chez nvidia...

Link to post
Share on other sites

Oui ben apparemment FreeBSD a un avantage en matière de cartes ATI: Le noyau qui gère les modules radeondrm.

J'ai un affichage nickel avec une 9600XT en 1600x1200. Je crois que la seule différence vient de ce module.

? non? Et

pour Lorinc, t'as regardé ce que te donnais la sortie de xorgcfg ?? c'est à dire la tentative automatique de création d'écran? il crée un fichier /root/xorg.conf.new si tu le fais en root dans ton répertoire. (du moins c'est comme ça sous FreeBSD, il lance en fait X -configure tout seul.

Mon fichier xorg.conf.new (sous freeBSD 5.3.beta1): (j'ai retiré les lignes commentées pour plus de lisibilité)

Section "ServerLayout"

Identifier "X.org Configured"

Screen 0 "Screen0" 0 0

InputDevice "Mouse0" "CorePointer"

InputDevice "Keyboard0" "CoreKeyboard"

EndSection

Section "Files"

RgbPath "/usr/X11R6/lib/X11/rgb"

ModulePath "/usr/X11R6/lib/modules"

FontPath "/usr/X11R6/lib/X11/fonts/misc/"

FontPath "/usr/X11R6/lib/X11/fonts/TTF/"

FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"

FontPath "/usr/X11R6/lib/X11/fonts/Type1/"

FontPath "/usr/X11R6/lib/X11/fonts/CID/"

FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"

FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"

EndSection

Section "Module"

Load "extmod"

Load "glx"

Load "dri"

Load "dbe"

Load "record"

Load "xtrap"

Load "speedo"

Load "type1"

Load "freetype"

EndSection

Section "InputDevice"

Identifier "Keyboard0"

Driver "keyboard"

EndSection

Section "InputDevice"

Identifier "Mouse0"

Driver "mouse"

Option "Protocol" "auto"

Option "Device" "/dev/sysmouse"

EndSection

Section "Monitor"

Identifier "Monitor0"

VendorName "___"

ModelName " CT1997PF"

Option "DPMS"

EndSection

Section "Device"

Identifier "Card0"

Driver "ati"

VendorName "ATI Technologies Inc"

BoardName "RV350 AR [Radeon 9600]"

BusID "PCI:1:0:0"

EndSection

Section "Screen"

Identifier "Screen0"

Device "Card0"

Monitor "Monitor0"

SubSection "Display"

Viewport 0 0

Depth 1

EndSubSection

SubSection "Display"

Viewport 0 0

Depth 4

EndSubSection

SubSection "Display"

Viewport 0 0

Depth 8

EndSubSection

SubSection "Display"

Viewport 0 0

Depth 15

EndSubSection

SubSection "Display"

Viewport 0 0

Depth 16

EndSubSection

SubSection "Display"

Viewport 0 0

Depth 24

EndSubSection

EndSection

si ça peut aider???

Link to post
Share on other sites
Identifier "Card0"

Driver "ati"

VendorName "ATI Technologies Inc"

BoardName "RV350 AR [Radeon 9600]"

BusID "PCI:1:0:0"

EndSection

c bizard, ton histoire. en fait, tu utilise les drivers de X pour gerer ta carte et tu as de bonne perf???

(y a moyen de nous faire tourner un glxgears sous BSD pour comparer)

perso, j'utilise les drivers officiel de ATI (closed source) et j'ai des perfs meilleurs qu'avec les drivers open.

mais c clair que si je puvais eviter de teindre mon kernel tout en puvant jouer à ut...

Link to post
Share on other sites

je ferai juste qq corrections cosmétiques

Section "InpuDevice" : clavier et souris => rajoute un t

signale peut-être "grep "^.[EW]" /var/log/X[org|Free86].0.log

pis j'en ai vue une ou deux autres comme ça mais rien de bien chanmé

Link to post
Share on other sites

bon lorinc, j'ai regardé hier, en 2d no problem, en 3d c'est pas ça. (genre 80FPS en fenêtre et 4 en fenetre plein écran 1600x1200) lol.

J'ai regardé sur freedesktop les drivers et les spec et un man radeon

voivi mes réglages:

Section "Module"

Load "dbe"

Load "dri"

Load "extmod"

Load "glx"

Load "record"

Load "xtrap"

Load "freetype"

Load "speedo"

Load "type1"

EndSection

~

~

~

Section "Device"

Option "BusType" "AGP"

Option "AGPFastWrite"

Option "AGPMode" "4"

Option "EnableDepthMoves" celui là semble servir à rien ???

Identifier "Card0"

Driver "ati"

VendorName "ATI Technologies Inc"

BoardName "RV360 [Radeon 9600XT]"

BusID "PCI:1:0:0"

VideoRam 131072

EndSection

Section "dri"

Mode 0666

EndSection

Radeon 9600XT.

Avec ces réglages j'ai:

236 à 240 fps en fenêtre

13 à 20 fps :( en fenêtre plein écran 1600x1200.

c'est toujours pas ça.

l'AGP 8x n'est pas supportée, et il manque pas mal de structures 3D pour que le driver soit interessant en 3D.

Link to post
Share on other sites
je ferai juste qq corrections cosmétiques

Section "InpuDevice" : clavier et souris => rajoute un t

signale peut-être "grep "^.[EW]" /var/log/X[org|Free86].0.log

pis j'en ai vue une ou deux autres comme ça mais rien de bien chanmé

bon, j'ai réparé l'oubli pour InputDevice...

pour le fichier de log, c'est comme un fichier de log normal, avec les mêmes commandes...

Link to post
Share on other sites

Bon ben je sais où est mon problème: AGP pas reconnu, mémoire de la ram : no device found. . j'attends les contributions des nforcistes linuxiens relativement à leur dmesg....:chinois: me permettra de déterminer le module du noyau à rajouter.

Link to post
Share on other sites
  • 1 month later...
:D merci , en fait je l'ai remarqué parce qu'ils ont oublié les config du X sur l'iso de la 5.3-RC1 , alors j'ai cherché sur le net (avec un clavier anglais... :craint: ) et bon j'ai réussi mais à la fin j'ai vu qu'il y avait juste cette ligne à rajouter :D
Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...