Jump to content

Archived

This topic is now archived and is closed to further replies.

tuXXX

[Tuto][Initié] Configuration de X

Recommended Posts

Mais je rêve où je suis très insistant (qui a dit lourd ?) avec ces deux problèmes !!? :incline::incline:

Share this post


Link to post
Share on other sites

Manque un topo sur le xinerama, mais vu que ma voodoo3 2000 PCI ne démarre pas, je peux rien faire :reflechis:

Tu veux que je te le fasse le topo ?

Je raconte quoi ?

comment configurer X pour être en Xinerama, en dualdesktop ? pour supporter 2 cartes, 1 carte dual ?

en cherchant bien je crois avoir déjà tout posté :) je te dis

Share this post


Link to post
Share on other sites

Sandeman tu penses a mon ptit test sous ut2004 si tu as le temps stp ??? :reflechis:

merci !

Share this post


Link to post
Share on other sites

tuXXX>

Topic : essai - tutorial pilote ATI sous Mandrake, dernière modification: 14/08/2004 post #22

tu pourrais aussi rappeler la structure (qui est présentée au début du /var/log)

(==) ServerLayout "XFree86 Configured"

(**) |-->Screen "Screen0" (0)

(**) | |-->Monitor "Monitor0"

(**) | |-->Device "Card0"

(**) |-->Screen "Screen1" (1)

(**) | |-->Monitor "Monitor1"

(**) | |-->Device "Card1"

(**) |-->Input Device "USB Mouse"

(**) |-->Input Device "PS/2 Mouse"

(**) |-->Input Device "Serial Mouse"

(**) |-->Input Device "Keyboard0"

rappeler les expressions régulières

grep "^[EW]" /var/log/XFree86.0.log pour gagner un peu de temps dans la fouille du log

un petit couplet sur Xorg, peut-être - notre Gentoo (qui compile KDE 3.3.0-rc2 comme une ourse ce matin, normalement ;) ayant pris l'orientation Xorg.

Remy> hier madame voulait absolement qu'on regarde les JO et le Western sur M6 ensemble, sorry, mais j'y pense ...

Share this post


Link to post
Share on other sites

remy>

root@gandalf ~ # emerge ut2004-demo

c'est parti je prends de l'avance :)

bonne idée de laisser ma machine allumée ce matin ...

Share this post


Link to post
Share on other sites

Yeah

je pourrais la reformuler moins "débonnaire"

oublies pas le tout petit topo pour les ATIstes :

Section "dri"

Mode 0666

EndSection

(en effet les drivers ATI gère la sécurité sur l'accès au module DRI - qui accède directement à certaines zones mémoire, c'est donc légitime, et l'accès au DRI se configure comme un accès fichier :

Mode 0600 : seul root peut faire du DRI et donc de l'accès natif OpenGL

Mode 0660 : seuls root et les utilisateurs du group dri

Mode 0666 : tout le monde.

Lorsqu'un utilisateur n'a pas accès :

- un message d'erreur apparaît : Xlib: extension "XFree86-DRI" missing on display ":0.0".

et/ou "Reverting to software rendering"

- les perfs OpenGL sont exécrables : 250 fps à glxgears, tuxracer tout saccadé, les screensavers OpenGL au ralenti ...

)

Share this post


Link to post
Share on other sites

voilou...

(ah, ces ati, peuvent pas faire comme tout le monde?)

(d'ailleur, pourquoi y a-t'il besoin du dri sur ati et pas nvidia? je parle pas des droits, mais du <<Load "dri">>)

Share this post


Link to post
Share on other sites

ah, ça, c'est parcequ'ATI utilise le DRM dans le noyau. Il faut donc compiler le DRM.

pour ATI toujours il vaut mieux compiler l'agp-gart en module seulement, et utiliser de préférence celui d'ATI. (quoique, je bench ça ce soir).

Share this post


Link to post
Share on other sites

pour nvidia, c pareil, vaut mieux utiliser le support agp du driver nvidia.

c'est plus rapide ;)

Share this post


Link to post
Share on other sites

Excellent topic :transpi::roll:

Juste un petit probleme

Je suis toujours obliger de rattaper la ligne xmodmap ... malgré que j'ai crée le fichier /etc/X11/Xmodmap :francais:

Share this post


Link to post
Share on other sites
Je suis toujours obliger de rattaper la ligne xmodmap ... malgré que j'ai crée le fichier /etc/X11/Xmodmap :roll:

ouais, c pas très sûr...

à la limite, tu met le xmodmap dans le xinitrc (/etc/X11/xinit/xinitrc) ou celui des users (~/.xinitrc)

...ou en dernier recours, dans le WM (kde et gnome le permettent)

Share this post


Link to post
Share on other sites

j'ai enfin mon interface grafique mais j'ai perdu tt mes terminaux virtuels :'(

je m'explik tant que je boot je voit tt les lignes defiler etc :)

il lance X

enlightenment c good :)

mais si je fait ctrl+alt+F1 la mon ecran se met en mode veille :'(

j'arrive plus a avoir l'affichage des terminaux. je me suis dit que j'avais trop poussé la config en 1600*1200 donc je suis redescendu juska 800*600 mais la je sais plus quoi faire :D

Share this post


Link to post
Share on other sites

Est ce que ta config est oc ?

Est ce que tes parametres de X sont ok ?

Share this post


Link to post
Share on other sites
j'ai enfin mon interface grafique mais j'ai perdu tt mes terminaux virtuels :'(

je m'explik tant que je boot je voit tt les lignes defiler etc :)

il lance X

enlightenment c good :)

mais si je fait ctrl+alt+F1 la mon ecran se met en mode veille :'(

j'arrive plus a avoir l'affichage des terminaux. je me suis dit que j'avais trop poussé la config en 1600*1200 donc je suis redescendu juska 800*600 mais la je sais plus quoi faire :francais:

T'as une ATI?

Share this post


Link to post
Share on other sites

moi j'avais un freeze avec les derniers drivers ATI en passant sur une console, mais c'est passé en changeant de noayau (2.6.3 -> 2.8.1)

par contre j'ai toujours plein d'artefacts...

faut aussi que je fasse un test en utilisant agp du noyau et celui d'ATI (le module, hein...)

Share this post


Link to post
Share on other sites

en general, les artefacts sont du a une frequence GDDR trop haute...

Share this post


Link to post
Share on other sites

2.6.8.1 :transpi:

chez un pote qui avait une 9700, j'ai galéré pour trouver un noyau qui marche bien et qui ne plante pas quand on retourne en console...

on avait finalement trouvé un 2.6.6 qui marchait...mais bon, c un peu relou...trouver le noyau qui va avec le driver :francais:

Share this post


Link to post
Share on other sites

woups, pardon pour la boulette, effectivement, j'ai pas de noyau perso codé par moi même avec 2 n° de version d'avance... :francais:

Share this post


Link to post
Share on other sites
woups, pardon pour la boulette, effectivement, j'ai pas de noyau perso codé par moi même avec 2 n° de version d'avance... :gne:

[un peu off]

Enfin aussi, il nous embrouille, linus, il a fait un 2.6.8.1 et maintenant il sort un 2.6.9-rc1 pour préparer le 2.6.9

Mais c'est le nouveau "development model" donc bon, faut juste un peu s'habituer :fou:

[/un peu off]

Share this post


Link to post
Share on other sites

c'est un copié/collé d'un poste d'un poste par rapport aux ati ,avec une difference par rapport a l'installation .

Sa peut etre interessant pour les ATIste ,on sait jamais :gne:

Moi j'ai utilisé cette methode :

Télécharge les drivers ici -> http://www.schneider-digital.de/html/download_ati.php

cliquer sur /html/download_ati ci ca marche pas.

Récupere et unzip (dans ton home par exemple) les drivers glx1_linux_Xta_version.zip ou ta_version correspond à ta version de ton serveur X.

Tu auras un répertoire Xta_version. 

cd Xta_version

chmod +x check.sh puis ./check.sh pour verifier la version de X.

Avec alien tu transforme le rpm en tgz (alien --to-tgz fglrx-y.z-xxx.rpm). 

Tu untar le fichier obtenu (tar xzvf fglrx-blablabla.tgz). Tu auras les dossiers lib, usr et opt.

Ce rendre dans build_mod cd ./lib/modules/fglrx/build_mod

chmod -x make.sh puis ./make.sh

Ce rendre dans fglrx cd ..

chmod -x make_install.sh puis ./make_install.sh

revenir a la racine de Xta_version et copier :

./usr/X11R6/lib/modules/dri/fglrx_dri.so dans /usr/X11R6/lib/modules/dri/

./usr/X11R6/lib/modules/drivers/fglrx_drv.o dans /usr/X11R6/lib/modules/drivers/

./usr/X11R6/lib/modules/linux/libglxdrm.a dans /usr/X11R6/lib/modules/linux/

modprobe fglrx

fglrxconfig pour configurer ta carte

c'est tout.

Ah si, tout ca en root bien entendu !

Share this post


Link to post
Share on other sites
c'est un copié/collé d'un post par rapport aux ati ,avec une difference par rapport a l'installation .

Sa peut etre interessant pour les ATIste ,on sait jamais :gne:

C'est quoi la différence?

Share this post


Link to post
Share on other sites

×
×
  • Create New...