Jump to content

Archived

This topic is now archived and is closed to further replies.

-rem-

[Debian GNU/Linux] Recompiler son propre noyau

Recommended Posts

Oki merci ...

J'ai modifié le /mnt/hda2/etc/lilo.conf ... mais lorsque je reboot, il ne prend pas les changements en compte :francais: .

Share this post


Link to post
Share on other sites

normal aussi, avec lilo, à chaque changement il faut le renlacner (pour qu'il corrige le mbr) ce dont n'a pas besoin grub :pleure:

Share this post


Link to post
Share on other sites

Arf ... j'avais oublié ...

Mais j'ai encore quelques problèmes ...

Je n'arrive pas à lancer lilo.

En fait il va recherche le /etc/lilo.conf de Knoppix et pas mon /mnt/hda2/etc/lilo.conf.

Sur ce, j'ai essayer de lancer lilo en lui donnant un fichier de configuration défini :

$ lilo -C /mnt/hda2/etc/lilo.conf

mais j'ai un message me disant fatal: creat /boot/map~: read-only file system.

Si je mount boot, j'ai un message me disant qu'il ne le trouve pas dans /etc/fstab ou /etc/mtab. (mais il est déjà mounter ... et puis se n'est pas un périphérique donc ça ne me semble pas très sensé de faire ça :transpi: )

J'ai aussi tester : $ cp /mnt/hda2/etc/lilo.conf /etc/lilo.conf.

Nouveau message d'erreur me disant de nouveau read-only file system ...

Merci d'avance

Share this post


Link to post
Share on other sites

Il suffit de chrooter ton système:

# chroot /mnt/hda2

Ensuite, execute lilo:

lilo

Et après, vire lilo et installe grub.

Share this post


Link to post
Share on other sites
Il suffit de chrooter ton système:

# chroot /mnt/hda2

Ensuite, execute lilo:

lilo

Et après, vire lilo et installe grub.

Hm... Pourquoi je dois chrooter /mnt/hda2 ?

Je n'ai plus de problème avec ça je pense ?

J'ai testé ça :

knoppix@ttyp0[/]$ chroot /mnt/hda2
chroot: cannot change root directory to /mnt/hda2: Operation not permitted
knoppix@ttyp0[/]$ chroot /boot
chroot: cannot change root directory to /boot: Operation not permitted
knoppix@ttyp0[/]$ su
root@ttyp0[/]# chroot /mnt/hda2
chroot: /bin/bash: No such file or directory

Share this post


Link to post
Share on other sites

Tu as dit toi-même que:

"En fait il va recherche le /etc/lilo.conf de Knoppix et pas mon /mnt/hda2/etc/lilo.conf.

"

Le chroot sert justement à te placer dans la racine de ton système d'origine, avec le noyau de la knoppix.

Donc en fait, si tu entres: /bin/toto, il lance effectivement le /bin/toto de ton système sur le disque.

Tu as bien monté le disque sur lequel est installé la racine sur /mnt/hda2?

Si oui, peut-être que /bin/bash n'existe tout simplement pas.

Essaie:

chroot /mnt/hda2 /bin/sh

Normalement, /bin/sh est un symlink vers ton shell, quel qu'il soit.

Share this post


Link to post
Share on other sites

[OFF] Ce serait bien de changer le titre pour qu'il orresponde aux "nouvelles directives" ( :cdmalades: ) [/OFF]

Share this post


Link to post
Share on other sites
[OFF] Ce serait bien de changer le titre pour qu'il orresponde aux "nouvelles directives" ( :cdmalades: ) [/OFF]

:-D

De quoi parles-tu?

Share this post


Link to post
Share on other sites

Voici les problèmes auquels je me heurte :

sh-2.05b# lilo
/dev/mapper/control: open failed: Permission denied
Is device-mapper driver missing from kernel?
/dev/mapper/control: open failed: Permission denied
Is device-mapper driver missing from kernel?
Incompatible libdevmapper 1.00.19-ioctl (2004-07-03)(compat) and kernel driver
Fatal: open /dev/hda: Permission denied
sh-2.05b#

Share this post


Link to post
Share on other sites
Fatal: open /dev/hda: Permission denied

se connecter en root d'abord?

Share this post


Link to post
Share on other sites

En fait je me suis trompé, les deux dernières lignes changent lorsque je me connecte en root avant :

knoppix@ttyp0[/]$ su
root@ttyp0[/]# mount /dev/hda2 /mnt/hda2
root@ttyp0[/]# chroot /mnt/hda2
Knoppix:/# lilo
/dev/mapper/control: open failed: No such device
Is device-mapper driver missing from kernel?
/dev/mapper/control: open failed: No such device
Is device-mapper driver missing from kernel?
Incompatible libdevmapper 1.00.19-ioctl (2004-07-03)(compat) and kernel driver
Warning: '/proc/partitions' does not exist, disk scan bypassed
Fatal: RESTRICTED is only valid if PASSWORD is set.

Désolé :byebye:

Cette question va finir dans le topic "Questions pour un pinguin" si ça continue :yes:

Share this post


Link to post
Share on other sites

Mais c'est normal que ça ne marche pas...

Tu ne peux pas exécuter lilo depuis le chroot car /dev n'est pas le bon (et peut même être vide si c'est devfs/udev), pareil pour /proc...

Share this post


Link to post
Share on other sites
Mais c'est normal que ça ne marche pas...

Tu ne peux pas exécuter lilo depuis le chroot car /dev n'est pas le bon (et peut même être vide si c'est devfs/udev), pareil pour /proc...

Et comment faire pour mettre le bon /dev et le bon /proc, etc ... :roll:

Si tu pouvais me mettre sur une piste ...

Merci

Share this post


Link to post
Share on other sites

pourquoi veux-tu absolument chrooter?

-C config-file

              lilo lit les instructions à propos des  systèmes  à  gérer  dans  un  fichier  de  configuration,  par  défaut

              /etc/lilo.conf.  Cette option permet d'indiquer un autre fichier de configuration.

-r root-directory

              Avant toute chose, effectue un chroot vers le répertoire indiqué. Cette option sert à réparer la configuration

              après avoir booté depuis une disquette de secours.

:roll:

Share this post


Link to post
Share on other sites

Heu ben on me l'a proposé donc j'étais parti sur cette voie la ...

Apparemment l'argument -r chroot aussi ... :transpi:

root@ttyp0[/]# lilo -C /mnt/hda2/etc/lilo.conf -r /mnt/hda2
/mnt/hda2/etc/lilo.conf: no such file or directory

Je ne comprends pas pourquoi il m'affiche cette erreur ...

Le fichier existe bien, et le hda2 est bien monté :-D

Share this post


Link to post
Share on other sites
Heu ben on me l'a proposé donc j'étais parti sur cette voie la ...

Apparemment l'argument -r chroot aussi ... :transpi:

root@ttyp0[/]# lilo -C /mnt/hda2/etc/lilo.conf -r /mnt/hda2
/mnt/hda2/etc/lilo.conf: no such file or directory

Je ne comprends pas pourquoi il m'affiche cette erreur ...

Le fichier existe bien, et le hda2 est bien monté :-D

Puis-ce que tu te retrouves dans le chroot, ce serait plutôt :

# lilo -C /etc/lilo.conf -r /mnt/hda2

Share this post


Link to post
Share on other sites

Juste ... mais dans ce cas j'obtiens ceci :

Fatal: open /dev/hda: Permission denied

Share this post


Link to post
Share on other sites

La même remarque que la dernière fois, connecte-toi en root...

Share this post


Link to post
Share on other sites

Oui, c'est ce que je fais, il me semble :

knoppix@ttyp0[knoppix]$ su
root@ttyp0[knoppix]# cd /
root@ttyp0[/]# cd mnt 
root@ttyp0[mnt]# mount hda2
root@ttyp0[mnt]# ls hda2
bin   cdrom  etc   initrd      lib         media  opt   root  srv  tmp  var
boot  dev    home  initrd.img  lost+found  mnt    proc  sbin  sys  usr  vmlinuz
root@ttyp0[mnt]# chroot /mnt/hda2
Knoppix:/# su


Knoppix:/# lilo -C /etc/lilo.conf
/dev/mapper/control: open failed: Permission denied
Is device-mapper driver missing from kernel?
/dev/mapper/control: open failed: Permission denied
Is device-mapper driver missing from kernel?
Incompatible libdevmapper 1.00.19-ioctl (2004-07-03)(compat) and kernel driver
Fatal: open /dev/hda: Permission denied
Knoppix:/#

Je chroot avant avec le répertoire /mnt/hda2 (c'est ce que va faire le lilo -r rep je pense), je fais su, il me met root (je l'étais déjà), et j'essaie d'exécuter lilo en lui disant quel fichier utiliser ...

Share this post


Link to post
Share on other sites

fait donc un copier/coller de ton /etc/fstab et de ton /etc/lilo.conf pour voir a quoi ca ressemble

Share this post


Link to post
Share on other sites

Voila zaverel >

knoppix@ttyp0[knoppix]$ su
root@ttyp0[knoppix]# cd / && cd /mnt && mount hda2
root@ttyp0[mnt]# chroot /mnt/hda2
Knoppix:/# su
Knoppix:/# ls
bin   cdrom  etc   initrd      lib         media  opt   root  srv  tmp  var
boot  dev    home  initrd.img  lost+found  mnt    proc  sbin  sys  usr  vmlinuz




Knoppix:/# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda2       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda1       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0




Knoppix:/# cat /etc/lilo.conf
# /etc/lilo.conf - See: `lilo(8)' and `lilo.conf(5)',
# ---------------       `install-mbr(8)', `/usr/share/doc/lilo/',
#                       and `/usr/share/doc/mbr/'.

# +---------------------------------------------------------------+
# |                        !! Reminder !!                         |
# |                                                               |
# | Don't forget to run `lilo' after you make changes to this     |
# | conffile, `/boot/bootmess.txt' (if you have created it), or   |
# | install a new kernel.  The computer will most likely fail to  |
# | boot if a kernel-image post-install script or you don't       |
# | remember to run `lilo'.                                       |
# |                                                               |
# +---------------------------------------------------------------+

# Specifies the boot device.  This is where Lilo installs its boot
# block.  It can be either a partition, or the raw device, in which
# case it installs in the MBR, and will overwrite the current MBR.
boot=/dev/hda

# Specifies the device that should be mounted as root. (`/')
#
root=/dev/hda2

# Enable map compaction:
# Tries to merge read requests for adjacent sectors into a single
# read request. This drastically reduces load time and keeps the
# map smaller.  Using `compact' is especially recommended when
# booting from a floppy disk.  It is disabled here by default
# because it doesn't always work.
#
# compact

# Installs the specified file as the new boot sector
# You have the choice between: text, bmp, and menu
# Look in lilo.conf(5) manpage for details
#
#install=menu

# Specifies the location of the map file
#
map=/boot/map

# You can set a password here, and uncomment the `restricted' lines
# in the image definitions below to make it so that a password must
# be typed to boot anything but a default configuration.  If a
# command line is given, other than one specified by an `append'
# statement in `lilo.conf', the password will be required, but a
# standard default boot will not require one.
#
# This will, for instance, prevent anyone with access to the
# console from booting with something like `Linux init=/bin/sh',
# and thus becoming `root' without proper authorization.
#
# Note that if you really need this type of security, you will
# likely also want to use `install-mbr' to reconfigure the MBR
# program, as well as set up your BIOS to disallow booting from
# removable disk or CD-ROM, then put a password on getting into the
# BIOS configuration as well.  Please RTFM `install-mbr(8)'.
#
# password=tatercounter2000

# Specifies the number of deciseconds (0.1 seconds) LILO should
# wait before booting the first image.
#
delay=20

# You can put a customized boot message up if you like.  If you use
# `prompt', and this computer may need to reboot unattended, you
# must specify a `timeout', or it will sit there forever waiting
# for a keypress.  `single-key' goes with the `alias' lines in the
# `image' configurations below.  eg: You can press `1' to boot
# `Linux', `2' to boot `LinuxOLD', if you uncomment the `alias'.
#
#message=/boot/bootmess.txt
       #prompt
       #delay=100
       #timeout=100

# Specifies the VGA text mode at boot time. (normal, extended, ask, <mode>)
#
# vga=ask
# vga=9
#
vga=normal

# Kernel command line options that apply to all installed images go
# here.  See: The `boot-prompt-HOWTO' and `kernel-parameters.txt' in
# the Linux kernel `Documentation' directory.
#
# append=""

# If you used a serial console to install Debian, this option should be
# enabled by default.
# serial=

#
# Boot up Linux by default.
#
#default=Linux

image=/vmlinuz
       label=Linux
       read-only
       restricted
       alias=1

       initrd=/initrd.img

image=/vmlinuz.old
       label=LinuxOLD
       read-only
       optional
       restricted
       alias=2

       initrd=/initrd.img.old


# If you have another OS on this machine to boot, you can uncomment the
# following lines, changing the device name on the `other' line to
# where your other OS' partition is.
#
# other=/dev/hda4
#       label=HURD
#       restricted
#       alias=3
Knoppix:/#


Share this post


Link to post
Share on other sites

Les 2 options :

restricted

alias= *

c'est toi qui les a mis ??

je dirait que ton probleme vient de restricted

Apparament il lui lui manque le mot de passe associé

regarde a "3.3. La sécurité physique

https://www-etud.iro.umontreal.ca/~guedonal...fsec-howto.html

et tu peut aussi faire faire un : man lilo.conf

et voir a mettre le vrai chemin du noyau et non pas passer par un lien symbolique

car sa complique le jeu pour installer plusieur noyau en meme temps.

Surtout que ca doit etre la source de ton probleme quand tu a changer de noyau au lieu d'en rajouter un autre.

image=/boot/vmlinuz-2.6.11-ck7

label="gentoo-ck7"

append="ramdisk_size=20000 devfs=nomount map=/boot/map-2.6.11-ck7"

root=/dev/hda1

initrd=/boot/initrd-2.6.11-ck7.img

read-only

Share this post


Link to post
Share on other sites

×
×
  • Create New...