Jump to content

Archived

This topic is now archived and is closed to further replies.

-rem-

[Debian GNU/Linux] Recompiler son propre noyau

Recommended Posts

Est-ce qu'il faut que je remplace le (hd0,0) ci dessous, par (hd0,5) qui correspond à l'emplacement de ma partition Linux?

Ben normalement, dans grub, il faut mettre 2 choses :

->d'abord où trouver le noyau, etc...

root (hdx,y)

->puis où booter (obligatoire, parce que le noyau peut très bien être sur une partition "/boot"

kernel /boot/kernel-2.x.y root=/dev/hdx

Share this post


Link to post
Share on other sites
Tiens j'ai pas tilte de suite, mais perso ma "/" je prefere l'avoir sur une partoche primaire ( ainsi que /boot ).

Tu as essayer avec les 3 lignes que je t'ai donne ? Au pire, au boot, tu lances une console grub, tu tapes root (hd0, <tab> il devrait te montrer la liste des partitions, ca donne quoi ?

J'ai fait les modif que tu m'as dit et au reboot j'ai:

ERROR 15: File not found

Je reviens donc sur le bootloader et je tape c pour lancer une console grub, à l'appelet Grub> je tape root(hdo, puis touche de tabulation, mais la seule chose que ça me fait, c'est de me renvoyer à la ligne :(

Share this post


Link to post
Share on other sites

Zut!!! j'avais oublié l'espace entre root et (hd0. Alors une fois appuyé sur TAB j'ai:

Possible partition are:

Partition num:0, Filesystem type unknown, partition type 0x7

Partition num:4, Filesystem type unknown, partition type 0x82 (c'est ma partition swap)

Partition num:5, Filesystem type is ext2fs (bizarre j'étais convaincu d'avoir créé une ext3!), partition type 0x83.

Share this post


Link to post
Share on other sites
Partition num:5, Filesystem type is ext2fs (bizarre j'étais convaincu d'avoir créé une ext3!), partition type 0x83.

C'est normal, le ext3, c'est du ext2+journal...

DOnc, ok, tu fait ça...

root (hd0,5)

puis

kernel /boot/<tab>

et tu fait de l'auto-completion comme sous linux...

kernel /boot/kernel-2.6.x root=/dev/hda6

puis tu tape "boot"

Share this post


Link to post
Share on other sites
C'est normal, le ext3, c'est du ext2+journal...

DOnc, ok, tu fait ça...

root (hd0,5)

puis

kernel /boot/<tab>

et tu fait de l'auto-completion comme sous linux...

kernel /boot/kernel-2.6.x root=/dev/hda6

puis tu tape "boot"

Alors, j’ai fait précisément :

grub> root (hd0,5) <ENTREE>

J’obtiens, « filesystem type is ext2s partition type 0x83 », jusque là tout est normal ;

grub> kernel /boot/ <TAB>

Possible files are : vmlinuz-2.4-26-1-386 config-2.4.26-1-386 initrd.img-2.4-26-1-386 System.map-2.4-26-1-386 grub System.map-2.6.7 config-2.6.7 vmlinuz-2.6.7

Je fais donc :

grub> kernel /boot/vmlinuz-2.6.7 root=/dev/hda6

grub> boot

Et j’obtiens comme toujours, le message : Please append a correct “root= » boot option, Kernel panic : VPS : Unable to mount root fs on unknown –block(0,0).

Ce qui semble logique dans la mesure où je n’ai rien fait d’autre que de reproduire ce que j’avais dans /boot/grub/menu.lst, j’ai essayé de refaire pareil mais au lieu de mettre root=/dev/hda6 j’ai mis root=/dev/hda5 et le résultat fut hélas le même

:transpi:

Share this post


Link to post
Share on other sites

Je viens d'avoir la même chose quand j'ai voulu démarrer sous debian...

En fait, moi j'ai mis du reiserfs...et il n'est pas inclus dans le noyau...mais dans l'initrd...

Donc toi c'est peut-être pareil...la système de fichiers n'est pas supporté...

Donc soit c'est le noyau debian et il y a un initrd, soit c'est toi qui a mal configuré..

Share this post


Link to post
Share on other sites
Donc soit c'est le noyau debian et il y a un initrd, soit c'est toi qui a mal configuré..

Je pense pas mettre trompé dans la config vu que j'ai suivi ton tuto presque à la lettre. Admettons que se soit une mauvaise configuration qui soit la cause de mon problème, à quel niveau de la config est-ce que j'aurais pu avoir foiré?

Share this post


Link to post
Share on other sites

Met tous les fs en dur dans le noyau... ainsi que le contrôleur de ta carte mère...

Share this post


Link to post
Share on other sites

Bon ben, je viens de mettre tous mes files system en dure. Dans character device, il n'y a pas le chopset de ma carte mère: le i875P, j'ai qd même mi en module le i865 chipset support. J'ai sauvegardé, compilé et installer l'image , mais au reboot sur le noyau 2.6.7 j'ai tjs le même message indiquant un kernel panic :keskidit:

Share this post


Link to post
Share on other sites

tu peux mettre le msg exact du kernel panic, et les 5 lignes qui le precede stp ? merci

Share this post


Link to post
Share on other sites
Bon ben, je viens de mettre tous mes files system en dure. Dans character device, il n'y a pas le chopset de ma carte mère: le i875P, j'ai qd même mi en module le i865 chipset support. J'ai sauvegardé, compilé et installer l'image , mais au reboot sur le noyau 2.6.7 j'ai tjs le même message indiquant un kernel panic :keskidit:

Mettre le chipset en module, c'est pas une bonne idée...

Si il peut pas utiliser le chipset, il va pas pouvoir booter...

Donc ça sert à rien...

Si tu veux tester des trucs, met en dur...

Share this post


Link to post
Share on other sites
tu peux mettre le msg exact du kernel panic, et les 5 lignes qui le precede stp ? merci

Bien sûr, ça donne:

NET: Registred protocol family 8

NET: Registred protocol family 20

ACPI: (supports S0 S1 S3 S4 S5)

Ensuite c'est plus intéressant:

VFS: Cannot open root device "hda6" or unknown-block(0,0)

Please append a correct “root=" boot option

Kernel panic : VPS : Unable to mount root fs on unknown –block(0,0).

Share this post


Link to post
Share on other sites
Mettre le chipset en module, c'est pas une bonne idée...

Si il peut pas utiliser le chipset, il va pas pouvoir booter...

Donc ça sert à rien...

Si tu veux tester des trucs, met en dur...

Oui, j'ai essayé de le mettre en dure mais j'avais juste la possibilité de le mettre en module ou de pas le mettre du tout.

Share this post


Link to post
Share on other sites

VFS: Cannot open root device "hda6" or unknown-block(0,0)

C'est sur que sans /, ca marche moins bien... C'est bizarre juste hda6 et pas /dev/hda6. cat /etc/fstab stp ?

j'ai essayé de le mettre en dure mais j'avais juste la possibilité de le mettre en module ou de pas le mettre du tout.

C'est parce que la categorie mere etait en module.

Share this post


Link to post
Share on other sites

Effectivement, y a bien un pb....

Proc….. ..…/proc……..… .proc…..…… defaults…....…..0…..……..0

/dev/hda6……/…………..ext3………..defaults, errors=remount-ro….0….1

/dev/hda5.......none..........swap..............sw..............0.............0

/dev/hdc......../media/cdrom0......iso9660 ro-user, noauto......0........0

/dev/hdd......../media/cdrom1......iso9660 ro-user, noauto......0........0

/dev/fd0........ /media/floppy0......auto .....rw,user, noauto......0........0

Désolais, c'est pas du copier-collé, vu que j'ai eu un pb avec ma connection internet sous linux.

Share this post


Link to post
Share on other sites

tu es bien sur que le systeme s'est install sur /dev/hda6 ? Aussi, es tu sur d'avoir activer le support ext3 dans le noyau ?

Share this post


Link to post
Share on other sites
tu es bien sur que le systeme s'est install sur /dev/hda6 ? Aussi, es tu sur d'avoir activer le support ext3 dans le noyau ?

Je suis sûr à 100% que tout ce qui concerne l'ext3 est en dur;

Je viens de vérifier avec un outil de partititionnement et j'ai bien:

hda1: windoz

hda5:swap

hda6:Linux

Share this post


Link to post
Share on other sites

fais voir l'extrait de ton actuel /boot/grub/grub.conf stp... C'est bizarre ton truc.

Share this post


Link to post
Share on other sites
fais voir l'extrait de ton actuel /boot/grub/grub.conf stp... C'est bizarre ton truc.

Je vais essayé, ça va p'têtre prendre un peu de tps vu que j'arrive pas a avoir la connection plus de 30 sec actuellement sous linux.

Share this post


Link to post
Share on other sites

j'arrive pas a avoir la connection plus de 30 sec actuellement sous linux.

pk ??? autre topic si tu veux et que ca le justifie...

Share this post


Link to post
Share on other sites

Voilà le résultat de la commande vi /boot/grub/menu.lst:

# default grub root device

## e.g. groot=(hd0,0)

# groot=(hd0,5)

## should update-grub create alternative automagic

boot options

## e.g. alternative=true

## alternative=false

# alternative=true

## should update-grub lock alternative automagic boot

options

## e.g. lockalternative=true

## lockalternative=false

# lockalternative=false

## altoption boot targets option

## multiple altoptions lines are allowed

## e.g. altoptions=(extra menu suffix) extra boot

options

## altoptions=(recovery mode) single

# altoptions=(recovery mode) single

## controls how many kernels should be put into the

menu.lst

## only counts the first occurence of a kernel, not

the

## alternative kernel options

## e.g. howmany=all

## howmany=7

# howmany=all

## ## End Default Options ##

title Debian GNU/Linux, kernel 2.6.7

root (hd0,5)

kernel /boot/vmlinuz-2.6.7 root=/dev/hda6 ro

savedefault

boot

title Debian GNU/Linux, kernel 2.6.7

(recovery mode)

root (hd0,5)

kernel /boot/vmlinuz-2.6.7 root=/dev/hda6 ro

single

savedefault

boot

title Debian GNU/Linux, kernel 2.4.26-1-386

root (hd0,5)

kernel /boot/vmlinuz-2.4.26-1-386

root=/dev/hda6 ro

initrd /boot/initrd.img-2.4.26-1-386

savedefault

boot

title Debian GNU/Linux, kernel 2.4.26-1-386

(recovery mode)

root (hd0,5)

kernel /boot/vmlinuz-2.4.26-1-386

root=/dev/hda6 ro single

initrd /boot/initrd.img-2.4.26-1-386

savedefault

boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items

below from the Debian

# ones.

title Other operating systems:

root

# This entry automatically added by the Debian

installer for a non-linux OS

# on /dev/hda1

title Windows NT/2000/XP

root (hd0,0)

savedefault

makeactive

chainloader +1

PS: Pour mon pb internet depuis que je viens de faire apt-get update ça semble allé tout seul....

Share this post


Link to post
Share on other sites

Tu devrais essayer comme on t'a dit avec tuxxx, vire "ro" a la fin de la ligne root=, et supprime aussi les 2 lignes qui suivent, inutiles.

Share this post


Link to post
Share on other sites
Tu devrais essayer comme on t'a dit avec tuxxx, vire "ro" a la fin de la ligne root=, et supprime aussi les 2 lignes qui suivent, inutiles.

Oui, c'est ce que j'ai fait, mais au reboot, j'ai toujours le même message de kernel panic :reflechis:

Après avoir valider les changements (:wq) dans /boot/grub/menu.lst, j'ai eu bizarrement (alors que j'étais bien en root) le message:

xlib: connection to ":0.0" refused by server

xlib: No protocol specified

Avant de rebooter sur mon noyau 2.6.7, jai donc fait chmod 755 /boot/grub/menu.lst , puis vi /boot/grub/menu.lst, histoire de voir que mes changements avaient bien était validé (ce qui fut le cas).

Share this post


Link to post
Share on other sites

×
×
  • Create New...