Jump to content
luxian

Firefox 56 - les modules ne modifient plus les menus

Recommended Posts

Bonjour,

Depuis la dernière mise à jour de Firefox 56 x64 pour Windows 10x64, je n'ai plus de modification de menu par mes modules !!
Sous v55, pas de problèmes.
Sous v57b8 dans un linux x64bit, pas de problèmes !

Le module que j'emploie le plus : screengrab est malheureusement impacté ! Mais d'autres greffons aussi, tel "I don't care about cookies".
Ce qui fait que je ne peux plus prendre de screenshot d'une page web en faisant un simple clic droit, vu que.. ben le menu du clic droit n'a pas l'option de screenshot installée par screengrab.

J'ai réinstallé Firefox 55.0.3 x64 ! ..... Et ils réapparaissent !
J'ai fait cette manipulations sur plusieurs PC, avec plusieurs environnements et comptes Firefox et j'ai le même comportement de la part de Firefox .... en v56 : plus de modifications de menus.
Par acquis de conscience, j'ai installé Firefox v57b8 x64 pour Windows ... nada, menu non modifié (et donc maintenant, je tourne sous v55 avec mes menus modifiés). C'est d'autant rageant que la v57b8 sous Linux a bien ses menus modififés.

 

Pour le moment, je suis revenu en v55 :( mais c'est pas glop, Firefox 56 charge plus vite les pages web avec beaucoup d'images.

 

Est-ce pareil chez vous ?

Sauriez-vous pourquoi svp ?

Avez-vous une idée pour corriger ?

 

Merci d'avance.



Dans l'image ci-dessous prises sous FF v55, c'est "I don't care about cookies" et "Screengrab" qui ne sont plus visibles dès que je met à jour (même après désinstallation / réinstallation).

greffons.png

Edited by luxian

Share this post


Link to post
Share on other sites

Bonjour,

Merci de t'être penché sur mon problème.

Ta réponse est vraie ...

Mais elle ne solutionne pas le problème.


"Screengrab" et "I don't care about cookies" ont été l'une des premières à respecter les nouvelles normes d'extensions Firefox v57. Ces deux extensions ne sont pas flaguées "obsolètes".

Plus précisément, screengrab est l'une des extensions qui est le plus souvent modifées .. vu que son auteur se paye en faisant afficher sa page web à chaque installation / mise à jour. Vu son modèle financier, il est dans son intérêt de respecter les normes attendues par Mozilla. Ca fait environ 4 mises à jour que le flag d'obsolescence n'est plus affiché par Firefox pour cette extension.

 

Le problème est donc ailleurs que dans la compatiblité.

 

Est-ce que par hasard, ça donne la même chose chez toi ?

 

obsoletes.PNG

Edited by luxian

Share this post


Link to post
Share on other sites

Petit complément dans ma recherche.

Dans about:config, il y a des options du type : extensions.screenshot.disabled

En les passant à false ou true ... rien n'y fait.

 

Par contre, chose surprenante .... DownThemAll qui est toujours "obsolète" malgré les régulières mises à jour, garde bien la modification du menu entre la v55 et la v56 !!!

Edited by luxian

Share this post


Link to post
Share on other sites

la v57 nécessite une réécriture complète de l'extension pour passer au format webext.

celles comme downthemall sont toujours mises à jour mais pour l'ancien format.

celles qui te posent problèmes sont "hybrides" et peut être fonctionnent mal maintenant dans l'ancien fomat
ou elles sont 100% webext et dans ce cas la version actuelle de firefox ne supporte peut être pas encore toutes les fonctionnalités de webext.

Share this post


Link to post
Share on other sites

C'est bien malin de la part de Firefox de faire une régression sur les fonctionnalités !

Si l'extension est dite "hybride", alors pourquoi n'est-elle pas flaguée comme "obsolète" directement. Il y a duperie ou erreur quelques part.

En sus ... ce que je ne comprend pas...

Pourquoi une extension si "hybride" que ça passerait NICKEL sous la version linux de Firefox 56 à 57b8  et que ça ne passe pas sous Windows x64 ... ??? i.e. : j'ai bien mes menus avec les mêmes extensions !

Edited by luxian

Share this post


Link to post
Share on other sites

Hello,

 

quand on voit le nombre de gens qui se plaignent et les extensions qui sont pas à jour pour webextensions, on se dit que ça va être un peu le bordel pour FF57...
https://addons.mozilla.org/en-US/firefox/addon/screengrab-fix-version/reviews/932808/
https://addons.mozilla.org/en-US/firefox/addon/screengrab-fix-version/?src=search

Concernant Screengrab, l'ancienne version est abandonnée (tjrs le problème de la MAJ pour être compatible webextensions), mais même la nouvelle version semble, d'après les commentaires, ne pas être parfaitement au point...

 

Edited by BTCKnight
Parecque je le veau bien... meuh

Share this post


Link to post
Share on other sites

Oui, la nouvelle version laisse à désirer.

Mais s'il n'y avait que screengrab dont le portage en v57 laissait à désirer ... toutes en fait :(

Allez, hop, retour en v55 qui elle ... marche.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...