Jump to content

connection limitée windows 8.1


styx2

Recommended Posts

Bonjour,

 

je viens d'acheter une tablette mpman pour ma femme, qui voulait absolument windows (8.1 dans ce cas précis), bref, on ne peut pas revenir la dessus.

Mon problème est la connection internet : impossible de l'établir.

 

Je parviens à me connecter à mon wifi, mais en connectivité limitée, et sans internet, le réseau est considéré public et l'adresse IP normalement fournie en dhcp n'est pas du tout la bonne, comme si la box n'était pas joignable.

Si j'essaie de passer en ip fixe, ça ne fonctionne pas mieux...

 

Cette box propose un réseau invité, qui lui fonctionne avec la tablette mais je ne veux pas l'utiliser en permanence.

De même si je crée un point d'accès wifi sur mon portable, cela fonctionne.

 

Il doit y avoir une incompatibilité quelque part, mais je ne trouve rien, ça fait quelques heures que j'écume le net, et là je dois m'avouer vaincu et je demande votre aide.

 

NB : le réseau en question n'est pas listé dans la base de registre HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles mais la tablette arrive quand même à se connecter sans redemander le mot de passe...

 

Merci d'avance

 

Link to comment
Share on other sites

Bonjour,

 

Pour commencer est-ce que tu as regarde si ta plage DHCP etait suffisante (j'entends par la le nombre d'adresses IP disponibles a allouer)?

Tu as essaye de voir ce que ca donnait en filaire?

 

Par ailleurs est-ce que tu as mis un Antivirus/Firewall particulier?

De memoire il m'etait arrive un probleme similaire avec NOD32. A la premiere connexion il avait du mettre un pop-up pour demander confirmation sur les connexions entrantes/sortantes et j'avais pas accepte.

 

PS: desole pour les accents je suis sur un QWERTY.

Link to comment
Share on other sites

Alors, merci de m'aider.

J'ai déjà ajouté 1 place dans la plage d'adresses IP disponible pour des appareils connectés en DHCP (ils sont paramétrés en location d'adresse IP fixe).

J'ai maintenant 9 appareils paramétrés, mais je ne pense pas que ce soit un facteur limitant puisqu'ils ne sont jamais tous allumés en même temps.

Pour le filaire, c'est une petite tablette sans port ethernet, et je n'ai pas d'adaptateur µUSB / réseau, donc pas de test en filaire.

 

Pour l'antivirus / firewall, c'est ceux de base de windows, j'ai même testé en désactivant les deux, sans succès.

 

Ce qui est étonnant c'est que le réseau invité fonctionne, mais l'adresse MAC de la passerelle n'est pas la même que le réseau principal, et je ne peux pas avoir accès à autant de réglages.

 

J'ai testé avec et sans filtrage par adresse MAC, ça ne change rien, et d'ailleurs la connexion se fait au wi-fi dans une certaine mesure, car la tablette apparaît dans la liste des appareils connectés.

 

J'avais pensé à une histoire de codage WPA ou WPA2, car j'ai le choix entre AES, TKIP, ou les 2, mais je n'ai rien trouvé de concluant.

Link to comment
Share on other sites

A priori tu as deja fait pas mal de tests alors je te propose d'essayer une solution un peu plus radicale: reinitialiser la couche TCP/IP.

 

Pour se faire il faut:

1. Ouvrir un prompt

2. Tape netsh int ip reset C:\resetlog.txt

3. Reboot

 

Si tu as des interrogations dessus, tu peux Google la ligne de commande directement, c'est assez frequent comme manipulation.

Pense aussi a supprimer ton reseau WiFi de la liste des reseaux pre-enregistres.

Link to comment
Share on other sites

Malheureusement pour moi ça fait aussi partie des tests déjà effectués.

La commande passe bien et fournit le résultat attendu, mais le problème persiste et je n'ai pas de fichier resetlog.txt à la fin.

Dans le détail :

Réinitialisation de Interface réussie
Réinitialisation de Voisin réussie
Réinitialisation de Chemin d'accès réussie
Echec de la réinitialisation de    .
Accès refusé
Redémarrez l'ordinateur...

J'ai aussi testé : netsh winsock reset catalog

netsh int ipv4 reset reset.log

puis carrément : netsh winsock reset all

 

aussi essayé :

netsh int tcp set heuristics disabled

netsh int tcp set global autotuninglevel=disabled

netsh int tcp set global rss=enabled

 

sans succès, la connexion est anormalement longue, puis devient limitée, sans accès internet...

Link to comment
Share on other sites

La tablette était sous windows 8.1 dès le début et n'a jamais pu se connecter à ce réseau.

J'ai fait des mises à jour, sans succès.

J'ai vu des gens se plaindre du même type de problème, résolu avec une mise à jour du driver.

Mon problème est que je ne trouve rien pour le chipset realtek RTL8723BS, et j'ai testé ceux de DELL, mais la tablette ne l'accepte pas.

Ce qui m'étonne c'est que ça fonctionne avec certains réseaux.

J'ai testé le paramétrage en IP fixe sur la tablette : ça fonctionne pour les autres réseaux, mais pas sur celui qui m'intéresse.


Voilà du nouveau :

en IP fixe, la tablette se connecte, je peux faire du ping sur les éléments de mon réseau, mais l'adresse IP vue par la passerelle n'est pas bonne, donc pas d'internet.

IPconfig /all

me donne :

...

DHCP activé              non

configuration automatique activée              oui

adresse d'autoconfiguration IPV4          169.254.115.164(préféré)

masque de sous reseau                         255.255.0.0

Adresse IPV4                                          192.168.0.XX  (en double)

masque de sous reseau                         255.255.255.0

...

Link to comment
Share on other sites

Je suis sur la bonne voie, mais je ne comprends vraiment pas ce qui me bloque :

j'ai finalement trouvé un driver pour mon chipset sur le site de DELL, qui passe avec cette tablette.

je viens de changer l'ip fixe à assigner, et ajoutant 1, et dans ce cas la tablette communique bien avec la box, et même internet.

J'ai donc une IP inutilisable en plein milieu de ma plage réservée!

Le pire c'est que si je restreint ma plage d'adresse IP sur la box, et que je donne une location d'IP au delà pour la tablette, ça ne met aucun message d'erreur, et la tablette se connecte bien avec l'adresse demandée, en dehors des adresses disponibles!

Je me demande donc si je n'ai pas simplement un problème de routeur DHCP avec l'adresse que je voulais mettre dès le départ. Mais dans ce cas, comment être sur que cela vient bien de là? Est-ce que cela présente un certain risque au niveau sécurité?


Edit :

Je n'avais plus internet à force de redémarrer la box, je viens seulement de voir le message de Aloyse57.

La tablette est bien compatible, puisqu'elle pouvait se connecter au réseau invité de la box.

Quand à redémarrer la box et la tablette, je l'ai fait un certain nombre de fois, sans même que ce soit nécessaire, mais pour être certain que ça ne vienne pas de là.

Link to comment
Share on other sites

Quand tu configurais la tablette avec une IP fixe, c'etait une adresse comprise dans la plage DHCP?

 

Les adresses IP obtenues via DHCP ont un bail pour eviter de recommencer tout le process de DHCP discover, offer.. a chaque connexion avec le routeur.

En somme, meme si l'ordinateur est eteint ou rarement utilise apres avoir obtenu son IP via DHCP, celle-ci lui est quand meme "reservee" jusqu'a expiration du bail (la duree est configurable). Par consequent, en affectant une IP deja attribuee a une autre machine (meme eteinte) cela peut creer ce genre de probleme.

 

Peut-etre qu'en faisant juste un ipconfig /renew cela reglera ton souci.

Link to comment
Share on other sites

J'ai une fonction pour effacer les locations DHCP dans l'interface de ma box. Et l'adresse IP en question n'était attribuée à aucun autre appareil. D'ailleurs, je ne peux toujours pas l'utiliser.

Sinon, ipconfig /release (et renew) ne fonctionnaient pas et indiquaient : "échec".

Il semble qu'il y a un problème qui me dépasse avec cette adresse

Link to comment
Share on other sites

edit:

 

Bon, je confirme :

sans rien changer à la box, si je passe en ip fixe sur la tablette (avec tout sauf celle qui pose problème, dans ou hors de la plage dhcp), j'ai une connexion et internet.

Par contre si j'assigne sur la tablette l'IP fixe qui pose problème, je reviens avec une connexion limitée.

 

Reste à trouver le pourquoi du comment.

Link to comment
Share on other sites

J'y avais pensé, mais je ne vois vraiment pas quoi. La seule chose que j'ai en connecté, c'est un bracelet en Bluetooth.

En plus le wifi est configuré en filtrage MAC, et refuse les autres connections, donc j'ai une liste complète de mes appareils branchés, normalement.

Je verrai demain à tête reposée si je trouve autre chose, et si un autre appareil pose le problème avec cette adresse, pour définitivement écarter un problème de tablette.

Merci

Link to comment
Share on other sites

Bon le problème vient pas du réseau ou encore dhcp/interface réseau/... Mais de Windows suite à ses derniers MAJ sur 8.1/10.

Pour forcer le profil privée, la répa ou la recréation du groupe résidentielle ne fonctionne plus ( Win7 uniquement ).

Pour moi il fallait aller dans le panneau de config "metro" tout moche,donnant à des paramètres inutiles. Sélectionner Wifi ou ethernet selon la liaison, ensuiteactiver-réactiver découverte réseau ou un machin dans le genre ( il n y a qu une seule option de mémoire ).

Link to comment
Share on other sites

Alors, voici les nouveautés du jour :

depuis mon portable sous archlinux, je peux me connecter sans aucun problème en IP fixe sur l'adresse qui pose problème à la tablette, et j'ai accès à internet.

Depuis un portable sous seven, l'adresse en question pose le même problème qu'avec la tablette et je me retrouve avec une connexion limitée, avec en plus un message d'erreur qui me dit que cette adresse est déjà utilisée par un autre ordinateur, mais lequel?

En gros windows détecte un appareil déjà connecté, mais pas linux. Comment puis-je savoir ce qui pose problème?

Est-ce juste une histoire de pare-feu de windows?

Link to comment
Share on other sites

Je pense pas que ce soit une histoire de pare-feu. Le message sur le PC sous Windows 7 est plutot clair.

D'ailleurs, l'appareil utilisant cette IP n'est pas forcement affiche au niveau de ton routeur (ca peut etre une tele, un NAS etc..) qui ne se connecte pas au WiFi.

 

Si tu fais un nbtstat -A ton_adresse_ip tu vas pouvoir recuperer le hostname de l'appareil en question. Ca va peut-etre t'aider a localiser le fautif..

Link to comment
Share on other sites

Bonsoir,

désolé de répondre un peu tard, j'ai manqué de temps ces derniers jours.

Après quelques essais avec airodump-ng, je ne vois aucune autre station connectée qui expliquerai mon problème.

Est-il possible qu'un appareil utilise 2 adresses IP?

Quel outil utiliser pour trouver cela?

nbstat n'est pas reconnue comme commande sous les 2 appareils windows.

 

@RinDman : j'avais essayé de forcer le profil privé directement depuis la base de registre, mais sans y parvenir, puisque de toutes façons, l'adresse IP attribuée n'était pas la bonne. Je n'arrive pas à trouver de moyen de faire la même chose depuis les réglages metro.

La plage d'IP pour le DHCP est assez large pour contenir les appareils, puisque l'adresse en question se trouve en plein milieu, et on peut se connecter avec d'autres adresses disponibles (testé avec succès depuis la tablette).

 

@RFN : bonne idée, mais je ne sais pas trop. J'ai virtualbox d'installé sur un poste mais je ne l'utilise que très rarement. Par contre sous windows j'ai office 2010 starter, qui affichait un disque virtuel à une époque, et qui semble ne plus le faire maintenant (je n'ai pas encore assez cherché).

 

Merci

Link to comment
Share on other sites

  • 2 weeks later...

seulement c'est uniquement valable pour les machines sous windows, mais malheureusement ça ne me donne rien de nouveau pour autant.

Je pense que je vais laisser tomber, mais j'aime bien savoir ce qui se passe malgré tout.

Ou alors j'attribue l'adresse IP problématique à une machine qui ne tourne pas sous windows, mais c'est quand même bizarre et ça risque peut être de déplacer le problème sur une autre adresse.

Je vais encore chercher un peu...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...