Jump to content

Archived

This topic is now archived and is closed to further replies.

Codenaim_TourisT

J'aimerais passer a linux

Recommended Posts

J'arrive pas a me connecter avec gaim. Sur le site de gaim, y dise ke je doit activer les cookies. Mais meme avec les cookies activés, ca marche pas. :francais:

Y a d'autre parametres a regler???

Ou y a un autre prog du meme style???

Share this post


Link to post
Share on other sites

Il y a Kopete qui fait ça très bien aussi, il permet de se connecter à MSN, ICQ, IRC, Jabber, Gadu-gadu et d'autres formats exotiques. En plus il s'intègre parfaitement à KDE, dont il utilise d'ailleurs le carnet d'adresses.

Share this post


Link to post
Share on other sites
La 10.0 rc est enfin dispo publiquement !

Il faudrait savoir ce qui reste à développer pour arriver à la version "finale" et surtout, mais Xzombi peut sans doute nous informer, est-ce que la 10.0rc est utilisable ou au contraire truffée de bugs ?

La version publique serait dispo en mai pour les membres du ClubMandrake

F

Depuis le 10 mars 2004, Mandrakelinux 10.0 Community est disponible sur des miroirs FTP. Donc gratuit. Les membres Silver on quand à eux droit à 5 iso plus ou moins utile et les membre Corporate on accès au ISO DVD. Le DVD contient le même stock que les 5 iso.

Mandrakelinux 10.0Depu Official sortira en Mai.

Mandrakelinux 10.0 inclut les logiciels suivants:

Noyau Linux 2.6.3

XFree86 4.3 avec support de Native POSIX Threads Library (NPTL)

Glibc 2.3.3

GCC 3.3.2

Apache 2.0.48, Samba 3.0, MySQL 4.0.18

ProFTPD 1.2.9, Postfix 2.0.18, OpenSSH 3.6.1p2

KDE 3.2, GNOME 2.4.2, IceWM 1.2.13

OpenOffice.org 1.1, KOffice 1.3, Gnumeric 1.2.6

Mozilla 1.6, The GIMP 1.2.5, XMMS 1.2.9

Matériel Recommandé :

Processeur : un processeur de classe x586 ou supérieur est nécessaire. Ce qui inclut les Pentium I/II/III/IV d'Intel, et les K6/II/III, Duron et Athlon/XP/MP de AMD. Les machines multi-processeurs sont aussi prises en charge. (*)

Mémoire : au moins 64 MO (32 MO or l'installation en mode tetxe) sont nécessaires ; 128 MO ou plus sont toutefois recommandés.

Disques : les disques IDE et SCSI sont pris en charge.

Taille de disque : au moins 500 MO sont nécessaires, 1 GO est toutefois recommandé.

Serial ATALa plupart des controlleurs sont gérés en mode non-RAID

Contrôleurs SCSI La plupart des contrôleurs SCSI sont pris en charge (Adaptec, Tekram, LSI Logic, Advansys...).

Contrôleurs RAID La plupart des contrôleurs RAID sont gérés, sauf les IDE et les serial-ATA. Cela dit, les contrôleurs RAID IDE et serial-ATA de chez 3Ware sont compatibles.

USB et USB 2.0 : la plupart des périphériques USB sont pris en charge.

Lecteurs et graveurs CD-ROM et DVD-ROM : la plupart des modèles IDE, SCSI, PCMCIA, IEEE 1394/FireWire sont pris en charge (DVD+RW et DVD-RW).

Cartes graphiques : la plupart des cartes ISA, PCI et AGP sont supportées, dont VESA, NVidia, ATI, 3DFX, SIS, S3, Matrox, Intel i865G, i85x, i81x, i845G, Trident.

L'accélération matérielle 3D est disponible pour Voodoo III/V/Banshee, Intel i8XX, ATI Rage 128/Pro & Radeon, Nvidia (GeForce et Nforce).

Adapteurs réseau : la plupart des cartes réseau basées sur des cartes mères Intel, Realtek, 3COM, NVIDIA®, Broadcom ainsi que les adaptateurs USB sont pris en charge. Idem pour une grande majorité de modems RNIS et DSL, ainsi que pour des périphériques sans-fil. La plupart des « WinModems » ne sont pas pris en charge.

Imprimantes : la plupart des imprimantes à jet d'encre et laser fonctionnent sous Mandrakelinux 10.0. Toutefois, les « WinPrinters » ne sont pas prises en charge

Cartes son : toutes les cartes compatibles SoundBlaster, Ensoniq (Audigy, Live), X Wave, Crystal, Intel, AMD, Nvidia Nforce, VIA, CMI C-Media, ESS Maestro, Yamaha YMF744, Terratec, AC'97.

Ordinateurs portables : une grande variété est prise en charge.

Divers : de nombreuses cartes TV, tablettes graphiques, scanners, webcams, appareils photo numériques et périphériques FireWire sont pris en charge.

Share this post


Link to post
Share on other sites

J'essayerai de voir tout ca kan je pourrai retourner sous linux.

Kan je lance linux, y fait tout kom d'hab, mais j'ai pas le mode graphique. J'ai ke la console. Je doit entrer mon login et mot de passe(ca me le faisait pas avant!).

J'ai essayer un init 4(j'crois ke c'est ca) pour activer le mode graphique mais rien. :byebye:

C'est normal ce genre de truc??

J'ai essayé d'installer les drivers ATI par la konsole, mais y me dit ki trouve pas le fichier. :francais:

Share this post


Link to post
Share on other sites

bon j'ai laisser tomber la RED HAT et Mandrake.........J'ai installer KNoppix 3.3 et je vais faire une MAJ.. J'en ai marre des problemes de patch and Co avc Red Hat..

Share this post


Link to post
Share on other sites
bon j'ai laisser tomber la RED HAT et Mandrake.........J'ai installer KNoppix 3.3 et je vais faire une MAJ.. J'en ai marre des problemes de patch and Co avc Red Hat..

N'oublie pas d'éditer le fichier /etc/apt/sources.list

Sinon ça peut créer des problèmes lorsque tu mettras le système à jour (j'avais eu un problème similaire avec une Knoppix 3.2... Et ça m'étonnerait que ça soit totalement résolu pour la 3.3 :D )

Mets par exemple la liste qui se trouve dans le tutoriel de Sentinel :yes:

Share this post


Link to post
Share on other sites
J'essayerai de voir tout ca kan je pourrai retourner sous linux.

Kan je lance linux, y fait tout kom d'hab, mais j'ai pas le mode graphique. J'ai ke la console. Je doit entrer mon login et mot de passe(ca me le faisait pas avant!).

J'ai essayer un init 4(j'crois ke c'est ca) pour activer le mode graphique mais rien. :D

C'est normal ce genre de truc??

J'ai essayé d'installer les drivers ATI par la konsole, mais y me dit ki trouve pas le fichier. :yes:

startx ça fonctionne pas? :D

Share this post


Link to post
Share on other sites

La liste indiquée dans le manuel est certainement obsolète maintenant, le plus simple pour être à jour est de supprimer le fichier de sources :

rm /etc/apt/sources.list

puis de lancer l'assistant de configuration de apt-get :

apt-setup

Comme ça tu peux choisir facilement tes sources (il faut dire Oui pour "non-free" et "non-US" et "Security")

Ensuite, si tu veux utiliser les packages des branches autres que "stable", il suffit d'éditer /etc/apt/sources.list et de remplacer "stable" par "testing" ou "unstable". Ou, mieux, de dupliquer les lignes indiquant "stable" afin d'avoir des sources pour les 3 branches à la fois.

Je sais, sous VI c'est pas de la tarte :)

Petit rappel donc : YY pour copier, P pour coller

Et pour les fous furieux :)

:%s/stable/testing/g

pour remplacer toutes les occurrences de "stable" par "testing" dans le fichier.

Share this post


Link to post
Share on other sites

J'ai essayé la commande startx et y me met :

(EE) Unable to locate/open config file

(EE) Error from xfree86HandleConfigFile()

Fatal server error :

no screens found

C'est grave docteur??? :humour::pleure::yes:

Ca marchait très bien hier!

Share this post


Link to post
Share on other sites

Ya un fichier de configuration de XFree86 qui est manquant, ou qui a foiré.

XFree86Config.

t'as installé un driver qui a foiré ton XFree86Config?

(genre driver de pilote).

Share this post


Link to post
Share on other sites
Des "drivers de pilotes" ? :D

ben oui , à installer sur des disques dur de stockage, pour gérer des cartes graphiques d'affichage

P'tain c'est super quand-même Linux, non !

patapé, patapé :fumer:

Share this post


Link to post
Share on other sites

Si t'es en mandrake ou redhat, il suffit de suivre les instructions disponibles sur site d'ATi.

Si tu es sous debian ou un de ses dérivés, il faudra transformer le .rpm en .deb avec l'utilitaire "alien", et ensuite la procédure est la même.

Dans les deux cas il est prossible, voire même probable, que le gestionnaire de packages râle, comme quoi des librairies sont déjà installées sur ta machine. Il suffit de "forcer" l'installation du package, et ensuite ça roule (option --force-overwrite sous apt-get, pour rpm je ne sais pas)

En tout état de cause, c'est entièrement indiqué dans le manuel d'installation d'ATi.

Share this post


Link to post
Share on other sites

J'ai installé les drivers ATI sous Mandrake 9.2. Tout c'est bien passé mais la procédure se déroule en 3 temps :

- télécharger le driver chez ATI mais il faut choisir *le bon*, i.e. celui qui correspond à ta version de Xfree86

- installer l'installeur sous nunux (rpm -i --force, je crois, c'est décrit dans le readme du site ATI)

- suivre la procédure de paramétrage du driver (résolution de l'écran, fréquences de rafraichissement etc.)

ensuite, tu peux lancer le serveur X (que c'est pratique de n'avoir pas à rebooter)

F

Share this post


Link to post
Share on other sites

Reprenons quelques bases, pour mieux comprendre.

Linux n'est pas un OS graphique. En gros et pour faire simple la couche graphique est séparée de l'OS proprement dit. Le boot se fait en mode texte et, en théorie, il faut se logguer d'abord puis après lancer la couche graphique (par la comande startx).

En fait, certaines distrib contournent ce petit désagrément en automatisant le lancement de XWindow au moment du boot. C'est le paramètre inittab qui permet cette petite manip. inittab 5 = boot graphique, inittab 3 = boot normal, mode texte.

Evidemment pour que ça marche, il faut que la cg soit reconnue, elle aussi, au boot. En cas de pépin, plein de choses peuvent se produire. Il arrive que si le boot graphique foire, linux se replie sur le boot en mode texte.

Il faut alors se logguer, et installer le pilote ATI comme indiqué précédemment. Si tu dois le télécharger, il fat le faire en FTP, mais en mode texte, "à l'ancienne"...voici quelques commandes

>ftp ftp.ati.com : pour se connecter sur le site ftp ati

>user : rentrer "anonymous"

> password : rentrer ton adresse email

>dir : pour lister les dossiers et les fichiers sur le serveur distant

>bin : pour télécharger les fichiers en mode binaire (sinon ton fichier local ne sera pas vu comme un exécutable)

>hash : permet d'afficher des "#" pendant le téléchargement, histoire de voir si tout va bien

>get nom_du_fichier : pour rappatrier le fichier que tu souhaites

>bye : pour se délogguer du serveur ftp.

Share this post


Link to post
Share on other sites

ba j'ai une question un peu idiote mais je cherche partout... comment fais tu pour trouver la version de ton XFREE86?

LE truc check.sh marche pas ou bien comment faire pour l'utilsier car la seule explicationn d'ati est : Lancer le programme Check.Sh pour determiner la version de votre XFree86 blablabla....

:eeek2::D:D comme explication :craint::roll::D

Share this post


Link to post
Share on other sites

Généralement ton gestionnaire de packages dispose d'une commande pour afficher les informations relatives à un package.

Sous debian :

dpkg -l | grep xserver-xfree86

(lister tous les packages mais n'afficher que xserver-xfree86)

Share this post


Link to post
Share on other sites

sinon, le control center de KDE le fait aussi (mais faut que la cg marche... ;-)

A noter aussi : chaque distrib liste la version des outils installés. Il suffit d'aller sur le site d'info de la distrib.

Share this post


Link to post
Share on other sites

J'ai essayé d'installer les drivers ati mais après avoir installé le package, y me demande d'éditer le fichier make.sh

Mais kan j'essaye de le faire y me met

zsh : permission denied

J'fait koi et comment????

Share this post


Link to post
Share on other sites
J'ai essayé d'installer les drivers ati mais après avoir installé le package, y me demande d'éditer le fichier make.sh

Mais kan j'essaye de le faire y me met

zsh : permission denied

J'fait koi et comment????

essaye de te logguer en root pour faire la manip, c'est la base.

Si ça ne marche pas, essaye de changer les permissions du fichier.

Le plus simple est la commande chmod 777 bom_du_fichier

F

Share this post


Link to post
Share on other sites

ahhh, les drivers ati... source d'ennui formidable.

Déja, faut arreter XFree avant de faire quoique ce soit.

CTRL+ALT+F1

se logger en root.

/etc/init.d/dm stop

ou

init 3

ensuite :

rpm -Uvh --force --nodeps fglrx-4.3.0-taversion.rpm

tu fais un :

cd /lib/modules/fglrx/build_mod/

sh make.sh

cd ..

sh make_install.sh

ca installe le module fglrx.o.gz (si noyau 2.4x) ou fglrx.ko.gz (si noyau 2.6x)

ensuite tu tapes:

fglrxconfig

et tu paramètres correctement ton affichage. Et ca doit rouler. A noter que quand t'installe le .rpm, ca doit compiler directement le module fglrx. essaye de lancer alors directement fglrxconfig, si ton accélération 3D fonctionne, n'y touche plus. Par contre si ca fonctionne pas, alors compile le module en suivant les instructions ci-dessus. A noter encore, qu'avec les chipset VIA-K7T, le support agp fonctionne proprement depuis les 2 dernières versions du drivers, donc à la question "Do you want to use the external AGP GART module", tu peux répondre oui sans problèmes.

Une fois tout ca fait, lance simplement :

X

si ca fonctionne, c que les paramétrages sont correct, si ca fonctionne pas, donne nous les erreurs que génère XFree.

tu reviens dans la console graphique

tu peux relancer le tout:

/etc/init.d/dm start

ou

init 5

si t'utilise le noyau 2.6 faut faire attention à la version de gcc que tu utilises sinon ca compilera pas proprement. Bon courage.

Gyan

Share this post


Link to post
Share on other sites

×
×
  • Create New...