Jump to content

Archived

This topic is now archived and is closed to further replies.

Codenaim_TourisT

J'aimerais passer a linux

Recommended Posts

J'ai essayé mais ca a pas marché.

le message d'erreur :

modprobe: Can't locate module fglrx

[drm] failed to load kernel module "fglrx"

(EE) fglrx(0): DRIScreenInit failed!

(EE) xf86OpenSerial: Cannot open device mx500 (nom ke j'ai donné a ma souris)

No such file or directory.

(EE) xf86OpenSerial: Cannot open device mx500

No such file or directory.

(EE) Mouse1: cannot open input device

(EE) PreInot failed for input device "Mouse1"

No core pointer

Fatal server error:

failed to initialize core devices

Si je me plante pas j'ai le noyau 2.4.18 / Mandrake 9.2

et les driver 3.7.6

J'ai une souris pas compatible ou j'me suit planté qqe part????

Ou il aime pas du tout mon écran de :yes: ???? (Typhoon T70S)

Ca serait pas plus simple de ré-installer mandrake???

Share this post


Link to post
Share on other sites

Est-ce que lors de la configuration de fglrxconfig, pour la souris, tu as choisis /dev/mouse ou /dev/psaux?

Essaie l'un et l'autre :yes:

Réinstaller le système... Ca n'arrangera pas le problème : lors de l'installation des drivers tu risques (fortement :pleure:) d'avoir le même problème :craint:

Share this post


Link to post
Share on other sites

Déja, le module n'est pas correctement installé.

D'autre part, tu as un problème avec ta souris qui n'est pas correctement configurée. Pas de pointeur viable, XFree se lance pas.

Si tu veux être sur qu'elle soit correctement configurée, lance le service harddrake au démarrage et suit les instructions. (ca marche très bien pour les souris)

Ensuite, tu utilises le noyau 2.4.18 et personnellement, je n'ai jamais eu de problèmes avec ces noyaux, disons plutot que les drivers ati marchent très bien avec les 2.4x.

As-tu bien installés les sources du noyau dans /usr/src/ ? (nécessaire pour la compilation du module)

Si oui, y'a t-il bien un lien symbolique /usr/scr/linux poitant vers /usr/src/linux-2.4.18 ?

Quelles sont les messages d'erreurs lors de la compilation du module fglrx ?

Gyan

Share this post


Link to post
Share on other sites
ahhh, les drivers ati... source d'ennui formidable.

Déja, faut arreter XFree avant de faire quoique ce soit.

CTRL+ALT+F1

se logger en root.

/etc/init.d/dm stop

ou

init 3

ensuite :

rpm -Uvh --force --nodeps fglrx-4.3.0-taversion.rpm

tu fais un :

cd /lib/modules/fglrx/build_mod/

sh make.sh

cd ..

sh make_install.sh

ca installe le module fglrx.o.gz (si noyau 2.4x) ou fglrx.ko.gz (si noyau 2.6x)

ensuite tu tapes:

fglrxconfig

et tu paramètres correctement ton affichage. Et ca doit rouler. A noter que quand t'installe le .rpm, ca doit compiler directement le module fglrx. essaye de lancer alors directement fglrxconfig, si ton accélération 3D fonctionne, n'y touche plus. Par contre si ca fonctionne pas, alors compile le module en suivant les instructions ci-dessus. A noter encore, qu'avec les chipset VIA-K7T, le support agp fonctionne proprement depuis les 2 dernières versions du drivers, donc à la question "Do you want to use the external AGP GART module", tu peux répondre oui sans problèmes.

Une fois tout ca fait, lance simplement :

X

si ca fonctionne, c que les paramétrages sont correct, si ca fonctionne pas, donne nous les erreurs que génère XFree.

tu reviens dans la console graphique

tu peux relancer le tout:

/etc/init.d/dm start

ou

init 5

si t'utilise le noyau 2.6 faut faire attention à la version de gcc que tu utilises sinon ca compilera pas proprement. Bon courage.

Gyan

Bon alors,

j'ai essayé ca, toujours pas d'accelration 3D :incline:

mais j'me bas avec fglrxconfig, je capte pas tous, qd je retourne sous l'interface grapihique, g une résolution 1280*1024 en 640*480 :yes: avec la souris qui déplace l'écran, ou bien encore mieu en 1280*1024 et tous est affichertou petit, on dirai du 2048 :D

et l'acceleration 3D à pas l'air de marché

comment fait-on pour vérifier si elle est activé ? moi je vérifie en lanssant Chrominium :yes: 5FPS :zzz:

Pourrai avoir + de détails sur "fglrxconfig" ? :mdr:

j'fai réessayer la manip encore une fois :zzz:

Share this post


Link to post
Share on other sites

alors voilà ce ke g qd je fait la manip

[root@localhost k]# rpm -Uhv --force --nodeps /home/k/Documents/Drivers/ATI/fglrx-4.3.0-3.7.6.i386.rpm
Préparation...              ########################################### [100%]
  1:fglrx                  ########################################### [100%]
*** Trying to install a precompiled kernel module.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Error: no kernel module build environment - please consult readme.
Installed: qt3 (gcc 3.2) based control panel application
===
ATI display drivers successfully installed
please run 'fglrxconfig' now
===
[root@localhost k]# cd /lib/modules/fglrx/build_mod
[root@localhost build_mod]# sh make.sh
ATI module generator V 2.0
==========================
initializing...
kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h
[root@localhost build_mod]# cd..
[root@localhost fglrx]# sh make_install.sh
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
[root@localhost fglrx]#

tous ces failed ca me gave :mad2: , c'est quoi le kernel modules environement ?

(RAPPEL : chui fétus padawan liuxien :pleure: )

Share this post


Link to post
Share on other sites

Bon, restons zeeeen.

Tester accélaration graphique:

effectivement, avec chromium tu es fixé.

ou sinon, tu peux essayer :

[root@Gyanopolis src]# fglrxinfo

display: :0.0 screen: 0

OpenGL vendor string: ATI Technologies Inc.

OpenGL renderer string: RADEON 9700 PRO Generic

OpenGL version string: 1.3 (X4.3.0-3.7.6)

Ce qui t'indique que le pilote est bien installé, utilisant la version OpenGL d'ATI. Tu peux vérifier en lancant

[root@Gyanopolis src]# fgl_glxgears

1031 frames in 5.0 seconds = 206.200 FPS

1037 frames in 5.0 seconds = 207.400 FPS

1030 frames in 5.0 seconds = 206.000 FPS

Juste une confirmation déja:

Dans ton post précédent :

*** Error: no kernel module build environment -

ATI module generator V 2.0

==========================

initializing...

kernel includes at /usr/src/linux/include not found or incomplete

file: /usr/src/linux/include/linux/version.h

tu as bien installé les sources du noyau ? (m'est avis que non)

si 'non' :

uname -rs --> pour connaitre la version du noyau que tu utilises.

installer le package kernel-source correspondant à ta version

vérifie si le lien "linux" dans /usr/src/ pointe bien vers /usr/src/linux-2.taversionnoyau

si 'non' --> ln -s /usr/src/linux-2.xxx /usr/src/linux

si 'oui' --> bah c'est un bon point déja.

si 'oui' :

m..de, ca va être plus compliqué que prévu mais ne perdons pas espoir.

Possible d'avoir le contenu de ton fichier /etc/X11/XF86Config-4 ? (sans tous les

commentaires)

Gyan.

Share this post


Link to post
Share on other sites

:francais: car tres interressant pour resoudre les problemes de pilote ATI......

j'attend la suite de l'episode avec impatience...... :francais:

Share this post


Link to post
Share on other sites

×
×
  • Create New...