Jump to content

Archived

This topic is now archived and is closed to further replies.

aurielle

Le nouveau linux d'Em1ly

Recommended Posts

Bref, je comprends plus rien :transpi::D:down::transpi:

Em1ly peux tu me coller le résultat de ça stp, merci d'avance

muriel@althea:~> ls /etc
(Je colle pas le mien ça fait trop de ligne)
muriel@althea:~>

Ps: CaseyN, faut lire tout depuis le début (elle a expliqué déja pourquoi xubuntu avec le cd ubuntu :D )

Share this post


Link to post
Share on other sites
 emily@emily-devilz:~$ ls /etc
acpi						   gre.d				odbcinst.ini
adduser.conf				   groff				openalrc
adjtime						group				openoffice
aliases						group-			   opt
alternatives				   grub.d			   pam.conf
anacrontab					 gshadow			  pam.d
apm							gshadow-			 pango
apparmor					   gtk-2.0			  papersize
apparmor.d					 hal				  passwd
apport						 hdparm.conf		  passwd-
apt							hdparm.conf_backup   pcmcia
at.deny						hesiod.conf		  perl
avahi						  host.conf			pnm2ppa.conf
bash.bashrc					hostname			 popularity-contest.conf
bash_command_not_found		 hosts				power
bash_completion				hosts.allow		  ppp
bash_completion.d			  hosts.deny		   printcap
belocs						 hotplug			  profile
bindresvport.blacklist		 hp				   protocols
blkid.tab					  iftab				pulse
blkid.tab.old				  inetd.conf		   purple
bluetooth					  init.d			   python
bogofilter.cf				  initramfs-tools	  python2.5
bonobo-activation			  inputrc			  qt3
brlapi.key					 iproute2			 rc0.d
brltty						 issue				rc1.d
brltty.conf					issue.net			rc2.d
ca-certificates.conf		   java				 rc3.d
ca-certificates.conf.dpkg-old  java-6-sun		   rc4.d
calendar					   jvm				  rc5.d
chatscripts					jvm.d				rc6.d
compizconfig				   kernel-img.conf	  rc.local
console-setup				  laptop-mode		  rcS.d
console-tools				  ldap				 readahead
cron.d						 ld.so.cache		  resolvconf
cron.daily					 ld.so.conf		   resolv.conf
cron.hourly					ld.so.conf.d		 rmt
cron.monthly				   lftp.conf			rpc
crontab						libao.conf		   samba
cron.weekly					libgda			   sane.d
cups						   libgda-3.0		   scim
dbus-1						 libpaper.d		   screenrc
debconf.conf				   locale.alias		 scrollkeeper.conf
debian_version				 localtime			securetty
default						logcheck			 security
defoma						 login.defs		   services
deluser.conf				   logrotate.conf	   sgml
devfs						  logrotate.d		  shadow
dhcp3						  lsb-base			 shadow-
dictionaries-common			lsb-base-logging.sh  shells
discover.conf				  lsb-release		  skel
discover.conf-2.6			  ltrace.conf		  sound
discover.d					 magic				ssh
dpkg						   magic.mime		   ssl
emacs						  mailcap			  sudoers
environment					mailcap.order		sysctl.conf
esound						 manpath.config	   syslog.conf
event.d						mediaprm			 terminfo
fdmount.conf				   menu-methods		 timezone
ffserver.conf				  mime.types		   ucf.conf
firefox						mke2fs.conf		  udev
fonts						  modprobe.d		   uniconf.conf
foomatic					   modules			  updatedb.conf
fstab						  modutils			 update-notifier
fstab.pre-uuid				 mono				 usplash.conf
fuse.conf					  motd				 vim
gai.conf					   motd.tail			vnc.conf
gaim						   mtab				 w3m
gamin						  nanorc			   wgetrc
gconf						  Net				  wodim.conf
gdm							netscsid.conf		wpa_supplicant
gimp						   network			  wvdial.conf
gnome						  NetworkManager	   X11
gnome-app-install			  networks			 xdg
gnome-system-tools			 nsswitch.conf		xml
gnome-vfs-2.0				  ODBCDataSources	  zsh_command_not_found
gnome-vfs-mime-magic		   odbc.ini


emily@emily-devilz:~$

Share this post


Link to post
Share on other sites

Bon, eh bien j'ai toujours quelques problèmes curieux, et pourtant j'ai suivi les trucs de la documentation pas à pas, mais rien à faire chez moi ça ne fonctionne pas comme ça devrait...

Genre le client F@H qui est censé se lancer en tant que service au démarrage, ne démarre pas

Amule qui se ferme tout seul (plante) quand je veux recharger la liste des serveurs...

Les lecteurs vidéos Totem ET VLC qui se ferment / plantent quand je veux lire les fichiers en avi...

(qui se trouvent sur une partition windows sur dd externe, mais pas de problèmes avec les mp3 qui sont sur ce même disque... :dd: )

Entre autres petits désagréments courants...

Faut dire que pour paramétrer un programme il y a 15 000 autres choses à modifier avant, c'est un vrai labyrinthe...

:bravo:

Donc s'il y a un spécialiste Ubuntu pour m'aider à tout vérifier ce qui est bon ou pas... :transpi:

:devil:

Share this post


Link to post
Share on other sites

Tu peux faire comme je te l'avais proposé dans un autre endroit?

emily@chatton:~> vlc /home/emily/mavideo.avi

enfin à condition que ta vidéo avi soit bien enregistrée dans la /home/emily sinon ça va pas aller :D

et là tu colles le contenu de la console, si toi tu le comprends pas, nos papy linuxiens aguerris comprendront l'erreur et te feront corriger ce qu'il faut.

J'ai retenu ça en 2007, toujours prendre la console pour lancer les logiciels qui plantent afin d'avoir des explications sur ce qui pose problème.

Sinon le problème vient souvent de l'utilisateur, j'ai souvent fait pareil que dans la doc.... sauf qu'il manquait un .

ou alors un espace avant le / ou encore en $ au lieu de # ou encore en m au lieu de M. D'accord c'est presque pareil mais c'est inexact....

Share this post


Link to post
Share on other sites

:roll:

emily@emily-devilz:~$ vlc /media/Bionical/incoming2/DragonWarsVOSTFR.avi
VLC media player 0.8.6c Janus
libdvdnav: Using dvdnav version 0.1.10 from http://dvd.sf.net
libdvdread: Using libdvdcss version 1.2.9 for DVD access
libdvdread: Can't stat /media/Bionical/incoming2/DragonWarsVOSTFR.avi
Aucun fichier ou répertoire de ce type
libdvdnav: vm: faild to open/read the DVD
[00000290] main input error: no suitable access module for `/media/Bionical/incoming2/DragonWarsVOSTFR.avi'
[00000281] main playlist: nothing to play

Erreur vlc: Unable to open '/media/Bionical/incoming2/DragonWarsVOSTFR.avi'

Je vais essayer en rennommant le fichier enn un seul mot et en le mettannt dans home, là il est sur un dd externe.

AERFFF ç'a marché une fois, j'aurais pu me regarder le film mais j'ai fermé le terminal ç'a fermé vlc.

J'ai rééssayé, ben ça ne fonctionne de nouveau plus... Faux espoir :oops:

 emily@emily-devilz:~$ vlc /home/emily/dragonwars.avi
VLC media player 0.8.6c Janus
X Error of failed request:  BadAlloc (insufficient resources for operation)
 Major opcode of failed request:  140 (XVideo)
 Minor opcode of failed request:  19 ()
 Serial number of failed request:  88
 Current serial number in output stream:  89

emily@emily-devilz:~$ vlc /home/emily/dragonwars.avi
VLC media player 0.8.6c Janus
The program '.' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
 (Details: serial 87 error_code 11 request_code 140 minor_code 19)
 (Note to programmers: normally, X errors are reported asynchronously;
  that is, you will receive the error a while after causing it.
  To debug your program, run it with the --sync command line
  option to change this behavior. You can then get a meaningful
  backtrace from your debugger if you break on the gdk_x_error() function.)

emily@emily-devilz:~$ vlc /home/emily/dragonwars.avi
VLC media player 0.8.6c Janus
X Error of failed request:  BadAlloc (insufficient resources for operation)
 Major opcode of failed request:  140 (XVideo)
 Minor opcode of failed request:  19 ()
 Serial number of failed request:  91
 Current serial number in output stream:  92
emily@emily-devilz:~$

Pas assez de ressources, j'pense bien, j'ai rien de lancé, faut pas déconnner :D

Share this post


Link to post
Share on other sites

Pour la première erreur, ça semble être un problème de droits (il ne peux pas ouvrir le fichier)

Il faudrait regarder si le /tmp n'est pas plein, si la mémoire n'est pas saturée, si il n'y a pas un périférique qui attend quelque chose etc.

Peut-on avoir les résultats des commandes suivantes ?

df -h
free -m
vmstat

Share this post


Link to post
Share on other sites

Le truc c'est que je rame de plus en plus, y'a souvent une à deux secondes de réaction toutes les 6 lettres quand j'écris quelque chose, c'est catastrophique. Idem pour la souris, se déplace en saaccade.

 emily@emily-devilz:~$ df -h
Sys. de fich.			Tail. Occ. Disp. %Occ. Monté sur
/dev/sda1			  16G  5,0G  9,4G  35% /
varrun				252M   88K  252M   1% /var/run
varlock			   252M	 0  252M   0% /var/lock
udev				  252M   76K  252M   1% /dev
devshm				252M   12K  252M   1% /dev/shm
lrm				   252M   34M  219M  14% /lib/modules/2.6.22-14-generic/volatile
/dev/sdb1			  94G   49G   45G  52% /media/Bionical
emily@emily-devilz:~$ free -mm
		 total	   used	   free	 shared	buffers	 cached
Mem:		   503		497		  6		  0		  6		257
-/+ buffers/cache:		232		270
Swap:		 1070		148		921
emily@emily-devilz:~$ vmstat
procs -----------memory---------- ---swap-- -----io---- -system-- ----cpu----
r  b   swpd   free   buff  cache   si   so	bi	bo   in   cs us sy id wa
3  0 152564   6788   7000 263604	0	0	12	19   40   20 30  3 65  1
emily@emily-devilz:~$

en tous cas j'ai mandriva en attente de gravure... j'ai hâte.

Share this post


Link to post
Share on other sites

Effectivement il y a un problème.

Il semble que tu n'aie plus beaucoup de mémoire (6M ce n'est pas énorme).

Est ce que tu éteins ta machine tous les jours ou elle reste en permanence allumée ?

Regarde si tu as un processus gourmand en mémoire.

Essaye de lancer la commande top. Normalement c'est trié par défaut par %CPU (tu peux en profiter pour voir s'il y a un processus gourmand en CPU déjà).

Ensuite pour changer la colonne de comparaison, il faut utiliser la touche '>' pour aller vers la droite (avec le shift donc sur un clavier azerty). Regarde si un ou plusieurs process utilisent beaucoup de mémoire.

Share this post


Link to post
Share on other sites

Ya un gros problème... tu as 512Mo de RAM selon ce qui est ecris... et 6 de libre (comme le dit Theocrite), tu as quoi qui tourne pour avoir si peu de libre?

Expérience personnelle : Ubuntu + Gnome sur 512 de RAM = 89Mo de bouffé pour les services résidents + 34% pour le cache... vérifie si tu as pas des services inutiles.

Bonne chance :yes:

Share this post


Link to post
Share on other sites
Expérience personnelle : Ubuntu + Gnome sur 512 de RAM = 89Mo de bouffé pour les services résidents
Ben oui, il ne reste plus que 423 M pour Firefox après. Ce n'est pas énorme !

:yes:

Share this post


Link to post
Share on other sites

:yes:

Pour les "petites" configs faut voir avec du Opéra ou un truc light (Lynx :D)

-------------------->[]

Share this post


Link to post
Share on other sites
Ben oui, il ne reste plus que 423 M pour Firefox après. Ce n'est pas énorme !

:yes:

Bah, le problème, ce n'est pas tant ce qu'il lui faut que ce qu'on peut espérer qu'il rende... cette sâleté a même déjà eu le culot de m'envoyer un killall se faire mettre...

Share this post


Link to post
Share on other sites

Ben, je ne l'éteins jamais...

Et j'ai 512 en ram de base mais les 2 Go en swap ils servent à quoi alors ? !

emily@emily-devilz:~$ top

top - 02:58:59 up 5 days,  6:17,  2 users,  load average: 1.53, 0.81, 0.51
Tasks: 101 total,   3 running,  98 sleeping,   0 stopped,   0 zombie
Cpu(s): 24.1%us,  1.3%sy,  0.0%ni, 74.6%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:	515900k total,   441304k used,	74596k free,	11684k buffers
Swap:  1096192k total,   152524k used,   943668k free,   199412k cached

 PID USER	  PR  NI  VIRT  RES  SHR S %CPU %MEM	TIME+  COMMAND			
20749 emily	 15   0  196m  75m  22m S  4.0 15.1  36:22.32 firefox-bin		
15681 emily	 15   0  181m  48m  20m S  0.0  9.7   4:00.98 nautilus		   
4355 root	  15   0 62120  41m 8420 R  9.6  8.2 342:32.10 Xorg			   
22632 emily	 15   0 53224  39m 4840 R  1.0  7.9   7:30.14 wish			   
5510 emily	 15   0 57676  21m  11m S  0.0  4.2  13:16.62 gnome-panel		
22686 emily	 15   0 55616  17m  10m S  2.0  3.4   0:01.60 gnome-terminal	 
5557 emily	 15   0 40012  13m 9480 S  0.0  2.6   0:48.36 nm-applet		  
5536 emily	 18   0 32828  11m 9928 S  0.0  2.4   0:17.26 update-notifier	
5597 emily	 18   0 41868  10m 9372 S  0.0  2.2   0:05.80 mixer_applet2	  
6330 emily	 15   0 37516  10m 7660 S  0.0  2.1   1:43.62 notification-da	
5578 emily	 21   0 64260  10m 8940 S  0.0  2.1   0:04.29 trashapplet		
5507 emily	 15   0 19020 9972 8036 S  7.3  1.9 176:02.48 metacity		   
5520 emily	 15   0 33328 9176 7056 S  0.0  1.8   1:29.68 gnome-volume-ma	
5501 emily	 15   0 39132 7808 6956 S  0.0  1.5   1:15.22 gnome-settings-	
5547 emily	 18   0 35472 7276 6832 S  0.0  1.4   0:00.54 evolution-alarm	
5458 emily	 21   0 28192 6656 6232 S  0.0  1.3   0:00.92 x-session-manag	
5532 emily	 16   0 19772 6180 5876 S  0.0  1.2   0:00.17 vino-session

Share this post


Link to post
Share on other sites
Et j'ai 512 en ram de base mais les 2 Go en swap ils servent à quoi alors ? !
Franchement à rien.

Si jamais tu devais swapper 2G, ça ramerait à mort.

De ce que je vois, ça m'a l'air normal ces valeurs. As tu toujours les ralentissement ?

J'avais aussi oublié de regarder le vmstat. Tu as trois process en attente d'exécution. Mais comme tu ne redémarre pas souvent ta machine, ça ne veut pas dire grand chose (c'est une moyenne depuis le dernier redémarrage).

Que donne un

vmstat 5

(Les 4 ou 5 premières lignes).

Share this post


Link to post
Share on other sites
22632 emily 15 0 53224 39m 4840 R 1.0 7.9 7:30.14 wish

C'est quoi le truc en tcl/tk qui arrive à bouffer autant de mémoire ? (simple curiosité perso :byebye: )

Share this post


Link to post
Share on other sites
 emily@emily-devilz:~$ vlc /home/emily/dragonwars.avi
VLC media player 0.8.6c Janus
X Error of failed request:  BadAlloc (insufficient resources for operation)
 Major opcode of failed request:  140 (XVideo)
 Minor opcode of failed request:  19 ()
 Serial number of failed request:  88
 Current serial number in output stream:  89

emily@emily-devilz:~$ vlc /home/emily/dragonwars.avi
VLC media player 0.8.6c Janus
The program '.' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
 (Details: serial 87 error_code 11 request_code 140 minor_code 19)
 (Note to programmers: normally, X errors are reported asynchronously;
  that is, you will receive the error a while after causing it.
  To debug your program, run it with the --sync command line
  option to change this behavior. You can then get a meaningful
  backtrace from your debugger if you break on the gdk_x_error() function.)

emily@emily-devilz:~$ vlc /home/emily/dragonwars.avi
VLC media player 0.8.6c Janus
X Error of failed request:  BadAlloc (insufficient resources for operation)
 Major opcode of failed request:  140 (XVideo)
 Minor opcode of failed request:  19 ()
 Serial number of failed request:  91
 Current serial number in output stream:  92
emily@emily-devilz:~$

Pas assez de ressources, j'pense bien, j'ai rien de lancé, faut pas déconnner :byebye:

Le BadAlloc c'est sans aucun doute un problème causé par une mise à jour de sécurité de xorg-server.

Met à jour ta distribution et redémarre le serveur X, normalement ça devrait remarcher après.

Sinon si c'est vraiment le bug en question et que tu peux pas mettre à jour, y'a une méthode pour que ça marche, c'est de rajouter ça à la Section "Extensions" du xorg.conf :

Option "MIT-SHM" "no"

EDIT :

https://bugs.launchpad.net/ubuntu/+source/x...ver/+bug/183969

https://bugs.gentoo.org/206490

Share this post


Link to post
Share on other sites
22632 emily 15 0 53224 39m 4840 R 1.0 7.9 7:30.14 wish

C'est quoi le truc en tcl/tk qui arrive à bouffer autant de mémoire ? (simple curiosité perso :byebye: )

Très probablement amsn.

Share this post


Link to post
Share on other sites
22632 emily 15 0 53224 39m 4840 R 1.0 7.9 7:30.14 wish

C'est quoi le truc en tcl/tk qui arrive à bouffer autant de mémoire ? (simple curiosité perso :byebye: )

amsn ;)

Et pour Fx c'est clair que c'est un bouffe-mémoire !

Là je suis à 280Mo...

Mais j'éteinds jamais mon pc... Parfois je redémarre l'interface graphique, parfois je redémarre Fx tout seul (c'est suffisant :pleure:)

N'empeche, en plus de ces 497Mo de ram utilisés, elle a déjà swappé 140Mo :eeek:

C'est toujours ta DSL ?

EDIT: grilled by Théo :fou:

Share this post


Link to post
Share on other sites
22632 emily 15 0 53224 39m 4840 R 1.0 7.9 7:30.14 wish

C'est quoi le truc en tcl/tk qui arrive à bouffer autant de mémoire ? (simple curiosité perso :francais: )

amsn ;)

Et pour Fx c'est clair que c'est un bouffe-mémoire !

Là je suis à 280Mo...

Mais j'éteinds jamais mon pc... Parfois je redémarre l'interface graphique, parfois je redémarre Fx tout seul (c'est suffisant :cap:)

N'empeche, en plus de ces 497Mo de ram utilisés, elle a déjà swappé 140Mo :D

C'est toujours ta DSL ?

EDIT: grilled by Théo :fumer:

Wai c'est aMsn et suis sous ubuntu, pas DSL (because c'est en anglais ;))

Mais pourquoi amsn bouffe autant que le vrai msn ?

emily@emily-devilz:~$ vmstat 5
procs -----------memory---------- ---swap-- -----io---- -system-- ----cpu----
r  b   swpd   free   buff  cache   si   so	bi	bo   in   cs us sy id wa
0  0 152516  23924  79272 206964	0	0	12	18   62   77 29  3 66  1
0  0 152516  23916  79284 206964	0	0	 0	30  368  617 15  4 81  0
1  0 152516  23916  79284 206964	0	0	 0	 0  362  615 17  1 82  0
0  0 152516  23916  79284 206964	0	0	 0	 0  365  624 17  0 83  0
1  0 152516  23916  79284 206964	0	0	 0	 0  362  615 17  0 83  0
0  0 152516  23916  79284 206964	0	0	 0	92  376  620 17  0 83  0
0  0 152516  23916  79288 206964	0	0	 0	86  377  623 17  1 82  0
0  0 152516  23916  79292 206964	0	0	 0	 1  366  620 16  0 84  0

Trop super, je branche une carte SD, il me la trouve une heure après, quand je ferme amsn :dd:

Je vais reboot, pour voir.

MaJ, Reboot machine donc aucun prog de lancé, je teste:

 emily@emily-devilz:~$ vlc /home/emily/dragonwars.avi
VLC media player 0.8.6c Janus
X Error of failed request:  BadAlloc (insufficient resources for operation)
 Major opcode of failed request:  140 (XVideo)
 Minor opcode of failed request:  19 ()
 Serial number of failed request:  103
 Current serial number in output stream:  104
emily@emily-devilz:~$

Ca n'y change rien... :D

Redémarrer le serveur X je veux bien, mais c'est où ? :ouioui:

Share this post


Link to post
Share on other sites

Tu la mets bien à jour régulièrement, ta machine?

Apparemment, il y a eu de la merdouille dans des patches de sécurité pour X.org qui ont causé ce genre de problèmes (impression donnée en googlant vite fait sur ton message d'erreur)... il semble que des patches corrigeant ce bug soient sortis pour ta distro...

Sinon, tu peux peut-être essayer en passant par un autre type de sortie que xv, x11 par exemple, en allant dans la configuration de vlc... xv utilise les capacités d'overlay de ta machine, alors que x11 fait tout en software (bouffe plus de perfs, peut être moins fluide, mais est censé faire appel à moins de fonctions)...

Autrement, pour redémarrer X.org, sur ta machine, vu qu'il est lancé par le service qui te permet de te connecter graphiquement, ie gdm, il suffit de redémarrer ce service : "sudo invoke-rc.d gdm restart", ou "sudo /etc/init.d/gdm restart", si tu n'as pas invoke-rc.d (je ne me souviens plus si tu as ça, bien que ce soit dérivé de Debian)...

Edit : plein d'edits, et pas vu que tu traînais là à cette heure :francais:

Share this post


Link to post
Share on other sites

Les mises à jour sont effectuées dès qu'il y en a de disponibles.

En ce qui concerne le redémarrage de serveur, ça me met la liste avec [OK] au bout (si ce n'est qu'il me dit "fréquance de cpu not supported"

et ensuite, il ne se passe plus rien et biensûr je ne sais pas comment revenir en graphique :francais:

Donc redémarrage forcé...

Pour configuration de vlc, j'ai sortie vidéo en niveau de gris / plein écran / overlay comme options disponibles, rien d'autre... c'était en overlay, je décoche pour voir... même résultat.

Et dans les préférences il n'y a rien qui parle de XV ou X11... ;)

En faisant une recherche sur xorg dans synaptic, je vois plein de debug package liés à x11, je prends, pour voir :cap:

Share this post


Link to post
Share on other sites

Oki, pour le redémarrage de serveur... en fait, c'est plus propre de faire ça dans un TTY (ie, la console sans serveur X)... tu fais ctrl+alt+F2 (ou un autre F* de 1 à 6, habituellement), tu t'y logues, puis tu peux normalement faire le restart en un coup (tu peux alors te déloguer du TTY)...

... ce qui se passe est que tu lances cette instruction dans un terminal sous X.org, mais le fait de tuer ce dernier empêche le script de demander le redémarrage puisque le terminal d'où il a été lancé est tué avec X.org,...

Pour VLC, ça fait des lustres que je ne l'ai pas utilisé (chacun son truc), mais il me semble qu'il faut passer en options avancées pour accéder à ça...

Pour les paquets «debug», il me semble que ça sert plutôt aux développeurs pour avoir plus de messages d'erreur que pour corriger des problèmes... du coup, je ne vois vraiment pas d'où ça vient... ça ne marche toujours pas avec un autre lecteur, après ton update et redémarrage de X.org? Dans ce cas, peut-être qu'un bugreport...

Share this post


Link to post
Share on other sites

Euh... Pour se logguer, c'est bien le même nom d'user et pass qu'au démarrage d'ubuntu ?

Je pose la question parce que ça me met login incorrect...

donc no way de restart quoi que ce soit.. :dd:

Pour vlc, même en option avancée y'a rien qui se rapporte à ça.

Share this post


Link to post
Share on other sites

×
×
  • Create New...