Jump to content

Archived

This topic is now archived and is closed to further replies.

uranus49

[tuto][initié]Postfix : Créer son serveur de Mail

Recommended Posts

Effectivement pour faire un serveur que je disais "vrai", il faut un nom de domaine valide, une adresse IP fixe et le port 25 ouvert.

Ben pourquoi une ip fixe? Dans le standard les adresses sont sous la forme user@server avec server une adresse DNS.

Donc pour moi il suffit d'avoir une adresse DNS valide et le serveur mail derrière le port 25 à cette adresse DNS.

(donc si on a une adresse qui change, faut juste qu'on avertisse le DNS assez rapidement)

Share this post


Link to post
Share on other sites

Le DNS donne aussi un TTL, faut le régler à 0 si on veut que l'adresse ne soit pas cachée par les autres dns, mais après le dns se prendra toutes les requêtes dns sur le domaine.

Share this post


Link to post
Share on other sites

Un nom de domaine en .fr ça coûte dans les 8 ¤ par an, donc si on a une ipfixe ça n'est pas inaccessible. :francais:

L'adresse IP fixe n'est effectivmeent pas indispensable.

En effet pour le nom de domaine ca coute pas si cher que ca. De toute facon, la methode reste sensiblement la meme a ceci pres que l'on ne passe pas par gmail.

Au fait, si j'ai mis tuto initié, c'est parce que je considere que le serveur de mail n'est pas un chose simple a mettre en place car :

1. il faut un serveur DNS

2. Postfix ne se configure que en ligne de commande

3. Le nombre de parametres est impressionnant.

Sinon, serait-il possible de mettre un lien dans la liste des tutos pour ce tuto? merci d'avance ! :francais:

Share this post


Link to post
Share on other sites

En parlant de configuration de serveur de courrier Postfix. J'ai une question ?

-----------------------------

Dans la circonstance que j'aurais un site Web à installer, mais que je ne veux pas installer un serveur de courrier complet (avec nom de domaine et tout et tout), mais que je veux utiliser... et je dois utiliser quand même pour:

1- Récupérer les messages de la boîte root, postmaster, etc. (Pour ça c'est OK, je n'ai pas vraiment besoin de configurer quoi que ce soit, un client Outlook qui accède via le réseau local à la boîte c'est bon).

2- Pour que certaines applications en PHP qui nécessite l'envoi de courrier vers des destinataire externe (ex.: forum, annonces classées ou autres)

Dans cette situation, le serveur Postfix ne sera valide sur Internet car il ne possède pas d'entrées MX, ni un nom de domaine valide (localhost.localdomain).

Est-ce qu'il est possible de configurer une boîte de courrier unique et valide du genre celle fournit par ton FAI pour expédier tous les messages externes à la machine ?

Par exemple mon adresse personnelle valide qui serait toto@moncourrier.com serait utilisé pour l'expédition de tous les comptes locaux et ces messages expédiés contiendrait dans l'en-tête du message l'adresse toto@moncourrier.com et non apache@localhost.

NOTE: Mon FAI exige maintenant que toutes connexions se fassent en SMTP Authentifié et sur le port TCP:1025.

Donc, si le message n'est pas délivré localement, il est redirigé vers la boîte de courrier de mon FAI en prenant des en-tête valide afin de ne pas se faire balancer par des antispams (et ce pour tous les comptes de courrier locaux et non individuellement).

*** Aucune configuration nécessaire pour la réception de message, uniquement pour de l'expédition.

--------------------------

Merci pour vos conseils !

Share this post


Link to post
Share on other sites

Cela reviens a ce que l'on disait plus haut :D

1. Soit tu as un nom de domaine valide sur INternet et tu pourras créer une boite comme ton FAI avec l'en-tete de ton domaine ou l'entete que tu veux meme si je ne m'abuse. (a confirmer cependant...)

2. Soit comme dans le tuto, tu passe par ton FAI ou par gmail ici en l'occurence.

"NOTE: Mon FAI exige maintenant que toutes connexions se fassent en SMTP Authentifié et sur le port TCP:1025."

Je ne sais pas de quel FAI tu parles, mais il faut donc que tu ouvre le port 1025 sur ton firewall et que sur ton client Outlook par exemple tu specifie le port 1025 avec login et mot de passe pour que se soit automatique. Ca ne change pas fondamentalement la configuration du serveur Postfix.

"Donc, si le message n'est pas délivré localement, il est redirigé vers la boîte de courrier de mon FAI en prenant des en-tête valide afin de ne pas se faire balancer par des antispams (et ce pour tous les comptes de courrier locaux et non individuellement)."

Oui :) C'est pourquioi si tu n'as pas de domaine valide, il faut passer par le FAI ou gmail ou autre..

Bonne journée

Share this post


Link to post
Share on other sites

Si c'est Postfix qui fait relais SMTP, c'est à son niveau qu'il faut gerer l'authentification....C'est Postfix qui relais au SMTP si Postfix ne gere pas le domaine...

Logiquement il n'y a pas de port a ouvrir puisque c'est en sortie et la majeur partie des Firewall sont fermés en entrée et ouvert en sortie....

My 2 cents.

++

Share this post


Link to post
Share on other sites

Alors comment faire un relais SMTP avec Postfix vers le serveur de mon FAI sur le port 1025 avec authentification SMTP ?

Share this post


Link to post
Share on other sites

Alors comment faire un relais SMTP avec Postfix vers le serveur de mon FAI sur le port 1025 avec authentification SMTP ?

bonjour,

ajoutes ceci au main.cf

smtp_sasl_auth_enable = yes

smtp_sasl_password_maps = hash:/etc/postfix/sasl_client

smtp_sasl_security_options = noanonymous

relayhost smtp.du.fai:1025

et dans le sasl_client tu mets:

smtp.du.fai user:pass

puis postmap sur ce fichier

un chmod pour limiter l'acces en lecture (password en clair)

et postfix reload

Share this post


Link to post
Share on other sites

Ok, merci et plutôt intéressant comme premier post que tu fais sur le forum PCInpact !!!

Share this post


Link to post
Share on other sites

Ca fait la soirée que je suis dessus, j'en ai un peu marre :/

Est ce que quelqu'un peut m'expliquer le trajet d'un mail venant d'un expediteur exterieur et arrivant sur mon postfix.

De ce que j'ai compris... Ca arrive par smtp, et postfix le fout dans le spool de base, qui est pour moi actuellement :

/var/mail/16ar

Si j'ai un IMAP configuré (j'utilise courier car j'avais suivi un autre tutorial a l'époque), ou est ce qu'IMAP va chercher les mails ? dans /var/mail/16ar ? Dans ~/Mail ?

Et si sur ma machine distante, j'ai un mutt, le fait de déplacer des mail de /var/mail/16ar vers ~/Mail, ca risque pas de foutre la merde pour l'IMAP ?

Bref, je suis un peu perdu ...

Je vais relire le topic sans regarder les config, juste pour essayer de comprendre :/

Mais en tout cas merci pour le topic, c'est juste que les mails, c'est vraiment, mais vraiment pas aussi aisé que je pensais...

Share this post


Link to post
Share on other sites

Bah faut que tu configures les deux pour qu'ils aillent chercher les mails au même endroit. Tu peux utiliser /var/spool/mail/user, ~/Maildir ou autre... Normalement tu dois pouvoir configurer Courier pour qu'il aille chercher les mails au bon endroit.

Share this post


Link to post
Share on other sites

j'en ai vraiment ma claque lol. J'ai suivi 20 000 tutos du début à la fin...

Pas un seul qui a reussi a me faire aller mes mails venant sur postfix directement dans un ~/Maildir !

En gros, je veux juste que mes mails arrivent directement dans un maildir ~/mails pour chaque personne. Pas que ca soit dans un mailbox sur le /var/.

Apres je configurerai courier-imap... Mais deja la, j'arrive même pas a faire ca ...

Je comprends pas, pourtant j'ai pas autant galéré sur mon ancien serveur avant qu'il crashe ... Et ca faisait exactement ce que je voulais ... Mais la, j'ai beau avoir l'impression de changer les options, ca arrive toujours dans ce **** de /var/mail/16ar ... Chiant ... J'ay ai passé 5 h voire plus hier ... Ca me gave

Share this post


Link to post
Share on other sites

Voici ce que j'ai dans le fichier /etc/postfix/main.cf :

# DELIVERY TO MAILBOX
#
# The home_mailbox parameter specifies the optional pathname of a
# mailbox file relative to a user's home directory. The default
# mailbox file is /var/spool/mail/user or /var/mail/user.  Specify
# "Maildir/" for qmail-style delivery (the / is required).
#
#home_mailbox = Mailbox
home_mailbox = Maildir/

Share this post


Link to post
Share on other sites

j'en ai vraiment ma claque lol. J'ai suivi 20 000 tutos du début à la fin...

Pas un seul qui a reussi a me faire aller mes mails venant sur postfix directement dans un ~/Maildir !

En gros, je veux juste que mes mails arrivent directement dans un maildir ~/mails pour chaque personne. Pas que ca soit dans un mailbox sur le /var/.

Apres je configurerai courier-imap... Mais deja la, j'arrive même pas a faire ca ...

Je comprends pas, pourtant j'ai pas autant galéré sur mon ancien serveur avant qu'il crashe ... Et ca faisait exactement ce que je voulais ... Mais la, j'ai beau avoir l'impression de changer les options, ca arrive toujours dans ce **** de /var/mail/16ar ... Chiant ... J'ay ai passé 5 h voire plus hier ... Ca me gave

il faut que tu parametres ton mda pour la livraison

si tu utilises procmail il te faut lui indiquer de livrer dans les homes des users:

tu crees un fichier /etc/procmailrc

et tu mets dedans un truc du style pour avoir les maildir dans chaque repertoire utilisateur (fais un tour sur google pour les details ou pour une autre config)

DEFAULT=$HOME/Mail/

MAILDIR=$HOME/Maildir/

VERBOSE=yes

LOGFILE=$HOME/Maildir/.procmaillog

Share this post


Link to post
Share on other sites

Mon problème est reglé depuis hier soir :)

Merci à vous :francais: En particulier a tsubasa :) (et #postfix sur freenode :turevesmongars: )

Quel probleme ? J'avais encore cette saloperie de ~/.forward que j'avais créé suite au conseil d'un pote. Résultat, 5 H perdue ... wééé :postsinutiles:

Share this post


Link to post
Share on other sites

Merci pour les reponses j'arrive un peu tard :zarb:

16ar, si tu as des liens utiles pour la configuration de IMAP, ne te prive pas pour les mettre.

:D

Share this post


Link to post
Share on other sites

J'ai une petite question à propos de Postfix sous Debian.

Lorsque je lance son installation avec apt-get, j'ai quelques questions dans un affichage à la "ncurses" pour configurer les paramètres de base, il y a une question que je ne sais pas vraiment quel choix est le meilleur et/ou peut avoir un impact majeur sur le fonctionnement.

Il me demande:

Quand on impose des mises à jour synchronisées, l'envoi des courrierls se fais plus lentement. Dans le cas contraire, il y a des risques de perdre des courriels si le système meurt inopinément et si vous n'utilisez pas un système de fichiers journalisé, comme ext3.

La valeur par défaut est «off»

Forcer des mises à jour synchronisées de la file d'attente des courriels ?

<OUI> <NON>

L'explication est quand même clair: Si j'active les maj synchro je m'assure de ne pas perdre des couriers... mais je ralenti le système. Mais quel est la réalité de cet option ?

Est-ce valable, est-ce que ça ralenti énormément le système (si j'ai environ 75 boîtes de courrier sur ce serveur), est-ce qu'il existe un avantage réel ?

Share this post


Link to post
Share on other sites

c'est assez pointu en fait comme parametrage et il serait trop long de detailler ce que cela fait reellement et comment.

pour resumer cela modifie les attributs etendus des repertoires qui contiennent les queues de postfix en activant le flag synchronous updates (S) (partition EXT3)

de memoire l'installeur de la debian doit regler un truc du style si tu choisis yes

mail:~# lsattr /var/spool/postfix/
------------------ /var/spool/postfix/hold
------------------ /var/spool/postfix/etc
------------------ /var/spool/postfix/lib
------------------ /var/spool/postfix/usr
------------------ /var/spool/postfix/private
------------------ /var/spool/postfix/pid
------------------ /var/spool/postfix/public
--S--------------- /var/spool/postfix/incoming
--S--------------- /var/spool/postfix/active
--S--------------- /var/spool/postfix/bounce
--S--------------- /var/spool/postfix/defer
--S--------------- /var/spool/postfix/deferred
--S--------------- /var/spool/postfix/flush
--S--------------- /var/spool/postfix/saved
--S--------------- /var/spool/postfix/corrupt
------------------ /var/spool/postfix/maildrop
------------------ /var/spool/postfix/trace
------------------ /var/spool/postfix/var
------------------ /var/spool/postfix/prng_exch
------------------ /var/spool/postfix/smtp_scache.db
------------------ /var/spool/postfix/smtpd_scache.db

cela va ecrire immediatement tous les changements sur les fichiers.

le probleme c'est que cela diminue grandement les performances.

d'ailleurs la doc de postfix ne conseille pas la meme chose mais plutot de desactiver le synchronous mode

 chattr -R -S /var/spool/postfix 

et d'activer le data=journal

(postfix se charge lui meme de faire un fsync pour l'ecriture dans /var/spool/postfix.)

idealement il faudrait une partition /var en data=ordered (donc monté par defaut) et appliquer les attributs suivants sur /var/spool/postfix

chattr -R -S +j +A /var/spool/postfix/

c'est a dire : no synchronous updates, no atime updates et data journalling

et aussi desactivé le write-cache sur le disque. Mais la il vaut mieux avoir un disque dedié pour le /var/spool/postfix pour eviter de perdre en performances ce qu'on gagne en securité. Ou idealement avoir des caches de disques persistents mais c'st une autre histoire.

Si on respecte ces points il n'y aurait pas de perte de données en cas de probleme tout en ayant de tres bonne performances

tout ca pour dire que pour 70 boites mails tu ne sentiras pas la difference donc tu peux laisser l'option par default

Share this post


Link to post
Share on other sites

Et bien pour une question pointue, j'ai eu une réponse pointue aussi :D

Merci de ces renseignements !!! Je peux constater que ces modifications seraient très valables dans la circonstance d'une gestion de plusieurs milliers de boîtes avec un volume d'échange élevé pour augmenter la vitesse d'exécution entre les disques durs et les interfaces réseau (augmenter les performances directement) et si on a un système quand même bien protégé (batteries backup fiables et disques SCSI en RAID5 ou plus) on oubli la synchronisation activée pour sécurité et on opte pour ta solution :yes:

Et comme tu as très bien compris ma situation, l'option de synchronisation peut être intéressante dans ma circonstance (pour une petite entreprise avec un serveur de petit budget et un nombre limité d'utilisateurs) afin d'éviter la pertes de fichiers et/ou corruptions des boîtes.

Share this post


Link to post
Share on other sites

De la chaire a Banta m'a ecrit un message privé fort interessant auquel je n'ai pas su trouver reponse, faute de pouvoir tester. Je lui ai demandé de poster afin que vous puissiez eventuellement lui repondre mais il ne l'a toujours pas fait . Je copie-colle donc son message en esperant qu'il pourra le lire et trouver la reponse qui lui convient :

de la part de Nargash :

Bonjour :)

Voila, Je possède un compte chez dyndns.org car j'ai une adresse ip dynamique et je voulais héberger mon mini site chez moi. J'ai un problème assez embetant, je suis en train de configurer postfix sous debian pour me faire un serveur mail et j'ai reussi a envoyer des mails en non-local sur une adresse du style "laposte.net" mais je n'arrive pas a en recevoir . Je recoi tjr un message d'erreur du genre : - Ces destinataires ont été traités par le serveur de messagerie :

user@nomdomaine.dyndns.org; Échec; 5.4.0 (état du réseau ou d'acheminement différent ou non défini)

J'ai aussi penser a définir au niveau de mon compte dyndns que j'utilisais comme MX mon "nomdomaine.dyndns.org" (le backup mx activé aussi)

Autrement en local j'arrive a recevoir et envoyer sans probleme.

J'ai configurer les fichier

/etc/postfix/main.cf

/etc/postfix/transport

/etc/postfix/virtual

/etc/postfix/canonical

/etc/aliases

/.fetchmailrc

Mais il est possible ke je me soit trompé quelque part :(

Sinan j'ai installer postfix , procmail , fetchmail , qpopper

Au niveau du routeur les ports 25 et 110 sont bien ouvert et pour la freebox j'ai desactiver le bridage du port 25.

Merci pour votre contribution :) :reflechis:

Share this post


Link to post
Share on other sites

le probleme de reception est il present depuis n'importe quel compte email externe ?

le message de retour est t'il tjs le meme ?

que donnent les tests du nom de domaine sur dnsreport ? (http://www.dnsreport.com/)

a t on des logs sur le server local qui indiqueraient l'arrivée des mails ?

Share this post


Link to post
Share on other sites

Bonjour à vous tous!

Depuis plusieurs semaines j'essaie de faire en sorte que les mails envoyés par Postfix passent par le relais gmail, mais je n'y arrive vraiment pas!

J'ai essayé, laissé tomber, retenté ma chance, suivi plusieurs tutoriels prévus pour des cas très semblables au mien, mais ça ne marche toujours pas...

Je vous explique ma situation: je dispose d'une machine-serveur sous FreeBSD 6.2 dans mon placard. J'aimerais qu'il puisse me servir de serveur de mail. Pour le moment, on peut envoyer des mails sur moi@monadresse.no-ip.org sans problème. J'ai également configuré ces comptes dans Gmail, ce qui fait que je peux sans problème envoyer des mails en tant que moi@monadresse.no-ip.org à n'importe quelle adresse, en configurant KMail ou Thunderbird pour qu'il utilise le serveur SMTP de Gmail.

Mais ce que j'aimerais, c'est que Postifx puisse aussi utiliser le seveur SMTP de gmail comme relais. C'est le but de plusieurs tutoriels que j'ai suivi à la lettre, sans jamais y arriver. Je suis plutôt content d'avoir trouvé celui-ci, en français en plus :) et je l'ai parcouru rapidement vu que j'avais déjà fait tout ce qu'il indiquait (je parle bien de la partie SMTP).

Un autre problème problème vient du triste fait que je suis abonné chez AOL, qui bloque le port 25, et je suis donc obligé de dire à Postfix d'utiliser le port 587.

Quand j'essaie d'envoyer un mail sur mon adresse gmail, voilà ce qui apparaît dans mon /var/log/maillog:

Apr 29 11:51:34 mandresic postfix/pickup[83236]: 2A1855C96: uid=0 from=<root>

Apr 29 11:51:34 mandresic postfix/cleanup[83241]: 2A1855C96: message-id=<20070429095134.2A1855C96@monadresse.no-ip.org>

Apr 29 11:51:34 mandresic postfix/qmgr[83237]: 2A1855C96: from=<root@monadresse.no-ip.org>, size=385, nrcpt=1 (queue active)

## L'erreur suivante vient sûrement du fait que j'ai recompilé OpenSSL entre temps suite à un problème avec le script CA.pl

Apr 29 11:51:34 mandresic postfix/smtp[83243]: warning: run-time library vs. compile-time header version mismatch: OpenSSL 0.9.7 may not be compatible with OpenSSL 0.9.8

Apr 29 11:51:34 mandresic postfix/smtp[83243]: setting up TLS connection to smtp.gmail.com

Apr 29 11:51:34 mandresic postfix/smtp[83243]: certificate verification failed for smtp.gmail.com: num=20:unable to get local issuer certificate

Apr 29 11:51:34 mandresic postfix/smtp[83243]: SSL_connect error to smtp.gmail.com: -1

Apr 29 11:51:34 mandresic postfix/smtp[83243]: warning: TLS library problem: 83243:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:s3_clnt.c:844:

Apr 29 11:51:34 mandresic postfix/smtp[83243]: 2A1855C96: Cannot start TLS: handshake failure

Apr 29 11:51:35 mandresic postfix/smtp[83243]: setting up TLS connection to smtp.gmail.com

Apr 29 11:51:35 mandresic postfix/smtp[83243]: certificate verification failed for smtp.gmail.com: num=20:unable to get local issuer certificate

Apr 29 11:51:35 mandresic postfix/smtp[83243]: SSL_connect error to smtp.gmail.com: -1

Apr 29 11:51:35 mandresic postfix/smtp[83243]: warning: TLS library problem: 83243:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:s3_clnt.c:844:

Une petite idée? J'ai passé tellement de temps dessus que je commence à en avoir assez de chercher, j'éspère que vous pourrez me conseiller! ;)

Merci à tous

Share this post


Link to post
Share on other sites

Tu m'as la'air d'avoir des problemes avec le systeme SSL :

"

Apr 29 11:51:34 mandresic postfix/smtp[83243]: SSL_connect error to smtp.gmail.com: -1

Apr 29 11:51:34 mandresic postfix/smtp[83243]: warning: TLS library problem: 83243:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:s3_clnt.c:844:

Apr 29 11:51:34 mandresic postfix/smtp[83243]: 2A1855C96: Cannot start TLS: handshake failure

Apr 29 11:51:35 mandresic postfix/smtp[83243]: setting up TLS connection to smtp.gmail.com

Apr 29 11:51:35 mandresic postfix/smtp[83243]: certificate verification failed for smtp.gmail.com: num=20:unable to get local issuer certificate

Apr 29 11:51:35 mandresic postfix/smtp[83243]: SSL_connect error to smtp.gmail.com: -1

Apr 29 11:51:35 mandresic postfix/smtp[83243]: warning: TLS library problem: 83243:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:s3_clnt.c:844:

"

Je ne sais pas comment ca se biture sous FreeBSD mais je te conseille de reinstaller l'application OpenSSlLcar il y a des erreurs dans les librairies (TLS library problem: 83243:error:14090086:SSL ). ;)

Ce fichier en particulier donne une erreur : "s3_clnt.c". Le status du mail ne doit pas etre "sent" mais "undelivered" j'imagine...

Si quelqu'un a une meilleure idée qu'il n'hesite pas :transpi:

Share this post


Link to post
Share on other sites

Moui, en fait ce petit message d'erreur pourrait ne pas être si anodin... ("warning: run-time library vs. compile-time header version mismatch: OpenSSL 0.9.7 may not be compatible with OpenSSL 0.9.8")

J'ai commencé à travailler sur la mise en place du relais avec la version 0.9.7 d'OpenSSL, en tous cas je crois que c'est celle-là qui était installée. J'avais quelques erreurs, alors j'ai désinstallé, recompilé et réinstallé OpenSSL. J'ai ensuite eu un problème avec le script CA.pl qui ne fonctionnait plus correctement. J'ai donc à nouveau désinstallé OpenSSL, mais cette fois-ci j'ai pris la version la plus récente proposée par les ports de FreeBSD, la version 0.9.8. Je ne sais pas trop ce qui s'est passé entre temps... Je vais tenter de regénérer tous mes certificats, des fois que... Si ça ne marche pas, je tenterai de réinstaller OpenSSL 0.9.7.

Merci pour le conseil!

PS: La seule chose que j'ai du faire différemment par rapport aux tutos prévus pour Linux, c'est d'indiquer que les fichiers de conf de Postfix se trouvent dans /usr/local/etc/postfix et non pas dans /etc/postfix (je n'ai pas pris le temps de créer un lien symbolique...). Donc faut pas se sentir dépaysé :transpi:

Share this post


Link to post
Share on other sites

×
×
  • Create New...