Jump to content

Archived

This topic is now archived and is closed to further replies.

chameauman

[Resolu]ubuntu 6.06, partition illisible

Recommended Posts

Bonjour, j'viens d'installé ubuntu 6.06 sur mon PC, et voilà la configuration: HDD1: 1partition windows, HDD2: 1partition NTFS (hdb1) (medias...), 1partition root (hdb2)(5Go) et 1 swap(hdb3). Donc, dans le poste de travail, lorsque que je clique sur (hdb1), il me dit que:

Impossible de monter le volume sélectionné

erreur : le périphérique /dev/hdb1 n'est pas amovible

erreur: impossible d'exécuter pmount.

Que faire?

Autre question, je suis l'heureux propriétaire d'un créative zen micro photo, mais ce dernier n'est pas reconnu du tout par ubuntu, que faire aussi?

Merci d'avance pour vos conseil avisés.

Share this post


Link to post
Share on other sites

Et (en ligne de commande) tapes

fdisk -l

pour voir tes partitions.

Tu peux aussi faire

cat /etc/partitions

en user normal.

Share this post


Link to post
Share on other sites

C'est parce que ta partition est en NTFS et qu'elle ne peut etre accessible que par le root...

Autrement dit, tu dois faire

sudo nautilus

Pour démarrer le gestionnaire de fichier en temps que root et comme ca tu pourras accéder a ta partition montée...

Ne fais pas ca en tout temps, évite le NTFS tant que possible!

Share this post


Link to post
Share on other sites

Non pas besoin d'être root...

mount ... -o umask=0000 et c'est bon.

Share this post


Link to post
Share on other sites

Moi aussi je préfère le coup de la partition montée avec "umask=000" plutôt que le "sudo nautilus"

Dans un cas ça ne change pas du tout la sécurité du système, alors que dans l'autre (avec sudo) une fausse manip peut détruire le système en 1/2 seconde...

Share this post


Link to post
Share on other sites

Bon j'ai éssayé de rentré des commandes, mais j'n'y arrive pas, par contre, la partition windows en NTFS de mon premier disque dur s'est monté toute seule et je peu y'accéder, c'est pour celà que je me suis posé la question.

Share this post


Link to post
Share on other sites

j'ai testé hier kUbuntu et no problemo pour le ntfs, je n'ai rien dû faire pour que ça aille et que je sache la lire.

C'est ubuntu donc, c'est censé être simple.

Il faudrait impérativement une copie du fstab.

Share this post


Link to post
Share on other sites

Wé c'est marrant...

Moi j'avais essayé de monter une partoche ntfs en 0000 mais il refusait...

Il la montait qd meme mais juste le root en lecture et exec

Share this post


Link to post
Share on other sites

sudo mount -o remount,rw,umask=0000 /dev/hdXX

ou

sudo mount -o remount,rw,umask=0000 /mnt/windows

Share this post


Link to post
Share on other sites

Wé c'est marrant...

Moi j'avais essayé de monter une partoche ntfs en 0000 mais il refusait...

Il la montait qd meme mais juste le root en lecture et exec

les drivers d'écriture sur du ntfs sont actuellement rarement inclus dans les noyaux...enfin, je croyais....

Share this post


Link to post
Share on other sites

Wé c'est marrant...

Moi j'avais essayé de monter une partoche ntfs en 0000 mais il refusait...

Il la montait qd meme mais juste le root en lecture et exec

les drivers d'écriture sur du ntfs sont actuellement rarement inclus dans les noyaux...enfin, je croyais....

Il n'y a pas de driver d'écriture sur le ntfs...

(y'a juste captive, et peut-être fuse-ntfs, mais bon c'est pas intégré au noyau, il faut plus qu'une ligne dans le fstab quoi...)

Share this post


Link to post
Share on other sites
CONFIG_NTFS_RW:

This enables the partial, but safe, write support in the NTFS driver.

The only supported operation is overwriting existing files, without changing the file length. No file or directory creation, deletion or renaming is possible. Note only non-resident files can be written to so you may find that some very small files (<500 bytes or so) cannot be written to.

While we cannot guarantee that it will not damage any data, we have so far not received a single report where the driver would have damaged someones data so we assume it is perfectly safe to use.

Note: While write support is safe in this version (a rewrite from scratch of the NTFS support), it should be noted that the old NTFS write support, included in Linux 2.5.10 and before (since 1997), is not safe.

This is currently useful with TopologiLinux. TopologiLinux is run on top of any DOS/Microsoft Windows system without partitioning your hard disk. Unlike other Linux distributions TopologiLinux does not need its own partition. For more information see <http://topologi-linux.sourceforge.net/>

Comme je le disais je ne sais plus où il y a quelques jours :

Écriture safe sur les fichiers existants.

Mais :

* Pas de rename

* Pas de suppression

* Pas de changement de la taille du fichier.

* Impossible de toucher aux petits fichiers (moins de 500 o)

EDIT : 2.6.17.1

EDIT :

File systems

=> DOS/FAT/NT Filesystems

==> NTFS file system support

===> NTFS write support

Share this post


Link to post
Share on other sites

Tant qu'on y est, j'ai une question assez sensible ici

voilà, j'ai actuellement le raid 0 sur mon PC, qui est géré par un chipset promise (SATA) (carte mère ASUS P4C800dlx). sous windows XP (5 Partitions) OS par défaut, WinXP

j'ai entendu parlé de fake raid sur ce genre et type de chipset (promise, sillicon,...)

je voudrai installer ubuntu sur cette environement raid0, j'ai alloué de la place pour celui-ci

est ce que mes array seront vues et reconnues par Ubuntu ??

Enfait, pour résumer la situation actuelle, j'ai pris un 3ième disque dur (SATA non raid) sur lequel j'ai installé ubuntu mes deux disques raid0 eux, sont déconnectés, donc, je n'ai qu'un seul disque en ce moment (j'ai isolé le raid0).

maintenant si il n'y pas de solution pour faire reconnaitre les array actuelle, est-il possible de repartir de 0 et d'installer Ubuntu en raid 0 software et ensuite mettre windows XP

voilà merci

Share this post


Link to post
Share on other sites
Comme je le disais je ne sais plus où il y a quelques jours :

Écriture safe sur les fichiers existants.

Mais :

* Pas de rename

* Pas de suppression

* Pas de changement de la taille du fichier.

* Impossible de toucher aux petits fichiers (moins de 500 o)

En même temps, pour 99% des gens (moi inclus), c'est exactement comme si l'écriture n'était pas disponible au final...

Share this post


Link to post
Share on other sites

Tant qu'on y est, j'ai une question assez sensible ici

voilà, j'ai actuellement le raid 0 sur mon PC, qui est géré par un chipset promise (SATA) (carte mère ASUS P4C800dlx). sous windows XP (5 Partitions) OS par défaut, WinXP

j'ai entendu parlé de fake raid sur ce genre et type de chipset (promise, sillicon,...)

je voudrai installer ubuntu sur cette environement raid0, j'ai alloué de la place pour celui-ci

est ce que mes array seront vues et reconnues par Ubuntu ??

Enfait, pour résumer la situation actuelle, j'ai pris un 3ième disque dur (SATA non raid) sur lequel j'ai installé ubuntu mes deux disques raid0 eux, sont déconnectés, donc, je n'ai qu'un seul disque en ce moment (j'ai isolé le raid0).

maintenant si il n'y pas de solution pour faire reconnaitre les array actuelle, est-il possible de repartir de 0 et d'installer Ubuntu en raid 0 software et ensuite mettre windows XP

voilà merci

J'ai deja entendu dire qu'il y avait quelques problemes avec le raid0 en hard et linux...

Moi je te dirais de repartir de 0, et donc de :

- sauvegarder toutes tes données

- virer ton raid (moisi :chinois: )

- réinstaller windows ou restaurer ta partoche

- réinstaller ubuntu (cd alternate pour le raid) et refaire une belle install convenablement

- jouir de ton systeme stable :chinois:

Share this post


Link to post
Share on other sites
J'ai deja entendu dire qu'il y avait quelques problemes avec le raid0 en hard et linux...

Moi je te dirais de repartir de 0, et donc de :

- sauvegarder toutes tes données

- virer ton raid (moisi :chinois: )

- réinstaller windows ou restaurer ta partoche

- réinstaller ubuntu (cd alternate pour le raid) et refaire une belle install convenablement

- jouir de ton systeme stable :chinois:

ici ce n'est pas tout à faire un raid hardware, on parle de fake raid, j'ai fait des recherches sur le forum et l'aide de ubuntu-fr

ça reste un raid software malgré tout.

il parrait que c'est impossible de faire reconnaitre par linux les partions raid 0 qui sont présentes sous windows.

soit je passe en raid 0 (géré par ubuntu) sans dual boot xp, ou soit je reste sous winxp et adieu la solution linux (ça, je n'ai pas envie)

ou alors adieu le raid et dual boot XP, Ubuntu

Share this post


Link to post
Share on other sites

Je ne dis pas le contraire. Je dis juste qu'il y a une option dans le noyau pour le NTFS.

Bon c'est pas un vrai driver fonctionnel toussa, mais mon post n'était pas là pour te reprendre.

C'est juste une info pour ceux qui ne le savaient pas. Tout le monde ne recompile pas son noyal et même en le recompilant, dur de retenir toutes les options.

Share this post


Link to post
Share on other sites

# /etc/fstab: static file system information.

#

# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0

/dev/hdb2 / ext3 defaults,errors=remount-ro 0 1

/dev/hda1 /media/hda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

/dev/hdb3 none swap sw 0 0

/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0

voilà mon fstab (comment j'commence à parler comme si j'y connaissai qqchose). Mais bon ce qui est super bizare, c'est que mon premier disque en NTFS avec windows dessus est reconnu automatiquement, sans aucun PB avec un beau raccourci sur le bureau... :francais:

Donc voilà il me manque /dev/hdb1 si j'comprends bien?????

Share this post


Link to post
Share on other sites

Tu vois, chaque ligne correspond à une partition.

Il n'y a pas de partition hdb1.

Il faudrait que tu rajoutes :

/dev/hdb1 /media/hdb1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

Share this post


Link to post
Share on other sites

Bon, alors j'ai rajouté la ligne

/dev/hdb1 /media/hdb1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1 dans mon fstab, mais ça n'a rien fait, j'ai ensuite tapé "mkdir /media/hdb1", sauf que le dossier reste vide malheureusement, et ensuite j'ai tapé

nicolas@nicolas-desktop:~$ sudo mount -o remount,rw,umask=0000 /dev/hdb1

mount: /media/hdb1 n'est pas déjà monté ou option erronée

et voilà la réponse.... Non mais je sais pas, y'a peut être un probléme sur la partition ou jesais pas quoi??????

Share this post


Link to post
Share on other sites

mount -a

EDIT et un petit man mount pour comprendre ce que tu fais.

Share this post


Link to post
Share on other sites

chameauman, faudrait peut-être le faire dans le bon sens... c'est qui si tu mettais de l'essence dans le réservoir de ta nouvelle que tu n'as pas encore commandé là.

1) d'abord créer le point de montage

2) éditer fstab (allez je te renote):

/dev/sda1	   /media/windows  ntfs	users,exec,ro,umask=0222 0 0

3) mount /media/windows dans mon cas ou mount -a (pour un répertoire, mount -a c'est bof quoi je trouve).

4) tu nous dis merci :cartonrouge:

Share this post


Link to post
Share on other sites

×
×
  • Create New...