Jump to content

Nouveaux Drivers Ati


Recommended Posts

Bonjour, je voulais savoir si quelqu'un a déjà installer les derniers drivers ati avec leur sublime programme pour configurer xorg, parce que j'ai essayer de l'utiliser, mais je n'arrive pas a obtenir l'accélération 3D. j'ai fai un aticonfig --initial, et donc ca ma théoriquement configurer mon xorg.conf, mais bon, ca me parait beaucoup trop simple.

damunix

Link to comment
Share on other sites

Bonjour, je voulais savoir si quelqu'un a déjà installer les derniers drivers ati avec leur sublime programme pour configurer xorg, parce que j'ai essayer de l'utiliser, mais je n'arrive pas a obtenir l'accélération 3D. j'ai fai un aticonfig --initial, et donc ca ma théoriquement configurer mon xorg.conf, mais bon, ca me parait beaucoup trop simple.

damunix

Tu as un backup de ton ancien xorg.conf configuré pour fglrx ? Si oui, garde le je pense :roll:

C'est ce que j'ai fait, et ct ok. Sinon, oui, le aticonfig, j'ai eu du mal comprendre comment l'utiliser, et a priori, il n'a pas marché :zarb:

Link to comment
Share on other sites

Ben maleureusement non, j'ai pas gardez de sauivegarde, paour la simple mais affreuse raison, j'ai mon écrzan de pc portable qui a fumer, donc retour en sav, et c con ils ont rien compris ils ont réinstaller le système d'origine après avoir réparer, donc adieu gentoo...... bande de boulet !!!!!! donc voila je me retrouve avec ce magnifique nouveau driver qui ne marche pas........... Peuvent pas le sortir en open source aussi qu'on puisse faire de VRAI driver !!!!!!!

damunix, en colère

Link to comment
Share on other sites

# === Screen Management ===

# Note: When OpenGL Overlay is enabled, Video Overlay

# will be disabled automatically

# vendor=1002, device=4150

Identifier "ATI Graphics Adapter"

Driver "fglrx"

Option "no_accel" "no"

Option "no_dri" "no"

# === misc DRI settings ===

Option "mtrr" "off" # disable DRI mtrr mapper, driver has its own code for mtrr

# Option "DesktopSetup" "0x00000000"

Option "MonitorLayout" "AUTO, AUTO"

Option "IgnoreEDID" "on"

Option "HSync2" "unspecified"

Option "VRefresh2" "unspecified"

Option "ScreenOverlap" "0"

# === TV-out Management ===

Option "NoTV" "yes"

Option "TVStandard" "NTSC-M"

Option "TVHSizeAdj" "0"

Option "TVVSizeAdj" "0"

Option "TVHPosAdj" "0"

Option "TVVPosAdj" "0"

Option "TVHStartAdj" "0"

Option "TVColorAdj" "0"

Option "GammaCorrectionI" "0x06419064"

Option "GammaCorrectionII" "0x00b02c0b"

# === OpenGL specific profiles/settings ===

Option "Capabilities" "0x00000000"

# === Video Overlay for the Xv extension ===

Option "VideoOverlay" "on"

# === OpenGL Overlay ===

Option "OpenGLOverlay" "off"

# === Center Mode (Laptops only) ===

Option "CenterMode" "off"

# === Pseudo Color Visuals (8-bit visuals) ===

Option "PseudoColorVisuals" "off"

# === QBS Management ===

Option "Stereo" "off"

Option "StereoSyncEnable" "0"

# === FSAA Management ===

Option "FSAAEnable" "no"

Option "FSAAScale" "1"

Option "FSAADisableGamma" "no"

Option "FSAACustomizeMSPos" "no"

Option "FSAAMSPosX0" "0.000000"

Option "FSAAMSPosY0" "0.000000"

Option "FSAAMSPosX1" "0.000000"

Option "FSAAMSPosY1" "0.000000"

Option "FSAAMSPosX2" "0.000000"

Option "FSAAMSPosY2" "0.000000"

Option "FSAAMSPosX3" "0.000000"

Option "FSAAMSPosY3" "0.000000"

Option "FSAAMSPosX4" "0.000000"

Option "FSAAMSPosY4" "0.000000"

Option "FSAAMSPosX5" "0.000000"

Option "FSAAMSPosY5" "0.000000"

# === Misc Options ===

Option "UseFastTLS" "1"

Option "BlockSignalsOnLock" "on"

Option "UseInternalAGPGART" "no"

Option "ForceGenericCPU" "no"

#BusID "PCI:1:0:0"

EndSection

avec bien sur le module de mon chip agp (nvidia-agp chez moi) + agpgart

et surtout enlever le support du DRI

et

Section "DRI"

# Access to OpenGL ICD is allowed for all users:

# Access to OpenGL ICD is restricted to a specific user group:

# Group 100 # users

# Mode 0660

Mode 0666

EndSection

ça devrait suffir, si ça ne marche pas, tu grep les EE de ton /var/log/Xorg.0.log et tu fais une recherche dans le forum avec ça :chinois:

Link to comment
Share on other sites

bon alors j'ai un message bizare dans le log de Xorg

(II) fglrx(0): [drm] DRM interface version 1.0
(II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:0:0"
(II) fglrx(0): [drm] added 8192 byte SAREA at 0xe0fca000
(II) fglrx(0): [drm] mapped SAREA 0xe0fca000 to 0xb7a49000
(II) fglrx(0): [drm] framebuffer handle = 0xd8000000
(II) fglrx(0): [drm] added 1 reserved context for kernel
(II) fglrx(0): DRIScreenInit done
(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0):	 Name: fglrx
(II) fglrx(0):	 Version: 8.23.7
(II) fglrx(0):	 Date: Mar  6 2006
(II) fglrx(0):	 Desc: ATI FireGL DRM kernel module
(II) fglrx(0): Kernel Module version matches driver.
(II) fglrx(0): Kernel Module Build Time Information:
(II) fglrx(0):	 Build-Kernel UTS_RELEASE:		2.6.14-gentoo-r5
(II) fglrx(0):	 Build-Kernel MODVERSIONS:		no
(II) fglrx(0):	 Build-Kernel __SMP__:			no
(II) fglrx(0):	 Build-Kernel PAGE_SIZE:		  0x1000
(II) fglrx(0): [drm] register handle = 0xd0100000
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
(EE) fglrx(0): cannot init AGP
(II) fglrx(0): [drm] removed 1 reserved context for kernel
(II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0xe0fca000 at 0xb7a49000
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!				  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)			 *
(WW) fglrx(0): * no 3D acceleration available				*
(WW) fglrx(0): ********************************************* *

j'ai recompiler le noyau, les modules et le driver ati, mais bon toujours pareille

Link to comment
Share on other sites

dans ton noyau :

Device Drivers  --->
	 Character devices  --->
  < > Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)

est bien décoché ?

d'autre part, ajoute intel-agp à la liste des modules à loader au demarrage (echo "intel-agp" >> /etc/modules.autoload.d/kernel-2.6)

et dans ton xorg.conf met l'option "UseInternalAGPGART" à "no"

voilà

Link to comment
Share on other sites

oui il est bien désactiver .

Pourquoi mettre ca au démarrage ? du reste ca ne sert a rien je ne l'es pas dasn mes modules. Ma carte mère est une basede via, donc il y aura très peut d'intel dedans. Dureste j'ai mis tout en dur dans mon noyau, ou presque...

quesque c'est chiant quand meme !!!!!

Link to comment
Share on other sites

non définitivement il veut pas. Une question aussi, avec les drivers ATI du noyau (j'ai un secodn pc ac une 9200), on le met dans le noyau, ok mais après, il y a quelque chose a configurer ? a installer ? xorg ca je veut bien, mais bon, j'ai pas la non plus d'accélération 3D.....

Link to comment
Share on other sites

Hellow,

Sorry je viens comme un cheveu dans la soupe mais je viens de mettre les nouveaux drivers sur ma mandriva et je me demandais si le fait que ce soit en rpm, et donc automatique, pouvait etre aussi mal foutu que toi?

J'avoue que j'ai pas encore su tester l'acceleration 3D faute de moyens (je sais pas comment on fait :ouioui:)

Link to comment
Share on other sites

Salut, j'ai la solution à ton problème,

http://www.rage3d.com/board/showpost.php?p...60&postcount=18

En gros : tapes dans une console

$ cat /proc/mtrr

si la réponse est quelque chose comme ça (size > 2000000MB)

reg00: base=0x00000000 ( 0MB), size=984064MB: write-back, count=1

Alors voici la solution (en root)

$ init 3

(relog toi en root)

$ echo "disable=0" >| /proc/mtrr

$ echo "base=0x0 size=0x40000000 type=write-back" >| /proc/mtrr

$ init 5

$ fglrxinfo

Remplace 0x40000000 avec la valeur pour ta mémoire vive (pas video):

0x08000000 = 128Mb

0x10000000 = 256Mb

0x40000000 = 1Gb

0x60000000 = 1.5Gb

0x80000000 = 2Gb

et la ça doit fonctionner

Par contre cette méthode ne fonctionne que pour la session en cours, pour que ça marche tout le temps, tu dois faire un fichier texte avec les 2 ligne en "echo ...", nommé fix_mtrr par exemple, et le rajouter dans les scripts à lancer au démarrage (fichier /etc/init.d/boot.local dans mon cas).

Link to comment
Share on other sites

Non ben désolé, j'ai résolut mon probleme autrement. Voila ce que j'ai fais :

J'ai 'récupéré sur internet une version de Xorg que j'ai légèrement bidouiller, je pourai la mettre si cela interesse qulqu'un, ensuite j'ai recompiler le noyau avec en ajoutant le support (dans l'aGP) des processeur 64bits athlon, j'ai beau avoir un processeur 32 bits, j'ai souvent eu le problème, j'ai ensuite redémarrer, et là j'ai l'acélération 3D.... Enfin !!!!

avec un Glxgeras, cela me donne quelque chose comme 2440 ou un peu plus. Donc c'est pas trop mal.

pfffff c'est quand meme la galère !!!!! Ils exagerent...

damunix

Link to comment
Share on other sites

Hellow,

Apparement il y a un projet sur sourceforge.net nommé R300 et qui pourrait résoudre nos problèmes...

le petit lien : http://sourceforge.net/projects/r300

testé (il y a 2 mois, ça a sûrement évolué depuis) sur une radeon9600 et j'avais une bonne stabilité, malgré des perfs carément en dessous de fglrx.

par contre, cvs only...

d'ailleurs r300 a mergé avec le cvs de mesa :byebye:

Link to comment
Share on other sites

Hellow,

Apparement il y a un projet sur sourceforge.net nommé R300 et qui pourrait résoudre nos problèmes...

le petit lien : http://sourceforge.net/projects/r300

testé (il y a 2 mois, ça a sûrement évolué depuis) sur une radeon9600 et j'avais une bonne stabilité, malgré des perfs carément en dessous de fglrx.

par contre, cvs only...

d'ailleurs r300 a mergé avec le cvs de mesa :p

La par contre tu me parles en russe lol

J'ai rien capté!

Par contre, ya un truc qui me semble bizarre... En fait j'ai pas le 3D rendering mais j'ai qd meme la 3D puisque quand j'utilise la commande glxgears, j'ai qd meme de la 3D mais voici les perfs :

[tyrann@localhost Desktop]$ glxgears
1696 frames in 5.0 seconds = 339.188 FPS
1680 frames in 5.0 seconds = 335.964 FPS
Relais brisé (pipe)
[tyrann@localhost Desktop]$

C'est pas extraordinaire :byebye:

J'ai une radeon9700 mobility sur mon portable

Link to comment
Share on other sites

Chez moi, toutes les évolutions des drivers Linux d'ATI fonctionnent depuis 3 mois. J'ai une mobility x700 (radeon fglrx choisi et xorg 6.9 avec accél. 3D) et les 8.24.8 actuellement, et glxgears me renvoie aux environs de 4300 fps. J'ai configuré comme demandé, aticonfig --initial. J'avais les mêmes scores sous glxgears après un fglrxconfig.

Link to comment
Share on other sites

  • 3 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...