Jump to content

Archived

This topic is now archived and is closed to further replies.

Amnesiac

[Tuto][Débutant] Ubuntu

Recommended Posts

Essaye "dhcpcd eth0" pour voir (ou depuis une console dans le système)

Share this post


Link to post
Share on other sites

route -n

affiche bien la gateway appropriée ?

Si c'est le cas, est ce que tu peux pinger la passerelle ?

Si c'est le cas, est ce que tu as les bons dns dans ton /etc/resolv.conf ?

Si c'est le cas, est ce que tu peux les pinger ?

Tu peux directement faire un tracroute (ou un tracepath) sur tes dns pour éviter les deux pings.

Tu peux aussi tester la résolution de tes noms.

Par exemple

host pcinpact.com adsl-ns2.free.fr
host pcinpact.com 212.27.32.177
dig pcinpact.com @adsl-ns1.free.fr
dig pcinpact.com @212.27.32.176

Pour quelqu'un chez free.

Share this post


Link to post
Share on other sites
Essaye "dhcpcd eth0" pour voir (ou depuis une console dans le système)
ubuntu@ubuntu:~$ dhcpcd eth0
The program 'dhcpcd' is currently not installed.  You can install it by typing:
sudo apt-get install dhcpcd
You will have to enable the component called 'universe'
bash: dhcpcd: command not found
ubuntu@ubuntu:~$ sudo apt-get install dhcpcd
Reading package lists... Done
Building dependency tree	   
Reading state information... Done
E: Couldn't find package dhcpcd
ubuntu@ubuntu:~$

:transpi:

maintenant les tests de theocrite :

route -n

ca donne bien l'adresse de la passerelle :francais:

les pings fonctionnent (adrip ou adresse "texte) :

ubuntu@ubuntu:~$ ping www.yahoo.fr
PING www.euro.yahoo-eu1.akadns.net (217.146.186.51) 56(84) bytes of data.
64 bytes from www.vip.ird.yahoo.com (217.146.186.51): icmp_seq=1 ttl=54 time=48.7 ms
64 bytes from www.vip.ird.yahoo.com (217.146.186.51): icmp_seq=2 ttl=54 time=50.1 ms
64 bytes from www.vip.ird.yahoo.com (217.146.186.51): icmp_seq=3 ttl=54 time=50.3 ms
64 bytes from www.vip.ird.yahoo.com (217.146.186.51): icmp_seq=4 ttl=54 time=50.4 ms

--- www.euro.yahoo-eu1.akadns.net ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 2999ms
rtt min/avg/max/mdev = 48.725/49.923/50.425/0.715 ms

par contre, le tracepath :ouioui: :

ubuntu@ubuntu:~$ tracepath 217.146.186.51
1:  ubuntu.local (192.168.1.2)							 0.100ms pmtu 1500
1:  no reply
2:  no reply
3:  no reply
4:  no reply
5:  no reply

ubuntu@ubuntu:~$ tracepath www.yahoo.fr
1:  ubuntu.local (192.168.1.2)							 0.094ms pmtu 1500
1:  no reply
2:  no reply

on dirait qu'il ne trouve pas la passerelle :ouioui:

ça donne le meme résultat pour n'importe quelle adresse ip

Share this post


Link to post
Share on other sites

$ ou # cat /etc/resolv.conf

chez moi ca donne ca:

nameserver 208.67.222.222
nameserver 208.67.220.220
nameserver 212.27.54.252
nameserver 212.27.39.135
nameserver 212.27.53.252

(OpenDNS + Free)

Share this post


Link to post
Share on other sites

j'ai :

nameserver 192.168.1.1

donc l'adresse de la passerelle

il me dit que je n'ai pas les droits pour le modifier :francais:

Share this post


Link to post
Share on other sites

t'as les DNS sur ta passerelle???

sinon un ping 208.69.34.231 (www.google.fr) ca passe???

si oui:

sudo gedit /etc/resolv.conf

mets le mot de passe que tu utilise pour te loguer sur ta session.

mets les serveurs DNS d'OpenDNS, t'es sur que ceux-la fonctionnent. :ouioui:

nameserver 208.67.222.222
nameserver 208.67.220.220

si le ping passe pas, ya un souci :p

Share this post


Link to post
Share on other sites
mets le mot de passe que tu utilise pour te loguer sur ta session.
en live usb, je n'ai pas eu de mot de passe à saisir

j'arrive directement sur le bureau

je vais essayer le reste !

Share this post


Link to post
Share on other sites

1/Souvent certaines passerelles/routeurs ne se sentent plus pisser et décident de faire relay dns plus ou moins bien.

Quand c'est moins bien, il est utile de remettre des dns propres.

2/ dhcpd n'est pas toujours présent.

Globalement ils s'appelle toujours dhcp* ou pump* (essayer avec tabulation pour compléter).

3/ Que donnent les host et les dig ?

Share this post


Link to post
Share on other sites

avec sudo gedit /etc/resolv.conf

j'ai réussi à éditer et sauvegarder !

pour les résultats :

ubuntu@ubuntu:~$ ping www.google.fr
PING www.l.google.com (209.85.129.147) 56(84) bytes of data.
64 bytes from fk-in-f147.google.com (209.85.129.147): icmp_seq=1 ttl=243 time=46.3 ms
64 bytes from fk-in-f147.google.com (209.85.129.147): icmp_seq=2 ttl=243 time=39.2 ms
64 bytes from fk-in-f147.google.com (209.85.129.147): icmp_seq=3 ttl=243 time=45.9 ms
64 bytes from fk-in-f147.google.com (209.85.129.147): icmp_seq=4 ttl=243 time=41.9 ms
64 bytes from fk-in-f147.google.com (209.85.129.147): icmp_seq=5 ttl=243 time=46.0 ms

--- www.l.google.com ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 3999ms
rtt min/avg/max/mdev = 39.267/43.904/46.302/2.821 ms
ubuntu@ubuntu:~$

ubuntu@ubuntu:~$ ping 209.85.129.147
PING 209.85.129.147 (209.85.129.147) 56(84) bytes of data.
64 bytes from 209.85.129.147: icmp_seq=1 ttl=243 time=40.6 ms
64 bytes from 209.85.129.147: icmp_seq=2 ttl=243 time=45.7 ms
64 bytes from 209.85.129.147: icmp_seq=3 ttl=243 time=46.6 ms
64 bytes from 209.85.129.147: icmp_seq=4 ttl=243 time=45.7 ms

--- 209.85.129.147 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 2998ms
rtt min/avg/max/mdev = 40.659/44.691/46.620/2.369 ms
ubuntu@ubuntu:~$

ubuntu@ubuntu:~$ ping 208.69.34.231
PING 208.69.34.231 (208.69.34.231) 56(84) bytes of data.
64 bytes from 208.69.34.231: icmp_seq=1 ttl=49 time=180 ms
64 bytes from 208.69.34.231: icmp_seq=2 ttl=49 time=179 ms
64 bytes from 208.69.34.231: icmp_seq=3 ttl=49 time=179 ms
64 bytes from 208.69.34.231: icmp_seq=4 ttl=49 time=178 ms
64 bytes from 208.69.34.231: icmp_seq=5 ttl=49 time=183 ms

--- 208.69.34.231 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 3999ms
rtt min/avg/max/mdev = 178.833/180.493/183.868/1.828 ms
ubuntu@ubuntu:~$

ubuntu@ubuntu:~$ host pcinpact.com adsl-ns2.free.fr
Using domain server:
Name: adsl-ns2.free.fr
Address: 212.27.32.177#53
Aliases: 

Host pcinpact.com not found: 5(REFUSED)
ubuntu@ubuntu:~$

ubuntu@ubuntu:~$ host pcinpact.com 212.27.32.177
Using domain server:
Name: 212.27.32.177
Address: 212.27.32.177#53
Aliases: 

Host pcinpact.com not found: 5(REFUSED)
ubuntu@ubuntu:~$

ubuntu@ubuntu:~$ dig pcinpact.com 212.27.32.177

; <<>> DiG 9.4.2 <<>> pcinpact.com 212.27.32.177
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21271
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;pcinpact.com.			IN	A

;; ANSWER SECTION:
pcinpact.com.		9778	IN	A	194.246.101.68

;; AUTHORITY SECTION:
pcinpact.com.		7607	IN	NS	stalker.pcinpact.com.
pcinpact.com.		7607	IN	NS	baine.digital-network.net.

;; ADDITIONAL SECTION:
stalker.pcinpact.com.	86315	IN	A	194.246.101.191
baine.digital-network.net. 14129 IN	A	194.246.101.57

;; Query time: 31 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Thu May 22 16:51:47 2008
;; MSG SIZE  rcvd: 139

;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 54491
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;212.27.32.177.			IN	A

;; ANSWER SECTION:
212.27.32.177.		10000	IN	A	62.210.183.20
212.27.32.177.		10000	IN	TXT	"Fake Answer: NXDOMAIN"

;; Query time: 29 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Thu May 22 16:51:47 2008
;; MSG SIZE  rcvd: 81

ubuntu@ubuntu:~$

ubuntu@ubuntu:~$ dig pcinpact.com dsl-ns1.free.fr

; <<>> DiG 9.4.2 <<>> pcinpact.com dsl-ns1.free.fr
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29989
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;pcinpact.com.			IN	A

;; ANSWER SECTION:
pcinpact.com.		45760	IN	A	194.246.101.68

;; AUTHORITY SECTION:
pcinpact.com.		83567	IN	NS	baine.digital-network.net.
pcinpact.com.		83567	IN	NS	stalker.pcinpact.com.

;; Query time: 27 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Thu May 22 16:52:45 2008
;; MSG SIZE  rcvd: 107

;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2001
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;dsl-ns1.free.fr.		IN	A

;; ANSWER SECTION:
dsl-ns1.free.fr.	10000	IN	A	62.210.183.20
dsl-ns1.free.fr.	10000	IN	TXT	"Fake Answer: NXDOMAIN"

;; Query time: 30 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Thu May 22 16:52:45 2008
;; MSG SIZE  rcvd: 83

ubuntu@ubuntu:~$

Share this post


Link to post
Share on other sites

les ping sont passés, donc c'est bon maintenant :francais:

Share this post


Link to post
Share on other sites

Donc ça fonctionne ?

Pour info, les commandes que je t'ai donné c'était si tu était abonné à free (peut être bien uniquement pour les dégroupés, je ne sais pas).

En tout cas, tu peux voir avec le dig que ça fonctionne vu que tu as oublié le @ :craint:

Share this post


Link to post
Share on other sites
les ping sont passés, donc c'est bon maintenant :reflechis:
bah non

toujours pas :ouioui:

Firefox ne trouve pas google (soit en tapant www.google.fr , soit en tapant l'adresse Ip)

et comment expliquer que le tracepath ne passe pas le proxy ??

pour theo :

j'ai bien rentré le "@", mais ça changeait le prompt :craint: et le "@" ne s'affichait pas...

Share this post


Link to post
Share on other sites

Et pourtant, tu pingues google :

ubuntu@ubuntu:~$ ping www.google.fr
PING www.l.google.com (209.85.129.147) 56(84) bytes of data.
[...]
5 packets transmitted, 5 received, 0% packet loss, time 3999ms

Et dans le dig on voit bien que la résolution ne pose pas de problèmes.

ubuntu@ubuntu:~$ dig pcinpact.com 212.27.32.177
[...]
;; ANSWER SECTION:
pcinpact.com.		9778	IN	A	194.246.101.68
[...]
;; ANSWER SECTION:
212.27.32.177.		10000	IN	A	62.210.183.20
212.27.32.177.		10000	IN	TXT	"Fake Answer: NXDOMAIN"

Donc la résolution dns et la passerelle sont ok. Peut être un problème de conf de firefox. Est ce que tu as configuré quelque chose ? (proxy ?).

Sinon essaye un wget sur google pour être sûr.

Sinon peut être un firewall entre les deux qui bloque le port 80 et pas les requêtes ICMP.

Share this post


Link to post
Share on other sites
Peut être un problème de conf de firefox. Est ce que tu as configuré quelque chose ? (proxy ?).
j'ai mis sur "détection auto du proxy" (comme sur XP)
Sinon essaye un wget sur google pour être sûr.
c'est quoi "wget" ? :ouioui:
Sinon peut être un firewall entre les deux qui bloque le port 80 et pas les requêtes ICMP.
je vais regarder, mais au niveau logiciel, je n'ai rien installé

peut etre au niveau matériel sur la cm ? :ouioui:

Share this post


Link to post
Share on other sites

Bon alors dans ce cas, contente toi d'un

 telnet google.fr 80

Share this post


Link to post
Share on other sites
Bon alors dans ce cas, contente toi d'un
 telnet google.fr 80

ubuntu@ubuntu:~$ telnet google.fr 80
Trying 216.239.59.104...
Connected to google.fr.
Escape character is '^]'.
Connection closed by foreign host.
ubuntu@ubuntu:~$

:chinois:

Share this post


Link to post
Share on other sites

Heu, je ne sais pas si tu as remarqué, mais ça fonctionne :transpi:

Connected to google.fr.

Share this post


Link to post
Share on other sites
Heu, je ne sais pas si tu as remarqué, mais ça fonctionne :transpi:
:transpi:

en fait comme le prompt ne revenait pas, j'ai cru que ca ne fonctionnait pas :transpi:

donc ça doit être un problème de config de firefox !

Share this post


Link to post
Share on other sites

Probablement. Est ce que tu as un proxy ou non ? Et est ce que tu en as un de configuré dans firefox ?

Share this post


Link to post
Share on other sites

Salut tout le monde,

je trouve mon Ubuntu super lent sur mon laptop, en comparaison, Vista est 10x plus rapide.

Par exemple, lorsque je réduis une fenêtre, j'ai des trainés des contours pendants quelques secondes.

Si je bouge une fenêtre trop rapidement, celle-ci remplit complètement mon écran.

Le menu de gnome met 5 bonnes secondes à s'afficher, etc.

J'ai installé les derniers Catalysts, et voici mon Xorg :

Section "InputDevice"
Identifier	"Generic Keyboard"
Driver		"kbd"
Option		"XkbRules"	"xorg"
Option		"XkbModel"	"pc105"
Option		"XkbLayout"	"fr"
Option		"XkbVariant"	"latin9"
EndSection

Section "InputDevice"
Identifier	"Configured Mouse"
Driver		"mouse"
Option		"CorePointer"
Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
Identifier	"Synaptics Touchpad"
Driver		"synaptics"
Option		"SendCoreEvents"	"true"
Option		"Device"	"/dev/psaux"
Option		"Protocol"	"auto-dev"
Option		"HorizEdgeScroll"	"0"
EndSection

Section "Device"
Identifier	"Configured Video Device"
Driver		"fglrx"
EndSection

Section "Monitor"
Identifier	"Configured Monitor"
EndSection

Section "Screen"
Identifier	"Default Screen"
Monitor		"Configured Monitor"
Device		"Configured Video Device"
Defaultdepth	24
EndSection

Section "ServerLayout"
Identifier	"Default Layout"
 screen "Default Screen"
Inputdevice	"Synaptics Touchpad"
EndSection
Section "Module"
Load		"glx"
EndSection

Share this post


Link to post
Share on other sites

×
×
  • Create New...