Jump to content

Archived

This topic is now archived and is closed to further replies.

plarot_1

[noob] topic du parfait noob

Recommended Posts

le su on en parle abondamment.

:p surtout que sous Ubuntu Root est désactivé par défaut et qu'il faut utilisé sudo

Share this post


Link to post
Share on other sites

pour ta partie Wifi, sorry ... mais ce n'est pas à Linux qu'il faut s'en prendre, mais au constructeur qui ne daigne pas fournir de drivers ...

pour ta partie windows, lance en root un

fdisk -l

tu auras la liste de toutes les partitions lisibles sur ta machine ...

puis un

mount

pour voir ce qui est monté

d'ailleurs certains sont peut-être rendues dans /media ...

tu nous donnes ça et la dernière version de ton fichier /etc/fstab et on verra ce qu'on peut faire pour toi ...

Si par la suite te prends l'envie et le courage d'écrire un petit topic de 4/5 posts décrivant ton expérience d'installation Linux, les pb que tu as rencontré et les solutions apportées, la communauté t'en sera reconnaissante ... (si tu sais, partages)

Share this post


Link to post
Share on other sites
Si par la suite te prends l'envie et le courage d'écrire un petit topic de 4/5 posts décrivant ton expérience d'installation Linux, les pb que tu as rencontré et les solutions apportées, la communauté t'en sera reconnaissante ... (si tu sais, partages)

C'est une excellente idée :p C'est bien Sandeman d'encourager ce genre de démarche, et j'engage chaque membre de notre belle communauté à encourager les gens à le faire lorsque vous pensez que cela pourrait enrichir le contenu de notre source d'information linux. Qui sait, ptet qu'un jour le forum linux de pcINpact sera LA référence française linux :-D

C'est meme d'une maniere generale une belle facon de remercier la communauté qui t'as aider à résoudre ton probleme ou trouver le moyen de le résoudre. Bon, c'est sur, pas besoin d'un retour pour chaque post, mais c'est généralement un bon geste que de faire un récapitulatif du probleme et de la façon de le résoudre.

Share this post


Link to post
Share on other sites

oula il y a de la réponse aujourdui, bon alors, dans l'rdre :

@ saintshakajin : j'ai bel et bien recherché ce que tu m'avais dis mais la page dont tu parles ne m'a menée à rien .. j'ai donc suivi une sorte de tuto de telecharger.com ou ils expliquait beaucoupp plus simplement comment s'y prendre .. mais sans succès ..

@ Sandeman : 1° je vais faire ca je vous dis ce qu'il en est après ..

2° pour ce qui est d'un texte sur "mon expérience" linux c'est vrai que c'est une bonne idée et je dis pourquoi pas, mais seulement quand tout marchera correctement sinon il y aura des parties sans réponses .. mais vraiment je serais pret à le faire

pour le wifi, je vais aller chercher ma clé USB wifi et voir si elle fonctionne mais en lisant les pages sur lstab, j'ai vu qu'il fallait aussi rajouter une ligne pour les clé USB pour qu'elle soit reconnues mais esque pour ma clé s'en est de meme ?

merci à tous !

:eeek2:

Share this post


Link to post
Share on other sites

bon voila un petit rapport pour les choses demandées :

fdisk -l

root@ubuntu:/home/benjamin # fdisk -l

Disque /dev/hdc: 80.0 Go, 80026361856 octets

255 têtes, 63 secteurs/piste, 9729 cylindres

Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce    Début        Fin      Blocs    Id  Système

/dev/hdc1  *          1        2295    18434556    7  HPFS/NTFS

/dev/hdc2            2296        9728    59705572+  f  W95 Etendu (LBA)

/dev/hdc5            2296        9728    59705541    7  HPFS/NTFS

Disque /dev/hdd: 13.0 Go, 13020069888 octets

255 têtes, 63 secteurs/piste, 1582 cylindres

Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce    Début        Fin      Blocs    Id  Système

/dev/hdd1  *          1        1514    12161173+  83  Linux

/dev/hdd2            1515        1582      546210    5  Extended

/dev/hdd5            1515        1582      546178+  82  Linux swap / Solaris

mount

/dev/hdd1 on / type ext3 (rw,errors=remount-ro)

proc on /proc type proc (rw)

sysfs on /sys type sysfs (rw)

devpts on /dev/pts type devpts (rw,gid=5,mode=620)

tmpfs on /dev/shm type tmpfs (rw)

/dev on /.dev type unknown (rw,bind)

none on /dev type tmpfs (rw,size=5M,mode=0755)

usbfs on /proc/bus/usb type usbfs (rw)

fstab (remis d'origine)

# /etc/fstab: static file system information.

#

# <file system> <mount point>  <type>  <options>      <dump>  <pass>

proc            /proc          proc    defaults        0      0

/dev/hdd1      /              ext3    defaults,errors=remount-ro 0      1

/dev/hdd5      none            swap    sw              0      0

/dev/hda        /media/cdrom0  udf,iso9660 ro,user,noauto  0      0

/dev/fd0        /media/floppy0  auto    rw,user,noauto  0      0

donc voila en gros on voit qu'il reconnait mon disque dur windows (le 80Go) d'après ce que j'ai compris et que apparament les partitions s'appeleraient hdc1&5 c'est ca ?

merci

++

Share this post


Link to post
Share on other sites

exactement. Content de voir que la lumière à toi s'est faite.

mkdir /mnt/windows1
mount -t auto /dev/hdc1 /mnt/windows1
mkdir /mnt/windows2
mount -t auto /dev/hdc5 /mnt/windows2

echo "/dev/hdc1      /mnt/windows1              ntfs   auto  0      1" >> /etc/fstab
echo "/dev/hdc5      /mnt/windows2              ntfs    auto 0      1" >> /etc/fstab

à adapter à tes besoins (pour le nom des montages Windows)

Share this post


Link to post
Share on other sites

merci pour ta rep mais la lumiere s'est pas encore tout a fait faite lol il me reste pas mal d'ombre ... quesque tu entends par "à adapter à tes besoins (pour le nom des montages Windows) " sachant que j'ai 2 partitions (C: et D: .. je ne sais pas si c'est ca que tu veux dire et ou les mettre)

merci

EDIT : a oui et aussi esqu'il me faut rajouter une ligne dans le fstab pour que ubuntu reconnaisse ma clé USB wifi ??

Share this post


Link to post
Share on other sites

c'est pour les /mnt/windows1 et /mnt/windows2, tu les appelles comme tu veux, le tout c'est :

1. de les créer

2. rester cohérent (si tu créé /mnt/win_c, faut mettre /mnt/win_c dans le fstab)

sinon, pour ta clef usb, s'il n'y a pas de systeme de fichiers à monter, alors pourquoi diable veux-tu la monter ? si ce n'est un périphérique n'offrant pas d'arborescence, tu n'a rien à monter, logique, non ?

Share this post


Link to post
Share on other sites

bon j'ai fait comme vous avez en restant cohérent, je reboot et voial ce qu'il me disent :

*mounting local filesystem ...

[mntent] : line 11 in /etc/fstab is bad

[mntent] : line 13 in /etc/fstab is bad

[mntent] : line 15 in /etc/fstab is bad

[mntent] : line 16 in /etc/fstab is bad

mount : mount point /mnt/c does not exist

mount : mount point /mnt/d does not exist

donc je ne comprends pas trop .. voila mon fstab :

# /etc/fstab: static file system information.

#

# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc            /proc           proc    defaults        0       0

/dev/hdd1       /               ext3    defaults,errors=remount-ro 0       1

/dev/hdd5       none            swap    sw              0       0

/dev/hda        /media/cdrom0   udf,iso9660 ro,user,noauto  0       0

/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0

mkdir /mnt/c windows

mount -t auto /dev/hdc1 /mnt/c windows

mkdir /mnt/d windows

mount -t auto /dev/hdc5 /mnt/d windows

echo "/dev/hdc1      /mnt/c windows              ntfs    auto 0      1" >> /etc/fstab

echo "/dev/hdc5      /mnt/d windows              ntfs    auto 0      1" >> /etc/fstab

et voila mon dossier mnt : http://img.photobucket.com/albums/v214/plarot_1/mnt.png

je viens d'avoir une petite idée en voyant le post de lorinc, peu-etre ne faut-il pas mettre d'espace dans les noms de fichiers et à la place des "_" ?? enfin c'est juste une supposition .

++ et merci

EDIT : autre chose aussi : comment passer en root avec "sudo" avec le poste de travail (l'explorateur quoi) parceque vu que j'ai pas trouvé la solution je suis obligé de créer les dossiers dans /mnt/ sous windows vu que je n'ai pas les droits root pour pouvoir les créer

et pour la clé USB, comment savoir si il la reconnait et si il l'a installée ??

merci

Share this post


Link to post
Share on other sites

vi, c'est exactement ça. il te dit que /mnt/c n'existe pas au lieu de "/mnt/c windows", parce qu'il ne prend pas les espaces.

les espaces sont assez compliqué à gerer, donc remplace les par des _ :francais:

Share this post


Link to post
Share on other sites

ralala qeul abruti .. je vais essayer ca de suite

et sion peu tu regarder vite fait ce que j'ai édité dans mon message précédent

merci beaucoup

Share this post


Link to post
Share on other sites

bon pour le "sudo nautilus", ca marche mais le reste ne marche pas !

voila ce que j'ai au démarrage après avoir modifié le fstab comme ceci :

# /etc/fstab: static file system information.

#

# <file system> <mount point>  <type>  <options>      <dump>  <pass>

proc            /proc          proc    defaults        0      0

/dev/hdd1      /              ext3    defaults,errors=remount-ro 0      1

/dev/hdd5      none            swap    sw              0      0

/dev/hda        /media/cdrom0  udf,iso9660 ro,user,noauto  0      0

/dev/fd0        /media/floppy0  auto    rw,user,noauto  0      0

mkdir /mnt/c_windows

mount -t auto /dev/hdc1 /mnt/c_windows

mkdir /mnt/d_windows

mount -t auto /dev/hdc5 /mnt/d_windows

echo "/dev/hdc1      /mnt/c_windows              ntfs    auto 0      1" >> /etc/fstab

echo "/dev/hdc5      /mnt/d_windows              ntfs    auto 0      1" >> /etc/fstab

ensuite au démarrage j'ai :

* Checking root file system ...

WARNING: bad format on line 10 of /etc/fstab

WARNING: bad format on line 12 of /etc/fstab

--------------(quelques lignes passent)---------------

*Checking all files systems ...

WARNING: bad format on line 10 of /etc/fstab

WARNING: bad format on line 12 of /etc/fstab

*mounting local filesystems ...

[mntent] : line 11 in /etc/fstab is bad

[mntent] : line 13 in /etc/fstab is bad

[mntent] : line 15 in /etc/fstab is bad

[mntent] : line 16 in /etc/fstab is bad

mount : unknown filesystem type"

mount : unknown filesystem type"

donc voila je n'y comprends plus rien la la lumière s'est éteinte :transpi:

merci de m'aider :francais:

Share this post


Link to post
Share on other sites

aïe aïe... :|

mkdir /mnt/c_windows
mount -t auto /dev/hdc1 /mnt/c_windows
mkdir /mnt/d_windows
mount -t auto /dev/hdc5 /mnt/d_window

ça s'était des commande à mettre dans la console...

mkdir, c'est pour créer le repertoire (tu l'as déjà fais, donc le refait pas...)

mount, c'est pour monter l'arborescence. je t'invite à lire le tuto de rem sur le fstab et les systemes de fichiers :incline:

echo "/dev/hdc1      /mnt/c_windows              ntfs    auto 0      1" >> /etc/fstab
echo "/dev/hdc5      /mnt/d_windows              ntfs    auto 0      1" >> /etc/fstab

ça aussi...

echo est une commande pour afficher une prahse à l'écran, et >> redirige la sortie (donc l'écran) vers la fin d'un fichier. concretement, ça fait ecrire "/dev/hdc1 /mnt/c_windows ntfs auto 0 1" à la fin de fstab.

là, je t'invite à lire le tuto sur les première commande à connaître sous linux (je ne me rappelle plus le titre exact ;) )

ce qui à pôur effet de modifier ton fstab comme suit :

# /etc/fstab: static file system information.

#

# <file system> <mount point>  <type>  <options>      <dump>  <pass>

proc            /proc          proc    defaults        0      0

/dev/hdd1      /              ext3    defaults,errors=remount-ro 0      1

/dev/hdd5      none            swap    sw              0      0

/dev/hda        /media/cdrom0  udf,iso9660 ro,user,noauto  0      0

/dev/fd0        /media/floppy0  auto    rw,user,noauto  0      0

/dev/hdc1      /mnt/c_windows              ntfs    auto 0      1

/dev/hdc5      /mnt/d_windows              ntfs    auto 0      1

voilou ;)

EDIT : les détails

Share this post


Link to post
Share on other sites

lol ! donc je vais remttre mon fstab d'origine et ensuite mettre tout ca dans la console :| quel boulet .. mdr

merci je te tiens au jus

Share this post


Link to post
Share on other sites

CA MARCHE !!!!!!!

(a part que je dois a chaque fois faire sudo nautilus pour pouvoir y acceder .. mais ca c'est un détail)

bon maintenant la prochaine étape c'est le wifi .. j'ai branché ma clé USB mais la il n'y a meme plus de catégorie réseau sans fils dans les connexions réseaux contrairement à quand j'avais ma carte pci ..

donc comment faire pour voir si il la reconnait et pour lui faire installer celle-ci ??

merci beaucoup tout le monde

Share this post


Link to post
Share on other sites

c'est pas du détail...

change les droits sur le dossier, et ça ira tout seul :|

Share this post


Link to post
Share on other sites

ok je vais essayer de trouver ca .. bon et puis pour le wifi je vais essayer de reprendre tous les conseils qui m'ont étés donné pour ma carte pci meme si je pense que ca n'a rien a voir vu que c'est en usb .. donc si quelqu'un a d'autres idées qu'il ne se gene pas ..

++ merci

Share this post


Link to post
Share on other sites

change ton fstab par celui ci:

# /etc/fstab: static file system information.
#
# <file system> <mount point>  <type>  <options>      <dump>  <pass>
proc            /proc          proc    defaults        0      0
/dev/hdd1      /              ext3    defaults,errors=remount-ro 0      1
/dev/hdd5      none            swap    sw              0      0
/dev/hda        /media/cdrom0  udf,iso9660 ro,user,noauto  0      0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0      0
/dev/hdc1      /mnt/c_windows              ntfs    auto,umask=0022 0      1
/dev/hdc5      /mnt/d_windows              ntfs    auto,umask=0022 0      1

et tu auras l'accès en lecture depuis nautilus sans faire sudo nautilus

Share this post


Link to post
Share on other sites

ok merci .. et pour avoir l'accès à l'écriture, ca me met une erreur quand je vais dans les propriétés comme quoi il est en lecture seule donc je peux pas .. donc si je peux pas enregistrer sur mon disque ca n'est qu'à moitié utile !

Share this post


Link to post
Share on other sites

lit bien le tuto de rem sur le fstab (cf meilleur lien) tout est éxpliqué d'une manière limpide et tu pourra customiser cela comme tu voudra :chinois:

Share this post


Link to post
Share on other sites

ok merci du conseil ! la je viens de remplacer mes lignes par les tiennes et ca marche nikel ..

pour le wifi j'ai aucun résultat :cartonrouge: une idée quelqu'un ?

merci à tous

Share this post


Link to post
Share on other sites
change ton fstab par celui ci:

# /etc/fstab: static file system information.
#
# <file system> <mount point>  <type>  <options>      <dump>  <pass>
proc            /proc          proc    defaults        0      0
/dev/hdd1      /              ext3    defaults,errors=remount-ro 0      1
/dev/hdd5      none            swap    sw              0      0
/dev/hda        /media/cdrom0  udf,iso9660 ro,user,noauto  0      0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0      0
/dev/hdc1      /mnt/c_windows              ntfs    auto,umask=0222 0      1
/dev/hdc5      /mnt/d_windows              ntfs    auto,umask=0222 0      1

et tu auras l'accès en lecture depuis nautilus sans faire sudo nautilus

Petite erreur dans le umask=xxxx

Sinon, le ntfs n'est pas accessible en écriture sous linux (du moins nativement)

si tu veux de l'accès ntfs en ecriture cherche du coté de captive ntfs

Share this post


Link to post
Share on other sites

je corrige le 222 .. mais je ne vis pas la différence entre ta 1ere et ta 2nd phrase :cartonrouge: avec le 222 si j'ai bien compris avec le post de rem, ca modifie les droits .. donc avec le 222 j'aurais les droits d'écriture en utilisateur non-root ?

Share this post


Link to post
Share on other sites

×
×
  • Create New...