Jump to content

Archived

This topic is now archived and is closed to further replies.

tuXXX

[Tuto][Initié] Noyau linux

Recommended Posts

ok mais alors comment en fait-on un nouveau?

quand j'ai refait mon kernel il ma fait un nouveau system map et une bzImage (vmlinuz) mais pas de initrd :s

il faut le refaire avec "mkinitrd"...

pour tout avouer, je ne le fait pas à la main, je laisse genkernel (sous gentoo) le faire tout seul...

Mais si tu veux, tu utilise mkinitrd et après, tu te fait ton propre script et tu le met dedans...

Sinon, tu peux juste utiliser un ancien initrd, mais il faut le modifier :

 $ cd /boot
$ cp initrd-2.6.<X> initrd-2.6.<Y>.gz
$ gunzip initrd-2.6.<Y>.gz
$ mount -o loop initrd-2.6.<Y> /mnt/<mountpoint>

(évidemment tu remplace ce qu'il y a entre <> par ce qui va bien)

puis tu regarde tous les modules qui sont déjà là :

 $ find /mnt/<mountpoint>/lib/modules/2.6.<X>

ensuite, tu enlève les modules de l'ancien noyau :

 $ rm -r /mnt/<mountpoint>/lib/modules/2.6.<X>

ensuite, tu recrée un répertoir qui a le même nom que le numéro du noyau :

 $ mkdir /mnt/<mountpoint>/lib/modules/2.6.<Y>

puis tu copie les modules dont tu as besoin dans le linuxrc (les mêmes que ceux qui étaient dans l'autre répertoire)

et enfin, tu démonte l'initrd et tu le recompresse:

 $ umount /mnt/<mountpoint>
$ gzip initrd-2.6.<Y>
$ mv initrd-2.6.<Y>.gz initrd-2.6.<Y>

et voilà !!!

(au passage, si tu ne modifie pas le linuxrc qui est dedans l'initrd, et que les modules te sont inutiles, c'est pas super utile...)

Link to post
Share on other sites

ok.

la je crois avoir compris pkoi encore en 2.4 j'arrive a recompiler ais pkoi avec le noyau 2.6 il ma dit niet :vomi2:

je teste ca des que je recupere le net(ya des cons d'orage par chez moi qui ont cramé mon routeur :'(

Link to post
Share on other sites
avec debian y a l'option --intird lors du make kpkg pour faire le initrd.

ouais, mais je lui expliquait un peu comment faire à la main... juste pour montrer un peu comment ça marche (et puis, ça peut intéresser du monde...)

Link to post
Share on other sites
server:/home/switch# uname -r

2.6.7-1-686

bon non je suis pas fier de moi :'(

j'ai fait un apt-cache search kernel et en cherchant j'ai trouvé une kernel image pour mon system

mais il la carrement installé (normale en fait venant de apt-get :)) mais j'ai pas les sources dans /usr/src ni acces au config pour pouvoir le retoucher :'(

a part ca j'ai rien touché et mon X free met enfin moin de 10 secondes a se lancer :keskidit:

(oui il mettais souvent plus d'une minute juska ce matin :) )

Link to post
Share on other sites

'ai fait un apt-cache search kernel et en cherchant j'ai trouvé une kernel image pour mon system

mais il la carrement installé (normale en fait venant de apt-get :))

ouais enfin tu as fais un apt-get install poru installer...

C'est quioi ce delire avec le noyau debian la, qui dure depuis jene sais combien de page ??? Mon tuto n'est pas clair sur un point ?

Link to post
Share on other sites

bah pour 2.4 ca allais

passage 2.4----> 2.6 la c la 1er fois que je boot et j'y suis pour rien

j'ai pas fait gaffe si ca venais du initrd mon pb :)

mais la je vais tester ca cet aprem

make-kpkg --initrd --revision=1.0 kernel-image

si je spas de retour ce soir c que ca a pas marché. ou que mon routeur a repris la foudre :'(

Link to post
Share on other sites

euh j'ai dl les sources du 2.6.7

#make xconfig

* Unable to find the QT installation. Please make sure that the

* QT development package is correctly installed and the QTDIR

* environment variable is set to the correct location.

et apt il trouve pas QT :s

kkun a une source?

Link to post
Share on other sites
euh j'ai dl les sources du 2.6.7

#make xconfig

et apt il trouve pas QT :s

kkun a une source?

ben tu fait "make menuconfig" ...

tu me remercira plus tard quand tu devra le faire sur un PC sans X... (en plus, je trouve ça mieux, plus simple...)

Link to post
Share on other sites

je te remercie en retard :mdr: ayé mon PC a X

make menu conf en fait il avais un pb avec les Ncurses donc j'etais carrement partit sur make config

mais c troppppppppppp lonngggggggggggggg

donc par forcing j'ai installé mes Ncurses apt me disais que j'avais la dernieres version dpkg me repondais rien :'(

allez soyez cool c quoi QT? pour moi c quick time ;)

Link to post
Share on other sites

<modprobe noob>

Quand je demarre avec un nouveau noyau , je toruve plus mes modules :/

Par exemple le driver eagle pour le sagem fast 800 "n'exsite plus" modprobe eagle-usb ne donne rien

Je comprend pas si c'est normal et si il faut donc que je le reemerge ou si c'est un probleme ou s'il faut faire une commande (modules-update?) ...

Link to post
Share on other sites
<modprobe noob>

Quand je demarre avec un nouveau noyau , je toruve plus mes modules :/

Par exemple le driver eagle pour le sagem fast 800 "n'exsite plus" modprobe eagle-usb ne donne rien

Je comprend pas si c'est normal et si il faut donc que je le reemerge ou si c'est un probleme ou s'il faut faire une commande  (modules-update?) ...

oui, les modules sont uniques au noyau, et il en faut des nouveaux (recompiler, quoi) à chaque changement de noyau

EDIT : mis à jour...

Link to post
Share on other sites

bah voila j'ai retesté de faire mon kernel 2.6.7 a la main

et au boot

unexpected command ou format non pris en charge <ext2>

il est gentil je suis en ext3 :fumer:

donc voila je patauge toujours avec le kernel 2.6 :'(

PS j'ai pas testé avec l'options --initrd pour refaire mon noyau mais etant donné kil boot deja pas :'(

Link to post
Share on other sites
bah voila j'ai retesté de faire mon kernel 2.6.7 a la main

et au boot

unexpected command ou format non pris en charge <ext2>

il est gentil je suis en ext3 :fumer:

donc voila je patauge toujours avec le kernel 2.6 :'(

PS j'ai pas testé avec l'options --initrd pour refaire mon noyau mais etant donné kil boot deja pas :'(

oui, le ext3 est juste un ext2 journalisé...

la prochaine fois, essaye de mettre le support ext2 et ext3 en dur dans le noyau ! ça peut être utile pour booter...

Link to post
Share on other sites

t'as le même problème que moi, il manque le 'e' à ls, je peux pas faire

Ben ouais mon ami, rigole pas, pk tu crois que je dis toujours -harl ??? C'est pratique, et en plus a un putain de 'e' pret.... Et puis ca, on peut pas aliaser les options....

Link to post
Share on other sites


×
×
  • Create New...