Jump to content

Archived

This topic is now archived and is closed to further replies.

newbix

PCTV sur MDK10 ????

Recommended Posts

salut a tous

Bon alors soit je suis un boulet soit j'ai un serieux probleme (je pencherais plus tot pour le boulet :inpactitude2:) donc

J'ai cree ce docier /dev/v4l avec vbi0 et video0 dedans, et video0 dans /dev

En suite j'ai refait mon fichier module.conf il y a dedans maintenant ca :

alias char-major-81 bttv

pre-install bttv modprobe -k tuner

options i2c verbose=1 scan=1 i2c_debug=0

options bttv radio=0 card=39 vidmem=0xd00

options tuner debug=0 type=3

Apres j'ai cree un lien symbolique entre /dev/video0 et /dev/v4l/video0 avec :

En root:

ln -s /dev/v4l/video0 /dev/video0

Et puis de toute facon je demare xawtv avec xawtv -c /dev/v4l/video0 comme le dit Zav

Apres j'ai taper ca, je crois que ca doit configurer qqchose, c'etait sur lea linux :

[newbix@localhost newbix]$ cd /usr/local/bin

[newbix@localhost bin]$ v4l-conf

Et apres, je demare xawtv et la :arreterstop::cdmalades: rien!! :menfin::mdr:

Link to post
Share on other sites

bon , on va reprendre du debut:

tu est sur mandrake 10 final ?

tu utilise le kernel 2.4 ou le 2.6 ?

>uname -a (pour etre sur)

>lspci (pour connaitre le matos)

car , comme je l'ai deja dit pour un 2.4 les options sont a passer a modules.conf

et pour un 2.6 à modprobe.conf (c'est pas pareil)

Quand tu redemmare , est-ce que tu /dev/v4l/* ?

si ce n'est pas le cas :

lsmod (pour verifier les modules charger)

Si le module bttv n'est pas dans la liste :

modprobe bttv (c'est ce modules qui doit creer tout seul /dev/v4l/*)

Une fois cela fait

dmesg |grep bttv (pour verifier , une fois de plus)

lance xawtv:

xawtv -c /dev/v4l/video0 -v 1

et note bien ce qu'il raconte dans la console (message d'erreur , truc bizzare ...)

ps:

si tu as un dual-boot linux/windaube , ta carte marche t'elle bien sous windaube ?

Link to post
Share on other sites

Salut a tous!!

Alors pour le kernel :

[newbix@localhost newbix]$ uname -a

Linux localhost 2.6.3-7mdk #1 Wed Mar 17 15:56:42 CET 2004 i686 unknown unknown GNU/Linux

Le Matos :

[newbix@localhost newbix]$ lspci

00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host Bridge (rev 11)

00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP Bridge (rev 11)

00:1d.0 USB Controller: Intel Corp. 82801DB USB (Hub #1) (rev 02)

00:1d.1 USB Controller: Intel Corp. 82801DB USB (Hub #2) (rev 02)

00:1d.2 USB Controller: Intel Corp. 82801DB USB (Hub #3) (rev 02)

00:1d.7 USB Controller: Intel Corp. 82801DB USB2 (rev 02)

00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB PCI Bridge (rev 82)

00:1f.0 ISA bridge: Intel Corp. 82801DB LPC Interface Controller (rev 02)

00:1f.1 IDE interface: Intel Corp. 82801DB Ultra ATA Storage Controller (rev 02)

00:1f.3 SMBus: Intel Corp. 82801DB/DBM SMBus Controller (rev 02)

00:1f.5 Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio Controller (rev 02)

01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

03:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd.: Unknown device 8180 (rev 20)

03:03.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)

03:03.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)

Voici mon modprobe.conf :

alias net-pf-4 ipx

alias autofs autofs4

alias sound-slot-0 snd-intel8x0

options bttv tuner=3 card=39

alias char-major-89-* i2c-dev

options i2c-core i2c_debug=1

options i2c-algo-bit bit_test=1

alias char-major-81-* videodev

alias char-major-81-0 bttv

options bttv tuner=3 card=39

options tuner debug=1

install snd-intel8x0 /sbin/modprobe --first-time --ignore-install snd-intel8x0 && { /sbin/modprobe snd-pcm-oss; /bin/true; }

install usb-interface /sbin/modprobe usb-uhci; /sbin/modprobe ehci-hcd; /bin/true

remove snd-intel8x0 { /sbin/modprobe -r snd-pcm-oss; } ; /sbin/modprobe -r --first-time --ignore-remove snd-intel8x0

Au reboot je vois pas /dev/v4l/..... :D

Donc je tape :

[newbix@localhost newbix]$ lsmod

bash: lsmod: command not found :-D:-D;);)

[newbix@localhost newbix]$ modprobe bttv

bash: modprobe: command not found :pleure::pleure::pleure::pleure:

[newbix@localhost newbix]$ xawtv -c /dev/v4l/video0 -v 1

This is xawtv-3.91, running on Linux/i686 (2.6.3-7mdk)

visual: id=0x21 class=4 (TrueColor), depth=24

visual: id=0x22 class=5 (DirectColor), depth=24

x11: color depth: 24 bits, 3 bytes - pixmap: 4 bytes

x11: color masks: red=0x00ff0000 green=0x0000ff00 blue=0x000000ff

x11: server byte order: little endian

x11: client byte order: little endian

check if the X-Server is local ... * ok (unix socket)

main: dga extention...

DGA version 2.0

main: xinerama extention...

main: xvideo extention ...

main: xvideo extention [image]...

image format list for port 53

0x32595559 (YUY2) packed [ok: 16 bit YUV 4:2:2 (packed, YUYV)]

0x32315659 (YV12) planar

0x59565955 (UYVY) packed [ok: 16 bit YUV 4:2:2 (packed, UYVY)]

0x30323449 (I420) planar [ok: 12 bit YUV 4:2:0 (planar)]

main: init main window...

main: install signal handlers...

main thread [pid=3240]

main: open grabber device...

x11: 1024x768, 32 bit/pixel, 4096 byte/scanline, DGA

v4l-conf: using X11 display :0.0

dga: version 2.0

mode: 1024x768, depth=24, bpp=32, bpl=4096, base=0xd0000000

can't open /dev/v4l/video0: No such file or directory :pleure::pleure::pleure:

got sigchild

waitpid: No child processes

v4l-conf had some trouble, trying to continue anyway :pleure::pleure::pleure:

vid-open: trying: v4l2-old...

v4l2: open /dev/v4l/video0: No such file or directory :pleure::pleure::pleure:

vid-open: failed: v4l2-old

vid-open: trying: v4l2...

v4l2: open /dev/v4l/video0: No such file or directory :pleure::pleure::pleure:

vid-open: failed: v4l2

vid-open: trying: v4l...

v4l: open /dev/v4l/video0: No such file or directory :pleure::pleure::pleure:

vid-open: failed: v4l

no video grabber device available :pleure::pleure::pleure:

Pour quoi tu t'en prend comme ca a moi je te traite bien pour tant snif :chinois:

Voila voila vous en savez autant que moi.

En tout cas merci beaucoup les gars de votre patience :inpactitude2::francais:

Link to post
Share on other sites
[newbix@localhost newbix]$ lsmod

bash: lsmod: command not found ;):yes::mdr::-D

[newbix@localhost newbix]$ modprobe bttv

bash: modprobe: command not found :D:yes::pleure::pleure:

Il faut que tu fasse ces commandes en étant connecté en root

(pour faire cela, de n'importe quelle console, tu peux faire "su", ou "su root", ou "su-l root" pour ouvrir temporairement une session en root (logout ou COntrol-D pour sortir))

Link to post
Share on other sites
Voici mon modprobe.conf :

alias net-pf-4 ipx

alias autofs autofs4

alias sound-slot-0 snd-intel8x0

options bttv tuner=3 card=39

alias char-major-89-* i2c-dev

options i2c-core i2c_debug=1

options i2c-algo-bit bit_test=1

alias char-major-81-* videodev

alias char-major-81-0 bttv

options bttv tuner=3 card=39

options tuner debug=1

install snd-intel8x0 /sbin/modprobe --first-time --ignore-install snd-intel8x0 && { /sbin/modprobe snd-pcm-oss; /bin/true; }

install usb-interface /sbin/modprobe usb-uhci; /sbin/modprobe ehci-hcd; /bin/true

remove snd-intel8x0 { /sbin/modprobe -r snd-pcm-oss; } ; /sbin/modprobe -r --first-time --ignore-remove snd-intel8x0

deja , tu as 2 fois

options bttv tuner=3 card=39

essaie plutot sa:

alias net-pf-4 ipx

alias autofs autofs4

alias sound-slot-0 snd-intel8x0

options i2c verbose=1 scan=1 i2c_debug=0

options bttv tuner=3 card=39 gbuffers=4

install snd-intel8x0 /sbin/modprobe --first-time --ignore-install snd-intel8x0 && { /sbin/modprobe snd-pcm-oss; /bin/true; }

install usb-interface /sbin/modprobe usb-uhci; /sbin/modprobe ehci-hcd; /bin/true

remove snd-intel8x0 { /sbin/modprobe -r snd-pcm-oss; } ; /sbin/modprobe -r --first-time --ignore-remove snd-intel8x0

Link to post
Share on other sites

Je sais que ma question n'est pas en rapport avec l'installation de la carte PCTV, mais chez moi ma carte renvoie un courant electrique par l'entree TV... y a comme un gros probleme la! Non! Est-ce normal docteur?

Je pense qu'elle est foutue tout simplement!

Link to post
Share on other sites

Je pense que je vais pas me casser la tete et regarder la tele sur le poste et pas sur l'ordi ;-P

Ca m'evitera de faire 2 trucs en meme temps... et ca me fera une economie de courant sur mon ordi en enlevant la carte... zou a la poubelle...

Link to post
Share on other sites

bonjour a tous voila pas de connection internet c'est dur

bon alors ma carte tv ne tourne toujours pas mais cette fois j'ai internet sur mon pc sous linux :chinois: la classe non

donc j'ai pris le max d'info :

[newbix@localhost newbix]$ uname -a

Linux localhost 2.6.3-7mdk #1 Wed Mar 17 15:56:42 CET 2004 i686 unknown unknown GNU/Linux

[newbix@localhost newbix]$ lspci

00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host Bridge (rev 11)

00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP Bridge (rev 11)

00:1d.0 USB Controller: Intel Corp. 82801DB USB (Hub #1) (rev 02)

00:1d.1 USB Controller: Intel Corp. 82801DB USB (Hub #2) (rev 02)

00:1d.2 USB Controller: Intel Corp. 82801DB USB (Hub #3) (rev 02)

00:1d.7 USB Controller: Intel Corp. 82801DB USB2 (rev 02)

00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB PCI Bridge (rev 82)

00:1f.0 ISA bridge: Intel Corp. 82801DB LPC Interface Controller (rev 02)

00:1f.1 IDE interface: Intel Corp. 82801DB Ultra ATA Storage Controller (rev 02)

00:1f.3 SMBus: Intel Corp. 82801DB/DBM SMBus Controller (rev 02)

00:1f.5 Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio Controller (rev 02)

01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

03:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd.: Unknown device 8180 (rev 20)

03:03.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)

03:03.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)

[newbix@localhost newbix]$ su

Password:

[root@localhost newbix]# lsmod

Module Size Used by

ppp_async 11744 1

ppp_generic 29552 5 ppp_async

slhc 7200 1 ppp_generic

appletalk 34868 2

ax25 60876 2

ipx 28268 2

sg 38044 0

st 38616 0

sr_mod 17028 0

sd_mod 16832 0

scsi_mod 114648 4 sg,st,sr_mod,sd_mod

binfmt_misc 9960 1

nvidia 4809036 12

snd-seq-oss 31232 0

snd-seq-midi-event 7552 1 snd-seq-oss

snd-seq 51024 4 snd-seq-oss,snd-seq-midi-event

snd-pcm-oss 51812 0

snd-mixer-oss 17952 1 snd-pcm-oss

snd-intel8x0 32776 0

snd-ac97-codec 58148 1 snd-intel8x0

snd-pcm 93156 2 snd-pcm-oss,snd-intel8x0

snd-timer 24484 2 snd-seq,snd-pcm

gameport 4480 1 snd-intel8x0

snd-page-alloc 11972 2 snd-intel8x0,snd-pcm

snd-mpu401-uart 7072 1 snd-intel8x0

snd-rawmidi 23616 1 snd-mpu401-uart

snd-seq-device 8008 3 snd-seq-oss,snd-seq,snd-rawmidi

snd 52484 12 snd-seq-oss,snd-seq-midi-event,snd-seq,snd-pcm-oss,snd-mixer-oss,snd-intel8x0,snd-ac97-codec,snd-pcm,snd-timer,snd-mpu401-uart,snd-rawmidi,snd-seq-device

soundcore 9248 1 snd

md5 3872 1

ipv6 232352 10

af_packet 20520 2

hid 53312 0

raw 7616 1

ide-floppy 18752 0

ide-tape 34864 0

ide-cd 40548 0

cdrom 37184 2 sr_mod,ide-cd

floppy 59444 0

eagle-usb 110816 0

supermount 37876 1

intel-agp 17372 1

agpgart 31016 2 intel-agp

ehci-hcd 24196 0

uhci-hcd 29104 0

usbcore 99132 6 hid,eagle-usb,ehci-hcd,uhci-hcd

rtc 11576 0

ext3 110408 2

jbd 54328 1 ext3

[root@localhost newbix]# modprobe bttv

[root@localhost newbix]# dmesg |grep bttv

bttv: driver version 0.9.12 loaded

bttv: using 8 buffers with 2080k (520 pages) each for capture

bttv: Bt8xx card found (0).

bttv0: Bt878 (rev 17) at 0000:03:03.0, irq: 19, latency: 32, mmio: 0xddafe000

bttv0: detected: Pinnacle PCTV [card=39], PCI subsystem ID is 11bd:0012

bttv0: using: Pinnacle PCTV Studio/Rave [card=39,autodetected]

bttv0: gpio: en=00000000, out=00000000 in=00fff3ff [init]

bttv0: i2c: checking for MSP34xx @ 0x80... not found

bttv0: pinnacle/mt: id=4 info="PAL+SECAM / mono" radio=no

bttv0: using tuner=33

bttv0: i2c: checking for MSP34xx @ 0x80... not found

bttv0: i2c: checking for TDA9875 @ 0xb0... not found

bttv0: i2c: checking for TDA7432 @ 0x8a... not found

bttv0: registered device video0

bttv0: registered device vbi0

bttv0: PLL: 28636363 => 35468950 .. ok

voila voila

et sur tout merci d'avance

Link to post
Share on other sites

Déjà, :francais::mdr:;);):eeek::eeek::eeek::eeek::eeek::eeek:

...voilà...donc ça, c'était pour la masse de modules...

ensuite, pour la carte TV, au lieu de faire "modprobe bttv", tu fait "modprobe bttv card=xx tuner=xx" (regarder par exemple le site de lea-linux, chercher "TV"...)

si tu met les bonnes options, ça devrait marcher, après, il suffira de mettre ces options au démarrage et ce sera bon :yes:

Link to post
Share on other sites

Salut bon ba non il ne veux toujours pas boufer ma carte :yes::eeek2:

il suffira de mettre ces options au démarrage et ce sera bon 

tu peut m'en dir plus

quand j'essaie de configurer le matos je met 39 pour la carte et 3 pour le tuner.

mais toujours rien : no chanel no chanel......

merci les gars

Link to post
Share on other sites

Tiens pendant que j'y pense personne à reussi à faire marcher la pc tv rave qui possede un chipset non compatible avec linux? je sais que c'est un peu vague mais y'a une serie de pc tv rave qui ne passe pas sous linux :yes: et j'ai pas les infos sous la main

Link to post
Share on other sites

salut tout le monde

alors rmmod bttv pour enlever les modules ca me donne ca :

[root@localhost newbix]# rmmod bttv

ERROR: Module bttv does not exist in /proc/modules

[root@localhost newbix]#

mon modprob.conf

si ca peut vous aider

alias sound-slot-0 snd-intel8x0

alias tty-ldisc-14 ppp_synctty

alias char-major-108-* ppp_generic

alias tty-ldisc-13 n_hdlc

options bttv tuner=3 card=39

install snd-intel8x0 /sbin/modprobe --first-time --ignore-install snd-intel8x0 && { /sbin/modprobe snd-pcm-oss; /bin/true; }

install usb-interface /sbin/modprobe usb-uhci; /sbin/modprobe ehci-hcd; /bin/true

remove snd-intel8x0 { /sbin/modprobe -r snd-pcm-oss; } ; /sbin/modprobe -r --first-time

--ignore-remove snd-intel8x0

alias /dev/nvidia* nvidia

et mon /proc/modules donne ca :

ppp_async 11744 1 - Live 0xe19da000

ppp_generic 29552 5 ppp_async, Live 0xe1c1f000

slhc 7200 1 ppp_generic, Live 0xe19b0000

appletalk 34868 2 - Live 0xe1a94000

ax25 60876 2 - Live 0xe1bd6000

ipx 28268 2 - Live 0xe19fc000

sg 38044 0 - Live 0xe19f1000

st 38616 0 - Live 0xe19e6000

sr_mod 17028 0 - Live 0xe19d4000

sd_mod 16832 0 - Live 0xe19ce000

scsi_mod 114648 4 sg,st,sr_mod,sd_mod, Live 0xe1c02000

binfmt_misc 9960 1 - Live 0xe19b3000

nvidia 4809036 12 - Live 0xe20f3000

snd-seq-oss 31232 0 - Live 0xe1b79000

snd-seq-midi-event 7552 1 snd-seq-oss, Live 0xe1a73000

snd-seq 51024 4 snd-seq-oss,snd-seq-midi-event, Live 0xe1bf4000

snd-pcm-oss 51812 0 - Live 0xe1be6000

snd-mixer-oss 17952 1 snd-pcm-oss, Live 0xe1b60000

snd-intel8x0 32776 0 - Live 0xe1b56000

snd-ac97-codec 58148 1 snd-intel8x0, Live 0xe1b69000

snd-pcm 93156 2 snd-pcm-oss,snd-intel8x0, Live 0xe1bbe000

snd-timer 24484 2 snd-seq,snd-pcm, Live 0xe1b4f000

gameport 4480 1 snd-intel8x0, Live 0xe1a89000

snd-page-alloc 11972 2 snd-intel8x0,snd-pcm, Live 0xe1a8e000

snd-mpu401-uart 7072 1 snd-intel8x0, Live 0xe1a30000

snd-rawmidi 23616 1 snd-mpu401-uart, Live 0xe1a65000

snd-seq-device 8008 3 snd-seq-oss,snd-seq,snd-rawmidi, Live 0xe1a23000

snd 52484 13 snd-seq-oss,snd-seq-midi-event,snd-seq,snd-pcm-oss,snd-mixer-oss,snd-intel8x0,snd-ac97-codec,snd-pcm,snd-timer,snd-mpu401-uart,snd-rawmidi,snd-seq-device, Live 0xe1b41000

soundcore 9248 1 snd, Live 0xe1a85000

md5 3872 1 - Live 0xe1a33000

ipv6 232352 10 - Live 0xe1b84000

af_packet 20520 2 - Live 0xe1a6c000

hid 53312 0 - Live 0xe1a76000

raw 7616 1 - Live 0xe1a26000

ide-floppy 18752 0 - Live 0xe1a2a000

ide-tape 34864 0 - Live 0xe1a5b000

ide-cd 40548 0 - Live 0xe1a50000

cdrom 37184 2 sr_mod,ide-cd, Live 0xe1a45000

floppy 59444 0 - Live 0xe1a35000

eagle-usb 110816 0 - Live 0xe1a04000

supermount 37876 1 - Live 0xe1843000

intel-agp 17372 1 - Live 0xe183d000

agpgart 31016 2 intel-agp, Live 0xe18c4000

ehci-hcd 24196 0 - Live 0xe1836000

uhci-hcd 29104 0 - Live 0xe180c000

usbcore 99132 6 hid,eagle-usb,ehci-hcd,uhci-hcd, Live 0xe186b000

rtc 11576 0 - Live 0xe1808000

ext3 110408 2 - Live 0xe184f000

jbd 54328 1 ext3, Live 0xe1815000

Link to post
Share on other sites


×
×
  • Create New...