Jump to content

Archived

This topic is now archived and is closed to further replies.

newbix

PCTV sur MDK10 ????

Recommended Posts

C'est ce que je disais plus haut, le vidmem doit etre a 0xd00 ;-P

ca veux dire que j'aurais peut regarder la tele hier soir!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

:pleure::devil:

:toutafaitdaccord:

:sm:;)

Share this post


Link to post
Share on other sites
can't open /dev/video0: No such file or directory

il faut se mefier:

certains programme tv utilise /dev/video0 au lieu de /dev/v4l/video0

Dans se cas la , il faut faire un lien symbolique (raccourcie)

en root:

ln -s /dev/v4l/video0 /dev/video0

ou , pour xawtv en tout cas , le lancer comme sa :

xawtv -c /dev/v4l/video0

Share this post


Link to post
Share on other sites

ah voila autre chose d'interessant :

parce-que je suis sur qu'il utilise /dev/video0

car le centre de configurations du materiel, on peut faire afficher les comandes correspondantes au actions,

et ca j'en suis sur,

xawtv utilise /dev/video0

Ca ce precise, ca ce precise

bon apetit a tous :francais::roll:

Share this post


Link to post
Share on other sites

Bon appetit,

en tout cas on va peut-etre avoir une solution pour cette petite PCTV miro Pro de Pinnacle... ce serait genial car je ne pense pas qu'on soit les seuls a vouloir regarder la tele sous Linux ;-P

par contre dans kdetv, il trouve bien tous mes settings, mais il ne trouve toujours pas une image correcte. Toujours de la neige, on se croirait en hiver.

Share this post


Link to post
Share on other sites

J'ai cherche kdetv mais il me renvoi toujours sur les distributions de packages du mandrakclub (club dont je ne suis pas encore membre mais ca ne s'aurais tarder) connais-tu un lien pour le dl gratuitement enfin si ca vaux le coup bien sur car j'ai une connection 56K chez moi que j'utilise tres rarement (forfait a la minute) :mdr:

Share this post


Link to post
Share on other sites

avant de faire les difficiles :transpi: , utiliser xawtv

Pour les images neigeuses et autre regarer d'abord si il est bien configuré:

dans votre home , il y a un fichier caché ,chez moi :

/home/zaverel/.xawtv

soit vous faite apparetre les fichiers cachés soit en console:

vi /home/zaverel/.xawtv

en france la norme c'est le secam

[global]

ratio = 4:3

freqtab = france

pixsize = 128 x 96

pixcols = 1

jpeg-quality = 75

keypad-ntsc = no

keypad-partial = yes

osd = yes

osd-position = 30 , 20

use-wm-fullscreen = yes

# [station name]

# capture = overlay | grabdisplay | on | off

# input = Television | Composite1 | S-Video | ...

# norm = PAL | NTSC | SECAM | ...

# channel = #

# fine = # (-128..+127)

# key = keysym | modifier+keysym

# color = #

# bright = #

# hue = #

# contrast = #

[defaults] <--parametre par default

group = main

norm = SECAM

input = Television

capture = grab

color = 28%

bright = 51%

contrast = 42%

[fr2]

channel = 23

norm = PAL <--force en pal -->image de daube

capture = on

[fr3]

channel = 29

capture = on

pour connaitre les frequences

http://www.annuradio.online.fr/tv.php

Share this post


Link to post
Share on other sites

Desole Zav,

bon bin moi je suis en Belgique, mais je dirai que j'ai le meme probleme que newbix, c'est d'avoir une PCTV pinnacle LOL....

par contre, kdetv, j'ai du le compiler sous Mandrake 10 ;-P

mais merci quand meme pour ton aide et ta patience.

sous Mandrake, xvt devrait configurer le fichier .xawtv automatiquement, le probleme c'est qu'il ne trouve pas de signal sur aucunes des frequences. La meilleur c'est qu'on peut mettre l'option "toutes" et ca te check les frequences de 10Mhz a 2000Mhz tout les 0.25Mhz, ca prend du temps, chez moi toujours pas de canaux corrects...

C'est certainement un probleme de config, je ne sais pas! Je ne desespere pas ;-))) on y arrivera...

Pour le download des sources de kdetv, c'est sur www.kdetv.org et c'est gratos ;-P

Share this post


Link to post
Share on other sites

:transpi:

cool l'option toutes tu fait comment???

pour le fichier .xawtv je l'avais deja regarde il est semblable sauf qu'il y a moins de trucs dedans mais je ne pense pas que ca vienne de la.

Share this post


Link to post
Share on other sites

Quasiment tous les fichiers de config des logiciels que vous utilisez régulièrement sont stockés dans votre répertoire personnel sous la forme de fichiers débutant par un point, soit dans des dossiers débutant par ce même point ...

On ne les voit en effet pas quand on fait ls ... mais ls -a

tout ça pour dire que la config de xawtv se trouve normalement dans ~/.xawtv ...

(J'espère que je ne vous apprends pas les fichiers cachés :mdr: )

Share this post


Link to post
Share on other sites

merci tuxx pour l'eclairage, :mdr::mdr:

je ne connaissais pas l'option -a

mais le reste si quand meme

Share this post


Link to post
Share on other sites

pour essayer de faire plus simple vous supprimer le fichier .xawtv

faite (pas en root)

cd (enter)

rm .xawtv

xawtv -c /dev/v4l/video0

la vous regler le standard : tv norm (pal ou secam)

frequence table : france (meme pour la belgique)

aller dans channel editor

mettre le curseur de la sourie dans le rectangle sous channel

l'y laisser

faire haut ou bas avec les fleches de direction (y'en a 4 c'est a coté du pavé numerique)

Si vous avez une chaine, mettre son nom dans "station id" , puis add et save

Si vous ne trouver aucune chaine c'est que le tuner n'est pas le bon

verifier vos options tuner pour bttv et recommencer.

Il faut etre sur de pouvoir scanner sinon sa marchera jamais (a moins de brancher un magnetoscope sur l'entré video de la carte tv)

En general , il y a plutot des probleme pour le son (j'en sais quelquechose)

 

cool l'option toutes tu fait comment???

je l'ai pas preciser car sa depend si vous etes sous ke , gnomes,....

c'est pour sa que j'ai dit d'utiliser vi

Sinon cherche dans "affichage" pour kde

Share this post


Link to post
Share on other sites

Après moulte check sous Linux, j'ai fait un control sous windows, desinstallé les programmes Pinnacle et réinstallé le tout. Le programme Pinnacle ne trouve pas plus de canaux que sous Linux...

C'est à dire zéro :-(

Par contre si je fais une recherche à la main, je trouve assez bien de canaux, mais la qualité est horriblement laide... Je pencherai pour un problème avec ma carte... va falloir démonter le bidule et le replugger comme il se doit... m'a l'air pourtant correctement placée cette maudite carte...

Faudra peut-etre que je regarde à brancher la télé dans mon bureau ;-P

Share this post


Link to post
Share on other sites

salut a tous

j'ai essaye de faire tout ce aue vous m'avez dit mais un truc manque a ma grande stupeure : c'est ce maudit

fichier video0 il n'existe pas, pas plus que le fichier v4l je ne sais donc pas comment faire j'ai peur que le module ne soit meme

pas instale sur mon noyau

Share this post


Link to post
Share on other sites

modprobe bttv :transpi:

Et puis, chez moi, c'est /dev/video0 ...

Share this post


Link to post
Share on other sites

Salut,

ou encore /dev/v4l/video0, mais je pense que tux ou zav l'avait déjà précisé... en tout cas sur ma mandrake 10, c'est /dev/v4l/video0, j'ai pas vérifié si il y avait un /dev/video0. Et mon modem ADSL ne fonctionnant pas en kernel 2.6, je suis condamné à utiliser ma Redhat 9 en 2.4 pour surfer... LOL

Share this post


Link to post
Share on other sites

pour ton modem usb, j'ai eu un pb du meme genre avec une merde de Sagem. Oui, je le clame haut et fort, Sagem ne sait pas faire de driver linux pour ses modems. Tous obliges d'utiliser un driver ecrit par des linuxiens.... C'est une honte.

Enfin, moi perso, en 2.6.5 et plus, ca ne fonctionne pas. Jusque 2.6.4 ca fonctionne impecable. Donc si tu veux profiter de ta red hat sous un noyau 2.6, prends donc un 2.6.4 et tentes le coup !

Share this post


Link to post
Share on other sites

tuxxx > tu me dis : modprobe bttv mais faut-il etre en usager root ?? par ce que le terminal me repond bash modprobe command not found enfin le truc abituel quoi !!! :chinois::incline::keskidit::keskidit::francais::transpi:

aussi, faut-il etre dans un fichier special ?? :transpi:

Share this post


Link to post
Share on other sites

oui pour faire modprobe , il faut etre en root.

et rmmod pour les enlevé

(se mefier car souvent un module en appelle un autre)

modprobe bttv > videodev , v4l2-common , video-buf , tuner ..... (j'en ai surement oublié) et

Une question :

quand vous installer mandrake , il vous installe quel kernel : le 2.4 ,le 2.6 ou les 2 ?

car en 2.4 les options pour les modules sont dans /etc/modules.conf

et en 2.6 dans /et/modprobe.conf

ce qui fait que c'est peut etre a cause de sa que tu est em***der

une autre:

c'est quoi cette histoire avec le modem sagem?

je suis en 2.6.6 et mon modem marche (sagem fast 800 )

Share this post


Link to post
Share on other sites

Ah bin moi il a marche mon mooodem Eicon Diva, en 2.6.3, bon maitenant il ne marche plus, mais il a marche... enfin fonctionner... il a pas de pattes mon modem non plus...

J'utilise le driver de flash code, çà marche pour lui sur tous les noyaux... pas vraiment pour moi, certainement une option que j'ai oubliée... il trouve mon modem, mais il n'arrive pas à l'initialiser...

Oui, Mandrake 10, c'est en 2.6 no problemo...

Share this post


Link to post
Share on other sites

bonjour a tous.

Donc voila hier il y avait le match alors j'ai pris un coup de speed, modprobe bttv n'a pas marcher enfin fonctionner ba il n'a pas de pattes ( :byebye: Lulu!!!! :mdr: )

donc j'ai fouiner un peut et j'ai trouver un fichier dans /usr/src/documentation/v4l qui s'appel MAKEDEV en fait c'est un script je l'ai alors executer dans un terminal en "super user" et il m'a cree un docier v4l dans /dev et un fichier video0_4 dans /dev et /dev v4l

Il y avais aussi un fichier module.conf dans la documentation que j'ai copier et rajouter a celui de /etc module.conf mais il ne me parais pas complet, je le completerais ce soir hier il y avais le match :francais::yes: bon il aurais pu mieu jouer mais on se contentera volontier du score :8 :yes::-D

mon noyau est un 2.6.3 sur ma mdk 10

Share this post


Link to post
Share on other sites

Salut,

je pense que tu devrais y arriver, en fait de mon cote, c'est la carte qui a un probleme, j'ai reinstalle le cd pinnacle et la carte sous Xp marche pas non plus... Je pense que l'italie et le denmark vont gagner ce soir... et demain ce sera la hollande et la republique czech...

est-ce que tu as configurer ton modem sous linux?

a bientot,

Lulunix...

Share this post


Link to post
Share on other sites

Alors comme ça, c'était la carte TV (euh, sûr que c'était pas la réception/le cable?)

c'est sûr, ça va tout de suite moins bien marcher... :chinois:

Share this post


Link to post
Share on other sites

euh, peut-etre le duplicateur alors, mais la tele du salon fonctionne tres bien... je pense pas que ce soit le cable... je penche pour la carte qui est naze... mais bon, je peux toujours changer la connexion au duplicateur...

Share this post


Link to post
Share on other sites

×
×
  • Create New...