Jump to content

Archived

This topic is now archived and is closed to further replies.

newbix

PCTV sur MDK10 ????

Recommended Posts

salut a tous

voila je vien d'installer mandrake 10 (j'avais 9.2 avant) et mon probleme est que ma carte tuner (dev/video0) ne fonctionne pas :

avec xawtv, tvtime, et zaping il n'y a rien a faire l'ecrant reste bleu et les HP muets

j'ai a maintes reprises lancer un scan des chaines mais rein!

avec le paneau de control de mandrake il me propose de configurer cette carte mais lui non plus il n'y arive pas!!

La seule hypothese que j'ai c'est que ma carte graphique n'est pas installee

nVidia Gforce FX 5200. l'acceleration est elle necessaire pour faire fonctionner ce type de device??

Pour la feme c'etait pure deconnade :chinois:

Share this post


Link to post
Share on other sites

Salut,

j'ai une PCTV Miro sous Mandrake 10, il détecte ma carte, il arrive a scanner certaine chaines, mais apparement les frequences en Belgique ne fonctionne pas tres bien, l'image est enneigée.

Voilà ce qu'il me fait avec drakxtv ;-P

Jun 7 10:55:04 dns drakxtv[1923]: running: /sbin/modprobe bttv

Jun 7 10:55:04 dns kernel: Linux video capture interface: v1.00

Jun 7 10:55:04 dns kernel: bttv: driver version 0.9.12 loaded

Jun 7 10:55:04 dns kernel: bttv: using 8 buffers with 2080k (520 pages) each for capture

Jun 7 10:55:04 dns kernel: bttv: Bt8xx card found (0).

Jun 7 10:55:04 dns kernel: bttv0: Bt878 (rev 17) at 0000:00:07.0, irq: 18, latency: 64, mmio: 0xdddfe000

Jun 7 10:55:04 dns kernel: bttv0: detected: Pinnacle PCTV [card=39], PCI subsystem ID is 11bd:0012

Jun 7 10:55:04 dns kernel: bttv0: using: Pinnacle PCTV Studio/Rave [card=39,autodetected]

Jun 7 10:55:04 dns kernel: bttv0: i2c: checking for MSP34xx @ 0x80... found

Jun 7 10:55:04 dns kernel: bttv0: miro: id=16 tuner=1 radio=fmtuner stereo=yes

Jun 7 10:55:04 dns kernel: bttv0: using tuner=1

Jun 7 10:55:04 dns kernel: bttv0: i2c: checking for MSP34xx @ 0x80... found

Jun 7 10:55:05 dns kernel: msp34xx: init: chip=MSP3450G-B8 +nicam +simple +radio

Jun 7 10:55:05 dns kernel: msp3410: daemon started

Jun 7 10:55:05 dns kernel: bttv0: i2c: checking for TDA9875 @ 0xb0... not found

Jun 7 10:55:05 dns kernel: bttv0: i2c: checking for TDA7432 @ 0x8a... not found

Jun 7 10:55:05 dns kernel: tvaudio: TV audio decoder + audio/video mux driver

Jun 7 10:55:05 dns kernel: tvaudio: known chips: tda9840,tda9873h,tda9874h/a,tda9850,tda9855,tea6300,tea6420,tda8425,pic16c54 (PV951),ta8874z

Jun 7 10:55:05 dns kernel: tuner: chip found @ 0xc2

Jun 7 10:55:05 dns kernel: tuner: type set to 1 (Philips PAL_I (FI1246 and compatibles))

Jun 7 10:55:05 dns kernel: bttv0: registered device video0

Jun 7 10:55:05 dns kernel: bttv0: registered device vbi0

Jun 7 10:55:05 dns kernel: bttv0: registered device radio0

Jun 7 10:55:05 dns kernel: bttv0: PLL: 28636363 => 35468950 .. ok

Jun 7 10:55:05 dns drakxtv[1923]: launched command: xvt -T 'Recherche des canaux de télévision ...' -e scantv -n PAL -C /dev/v4l/vbi0 -c /dev/v4l/video0 -f europe-west -o /home/lucienm/.xawtv

Jun 7 10:55:20 dns kernel: tuner: TV freq (0.00) out of range (44-958)

Jun 7 10:55:46 dns drakxtv[1923]: created file /home/lucienm/.xawtv

est-ce que dans /var/log/messages tu as ce genre de ligne?

pas de frequence qppqremment, mais comment c'est possible?

Share this post


Link to post
Share on other sites

drakxtv j'essaierais ca ce soir!!!

mais quand je fais un scan, il test les frequences une par une mais en face de chaqunes d'elles il met la petite notte :-D : no chanel found :pleure:

Share this post


Link to post
Share on other sites

Il scan une centaine de canaux, il y a des image brouilliées, mais le tuner ne s'arrête pas pour ajusté l'image... pourtant sous windaube...çà marche, pas d'une grande qualité pour certains canaux mais çà marche :-(

Je te comprends, c'est désepérant... par contre, si tu cherche mythtv ou que tu fait un apt-get mythtv, tu devrais trouver un outil super génial pour la gestion des canaux... une sorte de palette de sélection pour les différents programmes télé...

en tout cas sur tous les sites que j'ai vu, il suffit de charger bttv (le tuner télé/radio), v4l (vidéo for linux, je suppose que c'est le controleur d'acquisition vidéo), mais sous mandrake, il t'installe tout çà, il te load les modules automatiquement, pas besoin de réfléchir à une config trop complex...

sur un autre forum, quelqu'un m'a dit qu'il fallait installer un add-on tuner pour v4l, j'en voit pas vraiment l'intéret... le type n'a pas su s'expliquer...

J'ai essayé les trucs de léa-linux.org, çà n'a pas marché non plus... Enfn il y a toujours plus dans plusieures tête que dans la mienne peut-etre que quelqu'un pourra nous aider... Je faire un peut de place et installer Fedora pour voir si par magie la carte fonctionnerait.

Je compte bien viré windaube un jour ou l'autre ;-P

Share this post


Link to post
Share on other sites

Quel est le modele de ta carte tv ?

j'ai une pctv avec un bt848 et ce modele n'a pas d'autodetection du tuner.

Il faut donc le preciser sinon sa scanne dans le vide

dans mon modprobe.conf j'ai sa :

options bttv card=39 tuner=3 radio=0 pll=0

Share this post


Link to post
Share on other sites

Zalut,

euh pas détectée?

Jun 7 10:55:04 dns kernel: bttv0: detected: Pinnacle PCTV [card=39], PCI subsystem ID is 11bd:0012

Jun 7 10:55:04 dns kernel: bttv0: using: Pinnacle PCTV Studio/Rave [card=39,autodetected]

avec drakxvt!? c'est automatique dans mandrake, j'ai la même carte que toi, çà marche chez toi? N'y aurait-il pas d'autres settings? Quel logiciel utilises-tu? xawtv ou un autre?

Ah par contre tu as tuner=3, hum serait-ce le hic dans ma confiig ;-P

Share this post


Link to post
Share on other sites

si vous avez des problèmes, vous pouvez aller voir sur léa :

ICI

vous faites :

rmmod bttv

modprobe bttv card=#1 tuner=#2 (avec ce qui correspond...)

...si ça marche vous mettez comme option dans modules.autoload (emplacement dépend de la distrib)

Share this post


Link to post
Share on other sites

Merci pour l'info,

malheureusement le tuner ne fonctionne pas très bien l'image est encore floue...

Je vais chercher, dés que j'ai trouvé, je poste ;-P

Share this post


Link to post
Share on other sites

voici les infos que j'ai pu trouver sur ma carte Pinacle pctv rave ou pro je ne sais plus (c celle qui a la telecomande) :

Vendeur: ?Brooktree Corporation

Bus: ?PCI

Identification de Bus: ?109e:36e:11bd:12

Position sur le bus: ?3:3:0

Description: ?Bt878

Module: ?bttv

Classe de matériel: ?MULTIMEDIA_VIDEO

j'ai trouver aussi comment parametrer le module de ma carte..

Mais le must : c que j'ai reussi a trouver des images en cherchant longtemps :iloveyou: donc je suis sur, ma carte est bien pluguee et fonctionne cerectement seulement le program ne me trouve aucune chaine et c la le bins

dracxtv en fait j'avais deja fait cette commande (je ne connaissais pas le nom) au moins une dixaine de fois mais toujours pareil : RIEN!!!!!!!!!!!!!!!

A o fait je crois que ca ce vois deja pas mal : je suis un debutant et je n'ai pas tout compris : modprob.conf je ne l'ai pas trouve

Share this post


Link to post
Share on other sites

Salut,

je suppose que c'était de modules.conf que tuxx parlait, le modules.conf est dans /etc/modules.conf, mais normalement si tu tapes la commande que tuxx explique et aussi si tu vas voir sur le site de lea, il y a moyen de comprendre.

Par contre, je peux dire que j'ai bien l'image mais pas très claire, il y a énormément de neige... celle avec la téléco, c'est la pro, les cartes sont toutes les même entre pro, miro et rave, il n'y a que le logiciel fourni qui est différence. Et par exemple la pro a une télécommande.

Je pense que la télécommande fonctionne avec Lirc.

Il y a aussi kdetv qui est un logiciel plus apprécié sur lea-linux, mais j'ai eu du mal à trouver des packages stables.

Share this post


Link to post
Share on other sites

En fait, chez moi, le modules.conf est généré automatiquement à partir d'autres fichiers par hotplug ...

ça dépend de la config ...

Moi c'est pareil, j'ai un peu galéré pour faire marcher ma carte TV, mais maintenant que ça marche ... j'y touche plus ...

...je vous aurait bien passé ma config de xawtv pour que vous ayez tout direct bien configuré, mais là, j'ai plus de PC ... donc ce sera pour plus tard (dans 1 semaine à priori...)

Share this post


Link to post
Share on other sites
...j'ai un peu galéré pour faire marcher ma carte TV, mais maintenant que ça marche ... j'y touche plus ...

:mdr: je te comprend ca fait mal de se faire mordre les doigts a chaques fois qu'on veux metre les mais dans le moteur :D

Share this post


Link to post
Share on other sites
...j'ai trouver aussi comment parametrer le module de ma carte..

Ouai mais en me relisant je vois que j'ai oublie de dire que je ne savais, et je ne sais toujours pas, quels parametres entrer ou si je les laisse comme ca???

apparement ca a l'air d'etre bon, si je vois des semblants d'image. ??? ce sont des images brouillees j'ai reussi a reconnaitre le tour du man et le logo de M6 mais c tout et c loin d'etre les bons reglages.

et j'ai essaye les trucs sur le site de lea mais, a mois que je me plante, les drivers et modules sont deja instales. mais je vais quand meme reessaye de configurer le module.

Share this post


Link to post
Share on other sites

Tu devrais avoir les lignes suivantes dans ton fichier /etc/modules.conf

alias char-major-81 bttv

pre-install bttv modprobe -k msp3400;modprobe -k tuner

options tuner type=5 debug=0

options bttv card=39 pll=0 radio=0

options i2c verbose=1 scan=1 i2c_debug=0

je pense que pour options tuner type, tu dois mettre un autre type, car moi je suis en PAL ;-P

mais sur léa-linux ils sont assez gentils pour t'indiquer les différentes options pour le SECAM.

Par contre j'ai reconnu la boutique et arte... hou hou hou.... enfin, c'est déjà une évolution par rapport à l'écran bleu...

j'essaie de recompiler kdetv, mais j'ai un problème de libqt-mt qui n'aurait pas certain symbol défini... Je vais essayer de recompiler çà avec une autre distrib...

pour ta carte; c'est bien card=39, çà ne change pas.

Share this post


Link to post
Share on other sites

http://bytesex.org/bttv/

c'est de la que sort le pilote

et la c'est la liste des tuners

tuner=0 - Temic PAL (4002 FH5)

tuner=1 - Philips PAL_I (FI1246 and compatibles)

tuner=2 - Philips NTSC (FI1236,FM1236 and compatibles)

tuner=3 - Philips (SECAM+PAL_BG) (FI1216MF, FM1216MF, FR1216MF)

tuner=4 - NoTuner

tuner=5 - Philips PAL_BG (FI1216 and compatibles)

tuner=6 - Temic NTSC (4032 FY5)

tuner=7 - Temic PAL_I (4062 FY5)

tuner=8 - Temic NTSC (4036 FY5)

tuner=9 - Alps HSBH1

tuner=10 - Alps TSBE1

tuner=11 - Alps TSBB5

tuner=12 - Alps TSBE5

tuner=13 - Alps TSBC5

tuner=14 - Temic PAL_BG (4006FH5)

tuner=15 - Alps TSCH6

tuner=16 - Temic PAL_DK (4016 FY5)

tuner=17 - Philips NTSC_M (MK2)

tuner=18 - Temic PAL_I (4066 FY5)

tuner=19 - Temic PAL* auto (4006 FN5)

tuner=20 - Temic PAL_BG (4009 FR5) or PAL_I (4069 FR5)

tuner=21 - Temic NTSC (4039 FR5)

tuner=22 - Temic PAL/SECAM multi (4046 FM5)

tuner=23 - Philips PAL_DK (FI1256 and compatibles)

tuner=24 - Philips PAL/SECAM multi (FQ1216ME)

tuner=25 - LG PAL_I+FM (TAPC-I001D)

tuner=26 - LG PAL_I (TAPC-I701D)

tuner=27 - LG NTSC+FM (TPI8NSR01F)

tuner=28 - LG PAL_BG+FM (TPI8PSB01D)

tuner=29 - LG PAL_BG (TPI8PSB11D)

tuner=30 - Temic PAL* auto + FM (4009 FN5)

tuner=31 - SHARP NTSC_JP (2U5JF5540)

tuner=32 - Samsung PAL TCPM9091PD27

tuner=33 - MT2032 universal

tuner=34 - Temic PAL_BG (4106 FH5)

tuner=35 - Temic PAL_DK/SECAM_L (4012 FY5)

tuner=36 - Temic NTSC (4136 FY5)

tuner=37 - LG PAL (newer TAPC series)

tuner=38 - Philips PAL/SECAM multi (FM1216ME MK3)

tuner=39 - LG NTSC (newer TAPC series)

tuner=40 - HITACHI V7-J180AT

tuner=41 - Philips PAL_MK (FI1216 MK)

tuner=42 - Philips 1236D ATSC/NTSC daul in

Share this post


Link to post
Share on other sites

De plus j'avais crus comprendre que pour les modules avec un kernel2.6 les options etait a passer

a modprobe.conf a la difference du kernel 2.4 ou là c'etait modules.conf.

Sinon dans mandrake controle center , gestion du materiel , par là , il y a configurer sa carte tv ,

en faisant "avancer" , on peut rentrer directement ces options . (tuner , carte , pll ,...).

xawtv marche bien normalement sauf que il vaut mieux le mettre par defaut en secam (si besoin)

car bien que le matos soit bien regler (tuner en secam) il a tendance a tout mettre en pal.

vi /home/*user*/.xawtv (c'est un fichier caché)

[global]

ratio = 4:3

freqtab = france

pixsize = 128 x 96

pixcols = 1

jpeg-quality = 75

keypad-ntsc = no

keypad-partial = yes

osd = yes

osd-position = 30 , 20

use-wm-fullscreen = yes

# [station name]

# capture = overlay | grabdisplay | on | off

# input = Television | Composite1 | S-Video | ...

# norm = PAL | NTSC | SECAM | ...

# channel = #

# fine = # (-128..+127)

# key = keysym | modifier+keysym

# color = #

# bright = #

# hue = #

# contrast = #

[defaults]

group = main

norm = SECAM

input = Television

capture = grab

color = 28%

bright = 51%

contrast = 42%

[fr2]

channel = 23

norm = PAL <<< changer et mettre SECAM ou suprimer la ligne

capture = on

Share this post


Link to post
Share on other sites
...Sinon dans mandrake controle center , gestion du materiel , par là , il y a configurer sa carte tv ,

en faisant "avancer" , on peut rentrer directement ces options . (tuner , carte , pll ,...).

oui c de ca que je parlais tout a l'heur mais il n'y a rien en face des champs come tuner, card.... donc faut-il les parametrer pour fair fonctionner ma carte??

par ce que ca "marche" en fin je distingue des images en couleur inversee :incline: et les scans de drakxtv ne trouvent rien du tout!!!!

Share this post


Link to post
Share on other sites

bonjour a tous voila ce que j'ai trouve dans mon module.conf :-D :

alias net-pf-4 ipx

probeall usb-interface usb-uhci ehci-hcd

above snd-intel8x0 snd-pcm-oss

alias sound-slot-0 snd-intel8x0

options bttv automute=1 gbuffers=4

je supose que ce n'est pas normal hein :-D

Share this post


Link to post
Share on other sites

sur lea j'ai trouver ca, mais je ne sais pas trop comment faire :

Configuration des modules

Pour charger automatiquement ces modules lorsqu'on en a besoin, ajoutez dans /etc/conf.modules ou /etc/modules.conf (pour les distributions récentes c'est forcément ce fichier là), les lignes suivantes, en adaptant les valeurs à votre configuration :

alias char-major-81 bttv

pre-install bttv modprobe -k tuner

options i2c    verbose=1 scan=1 i2c_debug=0

options bttv  radio=1 card=1 vidmem=0xdc0

options tuner  debug=0 type=3Autre exemple, pour une Debian (/etc/modules):

i2c-core i2c_debug=1

i2c_algo-bit i2c_debug=1

tuner debug=1 type=33

videodev

bttv radio=1 card=39 pll=1 fieldnr=1Description des paramètres des modules :

bttv

radio

vidmem : l'adresse du framebuffer sur votre carte vidéo.

Afin de déterminer ce paramètre, lancez /usr/local/bin/v4l-conf (ou juste : v4l-conf). Celui ci va vous répondre :

using X11 display :0.0 (dga available)

video mode: 1024x768, 16 bit/pixel, 2048 byte/scanline

framebuffer at 0xe4000000

ok.....

:-D

Share this post


Link to post
Share on other sites
sur lea j'ai trouver ca, mais je ne sais pas trop comment faire :

:keskidit:

alias char-major-81 bttv

pre-install bttv modprobe -k tuner

options i2c    verbose=1 scan=1 i2c_debug=0

options bttv  radio=1 card=1 vidmem=0xdc0

options tuner  debug=0 type=3

tu met ça dans ton /etc/modules.conf ...

en changeant l'option "card" de bttv par la bonne (voir la liste) et "type" de tuner (liste aussi)

Share this post


Link to post
Share on other sites

je remplace donc

alias net-pf-4 ipx

probeall usb-interface usb-uhci ehci-hcd

above snd-intel8x0 snd-pcm-oss

alias sound-slot-0 snd-intel8x0

options bttv automute=1 gbuffers=4

Par :

alias net-pf-4 ipx

probeall usb-interface usb-uhci ehci-hcd

above snd-intel8x0 snd-pcm-oss

alias sound-slot-0 snd-intel8x0

options bttv automute=1 gbuffers=4

alias char-major-81 bttv

pre-install bttv modprobe -k tuner

options i2c verbose=1 scan=1 i2c_debug=0

options bttv radio=1 card=1 vidmem=0xdc0

options tuner debug=0 type=3

mais il y a une ligne qui concerne ma carte dans les lingnes du dessus, je l'enleve ou la lesse??

Ah et oci la radio, enfin je crois, n'est pas suportee par la pctv, je dois metre :

radio=0??

Share this post


Link to post
Share on other sites

L'exemple de zaverel a l'air complet, as-tu essaye sous mandrake?

sous mandrake 10, c'est le kernel 2.6 qui tourne, je savais pas que c'etait dans un autre fichier pour la config des modules. Mais comme zav dit, il y a moyen de faire les changements dans le panneau de config.

pour connaitre la version du kernel un petit uname -a devrait suffir.

Je sais pas essayer ca avant jeudi. On va peut-etre y arriver.

la radio est sur la PCTV, il y a deux entree a l'arriere de ta carte.

card=39

Ah oui, je pense que vidmem, on doit mettre une autre adresse, sur lea-linux ils expliquent comment faire...

Share this post


Link to post
Share on other sites

salut a tous

Ah ba maintenant ca marche plus du tout!!!!! ;):devil:

j'ai remplacer mon encien fichier modulconf par ca :

alias net-pf-4 ipx

probeall usb-interface usb-uhci ehci-hcd

above snd-intel8x0 snd-pcm-oss

alias sound-slot-0 snd-intel8x0

options bttv automute=1 gbuffers=4

alias char-major-81 bttv

pre-install bttv modprobe -k 3

options i2c verbose=1 scan=1 i2c_debug=0

options bttv radio=0 card=39 vidmem=0xdc0

options tuner debug=0 type=3

et puis j'ai taper ce qui etait dis sur lea linux, mais apparement c'est pas bon

[newbix@localhost newbix]$ cd /usr/local/bin

[newbix@localhost bin]$ v4l-conf

v4l-conf: using X11 display :0.0

dga: version 2.0

mode: 1024x768, depth=24, bpp=32, bpl=4096, base=0xd0000000

can't open /dev/video0: No such file or directory

[newbix@localhost bin]$

j'ai en suite essaiye de lancer un scan mais il ne scan rien du tout et a la main je ne retrouve meme plus les images bizards que j'avais :mdr::mdr:

ca devien comique!!!!!!!!!

:pleure::mad2:

bon ba si vous avez des idees :toutafaitdaccord::sm:

Share this post


Link to post
Share on other sites

ah je vien de remarquer que vidmem est a l'adresse 0xdc0 dans le fichier et dans la reponse de comande il y a un truc qui ressemble a ca : 0xd0000000

une idee ?? :toutafaitdaccord::sm:

Share this post


Link to post
Share on other sites

×
×
  • Create New...