Jump to content

[Tuto][Initié] Topic officiel Gentoo


Recommended Posts

une live cd pour voir gentoo n'avancerait pas plus que knoppix, kde gentoo, mdk, knoppix, debian etc... c'est kde.

je croyait que gentoo faisait que des package super optimisés pour l'archi de destination...

c'est vrai que ça ferait un sacré paquet de Gentoo-liveCD :francais:

donc en fait, à la limite, si tu as une partoche de libre, tu peut t'installer Gentoo depuis le linux que tu as déjà installé?

Link to post
Share on other sites
  • Replies 946
  • Created
  • Last Reply

en fait le live-cd te permet essensiellement de booter et d'avoir un evironnement pour l'install, rien de ce qui est sur le live-cd ne se retrouve sur ton dur...

et pour avoir des binaires optimisés pour ta machine, il faut que tu les compiles, et pour arriver à les compiler il te faudra bien des binaires non optimisé à un moment (genre un environnement de base, un gcc...).... Gentoo c'est pas encore la génération spontannée de binaire :francais:

Link to post
Share on other sites
donc en fait, à la limite, si tu as une partoche de libre, tu peut t'installer Gentoo depuis le linux que tu as déjà installé?

Oui, tout à fait...

tu peux installer gentoo depuis n'importe quel linux :

->liveCD (live-CD gentoo, mais aussi knoppix)

->disquette (micro linux, etc...)

->une autre distrib...

je croyait que gentoo faisait que des package super optimisés pour l'archi de destination...

Ben non pas trop...

à la base, gentoo est juste basée sur les sources, donc pas de packages (sous-entendu binaires)

Mais il y a des "stage3" pour quelques archi...

Et des CD de packets précompilés...

Mais à la base, c'est juste des sources.

Link to post
Share on other sites

bon j'ai un nouveau probleme, j'ai suivi à la lettre le tuto gentoo sur cups et foomatic, j'ai une hp 720c tout se passe bien

je lance mon navigateur sur http://127.0.0.1:631/printers/hpqueue

il m'affiche une jolie page ouaibe avec

HP DeskJet 720C Foomatic/pnm2ppa (recommended) 

Description: HP DeskJet 720C

Location: pfffff

Printer State: idle, accepting jobs.

Device URI: parallel:/dev/lp0

l'imprimante est sur le lp0, verif avec dmesg

lp0: using parport0 (polling)

si je fait print test page il ne se passe rien et ca m'envoie sur le site de gentoo ...:yes::chinois:

la il faut que je reboot sous windaube pour imprimer.....

j'ai honte :chinois:

Dieu(x)Linux si tu(vous) exite(z) vraiment save my life :reflechis:

Link to post
Share on other sites

double post ????? faut que tu m'explique la ....

hmm je pense avoir déja tout configuré.... ce qui m'étonne c'est que je n'ai pas de message d'erreur, pas la moindre petite indication pour trouver une solution

Link to post
Share on other sites

Bonsoir tout le monde !

Je viens de finir l'installation d'une gentoo sur mon ordi et j'ai un tout petit problème :

Les paramètres du réseau ne sont pas sauvés :chinois:

Donc en fait, à chaque démarrage, je dois retaper ifconfig eth0 ${IP_ADDR} broadcast ${BROADCAST} netmask ${NETMASK} up

Suivi de route add default gw ${GATEWAY}

La carte eth0 est montée au démarrage.

Sous debian, je savais comment faire, mais là je galère un peu :oops: malgré le fait que j'ai suivi l'installation pas à pas :non:

Bonne soirée à tous ! et merci de votre (future) aide :-D

Link to post
Share on other sites

un petit tour dans /etc/conf.d/net, peut-être ?

suivi d'un brutal ln -s /etc/init.d/net.eth0 /etc/runlevel/default (je sais y'a plus élégant mais ce soir l'élégance c'est pas mon fort, voir le "Question pour un pingouin" ...

Link to post
Share on other sites

Beuh a priori, j'ai bien configuré /etc/conf.d/net sauf si j'ai oublié de sauvegarder... :transpi: (ce qui ne m'étonnerait pas venant de ma part :craint:)

Merci à toi, j'essaie ça demain matin dès que j'allume l'ordi :chinois:

Link to post
Share on other sites

bon j'ai voulu intallé un truc à la main car le buil était masqué... don j'ai fait

duke98 # ACCEPT_KEYWORDS="~x86" emerge /usr/portage/x11-plugins/desklet-clock/desklet-clock-0.32.ebuild

maintenant mon porage rale:

duron21 duke98 # emerge -s dvd               

Searching...  |Traceback (most recent call last):

  File "/usr/bin/emerge", line 2331, in ?

    searchinstance.execute(mysearch)

  File "/usr/bin/emerge", line 545, in execute

    if not portage.portdb.xmatch("match-visible",package):

  File "/usr/lib/portage/pym/portage.py", line 4710, in xmatch

    myval=match_from_list(mydep,self.xmatch("list-visible",None,mydep,mykey))

  File "/usr/lib/portage/pym/portage.py", line 4696, in xmatch

    myval=self.gvisible(self.visible(self.cp_list(mykey)))

  File "/usr/lib/portage/pym/portage.py", line 4806, in gvisible

    if db["/"]["porttree"].dbapi.xmatch("bestmatch-list", mykey, None, None, [mycpv]):

  File "/usr/lib/portage/pym/portage.py", line 4703, in xmatch

    myval=best(match_from_list(mydep,mylist))

  File "/usr/lib/portage/pym/portage.py", line 3537, in match_from_list

    raise KeyError, "Specific key requires an operator (%s) (try adding an '=')" % (mydep)

KeyError: "Specific key requires an operator (x11-plugins/desklet-clock-0.32) (try adding an '=')"

bon je le ferais plus mais comment récupérer portage

Link to post
Share on other sites

j'ai fait le emerge rsync mans pas le emerge portage, je tente

edit

duron21 duke98 # emerge portage

Calculating dependencies 

!!! Problem in sys-apps/portage dependencies.

!!! "Specific key requires an operator (x11-plugins/desklet-clock-0.32) (try adding an '=')"

il refuse d'emerger :mad2:

Link to post
Share on other sites
Imagine : suis à moitié les instructions de Sandeman...

:ouioui:http://www.gentoo.org/doc/fr/handbook/hand...l?part=1&chap=8

(section "Configurer le réseau")

donc modifie le fichier /etc/conf.d/net, et rc-update add net.eth0 default

(mais bon, c'est tout écrit...)

Sisi tout ça, j'avais fait. J'avais même sauvegardé le fichier et tout, l'interface se lançait au démarrage mais je dois quand même modifié les adresses à chaque fois :transpi:

Bon, j'ai encore un exam, je vais pas me prendre la tête avec ça pour le moment :non:

Link to post
Share on other sites
et si tu tentes de virer ton desklet-clock-0.32 (emerge -C desklet-clock) ?

Tu pourras toujours le mettre à la main, c'est pas bien gros comme programme

ben la ou c'est problematique c'est que si je veux l'installer il me dit qu'il est pas installé....

duron21 mnt # emerge -C desklet-clock

--- Couldn't find desklet-clock to unmerge.

>>> unmerge: No packages selected for removal.

je crois que j'ai trouvé la solution, mais c'est de l'allemand ....

j'ai un peu de mal :ouioui:

http://www.winfuture-forum.de/index.php?sh...=0entry205150

Link to post
Share on other sites
Habe den Fehler gerade herausgefunden. Das "=" Zeichen hätte in der /etc/portage/package.keywords gefählt. Nachdem die eine Zeile herausgenommen wurde, meckert emerge nicht mehr und alles geht.

ça veut dire qu'il manquait le symbole = dans le fichier /etc/portage/package.keywords et que en virant la ligne incriminée tout a remarché...

Link to post
Share on other sites
de rien, comme quoi l'allemand c'est pas seulement une langue de :kimouss: , ça peut aussi être utile...

"L'Allemand c'est pas une langue, c'est une maladie de la gorge"

En tout cas content que tu aies réparer ton portage.

D'autres moyens de le flinguer :

- planter une installe de python (bah oui le PC qui freeze ou la coupure de courant pendant les minstall ...)

- un chmod remyxien sur /usr/portage

- rm -fr /usr/portage au lieu de /usr/tmp/portage (j'ai failli ... )

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...